14:30:11 <dkliban> #startmeeting Pulp Triage 2016-05-06
14:30:11 <dkliban> #info dkliban has joined triage
14:30:12 <pulpbot> Meeting started Fri May  6 14:30:11 2016 UTC and is due to finish in 60 minutes.  The chair is dkliban. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:12 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:12 <pulpbot> The meeting name has been set to 'pulp_triage_2016_05_06'
14:30:12 <pulpbot> dkliban has joined triage
14:30:20 <ttereshc> !here
14:30:20 <ttereshc> #info ttereshc has joined triage
14:30:21 <pulpbot> ttereshc has joined triage
14:30:25 <bowlofeggs> !here
14:30:25 <bowlofeggs> #info bowlofeggs has joined triage
14:30:26 <pulpbot> bowlofeggs has joined triage
14:30:28 <preethi> #info preethi has joined triage
14:30:28 <preethi> !here
14:30:29 <pulpbot> preethi has joined triage
14:30:32 <smyers> !here
14:30:32 <smyers> #info smyers has joined triage
14:30:32 <pulpbot> smyers has joined triage
14:30:34 <ipanova> #info ipanova has joined triage
14:30:34 <ipanova> !here
14:30:34 <pulpbot> ipanova has joined triage
14:30:39 <jcline> #info jcline has joined triage
14:30:39 <jcline> !here
14:30:39 <pulpbot> jcline has joined triage
14:30:55 <dkliban> we have a quorum
14:31:01 <ttereshc> !care 1899
14:31:09 <smyers> Let's hope that works^ :)
14:31:20 <dkliban> !next
14:31:22 <pulpbot> 16 issues left to triage: 1773, 1865, 1866, 1881, 1883, 1884, 1885, 1886, 1890, 1893, 1894, 1895, 1897, 1898, 1899, 1900
14:31:22 <dkliban> #topic No "unprotected/http" option available for ostree repos - http://pulp.plan.io/issues/1773
14:31:23 <pulpbot> OSTree Support Issue #1773 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:23 <pulpbot> No "unprotected/http" option available for ostree repos - http://pulp.plan.io/issues/1773
14:31:30 <bowlofeggs> !care 1890
14:31:37 <bowlofeggs> !care 1893
14:31:45 <bowlofeggs> !care 1900
14:32:00 <smyers> We needinfo'd this last week, and it doesn't appear to have changed.
14:32:01 <dkliban> Was someone supposed to take a look at 1773?
14:32:05 <pcreech> !here
14:32:05 <pcreech> #info pcreech has joined triage
14:32:06 <pulpbot> pcreech has joined triage
14:32:13 <ttereshc> bowlofeggs, you are so careful)
14:32:13 <dkliban> i propose we skip it
14:32:19 <smyers> #idea Proposed for #1773: Skip this issue for this triage session.
14:32:19 <smyers> !propose skip
14:32:19 <pulpbot> Proposed for #1773: Skip this issue for this triage session.
14:32:28 <bowlofeggs> !agreed
14:32:28 <pulpbot> Error: "agreed" is not a valid command.
14:32:33 <smyers> dkliban, you can !accept to...er...accept :)
14:32:37 <dkliban> !accept
14:32:37 <dkliban> #agreed Skip this issue for this triage session.
14:32:38 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:32:39 <bowlofeggs> !accept
14:32:39 <pulpbot> 15 issues left to triage: 1865, 1866, 1881, 1883, 1884, 1885, 1886, 1890, 1893, 1894, 1895, 1897, 1898, 1899, 1900
14:32:39 <dkliban> #topic Error searching rpm repositories by fields using dot notation - http://pulp.plan.io/issues/1865
14:32:40 <pulpbot> Pulp Issue #1865 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:40 <pulpbot> Error searching rpm repositories by fields using dot notation - http://pulp.plan.io/issues/1865
14:33:08 <dkliban> asmacdo: are you working on 1865?
14:33:21 <bowlofeggs> is this a regression?
14:33:39 <smyers> This is likely a regression. I think asmacdo is still out
14:33:59 <bowlofeggs> !propose high, high
14:33:59 <pulpbot> Error: "propose" is not a valid command.
14:34:09 <smyers> "This pulp-admin command works with pulp/pulp-admin 2.5.3 and MongoDB 2.4.9 installed on RHEL 6." Definitely a regression
14:34:18 <smyers> Unexpected error, try !propose triage high high"
14:34:25 <bowlofeggs> !propose triage high high
14:34:25 <bowlofeggs> #idea Proposed for #1865: Priority: High, Severity: High
14:34:26 <pulpbot> Proposed for #1865: Priority: High, Severity: High
14:34:37 <dkliban> everyone agree?
14:34:45 <smyers> I need to support +1, I think, because +1
14:34:53 <smyers> well. pulpbot does. Not me. :)
14:34:57 <dkliban> lol
14:35:02 <jcline> Yeah
14:35:10 <dkliban> do we want to set a target release of 2.8.4?
14:35:16 <preethi> yes
14:35:18 <smyers> !propose h h 2.8.4
14:35:18 <pulpbot> Error: "propose" is not a valid command.
14:35:22 <smyers> hah
14:35:25 <smyers> !propose triage h h 2.8.4
14:35:25 <smyers> #idea Proposed for #1865: Priority: High, Severity: High, Target Platform Release: 2.8.4
14:35:25 <pulpbot> Proposed for #1865: Priority: High, Severity: High, Target Platform Release: 2.8.4
14:35:28 <bowlofeggs> sure
14:35:54 <smyers> I like it
14:35:56 <mhrivnak> hm, apparently I didn't get any of these messages since triage started.
14:35:58 * mhrivnak catches up
14:36:00 <dkliban> !next
14:36:02 <pulpbot> 14 issues left to triage: 1866, 1881, 1883, 1884, 1885, 1886, 1890, 1893, 1894, 1895, 1897, 1898, 1899, 1900
14:36:03 <dkliban> #topic The Pulp Python bindings don't use requests and fail to retry - http://pulp.plan.io/issues/1866
14:36:03 <pulpbot> Pulp Issue #1866 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:04 <pulpbot> The Pulp Python bindings don't use requests and fail to retry - http://pulp.plan.io/issues/1866
14:36:08 <mhrivnak> !here
14:36:08 <mhrivnak> #info mhrivnak has joined triage
14:36:09 <pulpbot> mhrivnak has joined triage
14:36:25 <jcline> I updated this a little bit I think, but not enough (perhaps)
14:36:37 <smyers> Another one I think we skipped last week. jcline do you still think it's NEEDINFO?
14:36:58 <bowlofeggs> RHEL 5 might be a concern here, unless it has software collections too?
14:37:18 <bowlofeggs> the story i'm workign on is to switch us to SCLs on EL 6, but maybe i could do it for RHEL 5 too to enable requests?
14:37:19 <jcline> Yeah, I don't think we could switch to requests soon
14:37:20 * smyers kicks rhel5
14:37:30 <bowlofeggs> i'm not sure whether EL 5 has SCLs or not though
14:37:36 <jcline> Or maybe only for pulp-admin if we want to only support pulp-admin on rhel6+
14:37:39 <mhrivnak> I think we can just wait for pulp 3 on that, when we won't need to support el5 anymore.
14:38:02 <bowlofeggs> !propose triage wait
14:38:02 <pulpbot> (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
14:38:07 <bowlofeggs> whoops
14:38:17 <bowlofeggs> well i propose we hold off
14:38:23 <jcline> Fine with me
14:38:30 <dkliban> but what do we do with the issue? skip it?
14:38:32 <bowlofeggs> yeah
14:38:38 <dkliban> !skip
14:38:40 <pulpbot> 13 issues left to triage: 1881, 1883, 1884, 1885, 1886, 1890, 1893, 1894, 1895, 1897, 1898, 1899, 1900
14:38:41 <dkliban> #topic pulp-admin fails to display the erratum if not all metadata is present - http://pulp.plan.io/issues/1881
14:38:41 <pulpbot> RPM Support Issue #1881 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:42 <pulpbot> pulp-admin fails to display the erratum if not all metadata is present - http://pulp.plan.io/issues/1881
14:39:28 <bowlofeggs> seems bad - it's a crash
14:39:35 <bowlofeggs> !propose medium high 2.8.4
14:39:35 <pulpbot> Error: "propose" is not a valid command.
14:39:42 <smyers> !propose triage normal high 2.8.4
14:39:42 <smyers> #idea Proposed for #1881: Priority: Normal, Severity: High, Target Platform Release: 2.8.4
14:39:43 <pulpbot> Proposed for #1881: Priority: Normal, Severity: High, Target Platform Release: 2.8.4
14:39:43 <mhrivnak> and apparently a regression.
14:39:44 <bowlofeggs> !propose triage medium high 2.8.4
14:39:48 <smyers> heh
14:39:51 <smyers> I think we agree.
14:39:55 <ipanova> agree
14:39:58 <mhrivnak> +1
14:39:58 <smyers> +1
14:40:04 <ttereshc> +1
14:40:12 <jcline> Also it's easy to fix
14:40:31 <smyers> remember to !accept, not !next
14:40:46 <dkliban> !accept
14:40:46 <dkliban> #agreed Priority: Normal, Severity: High, Target Platform Release: 2.8.4
14:40:47 <pulpbot> Current proposal accepted: Priority: Normal, Severity: High, Target Platform Release: 2.8.4
14:40:48 <dkliban> #topic As a user, I can sync and publish all package types - http://pulp.plan.io/issues/1883
14:40:48 <pulpbot> 12 issues left to triage: 1883, 1884, 1885, 1886, 1890, 1893, 1894, 1895, 1897, 1898, 1899, 1900
14:40:48 <pulpbot> Python Support Issue #1883 [ASSIGNED] (amacdona@redhat.com) - Priority: Normal | Severity: Medium
14:40:48 * smyers makes a note to have !next implicitly !accept, because it's silly to have two commands for that
14:40:48 <pulpbot> As a user, I can sync and publish all package types - http://pulp.plan.io/issues/1883
14:41:00 <mhrivnak> I think this should be a story.
14:41:05 <ipanova> +1
14:41:06 <mhrivnak> And I left a comment to that effect.
14:41:10 <bowlofeggs> this is also already in progress
14:41:13 <bowlofeggs> i propose we move on
14:41:26 <smyers> !propose accept
14:41:26 <smyers> #idea Proposed for #1883: Leave the issue as-is, accepting its current state.
14:41:27 <pulpbot> Proposed for #1883: Leave the issue as-is, accepting its current state.
14:41:38 <jalbertson> does it need to be a story?
14:41:48 <bowlofeggs> yeah this is a story
14:41:55 <asmacdo> im going to update that one
14:41:59 <jalbertson> ok
14:42:00 <asmacdo> you can move on
14:42:05 <dkliban> !next
14:42:07 <pulpbot> 11 issues left to triage: 1884, 1885, 1886, 1890, 1893, 1894, 1895, 1897, 1898, 1899, 1900
14:42:07 <dkliban> #topic Lazy integration - http://pulp.plan.io/issues/1884
14:42:08 <pulpbot> Python Support Issue #1884 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:08 <pulpbot> Lazy integration - http://pulp.plan.io/issues/1884
14:42:09 <bowlofeggs> this one is also a story
14:42:11 <mhrivnak> same
14:42:15 <bowlofeggs> !propose accept
14:42:15 <bowlofeggs> #idea Proposed for #1884: Leave the issue as-is, accepting its current state.
14:42:16 <pulpbot> Proposed for #1884: Leave the issue as-is, accepting its current state.
14:42:34 <smyers> Could also !propose other Convert to story
14:42:40 <mhrivnak> does "accept" mark it as triaged?
14:42:59 <bowlofeggs> let's move on
14:43:02 <smyers> That's the idea, but since it doesn't touch redmine it's still up to the triager
14:43:03 <mhrivnak> er, does proposing "accept" mean proposing marking it as triaged?
14:43:12 <dkliban> ok
14:43:20 <mhrivnak> ok. I think we should not mark it triaged.
14:43:25 <smyers> !propose skip
14:43:25 <smyers> #idea Proposed for #1884: Skip this issue for this triage session.
14:43:26 <pulpbot> Proposed for #1884: Skip this issue for this triage session.
14:43:28 <mhrivnak> and move on. :)
14:43:32 <mhrivnak> +1
14:43:32 <dkliban> #agreed Skip this issue for this triage session.
14:43:32 <dkliban> !accept
14:43:32 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:43:34 <pulpbot> 10 issues left to triage: 1885, 1886, 1890, 1893, 1894, 1895, 1897, 1898, 1899, 1900
14:43:34 <dkliban> #topic Pulp uploads are failing with "too many open files" error - http://pulp.plan.io/issues/1885
14:43:35 <pulpbot> Pulp Issue #1885 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:43:35 <pulpbot> Pulp uploads are failing with "too many open files" error - http://pulp.plan.io/issues/1885
14:43:42 <bowlofeggs> this one does sound bad
14:43:48 <bowlofeggs> !propose triage medium high 2.8.4
14:43:48 <bowlofeggs> #idea Proposed for #1885: Priority: Normal, Severity: High, Target Platform Release: 2.8.4
14:43:49 <smyers> ooof
14:43:49 <pulpbot> Proposed for #1885: Priority: Normal, Severity: High, Target Platform Release: 2.8.4
14:43:53 <bmbouter> I don't think we should accept this bug at this time
14:43:57 <bowlofeggs> why not?
14:43:58 <dkliban> mhrivnak: i did mark it as triaged but i'll change that now
14:44:02 <bowlofeggs> bmbouter: ?
14:44:12 <bmbouter> it's very likely an environmtal problem
14:44:30 <bowlofeggs> bmbouter: what if we accept it just to try to reproduce?
14:44:47 <ipanova> agree with bowlofeggs
14:45:02 <bmbouter> that sounds fine
14:45:06 <bowlofeggs> bmbouter: we could ask them for reproduction steps with a clean pulp install
14:45:11 <ipanova> #idea Proposed for #1885: Leave the issue as-is, accepting its current state.
14:45:11 <ipanova> !propose accept
14:45:11 <pulpbot> Proposed for #1885: Leave the issue as-is, accepting its current state.
14:45:18 <jcline> Yeah. If it turns out to be an environmental problem we can close it with a note
14:45:32 <smyers> +1
14:45:33 <bowlofeggs> cool sounds good
14:45:34 <bowlofeggs> +1
14:45:37 <bmbouter> I think they are hitting a scale limitation
14:45:39 <jalbertson> we should make sure to put in a note that it may be an environmental problem if it isn't already there
14:45:45 <bmbouter> we could document that better perhaps
14:45:48 <jalbertson> so whoever picks it up will know
14:45:57 <bmbouter> I'll put a note on it
14:46:01 <jalbertson> bmbouter, thank you
14:46:03 <jcline> bmbouter: that could be the fix for the issue
14:46:08 <dkliban> mark it as triaged?
14:46:14 <jcline> (making a docs pr, that is)
14:46:20 <bowlofeggs> let's not mark it triaged for this time
14:46:27 <smyers> #action bmbouter Update #1885 to note that this might be an environmental problem, not a pulp-specific problem.
14:46:27 <smyers> !action bmbouter Update #1885 to note that this might be an environmental problem, not a pulp-specific problem.
14:46:38 <bowlofeggs> but let's suggest it might be environmental, and ask for reproduction steps
14:46:47 <dkliban> can we skip now?
14:46:49 <bowlofeggs> !action bmbouter ask for reproduction steps
14:46:49 <bowlofeggs> #action bmbouter ask for reproduction steps
14:46:53 <smyers> so !propose skip?
14:46:54 <bowlofeggs> yeah
14:46:57 <bowlofeggs> !propose skip[
14:46:57 <pulpbot> Error: Missing "]".  You may want to quote your arguments with double quotes in order to prevent extra brackets from being evaluated as nested commands.
14:47:02 <smyers> hah
14:47:04 <bowlofeggs> !propose skip
14:47:04 <bowlofeggs> #idea Proposed for #1885: Skip this issue for this triage session.
14:47:04 <pulpbot> Proposed for #1885: Skip this issue for this triage session.
14:47:07 <smyers> you make pulpbot so mad
14:47:10 <bowlofeggs> haha
14:47:11 <dkliban> #agreed Skip this issue for this triage session.
14:47:11 <dkliban> !accept
14:47:11 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:47:13 <dkliban> #topic Removal of the unit fails if criteria contains unknown fields - http://pulp.plan.io/issues/1886
14:47:13 <pulpbot> 9 issues left to triage: 1886, 1890, 1893, 1894, 1895, 1897, 1898, 1899, 1900
14:47:14 <pulpbot> Pulp Issue #1886 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:47:15 <pulpbot> Removal of the unit fails if criteria contains unknown fields - http://pulp.plan.io/issues/1886
14:47:15 <bowlofeggs> are you getting tracebacks?
14:47:21 <smyers> not at all
14:47:27 <bowlofeggs> nice
14:47:47 <bowlofeggs> this is likely a regression
14:47:51 <bowlofeggs> !propose medium medium 2.8.4
14:47:51 <pulpbot> Error: "propose" is not a valid command.
14:47:59 <bowlofeggs> !propose triage medium medium 2.8.4
14:47:59 <bowlofeggs> #idea Proposed for #1886: Priority: Normal, Severity: Medium, Target Platform Release: 2.8.4
14:48:00 <pulpbot> Proposed for #1886: Priority: Normal, Severity: Medium, Target Platform Release: 2.8.4
14:48:03 <smyers> I'm not so sure
14:48:10 <smyers> Is this a bug? :)
14:48:29 <bowlofeggs> well, nothing a user can do should be able to produce a traceback
14:48:31 <jcline> Maybe this should return a 400?
14:48:33 <bowlofeggs> so it's at least a bug in that sense
14:48:38 <jcline> Yeah
14:48:38 <dkliban> yep
14:48:42 <bowlofeggs> if anything, we could return a nice error
14:48:44 <smyers> Right, but not a regression
14:48:48 <ipanova> smyers: seems like just for docker plugin, other plugins can handle that
14:48:55 <bowlofeggs> smyers: yeah maybe you are right
14:49:06 <jcline> Yeah, I'd be fine with not 2.8.4
14:49:15 <jalbertson> if it's not a regression, I'd say not 2.84
14:49:20 <mhrivnak> agreed.
14:49:22 <jalbertson> what jcline said  :)
14:49:23 <smyers> !propose med med
14:49:23 <pulpbot> Error: "propose" is not a valid command.
14:49:24 <bowlofeggs> this is weird
14:49:28 <smyers> !propose triage med med
14:49:28 <smyers> #idea Proposed for #1886: Priority: Normal, Severity: Medium
14:49:29 <pulpbot> Proposed for #1886: Priority: Normal, Severity: Medium
14:49:33 <bowlofeggs> you queried about docker
14:49:39 <bowlofeggs> but the traceback is about rpm?
14:49:40 <smyers> obviously need to support the naked !propose command.
14:49:51 <ttereshc> bowlofeggs, both
14:49:57 <dkliban> !accept
14:49:57 <dkliban> #agreed Priority: Normal, Severity: Medium
14:49:57 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
14:49:59 <pulpbot> 8 issues left to triage: 1890, 1893, 1894, 1895, 1897, 1898, 1899, 1900
14:50:00 <dkliban> #topic pulp-qpid-ssl-cfg echoes the NSS DB password - http://pulp.plan.io/issues/1890
14:50:00 <pulpbot> Pulp Issue #1890 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:50:00 <pulpbot> pulp-qpid-ssl-cfg echoes the NSS DB password - http://pulp.plan.io/issues/1890
14:50:01 <pulpbot> bowlofeggs: Issue 1890 is currently being discussed.
14:50:08 <smyers> ^ BAM
14:50:38 <bowlofeggs> hey nice!
14:50:47 <bowlofeggs> this one is a security hardening bug
14:50:55 <smyers> Need a CVE for it?
14:50:57 <bowlofeggs> it's pretty lame - it echoes a password onto your screeen
14:50:59 <jcline> Nope
14:51:07 <bowlofeggs> smyers: no i talked to PS and they said not a CVE but we should do it
14:51:09 <jcline> (to the CVE need)
14:51:13 <bowlofeggs> it's also a 1-liner
14:51:16 <smyers> ah
14:51:17 <bowlofeggs> just remove one line
14:51:20 <bowlofeggs> easy peasey
14:51:20 * smyers finished reading the bug
14:51:28 <bowlofeggs> !propose triage med med 2.8.4
14:51:28 <bowlofeggs> #idea Proposed for #1890: Priority: Normal, Severity: Medium, Target Platform Release: 2.8.4
14:51:29 <pulpbot> Proposed for #1890: Priority: Normal, Severity: Medium, Target Platform Release: 2.8.4
14:51:33 <bowlofeggs> nice friday task
14:51:40 <mhrivnak> +1
14:51:44 <smyers> !suggest also add the easy fix tag
14:51:44 <smyers> #idea also add the easy fix tag
14:52:02 <dkliban> #agreed Priority: Normal, Severity: Medium, Target Platform Release: 2.8.4
14:52:02 <dkliban> !accept
14:52:02 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium, Target Platform Release: 2.8.4
14:52:03 <bowlofeggs> !action bowlofeggs add the easy tag
14:52:03 <pulpbot> 7 issues left to triage: 1893, 1894, 1895, 1897, 1898, 1899, 1900
14:52:04 <dkliban> #topic pulp_docker does not support Docker < 1.10 with manifests that were published from Docker >= 1.10 - http://pulp.plan.io/issues/1893
14:52:04 <bowlofeggs> #action bowlofeggs add the easy tag
14:52:04 <pulpbot> Docker Support Issue #1893 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:52:04 <pulpbot> pulp_docker does not support Docker < 1.10 with manifests that were published from Docker >= 1.10 - http://pulp.plan.io/issues/1893
14:52:05 <pulpbot> bowlofeggs: Issue 1893 is currently being discussed.
14:52:22 <bowlofeggs> so this issue is theoretical at the moment
14:52:38 <bowlofeggs> i asked RCM to do some testing to find out if they are immediately impacted or not
14:52:47 <bowlofeggs> they haven't responded to that yet
14:52:54 <mhrivnak> How was it discovered?
14:52:54 <bowlofeggs> we will have to do something eventually
14:53:03 <ipanova> !propose skip
14:53:03 <ipanova> #idea Proposed for #1893: Skip this issue for this triage session.
14:53:04 <pulpbot> Proposed for #1893: Skip this issue for this triage session.
14:53:05 <bowlofeggs> i think they were just reading the 1.10 release notes
14:53:17 <bowlofeggs> and realized there was a potential problem
14:53:20 <ipanova> let's wait on RCM's input
14:53:21 <bowlofeggs> really, there is a real problem
14:53:35 <bowlofeggs> but it's unknown how urgent our attention needs to be
14:53:36 <bowlofeggs> +1
14:53:46 <dkliban> #agreed Skip this issue for this triage session.
14:53:46 <dkliban> !accept
14:53:46 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:53:48 <dkliban> #topic unassociate rpms API request using unit_ids removes all rpm from repo - http://pulp.plan.io/issues/1894
14:53:48 <pulpbot> 6 issues left to triage: 1894, 1895, 1897, 1898, 1899, 1900
14:53:49 <pulpbot> Pulp Issue #1894 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:53:50 <pulpbot> unassociate rpms API request using unit_ids removes all rpm from repo - http://pulp.plan.io/issues/1894
14:54:10 <smyers> lol
14:54:33 <mhrivnak> FWIW, I wouldn't mind slowing this triage down just a touch.
14:54:40 <smyers> still loling
14:54:42 <dkliban> ok
14:54:45 <bowlofeggs> whoah
14:54:52 <bowlofeggs> this bug is crazy
14:54:57 <smyers> !propose high high 2.8.4
14:54:57 <pulpbot> Error: "propose" is not a valid command.
14:54:57 <jcline> Yeah, haha
14:55:02 <smyers> !propose triage high high 2.8.4
14:55:02 <smyers> #idea Proposed for #1894: Priority: High, Severity: High, Target Platform Release: 2.8.4
14:55:03 <pulpbot> Proposed for #1894: Priority: High, Severity: High, Target Platform Release: 2.8.4
14:55:07 <smyers> Unless I'm missing something?
14:55:09 <bowlofeggs> +1
14:55:10 <smyers> Because wow.
14:55:17 <jcline> +1
14:55:25 <ttereshc> +1
14:55:31 <mhrivnak> This one is quite bizarre. +1
14:55:41 <bowlofeggs> !action pulp unbreak pulp
14:55:41 <bowlofeggs> #action pulp unbreak pulp
14:55:48 <smyers> Maybe might even bump the priority to urgent
14:56:04 <smyers> Because while the client should never return tracebacks it should *really* never empty your repos?
14:56:15 <bowlofeggs> hahaha
14:56:19 <smyers> I think that urgent's s a stretch, though
14:56:25 <bowlofeggs> there was an error so I DELETED EVERYTHING
14:56:39 <mhrivnak> I could see it either way.
14:56:49 <dkliban> i marked it high/high 2.8.4
14:57:19 <dkliban> next ?
14:57:21 <bowlofeggs> !propose move along
14:57:21 <pulpbot> Error: "propose" is not a valid command.
14:57:24 <bowlofeggs> !propose next
14:57:24 <pulpbot> Error: "propose" is not a valid command.
14:57:27 <bowlofeggs> !propose accept
14:57:27 <bowlofeggs> #idea Proposed for #1894: Leave the issue as-is, accepting its current state.
14:57:28 <pulpbot> Proposed for #1894: Leave the issue as-is, accepting its current state.
14:57:32 <dkliban> #agreed Leave the issue as-is, accepting its current state.
14:57:32 <dkliban> !accept
14:57:32 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:57:32 <bowlofeggs> whoops
14:57:34 <bowlofeggs> noooo
14:57:34 <pulpbot> 5 issues left to triage: 1895, 1897, 1898, 1899, 1900
14:57:34 <dkliban> #topic Recursive RPM unit copies are not recursive - http://pulp.plan.io/issues/1895
14:57:35 <pulpbot> RPM Support Issue #1895 [MODIFIED] (mhrivnak) - Priority: Normal | Severity: Medium | Target Release: 2.8.4
14:57:35 <pulpbot> Recursive RPM unit copies are not recursive - http://pulp.plan.io/issues/1895
14:57:39 <bowlofeggs> hahah i ruined it
14:57:46 <mhrivnak> !propose triage high high 2.8.4
14:57:46 <mhrivnak> #idea Proposed for #1895: Priority: High, Severity: High, Target Platform Release: 2.8.4
14:57:47 <pulpbot> Proposed for #1895: Priority: High, Severity: High, Target Platform Release: 2.8.4
14:57:52 <mhrivnak> already fixed.
14:58:01 <bowlofeggs> +1
14:58:08 <ttereshc> +1
14:58:11 <mhrivnak> recursive copy was completely broken.
14:58:13 <jcline> +1
14:58:15 <bowlofeggs> fwiw, i think i actually caused the last one to not be high/high
14:58:21 <bowlofeggs> so let's make sure we get that one right
14:58:43 <bowlofeggs> i was thinking +1 so i typed !propose accept, as in "i propose that dennis type !accept"
14:58:44 <dkliban> #agreed Priority: High, Severity: High, Target Platform Release: 2.8.4
14:58:44 <dkliban> !accept
14:58:44 <pulpbot> Current proposal accepted: Priority: High, Severity: High, Target Platform Release: 2.8.4
14:58:45 <dkliban> #topic catalog entries not created for pre-existing units - http://pulp.plan.io/issues/1897
14:58:46 <pulpbot> 4 issues left to triage: 1897, 1898, 1899, 1900
14:58:46 <pcreech> 1894 is set high/high
14:58:46 <pulpbot> RPM Support Issue #1897 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:58:47 <pulpbot> catalog entries not created for pre-existing units - http://pulp.plan.io/issues/1897
14:58:52 <bowlofeggs> but i changed the proposal ☹
14:59:10 * smyers punches bowlofeggs
14:59:23 <bowlofeggs> haha
14:59:32 <bowlofeggs> does this one cause any practical error?
14:59:36 <jcline> Yeah
14:59:36 <mhrivnak> !propose high high 2.8.4
14:59:36 <pulpbot> Error: "propose" is not a valid command.
14:59:48 <bowlofeggs> as in, what problem is there if the catalog entries are missing?
14:59:48 <jcline> It'll make fetching lazy content fail
14:59:50 <dkliban> bowlofeggs: please stop messing around with the propose command
14:59:52 <bowlofeggs> ah
14:59:55 <bowlofeggs> dkliban: lol
15:00:00 <jcline> 404s. Thousands of them.
15:00:01 <ipanova> !propose triage high high 2.8.4
15:00:01 <ipanova> #idea Proposed for #1897: Priority: High, Severity: High, Target Platform Release: 2.8.4
15:00:01 <pulpbot> Proposed for #1897: Priority: High, Severity: High, Target Platform Release: 2.8.4
15:00:01 <bowlofeggs> +1
15:00:05 <ipanova> +1
15:00:10 <bowlofeggs> +1
15:00:17 <smyers> +1
15:00:26 * jcline jumps on the +1 train
15:00:34 <mhrivnak> The problem is content cannot be accessed on-demand through the streamer.
15:00:45 <smyers> !action jcline needs to paint a picture of the 404 devastation that occurs as a result of #1897
15:00:45 <smyers> #action jcline needs to paint a picture of the 404 devastation that occurs as a result of #1897
15:00:52 <mhrivnak> We had a katello dev get into that situation.
15:00:57 <bowlofeggs> jcline: water colours please
15:01:22 <dkliban> are we ready to move on?
15:01:23 <bowlofeggs> let's move on
15:01:25 <mhrivnak> +1
15:01:26 <ipanova> yes
15:01:29 <dkliban> !accept
15:01:29 <dkliban> #agreed Priority: High, Severity: High, Target Platform Release: 2.8.4
15:01:30 <pulpbot> Current proposal accepted: Priority: High, Severity: High, Target Platform Release: 2.8.4
15:01:31 <pulpbot> 3 issues left to triage: 1898, 1899, 1900
15:01:31 <dkliban> #topic Errata search does not filter packages that are not in repo  - http://pulp.plan.io/issues/1898
15:01:32 <pulpbot> RPM Support Issue #1898 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:01:32 <pulpbot> Errata search does not filter packages that are not in repo  - http://pulp.plan.io/issues/1898
15:01:43 <smyers> haha right
15:01:48 <mhrivnak> oh boy
15:01:49 <smyers> Because we do that filtering on publish :(
15:01:55 <ttereshc> exactly
15:01:57 * smyers punches errata
15:02:10 * ttereshc joins smyers
15:02:13 <ipanova> smyers: is so violent today
15:02:19 <bowlofeggs> yeah i'm not sure what i think about this one
15:02:20 * smyers punches violence
15:02:30 <ipanova> smyers:  lol
15:02:30 <dkliban> lol
15:02:46 <mhrivnak> Given recent changes, it would actually be pretty easy to do the filtering.
15:02:52 <smyers> I think that it's possible that with ttereshc's work in rm #858 we can potentially refactor errata to be less junky
15:02:52 <pulpbot> RPM Support Issue #858 [MODIFIED] (ttereshc) - Priority: High | Severity: Medium | Target Release: 2.8.4
15:02:53 <pulpbot> As a user, I would like to receive updated errata metadata - http://pulp.plan.io/issues/858
15:03:01 <bowlofeggs> !propose triage medium med
15:03:01 <bowlofeggs> #idea Proposed for #1898: Priority: Normal, Severity: Medium
15:03:01 <pulpbot> Proposed for #1898: Priority: Normal, Severity: Medium
15:03:07 <ipanova> +1
15:03:15 <ttereshc> smyers, I am not sure but we can discuss it later
15:03:19 <mhrivnak> +1
15:03:21 <jcline> +1
15:03:21 <smyers> cool
15:03:43 <smyers> I think we're good then
15:03:48 <ttereshc> +1
15:04:05 <bowlofeggs> move along?
15:04:10 <ipanova> let's move on
15:04:15 <smyers> these are not the droids we're looking for.
15:04:21 <bowlofeggs> haha they really aren't
15:04:30 <dkliban> !accept
15:04:30 <dkliban> #agreed Priority: Normal, Severity: Medium
15:04:30 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
15:04:31 <dkliban> #topic Repo sync failure with "time data '' does not match format '%Y-%m-%d %H:%M:%S'" - http://pulp.plan.io/issues/1899
15:04:32 <pulpbot> 2 issues left to triage: 1899, 1900
15:04:32 <pulpbot> RPM Support Issue #1899 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:04:33 <pulpbot> Repo sync failure with "time data '' does not match format '%Y-%m-%d %H:%M:%S'" - http://pulp.plan.io/issues/1899
15:04:34 <pulpbot> ttereshc: Issue 1899 is currently being discussed.
15:05:21 <mhrivnak> ttereshc, sorry I haven't elaborated on our last emails about this one.
15:05:22 <ipanova> is it a pulp bug?
15:05:25 <ttereshc> I think it is not a bug in pulp, and I made a PR to fix fixtures repo
15:05:56 <ttereshc> mhrivnak, we can discuss after triage if it is a proper pulp behavior
15:05:57 <bowlofeggs> i propose we skip until we know if it's a fixture problem or not
15:06:03 <smyers> !propose skip
15:06:03 <smyers> #idea Proposed for #1899: Skip this issue for this triage session.
15:06:03 <mhrivnak> Is it possible that users will upgrade to pulp 2.8.4 and start getting this failure?
15:06:03 <pulpbot> Proposed for #1899: Skip this issue for this triage session.
15:06:04 <ipanova> i'd close it as it is not a bug in pulp
15:06:11 <smyers> It really looks like a fixture problem to me
15:06:12 <mhrivnak> when before it didn't fail?
15:06:19 <ipanova> smyers: +1
15:06:24 <jcline> Yeah, it looks like data validation is rightfully failing
15:06:40 <ttereshc> mhrivnak, first sync won't fail
15:06:44 <bowlofeggs> data validation shouldn't traceback though
15:06:52 <bowlofeggs> so we *should* at least fix that
15:07:07 <bowlofeggs> it should give a helpful error message to the user instead
15:07:08 <ipanova> smyers:  is there some !propose lest's close it?
15:07:09 <mhrivnak> My concern is that I think we're getting more strict about validation in a Z release.
15:07:14 <bowlofeggs> "the remote repo is out of its mind"
15:07:23 <smyers> #idea Proposed for #1899: Close as NOTABUG
15:07:23 <smyers> !propose other Close as NOTABUG
15:07:23 <pulpbot> Proposed for #1899: Close as NOTABUG
15:07:27 <smyers> ^ipanova
15:07:36 <ipanova> smyers: sweet
15:07:39 <smyers> With !propose other you can do whatever you want
15:07:41 <bowlofeggs> i propose we keep it as a bad error message bug
15:07:49 <bowlofeggs> #idea Proposed for #1899: keep it as a bad error message bug
15:07:49 <bowlofeggs> !propose other keep it as a bad error message bug
15:07:49 <pulpbot> Proposed for #1899: keep it as a bad error message bug
15:08:05 <smyers> I think that could/should be a new issue, rather than mangling this one
15:08:13 <bowlofeggs> yeah works for me
15:08:23 <ipanova> bowlofeggs: this kind of error we have in multiple situations
15:08:27 <smyers> !propose other Close as NOTABUG, open a new issue to track the validation error
15:08:27 <smyers> #idea Proposed for #1899: Close as NOTABUG, open a new issue to track the validation error
15:08:28 <pulpbot> Proposed for #1899: Close as NOTABUG, open a new issue to track the validation error
15:08:28 <bowlofeggs> we really do ☹
15:08:32 <mhrivnak> ttereshc, are we sure there is no data like this on CDN?
15:08:32 <bowlofeggs> +1
15:08:43 <jcline> I agree it shouldn't traceback, and I'm indifferent about whether this issue transforms or a new one is made.
15:09:00 <mhrivnak> as in, we're not going to have users try to sync repos they care about and suddenly start hitting this failure?
15:09:27 <ttereshc> mhrivnak, no we are not
15:09:28 <dkliban> seems like a problem to me
15:09:50 <smyers> I'm generally against completely rewriting issues into new ones, since we lose some paper trail in the event that this really *is* a bug and we should reopen this.
15:09:53 <jcline> Well if there is, isn't a malformed erratum that should get fixed there?
15:09:58 <ttereshc> mhrivnak, but if we will silently skip, then they won't be aware of the problem
15:10:12 <smyers> That said, I agree with ttereshc, this is a malformed errata, not a pulp bug.
15:10:48 <mhrivnak> Ok. If we think there's a chance the stricter validation will affect real-world repos, I think we need to carefully consider *some change* in 2.8.4.
15:11:12 <smyers> And also ttereshc++ for making the pulp-fixture PR, which has already been merged.
15:11:26 <bmbouter> FYI: I changed the errata with the first commit to the fixtures
15:11:30 <mhrivnak> malformed or not, if pulp was happily syncing a repo with 2.8.3, and starts failing with 2.8.4, that's a bad user experience.
15:11:49 <bmbouter> I was told the zoo repo errata was bad and that the one from jsherrill's zoo repo was the one to use
15:12:04 <dkliban> mhrivnak: so the repository chagned
15:12:08 <bmbouter> that likely introduced this issue
15:12:10 <jcline> Maybe have a task to check the errata on the CDN?
15:12:25 <bmbouter> if we're talking about the zoo repo here
15:12:26 <mhrivnak> Ok. If we're certain it's isolated to this repo, then that's fine.
15:12:28 <smyers> I think the current triage proposal is still good, and this is a discussion for after this meeting.
15:12:30 <ipanova> looking at pulp-fixtures updateinfo.xml it missed the updated field, but afaik errata should always have updated field. that said --> updateinfo.xml was not correct
15:12:35 <ipanova> ttereshc: am i right?^
15:12:50 <smyers> ^ that is my understanding
15:12:51 <ttereshc> I think so
15:13:06 <ipanova> then
15:13:07 <ipanova> !propose other Close as NOTABUG
15:13:07 <ipanova> #idea Proposed for #1899: Close as NOTABUG
15:13:08 <pulpbot> Proposed for #1899: Close as NOTABUG
15:13:23 <dkliban> we need to fix the fixture repo
15:13:27 <dkliban> so the bug could be about tht
15:13:32 <ttereshc> but mhrivnak's concern is also valid
15:13:33 <ipanova> dkliban: ttereshcsubmitted PR already
15:13:39 <mhrivnak> I see.
15:13:49 <dkliban> ipanova: PR to fix the fixture?
15:13:54 <ttereshc> dkliban, yes
15:13:54 <ipanova> dkliban: yep
15:13:56 <mhrivnak> ttereshc, if this came up only because of an error in the recent changes to the zoo repo, then I feel good about it.
15:13:59 <ipanova> and seems like already merged
15:14:16 <ttereshc> mhrivnak, let's discuss it.
15:14:21 <bowlofeggs> i think we should still have the last proposal, to file a new bug too
15:14:28 <smyers> yerp
15:14:28 <dkliban> i am not closing it yeet ... i am just skipping it.
15:14:34 <bowlofeggs> !propose other Close as NOTABUG, open a new issue to track the validation error
15:14:34 <bowlofeggs> #idea Proposed for #1899: Close as NOTABUG, open a new issue to track the validation error
15:14:34 <ttereshc> mhrivnak, I think the zoo repo was not good but you are also right
15:14:34 <pulpbot> Proposed for #1899: Close as NOTABUG, open a new issue to track the validation error
15:14:52 <ttereshc> mhrivnak, after triage
15:14:55 <smyers> It really should be closed, imo (as proposed)
15:15:07 <mhrivnak> I agree with the proposal.
15:15:16 <bowlofeggs> #idea Proposed for #1899: Leave the issue as-is, accepting its current state.
15:15:16 <bowlofeggs> !propose accept
15:15:17 <pulpbot> Proposed for #1899: Leave the issue as-is, accepting its current state.
15:15:21 <bowlofeggs> ugh
15:15:24 <bowlofeggs> #idea Proposed for #1899: Close as NOTABUG, open a new issue to track the validation error
15:15:24 <bowlofeggs> !propose other Close as NOTABUG, open a new issue to track the validation error
15:15:24 <pulpbot> Proposed for #1899: Close as NOTABUG, open a new issue to track the validation error
15:15:29 <bowlofeggs> i keep forgetting what that means
15:15:45 <mhrivnak> ttereshc, I think a new bug to improve the error handling would be great, and we can discuss details there? Does that line up with your thinking?
15:15:55 <dkliban> !skip
15:15:58 <ttereshc> mhrivnak, ok
15:15:59 <pulpbot> 1 issues left to triage: 1900
15:16:00 <dkliban> #topic RFE: Please enable/support Redis as a celery broker transport in pulp - http://pulp.plan.io/issues/1900
15:16:01 <pulpbot> Pulp Issue #1900 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:16:01 <pulpbot> RFE: Please enable/support Redis as a celery broker transport in pulp - http://pulp.plan.io/issues/1900
15:16:02 <pulpbot> bowlofeggs: Issue 1900 is currently being discussed.
15:16:04 <smyers> :( it should have been accepted
15:16:21 <bowlofeggs> yeah i thought we had agreement on that last one
15:16:41 <bowlofeggs> ok so this one is really a feature request, but i'm not sure how much they need it yet
15:16:41 <smyers> !suggest resolution for #1899 should have been "Close as NOTABUG, open a new issue to track the validation error"
15:16:41 <smyers> #idea resolution for #1899 should have been Close as NOTABUG, open a new issue to track the validation error
15:16:43 <dkliban> bowlofeggs: to close it as not a bug? i think that we need to test the change ttereshc made and then close it
15:16:58 <bowlofeggs> i've been talking with maxamillion about this one
15:17:09 <bowlofeggs> as fedora wants to use pulp, they do not want to use qpidd
15:17:16 <smyers> but not rabbit?
15:17:17 <bowlofeggs> they might use rabbit
15:17:19 <smyers> :)
15:17:23 <bowlofeggs> but they already have redis in a few places
15:17:26 <bowlofeggs> and they'd prefer to use that
15:17:31 <ipanova> we are anyway planning to get rid of qpid
15:17:32 <mhrivnak> Are we doing anything currently to make redis not work?
15:17:35 <bowlofeggs> since celery can do it, i think it won't be much work for us
15:17:43 <bowlofeggs> i think we may need ot test it
15:17:48 <bowlofeggs> i'd bet it doesn't "just work"
15:17:52 <bowlofeggs> just because of our settings
15:17:59 <bowlofeggs> i've not tried it though
15:18:23 <smyers> !propose other Convert to task: Test pulp with redis as a kombu backend
15:18:23 <smyers> #idea Proposed for #1900: Convert to task: Test pulp with redis as a kombu backend
15:18:24 <pulpbot> Proposed for #1900: Convert to task: Test pulp with redis as a kombu backend
15:18:28 <bowlofeggs> +1
15:18:28 <mhrivnak> +1
15:18:31 <ipanova> +1
15:18:39 <dkliban> !accept
15:18:39 <dkliban> #agreed Convert to task: Test pulp with redis as a kombu backend
15:18:39 <jcline> +1
15:18:39 <pulpbot> Current proposal accepted: Convert to task: Test pulp with redis as a kombu backend
15:18:40 <pulpbot> No issues to triage.
15:18:44 <ipanova> yay
15:18:48 <bowlofeggs> nice
15:18:50 <bowlofeggs> good job pulpbot
15:18:55 <dkliban> do we want to revisit any issues i skipped?
15:19:03 <mhrivnak> on #1900, who is going to do the converting?
15:19:05 <bowlofeggs> maybe that last one
15:19:15 <smyers> bowlofeggs, you mean 1899?
15:19:37 <bowlofeggs> smyers: yeah
15:20:11 <smyers> Yeah, I'd like to revisit that one as well
15:20:26 <dkliban> !issue 1899
15:20:26 <dkliban> #topic Repo sync failure with "time data '' does not match format '%Y-%m-%d %H:%M:%S'" - http://pulp.plan.io/issues/1899
15:20:27 <pulpbot> RPM Support Issue #1899 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:20:27 <pulpbot> Repo sync failure with "time data '' does not match format '%Y-%m-%d %H:%M:%S'" - http://pulp.plan.io/issues/1899
15:20:28 <pulpbot> ttereshc: Issue 1899 is currently being discussed.
15:20:54 <smyers> bowlofeggs, got that prosal handy?
15:21:00 <smyers> proposal
15:21:41 <smyers> #idea Proposed for #1899: Close as NOTABUG, open a new issue to track the validation error
15:21:41 <smyers> !propose other Close as NOTABUG, open a new issue to track the validation error
15:21:41 <pulpbot> Proposed for #1899: Close as NOTABUG, open a new issue to track the validation error
15:21:43 <smyers> found it
15:21:57 <bowlofeggs> oh thanks
15:22:17 <smyers> So why not close it?
15:22:32 <preethi> 2 things that I noticed with that bug
15:23:06 <preethi> syncing with same feed was successful in 2.8.3
15:23:39 <preethi> also the zoo repo in demo worked
15:23:47 <preethi> and the fixture one failed
15:23:52 <preethi> in 2.9
15:24:04 <mhrivnak> Sorry, computer froze, had to reboot. :(
15:24:07 <dkliban> preethi: yeah ... those repos aredifference
15:24:12 <dkliban> they are different
15:24:52 <ttereshc> and in 2.8.3 and before errata were not updated
15:25:08 <dkliban> preethi: zoo repo in demo_repos is different from the fixtures repo.
15:25:27 <dkliban> and the fixtures repo has now been fixed. so you should try it again
15:26:11 <preethi> dkliban: that is no problem. Just mentioed it since we were discussing the issue.
15:26:45 <dkliban> preethi: gotcha
15:26:50 <smyers> I guess the question is whether or not we introduced a regression by rejecting malformed errata that we used to accept, is that right?
15:27:12 <smyers> And then, is that really an issue, since the only malformed errata we've seen is the one we made for zoo?
15:27:19 <dkliban> did we used to accept it though?
15:27:22 <mhrivnak> smyers, I think that's exactly it.
15:27:38 <ttereshc> dkliban, yes we did
15:27:41 <mhrivnak> I think we did get stricter in a Z release.
15:27:50 <ttereshc> updated field is just a string
15:27:55 <mhrivnak> And also that the only place we've seen a problem is our own recent change to zoo.
15:28:05 <smyers> And that's the annoying part...
15:28:12 <dkliban> ttereshc: gotcha
15:28:20 <ttereshc> mhrivnak, we still accept malformed errata for the first time
15:28:27 <mhrivnak> Ya, it's kind of bad luck.
15:28:37 <mhrivnak> ttereshc, ah yes.
15:28:37 <ttereshc> but we can't update if it is malformed
15:29:00 <smyers> so that's potentially the new issue about how to handle the validation error
15:29:02 <ttereshc> in this case we fail
15:29:14 <ttereshc> smyers, agree
15:29:15 <smyers> But #1899 is not a bug, imo.
15:29:59 <smyers> And if we break backward compatibility in 2.8.3 for this, it's perfectly reasonable to fix it in 2.8.4.
15:30:33 <smyers> But while I think we did technically break backward compatibility, we only did it when updating the broken errata the we made for zoo.
15:30:51 <smyers> It's not even an edge case, it's a completely contrived unreal case.
15:31:11 <mhrivnak> +1
15:32:08 <dkliban> so whlol
15:32:11 <dkliban> lol
15:32:37 <ttereshc> smyers, we do not know what data can be in the `updated` field in our customers' databases..
15:32:42 <ttereshc> anything)
15:33:30 <smyers> Don't we, though? It would be whatever was in the errata they got from their feed, which (so far) we have no reason to think has been made "wrong"
15:33:44 <ttereshc> smyers, they can upload
15:33:56 <ttereshc> not only sync
15:34:01 <smyers> But if they upload something that isn't an errata...
15:34:04 <smyers> It's not pulp's fault
15:34:14 <mhrivnak> They can "upload" an errata.
15:34:38 <mhrivnak> But I suspect nobody does except RCM.
15:34:39 <smyers> Right, but if they upload something as an errata that isn't a valid errata, that isn't pulp's problem.
15:35:00 <ipanova> smyers: +1
15:35:04 <smyers> Except for the part where we need to improve the feedback on out validation, and explode with a good reason, not a traceback.
15:35:12 <mhrivnak> +1
15:35:18 <bmbouter> +1
15:35:22 <smyers> (which is the current proposal)
15:35:25 * mhrivnak notes that we are 5 minutes over time.
15:35:48 <jalbertson> smyers, I agree it isn't Pulp's problem, but it could be perceived that it was our problem, which is why I think we resolve that by improving the feedback
15:35:58 <smyers> ...which is the current proposal
15:36:06 <jalbertson> smyers, yep - I'm agreeing  :)
15:36:17 <smyers> sweet
15:36:17 <dkliban> can i so can we end triage?
15:36:29 <smyers> I think !accept then !end, yeah
15:36:34 <dkliban> #agreed Close as NOTABUG, open a new issue to track the validation error
15:36:34 <dkliban> !accept
15:36:34 <pulpbot> Current proposal accepted: Close as NOTABUG, open a new issue to track the validation error
15:36:35 <dkliban> #endmeeting
15:36:35 <dkliban> !end
15:36:35 <pulpbot> No issues to triage.