14:31:14 <mhrivnak> #startmeeting Pulp Triage 2016-05-20
14:31:14 <mhrivnak> #info mhrivnak has joined triage
14:31:15 <pulpbot> Meeting started Fri May 20 14:31:14 2016 UTC and is due to finish in 60 minutes.  The chair is mhrivnak. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:15 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:15 <pulpbot> The meeting name has been set to 'pulp_triage_2016_05_20'
14:31:15 <pulpbot> mhrivnak has joined triage
14:31:33 <ttereshc> #info ttereshc has joined triage
14:31:33 <ttereshc> !here
14:31:33 <pulpbot> ttereshc has joined triage
14:31:42 <pcreech> #info pcreech has joined triage
14:31:42 <pcreech> !here
14:31:42 <pulpbot> pcreech has joined triage
14:31:43 <ipanova> !here
14:31:43 <ipanova> #info ipanova has joined triage
14:31:43 <pulpbot> ipanova has joined triage
14:32:00 <jcline> !here
14:32:00 <jcline> #info jcline has joined triage
14:32:01 <pulpbot> jcline has joined triage
14:32:08 <mhrivnak> !next
14:32:10 <pulpbot> 18 issues left to triage: 1088, 1893, 1903, 1916, 1918, 1919, 1921, 1922, 1923, 1924, 1925, 1926, 1928, 1929, 1930, 1931, 1932, 1933
14:32:10 <mhrivnak> #topic Incremental publish could use the wrong primary.xml during fast-forward publish - http://pulp.plan.io/issues/1088
14:32:11 <pulpbot> RPM Support Issue #1088 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:12 <pulpbot> Incremental publish could use the wrong primary.xml during fast-forward publish - http://pulp.plan.io/issues/1088
14:32:23 <asmacdo> !here
14:32:23 <asmacdo> #info asmacdo has joined triage
14:32:23 <pulpbot> asmacdo has joined triage
14:33:06 <preethi> #info preethi has joined triage
14:33:06 <preethi> !here
14:33:06 <pulpbot> preethi has joined triage
14:33:09 <mhrivnak> Questions? Comments?
14:33:21 <pcreech> This one looks ok to me.. Since it's already on the next sprint and looks to be up to doate
14:33:23 <mhrivnak> we discussed this one recently.
14:33:48 <smyers> We even put it on the next sprint, it seems like it's behaving like high priority already
14:33:58 <smyers> severity is probably low
14:34:37 <mhrivnak> #idea Proposed for #1088: Priority: Normal, Severity: Low
14:34:37 <mhrivnak> !propose triage medium low
14:34:37 <pulpbot> Proposed for #1088: Priority: Normal, Severity: Low
14:34:42 <jcline> Yeah, probably, although as we said yesterday it _might_ be responsible for mysterious bugs
14:34:51 <jcline> I'm fine with medium low though
14:35:02 <bowlofeggs> !here
14:35:02 <bowlofeggs> #info bowlofeggs has joined triage
14:35:03 <pulpbot> bowlofeggs has joined triage
14:35:27 <pcreech> Yeah, i think yesterday we did say it could be more importnat than it looks on the surface..
14:35:29 <mhrivnak> Any last comments?
14:35:58 <mhrivnak> Being on the sprint means it'll get attention soon.
14:36:34 <smyers> It *could* be, but we don't know if it is. So it's getting done, but severity is actual impact. As far as we know, this is hurting anything.
14:36:44 <smyers> We still won't really know, even after fixing it, if it was hurting anything.
14:37:00 <jortel> !here
14:37:00 <jortel> #info jortel has joined triage
14:37:01 <pulpbot> jortel has joined triage
14:37:08 <mhrivnak> any objections or new proposals? Otherwise I'll accept.
14:37:14 <pcreech> Sounds good to me
14:37:15 <ipanova> let's triage it
14:37:18 <mhrivnak> #agreed Priority: Normal, Severity: Low
14:37:18 <mhrivnak> !accept
14:37:18 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:37:20 <mhrivnak> #topic pulp_docker does not support Docker < 1.10 with manifests that were published from Docker >= 1.10 - http://pulp.plan.io/issues/1893
14:37:20 <pulpbot> 17 issues left to triage: 1893, 1903, 1916, 1918, 1919, 1921, 1922, 1923, 1924, 1925, 1926, 1928, 1929, 1930, 1931, 1932, 1933
14:37:21 <pulpbot> Docker Support Issue #1893 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:37:22 <pulpbot> pulp_docker does not support Docker < 1.10 with manifests that were published from Docker >= 1.10 - http://pulp.plan.io/issues/1893
14:37:52 <pcreech> Did we get info on this from RCM yet?
14:38:08 <mhrivnak> Not that I know of. Who was following that?
14:38:22 <mhrivnak> bowlofeggs ?
14:38:33 <asmacdo> bowlofeggs, am i correct in saying that this *only* affects RCM?
14:38:43 <bowlofeggs> no this will affect everyone
14:38:52 <mhrivnak> agreed, it could affect any user.
14:38:53 <bowlofeggs> the question is "how much" and "when"
14:39:02 <asmacdo> isnt v1 basically gone?
14:39:08 <bowlofeggs> it's not about v1/v2
14:39:16 <bowlofeggs> it's about v2 schema 1 and v2 schema 2
14:39:29 <bowlofeggs> i haven't heard from rcm about this though
14:39:36 <bowlofeggs> other than their initial report
14:39:38 <mhrivnak> Who on their side was going to do the testing?
14:39:39 <bowlofeggs> it's def important
14:39:47 <bowlofeggs> not sure
14:40:03 <pcreech> +1 to deferring again till we can get more information on this
14:40:15 <mhrivnak> Who reported it to us?
14:40:21 <pcreech> (as that was the decision last week)
14:40:30 <mhrivnak> Or any suggestion on who we should follow up with?
14:40:37 <bowlofeggs> i just wrote twaugh to ask
14:40:46 <mhrivnak> Great, thanks.
14:40:51 <mhrivnak> !skip
14:40:53 <mhrivnak> #topic RPM import traceback (non-utf-8 metadata slipping through) - http://pulp.plan.io/issues/1903
14:40:53 <pulpbot> 16 issues left to triage: 1903, 1916, 1918, 1919, 1921, 1922, 1923, 1924, 1925, 1926, 1928, 1929, 1930, 1931, 1932, 1933
14:40:54 <pulpbot> Pulp Issue #1903 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:55 <pulpbot> RPM import traceback (non-utf-8 metadata slipping through) - http://pulp.plan.io/issues/1903
14:42:56 <mhrivnak> This only affects rpms that don't conform to the utf-8 standard requirement.
14:43:17 <smyers> Doesn't that mean they are't rpms?
14:43:25 <mhrivnak> We've seen a handful of old SUSE packages in that category in the past.
14:43:29 <bowlofeggs> smyers: lol
14:43:30 <smyers> Similar to how malformed errata shouldn't be accepted as errata?
14:43:48 <bowlofeggs> yeah this ticket should just be about better error reporting
14:44:04 <bowlofeggs> "this RPM didn't use UTF-8, please work with your vendor to correct this."
14:44:16 <jcline> I tend to agree. I also looked and the current behaviour for upload is to blindly encode to latin-1, which, as bowlofeggs noted in that issue, is dangerous and incorrect.
14:44:29 <jortel> +1
14:44:31 <smyers> !propose low low
14:44:32 <pulpbot> Error: "propose" is not a valid command.
14:44:32 <mhrivnak> It is also what createrepo_c does.
14:44:34 <mhrivnak> FWIW
14:44:34 <smyers> dammit
14:44:42 <smyers> #idea Proposed for #1903: Priority: Low, Severity: Low
14:44:42 <smyers> #info smyers has joined triage
14:44:42 <smyers> !propose triage low low
14:44:42 <pulpbot> smyers has joined triage
14:44:43 <pulpbot> Proposed for #1903: Priority: Low, Severity: Low
14:44:51 <smyers> Waht does createrepo_c do?
14:44:52 <mhrivnak> But we're drifting into how to fix it, rather than establishing priority.
14:45:06 <mhrivnak> createrepo and createrepo_c both will fall back to encoding as latin1
14:45:27 <bowlofeggs> citing other bad behavior is still [citation-needed]
14:45:39 <bowlofeggs> this is why python 3 was created without strings
14:45:57 <bowlofeggs> or really just "this is why python 3 was created"
14:46:01 <bowlofeggs> this being "this problem"
14:46:02 <smyers> But, again, if we agree that non-utf-8 rpms are malformed, we need to fix the error message and not mangle strings
14:46:08 <bowlofeggs> yep
14:46:46 <mhrivnak> any other thoughts on the priority?
14:46:48 <jortel> yep
14:46:54 <ttereshc> +1 to low low
14:47:10 <bowlofeggs> low/low
14:47:13 <bowlofeggs> how low can you go
14:47:14 <mhrivnak> #agreed Priority: Low, Severity: Low
14:47:14 <mhrivnak> !accept
14:47:14 <pulpbot> Current proposal accepted: Priority: Low, Severity: Low
14:47:16 <pulpbot> 15 issues left to triage: 1916, 1918, 1919, 1921, 1922, 1923, 1924, 1925, 1926, 1928, 1929, 1930, 1931, 1932, 1933
14:47:17 <mhrivnak> #topic Unable to install packages with `.` in the name on pip==8.1.2 - http://pulp.plan.io/issues/1916
14:47:17 <pulpbot> Python Support Issue #1916 [NEW] (unassigned) - Priority: Normal | Severity: Urgent
14:47:18 <pulpbot> Unable to install packages with `.` in the name on pip==8.1.2 - http://pulp.plan.io/issues/1916
14:47:29 <bowlofeggs> he said this wasn't an issue and we should close
14:47:49 <asmacdo> +1
14:48:06 <smyers> / pulpbot
14:48:29 <smyers> #idea Proposed for #1916: closed notabug
14:48:29 <smyers> !propose other closed notabug
14:48:29 <pulpbot> Proposed for #1916: closed notabug
14:48:46 <mhrivnak> smyers, will !accept cause pulpbot to close it?
14:49:34 <smyers> pulpbot does not touch redmine except in a read-only way
14:49:34 <pulpbot> Error: "does" is not a valid command.
14:49:36 <smyers> heh
14:49:48 <smyers> pulpbot echo I don't make changes to redmine.
14:49:48 <pulpbot> I don't make changes to redmine.
14:50:08 <mhrivnak> Gotcha.
14:50:17 <mhrivnak> #agreed closed notabug
14:50:17 <mhrivnak> !accept
14:50:17 <pulpbot> Current proposal accepted: closed notabug
14:50:19 <pulpbot> 14 issues left to triage: 1918, 1919, 1921, 1922, 1923, 1924, 1925, 1926, 1928, 1929, 1930, 1931, 1932, 1933
14:50:19 <mhrivnak> #topic pulp depends on m2crypto, which will not be ported to Python 3 - http://pulp.plan.io/issues/1918
14:50:20 <pulpbot> Pulp Issue #1918 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:50:21 <pulpbot> pulp depends on m2crypto, which will not be ported to Python 3 - http://pulp.plan.io/issues/1918
14:50:31 <smyers> Because giving IRC bots the ability to mess with our redmine issues is *terrifying* to me. :)
14:50:47 <smyers> !propose high med
14:50:47 <pulpbot> Error: "propose" is not a valid command.
14:50:55 <smyers> daaaaaaammit I wrote the damn thing
14:50:59 <smyers> !propose triage high med
14:50:59 <smyers> #idea Proposed for #1918: Priority: High, Severity: Medium
14:51:00 <pulpbot> Proposed for #1918: Priority: High, Severity: Medium
14:51:10 <smyers> This might even be an easay fix
14:51:21 <bowlofeggs> +1 we need to start prioritizing py3
14:51:25 <jcline> smyers, I looked a bit and we use m2crypto in the consumer stuff I think
14:51:36 <bowlofeggs> and m2 is no bueno anyway
14:51:38 <ipanova> !care 1928
14:51:48 <ipanova> hm
14:51:48 <mhrivnak> also in the bindings. We probably need to drop py 2.4 before we can do this.
14:51:49 <jcline> Everywhere else is an easy fix, but python-cryptography is 2.6+
14:52:00 <smyers> Right
14:52:02 <jcline> SCLs woo
14:52:11 <jortel> seems this should be a story or task
14:52:17 <bowlofeggs> yeah SCLs - we can still support EL5 that way
14:52:45 <bowlofeggs> agreed on high/med
14:52:52 <bowlofeggs> or even high/low
14:52:59 <mhrivnak> We also won't have a need to support el5 once we get to pulp 3.0.
14:53:03 <jcline> Actually there might not be el5 scls :(
14:53:13 <bowlofeggs> https://en.wikipedia.org/wiki/High/Low_%28Nada_Surf_album%29
14:53:14 <pulpbot> Title: High/Low (Nada Surf album) - Wikipedia, the free encyclopedia (at en.wikipedia.org)
14:53:15 <bowlofeggs> jcline:14:53:19 <jcline> Either way, High something.
14:53:40 <bowlofeggs> it's not severe… yet
14:53:43 <bowlofeggs> but it will be!
14:53:47 <smyers> To jortel's point, I actually can't decide if it's an Issue, Story, or Task.
14:53:49 <jcline> M2crypto is pretty much dead anyway. I would not be surprised if some were CVEs against it.
14:53:54 <bowlofeggs> py 2's days are numbered
14:54:07 <smyers> Seems like an enhancement until we move to py3
14:54:12 <mhrivnak> Oh good point. Refactor maybe?
14:54:12 <smyers> But then it's definitely a bug?
14:54:13 <jortel> right.  bug=defect and this is not a defect.
14:54:14 <bowlofeggs> i say not a story, but a refactor makes sense
14:54:19 <bowlofeggs> it's not a feature
14:54:27 <smyers> Refactor works
14:54:40 <smyers> No behavior change, just the internals, seems perfect
14:54:41 <jcline> I'm sure I could find defects in m2crypto, but I'm fine with whatever classification people want
14:54:44 <bowlofeggs> it will be an issue if it's not done in time
14:54:49 <bowlofeggs> so there's that aspect to it
14:55:05 <jortel> seems like a task
14:55:07 <bowlofeggs> and "in time" is sooner than you may think
14:55:18 <smyers> !propose other High Priority still, but change to Refactor or Task tracker
14:55:18 <smyers> #idea Proposed for #1918: High Priority still, but change to Refactor or Task tracker
14:55:19 <pulpbot> Proposed for #1918: High Priority still, but change to Refactor or Task tracker
14:55:30 <smyers> I wrote that weirdly. Go me.
14:55:40 <mhrivnak> jortel, why task instead of refactor?
14:55:52 <bowlofeggs> let's move on rather than debate task vs. refactor
14:55:57 <mhrivnak> I'm not sure it makes a lot of difference, but am curious. :)
14:56:30 <mhrivnak> Ok, there are 3 suggestions for refactor, so I'll go with that for now and move on.
14:56:41 <jortel> refactor seems more appropriate for changing how pulp does something but selecting a different lib seems like a task.  I'm fine with refactor.
14:56:50 <mhrivnak> #agreed High Priority still, but change to Refactor or Task tracker
14:56:50 <mhrivnak> !accept
14:56:50 <pulpbot> Current proposal accepted: High Priority still, but change to Refactor or Task tracker
14:56:52 <pulpbot> 13 issues left to triage: 1919, 1921, 1922, 1923, 1924, 1925, 1926, 1928, 1929, 1930, 1931, 1932, 1933
14:56:53 <mhrivnak> #topic pulp depends on python-ldap, which will not be ported to Python 3 - http://pulp.plan.io/issues/1919
14:56:53 <pulpbot> Pulp Issue #1919 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:56:54 <pulpbot> pulp depends on python-ldap, which will not be ported to Python 3 - http://pulp.plan.io/issues/1919
14:57:08 <bowlofeggs> same
14:57:24 <bowlofeggs> #idea Proposed for #1919: High Priority still, but change to Refactor or Task tracker
14:57:24 <bowlofeggs> !propose other High Priority still, but change to Refactor or Task tracker
14:57:24 <pulpbot> Proposed for #1919: High Priority still, but change to Refactor or Task tracker
14:57:27 <smyers> !suggest Consensus for #1918 was to use the refactor tracker
14:57:27 <smyers> #idea Consensus for #1918 was to use the refactor tracker
14:57:36 <mhrivnak> !accept
14:57:37 <mhrivnak> #agreed High Priority still, but change to Refactor or Task tracker
14:57:37 <pulpbot> Current proposal accepted: High Priority still, but change to Refactor or Task tracker
14:57:38 <mhrivnak> #topic pulp-rpm depends on pyliblzma, which will not be ported to Python 3 - http://pulp.plan.io/issues/1921
14:57:39 <pulpbot> 12 issues left to triage: 1921, 1922, 1923, 1924, 1925, 1926, 1928, 1929, 1930, 1931, 1932, 1933
14:57:40 <pulpbot> RPM Support Issue #1921 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:57:41 <pulpbot> pulp-rpm depends on pyliblzma, which will not be ported to Python 3 - http://pulp.plan.io/issues/1921
14:57:44 <bowlofeggs> !propose other High Priority still, but change to Refactor or Task tracker
14:57:44 <bowlofeggs> #idea Proposed for #1921: High Priority still, but change to Refactor or Task tracker
14:57:45 <pulpbot> Proposed for #1921: High Priority still, but change to Refactor or Task tracker
14:57:46 <smyers> !suggest Consensus for #1919 was also to use the refactor tracker
14:57:46 <smyers> #idea Consensus for #1919 was also to use the refactor tracker
14:57:55 <smyers> :)
14:57:56 <mhrivnak> #agreed High Priority still, but change to Refactor or Task tracker
14:57:56 <mhrivnak> !accept
14:57:56 <pulpbot> Current proposal accepted: High Priority still, but change to Refactor or Task tracker
14:57:56 <bowlofeggs> haha
14:57:58 <pulpbot> 11 issues left to triage: 1922, 1923, 1924, 1925, 1926, 1928, 1929, 1930, 1931, 1932, 1933
14:57:58 <mhrivnak> #topic unhandled exception when changing feed to equivalent repo - http://pulp.plan.io/issues/1922
14:57:59 <pulpbot> RPM Support Issue #1922 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:58:00 <pulpbot> unhandled exception when changing feed to equivalent repo - http://pulp.plan.io/issues/1922
14:58:11 <smyers> !suggest Consensus for #1921 was also to use the refactor tracker
14:58:11 <smyers> #idea Consensus for #1921 was also to use the refactor tracker
14:58:15 <bowlofeggs> hahaha
14:58:16 <bowlofeggs> sorry smyers
14:58:20 <smyers> gotta get those minutes lookin' good
14:58:58 <smyers> This issue hurts my brain.
14:59:03 <smyers> For the record.
14:59:12 <smyers> !suggest This issue hurts my brain.
14:59:12 <smyers> #idea This issue hurts my brain.
14:59:22 <smyers> (Now it' son the record)
14:59:37 <mhrivnak> Crap, I forgot to note who reported this to me. I'm pretty sure it was omaciel .
15:00:05 <smyers> So is the solution to just overwrite the link if it already exists?
15:00:11 <asmacdo> "cloud-qe" seems to back up your guess mhrivnak
15:00:22 <smyers> I don't get what's going enough well enough to triage it.
15:00:42 <bowlofeggs> does seem like a use case that should work, though not sure how important it is
15:00:56 <bowlofeggs> !propose triage med med
15:00:56 <bowlofeggs> #idea Proposed for #1922: Priority: Normal, Severity: Medium
15:00:57 <pulpbot> Proposed for #1922: Priority: Normal, Severity: Medium
15:01:03 <mhrivnak> I think it's basically saying if there are 2 mirrors of the same content, and you switch the feed from one to the other, it breaks.
15:01:20 <mhrivnak> And in the case where that was seen, both mirrors happened to also be pulps.
15:01:42 <bowlofeggs> could be that pulp doesn't write the data consistently in publish
15:01:47 <jortel> seems like higher than med/med
15:01:52 <bowlofeggs> because the CDN is mirrors all the way down
15:01:55 <bowlofeggs> and that works
15:02:14 <bowlofeggs> jortel: only if there's a real use case for this
15:02:15 <mhrivnak> Indeed, we know for sure the two pulps will have slightly different data in repodata/
15:02:18 <bowlofeggs> which i don't know of
15:02:46 <bowlofeggs> without a use case, i might even argue low/med
15:02:52 <smyers> Yeah, that's my feeling as well.
15:02:53 <mhrivnak> There are people using multiple pulps behind a load balancer, and active work to improve that use case.
15:03:08 <bowlofeggs> yeah that's a use case
15:03:43 <bowlofeggs> !propose med high
15:03:43 <pulpbot> Error: "propose" is not a valid command.
15:03:46 <smyers> So Pulp A and Pulp B are behind a load balancer, something else is keeping them synced, Pulp C syncs from the load balancer
15:03:50 <bowlofeggs> !propose triage med high
15:03:50 <bowlofeggs> #idea Proposed for #1922: Priority: Normal, Severity: High
15:03:50 <smyers> Alright
15:03:50 <pulpbot> Proposed for #1922: Priority: Normal, Severity: High
15:03:52 <smyers> I like it
15:04:01 <smyers> Makes sense now :)
15:04:03 <jortel> works for me
15:04:04 <mhrivnak> !accept
15:04:04 <pulpbot> Current proposal accepted: Priority: Normal, Severity: High
15:04:04 <mhrivnak> #agreed Priority: Normal, Severity: High
15:04:06 <mhrivnak> #topic POST /pulp/api/v2/content/actions/delete_orphans/ is broken - http://pulp.plan.io/issues/1923
15:04:06 <pulpbot> 10 issues left to triage: 1923, 1924, 1925, 1926, 1928, 1929, 1930, 1931, 1932, 1933
15:04:07 <pulpbot> Pulp Issue #1923 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:04:08 <pulpbot> POST /pulp/api/v2/content/actions/delete_orphans/ is broken - http://pulp.plan.io/issues/1923
15:04:21 <bowlofeggs> actually, putting two pulps behind a load balancer that aren't using NFS is not supported
15:04:26 <bowlofeggs> so i don't think that's a real use case
15:04:31 <bowlofeggs> i suggest going back to that last one
15:04:34 <bowlofeggs> if we can
15:05:04 <bowlofeggs> they would be using NFS and would be identical
15:05:15 <smyers> I think the best way is to bring it up after we get through the list?
15:05:29 <bowlofeggs> sure
15:05:30 <smyers> #1923 sounds like a regression and bad
15:05:35 <mhrivnak> sounds good.
15:05:42 <bowlofeggs> agreed on #1923
15:06:01 <jortel> +1
15:06:09 <asmacdo> smyers, i wouldnt say its that bad
15:06:18 <smyers> It's a regression.
15:06:20 <mhrivnak> There is a clear workaround it seems.
15:06:21 <asmacdo> there is another API endpoint that does the same thing
15:06:24 <smyers> Regressions are bad.
15:06:29 <bowlofeggs> it doesn't say how it's broken though right?
15:06:56 <bowlofeggs> yeah regressions are bad
15:06:57 <bowlofeggs> +1
15:06:59 <smyers> Having two API endpoints that do the same thing is also bad, but that's not justification to break one of them.
15:07:19 <mhrivnak> I don't think anyone is arguing it's justified to break one.
15:07:33 <smyers> So...we should fix this one.
15:07:35 <smyers> Immediately.
15:07:36 <bowlofeggs> yeah
15:07:47 <mhrivnak> But knowing that there's a workaround for an issue often affects the severity decision.
15:07:48 <bowlofeggs> !propose triage med high
15:07:48 <bowlofeggs> #idea Proposed for #1923: Priority: Normal, Severity: High
15:07:49 <pulpbot> Proposed for #1923: Priority: Normal, Severity: High
15:07:52 <smyers> !propose triage Urgent High 2.8.4
15:07:52 <pulpbot> Error: Unknown Severity
15:08:05 <smyers> Iiiinteresting.
15:08:16 <bowlofeggs> i could do urgent i supose ☺
15:08:21 <bowlofeggs> with two p's even
15:08:21 <smyers> Not having a workaround would make it Urgent. Having a workaround means it's high severity.
15:08:23 <asmacdo> on this is interesting
15:08:39 <asmacdo> it may have been broken for a very very long time
15:08:48 <mhrivnak> That's believable.
15:08:49 <asmacdo> i should have filed a bug on this, but i saw it jan 2015
15:08:51 <asmacdo> https://github.com/pulp/pulp/pull/1579#issuecomment-71904003
15:08:53 <pulpbot> Title: django conversion /v2/content/ by asmacdo · Pull Request #1579 · pulp/pulp · GitHub (at github.com)
15:09:42 <bowlofeggs> i'm ok with any of the proposed priorities
15:09:55 <mhrivnak> Ya, I also don't feel strongly about any of them.
15:09:55 <bowlofeggs> point is we should fix it
15:10:17 <bowlofeggs> smyers seems to feel strongly, so i say we go with his proposal
15:10:18 <smyers> I'm proposing it as a blocker for the next bugfix release (Urgent Prio) because it's a backward-incompabile API change.
15:10:20 <asmacdo> ill add a comment that it should probably point to the same view as the working endpoint
15:10:39 <smyers> So we should either release pulp 3 or fix it.
15:10:46 <bowlofeggs> +1
15:11:02 <bowlofeggs> we do have 2.2 users about to upgrade too ☺
15:11:33 <mhrivnak> #idea Proposed for #1923: urgent medium 2.8.4
15:11:33 <mhrivnak> !propose other urgent medium 2.8.4
15:11:33 <pulpbot> Proposed for #1923: urgent medium 2.8.4
15:11:41 <mhrivnak> Is that what we're thinking?
15:11:47 <smyers> medium sev is good, yeah
15:11:55 <smyers> "Partial but non-critical functionality loss, or other loss of functionality where users are still able to perform their critical tasks."
15:12:04 <smyers> i.e. "Use the other endpoint"
15:12:34 <mhrivnak> Would you agree that if it was broken in 2.7 also, the priority might be lower?
15:12:39 <smyers> Nope.
15:12:46 <jcline> Nope++
15:12:46 <pulpbot> Nope's karma is now 1
15:12:50 <mhrivnak> heh
15:12:58 <smyers> The moment the regression is discovered, it should immediately be recitifed.
15:13:11 <mhrivnak> !accept
15:13:11 <mhrivnak> #agreed urgent medium 2.8.4
15:13:11 <pulpbot> Current proposal accepted: urgent medium 2.8.4
15:13:13 <pulpbot> 9 issues left to triage: 1924, 1925, 1926, 1928, 1929, 1930, 1931, 1932, 1933
15:13:14 <mhrivnak> #topic pulp-server and python-pulp-streamer rpms both provide the pulp_streamer.service systemd unit - http://pulp.plan.io/issues/1924
15:13:14 <pulpbot> Packaging Issue #1924 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:13:15 <pulpbot> pulp-server and python-pulp-streamer rpms both provide the pulp_streamer.service systemd unit - http://pulp.plan.io/issues/1924
15:14:12 <mhrivnak> Seems bad. What's the impact on a user?
15:15:12 <ipanova> ichimonji10: ++
15:15:12 <pulpbot> ichimonji10: 's karma is now 3
15:15:19 <ichimonji10> ipanova: ++
15:15:19 <pulpbot> ipanova: 's karma is now 3
15:15:21 <ichimonji10> teamwork++
15:15:21 <pulpbot> teamwork's karma is now 4
15:16:01 <mhrivnak> !propose skip
15:16:01 <mhrivnak> #idea Proposed for #1924: Skip this issue for this triage session.
15:16:02 <pulpbot> Proposed for #1924: Skip this issue for this triage session.
15:16:15 <jcline> Why are we skipping?
15:16:17 <mhrivnak> Unless someone has more info, perhaps let's ask jcline to add some.
15:16:20 <mhrivnak> Ah, there you are.
15:16:21 <mhrivnak> :)
15:16:26 <mhrivnak> What's the impact on a user?
15:16:45 <jcline> Well, anyone wanting to use the yum file utilities is going to be confused.
15:16:56 <jcline> It's an easy fix and it's just a packaging problem, it seems
15:17:08 <bowlofeggs> this issue also exists in Fedora ☹
15:17:09 <jcline> I'm surprised yum doesn't get upset about installing both, but it doesn't.
15:17:19 <mhrivnak> Right, I'm also surprised by that.
15:17:21 <bmbouter> that is surprising
15:17:28 <smyers> So it doesn't actually break anything?
15:17:38 <smyers> I really would've thought it would break everything.
15:17:39 <jortel> yeah, I'd expect yum/dnf to fail when trying to install both packages
15:17:52 <bowlofeggs> $dnf provides \*pulp_streamer.ser\*
15:17:55 <jcline> smyers, I would also expect it to break everything. Hasn't so far, but who knows
15:18:00 <bowlofeggs> pulp-server-2.8.2-2.fc25.noarch : The pulp platform server
15:18:01 <bowlofeggs> Repo        : rawhide
15:18:03 <bowlofeggs> python2-pulp-streamer-2.8.2-2.fc25.noarch : The pulp lazy streamer
15:18:04 <bowlofeggs> Repo        : rawhide
15:18:06 <bowlofeggs> lol wut
15:18:20 <jcline> I know, right? Seems like maybe there's a bug in dnf/yum that lets this work
15:18:22 <smyers> But...if it *doesn't*, then it might not be a high severity
15:18:26 <mhrivnak> #idea Proposed for #1924: Priority: High, Severity: Low
15:18:26 <mhrivnak> !propose triage high low
15:18:26 <pulpbot> Proposed for #1924: Priority: High, Severity: Low
15:18:31 <bowlofeggs> yeah probably just low sev
15:18:34 <smyers> So yeah, high low's great
15:18:40 <jcline> Let's fix it and talk with upstream
15:18:43 <bowlofeggs> https://en.wikipedia.org/wiki/High/Low_%28Nada_Surf_album%29!propose
15:18:47 <smyers> hahaha
15:18:50 <bowlofeggs> haha
15:18:57 <bowlofeggs> btw, that album is really good
15:19:02 <mhrivnak> !accept
15:19:02 <mhrivnak> #agreed Priority: High, Severity: Low
15:19:02 <pulpbot> Current proposal accepted: Priority: High, Severity: Low
15:19:04 <mhrivnak> #topic v1 sync errors - http://pulp.plan.io/issues/1925
15:19:04 <pulpbot> 8 issues left to triage: 1925, 1926, 1928, 1929, 1930, 1931, 1932, 1933
15:19:05 <pulpbot> Docker Support Issue #1925 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Target Release: 2.8.4
15:19:06 <pulpbot> v1 sync errors - http://pulp.plan.io/issues/1925
15:19:18 <bowlofeggs> maybe pulpbot can paste that link whenever anyone says high/low
15:19:37 <smyers> it definitely could!
15:19:42 <smyers> But it probably never will...
15:19:45 <asmacdo> maybe you could just propose Nada Surf
15:20:01 <smyers> Okay, that one's pretty funny.
15:20:23 <bowlofeggs> i think RCM will hit this issue on a regular basis if we don't fix it
15:20:36 <smyers> Is it an avoidable race?
15:20:43 <bowlofeggs> i don't think os
15:20:45 <bowlofeggs> *so
15:20:49 <bowlofeggs> well
15:20:58 <smyers> Oh, I understand your comment now; I'd misread it.
15:20:58 <bowlofeggs> if the user only does concurrency of one worker it's avoidable
15:21:04 <bowlofeggs> but basically two workers can do this
15:21:23 <smyers> Right. Your suggestion plus ina's make sense.
15:21:28 <bowlofeggs> so there is a workaround but it's not great (set concurrency to 1)
15:21:37 <ipanova> that's an easy fix
15:21:45 <mhrivnak> Expensive workaround.
15:22:01 <mhrivnak> Anyone want to make a proposal?
15:22:04 <smyers> !propose triage High Medium 2.8.4
15:22:05 <pulpbot> Error: Unknown Severity
15:22:16 <smyers> what the hell, pulpbot. Did I forget a .lower() somewhere?
15:22:22 <bowlofeggs> hahaha
15:22:22 <smyers> #idea Proposed for #1925: Priority: High, Severity: Medium, Target Platform Release: 2.8.4
15:22:22 <smyers> !propose triage High med 2.8.4
15:22:22 <pulpbot> Proposed for #1925: Priority: High, Severity: Medium, Target Platform Release: 2.8.4
15:22:26 <smyers> Apparently so.
15:22:26 <jortel> +1
15:22:27 <bowlofeggs> +1
15:22:28 <ipanova> +1
15:22:30 <mhrivnak> #agreed Priority: High, Severity: Medium, Target Platform Release: 2.8.4
15:22:30 <mhrivnak> !accept
15:22:30 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium, Target Platform Release: 2.8.4
15:22:31 <mhrivnak> #topic package without epoch in the erratum pkglist is not handled correctly during publish - http://pulp.plan.io/issues/1926
15:22:32 <pulpbot> 7 issues left to triage: 1926, 1928, 1929, 1930, 1931, 1932, 1933
15:22:33 <pulpbot> RPM Support Issue #1926 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:22:34 <pulpbot> package without epoch in the erratum pkglist is not handled correctly during publish - http://pulp.plan.io/issues/1926
15:23:25 <mhrivnak> ugh
15:23:38 <smyers> heh. https://github.com/seandst/supybot-pulptriage/blob/master/plugin.py#L280 - note what's missing on line 281 :)
15:23:39 <pulpbot> Title: supybot-pulptriage/plugin.py at master · seandst/supybot-pulptriage · GitHub (at github.com)
15:23:44 <smyers> ttereshc++ for this
15:23:56 <smyers> If it's just the demo repo, we should just fix the demo repo
15:24:14 <mhrivnak> I have a feeling that some old el5 repos are like this too.
15:24:18 <mhrivnak> But I don't recall for sure.
15:24:39 <smyers> !propose other CLOSED NOTABUG, open a bug on pulp-fixtures to fix the demo repo generator
15:24:39 <smyers> #idea Proposed for #1926: CLOSED NOTABUG, open a bug on pulp-fixtures to fix the demo repo generator
15:24:40 <pulpbot> Proposed for #1926: CLOSED NOTABUG, open a bug on pulp-fixtures to fix the demo repo generator
15:25:11 <smyers> #idea If it *is* a problem with el5, we can reopen it
15:25:11 <smyers> !suggest If it *is* a problem with el5, we can reopen it
15:25:20 <mhrivnak> If there are any real repos with this trait, it's a big problem.
15:25:30 <jcline> Worth knowing that yum assumes an epoch of 0 if it's not present
15:25:56 <smyers> I'm happy to also needinfo it and come back to it next week
15:26:02 <mhrivnak> If there are real repos like this, it could lead to falsely thinking an errata has been installed.
15:26:24 <bowlofeggs> +1 to not a bug
15:26:35 <bowlofeggs> until we actually see real repos, we should close
15:26:38 <jcline> I'm fine with not a bug
15:26:44 <bowlofeggs> i dont' think we should keep bugs for paranoia's sake
15:26:45 <ttereshc> is there an easy way to find if such repos exist?
15:26:52 <mhrivnak> I have enough of a hunch that there are real repos that I think we should not close it yet.
15:27:06 <bowlofeggs> i think we should close it untila  URL is at hand
15:27:21 <smyers> I wonder if we can back it up a little bit, and focus on this: "Since our demo repo does not contain `epoch` for packages in updateinfo.xml, there will be a `null` value for epoch in the erratum pkglist in the database."
15:27:25 <jcline> ttereshc, short of lazy-syncing the CDN, Centos repos, SLES/OpenSuse repos, Scientific linux repos, etc, I don't know
15:27:29 <smyers> Is that wrong?
15:27:42 <smyers> Should we store 0 instead of null?
15:27:59 <jcline> Possibly?
15:27:59 <mhrivnak> Given the potential severity, I'd rather keep it open. I'll volunteer to go look for real repos like this.
15:28:10 <jortel> I think we should
15:28:21 <mhrivnak> We likely should do that.
15:28:36 <ttereshc> it's an easy fix anyway, we can just fix it
15:28:38 <jcline> I guess if it's ever *not* 0 and it's in the repodata that way, the data is already broken
15:28:40 <smyers> Nevermind if we have or have not seen this in the wild, or ever will, I think that question is the crux of the issue. Is storing null appropriate? I'll update the issue, and in the meantime...
15:28:44 <smyers> !propose needinfo
15:28:44 <smyers> #idea Proposed for #1926: This issue cannot be triaged without more info.
15:28:45 * pcreech wonders if we just go null=>0
15:28:45 <pulpbot> Proposed for #1926: This issue cannot be triaged without more info.
15:29:00 <pcreech> sounds like an easy afternoon fix anyways
15:29:08 <mhrivnak> !accept
15:29:08 <mhrivnak> #agreed This issue cannot be triaged without more info.
15:29:08 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
15:29:10 <pulpbot> 6 issues left to triage: 1928, 1929, 1930, 1931, 1932, 1933
15:29:10 <mhrivnak> #topic Cannot reuse distributor for directory and web publish - http://pulp.plan.io/issues/1928
15:29:11 <pulpbot> RPM Support Issue #1928 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:29:12 <pulpbot> Cannot reuse distributor for directory and web publish - http://pulp.plan.io/issues/1928
15:29:13 <pulpbot> ipanova: Issue 1928 is currently being discussed.
15:29:27 <ipanova> this is a real problem, that's the result of no-op publish. if user will specify something in override config, publish will not happen
15:29:28 <smyers> ^ hehehe I love the care feature :)
15:29:48 <bowlofeggs> yeah care is great
15:30:30 <mhrivnak> ipanova, should we wait on this until you update the description?
15:30:31 <bowlofeggs> smyers: another url pulpbot can send when people !care is https://en.wikipedia.org/wiki/...I_Care_Because_You_Do
15:30:32 <pulpbot> Title: ...I Care Because You Do - Wikipedia, the free encyclopedia (at en.wikipedia.org)
15:30:52 <ipanova> mhrivnak: no let's triage it. i will take care of it and assign to myself
15:31:09 <smyers> ipanova, what do you propose for triage?
15:31:14 <mhrivnak> ipanova, ok. want to propose a priority?
15:31:17 <smyers> haha
15:31:27 <smyers> sorry :)
15:31:37 <ipanova> !Propose triage High normal
15:31:37 <ipanova> #idea Proposed for #1928: Priority: High, Severity: Medium
15:31:38 <pulpbot> Proposed for #1928: Priority: High, Severity: Medium
15:31:53 <mhrivnak> other thoughts or questions? last call...
15:32:09 <ipanova> and it needs to be fixed in this sprint
15:32:11 <smyers> ipanova++ do what she says :)
15:32:14 <mhrivnak> !accept
15:32:14 <mhrivnak> #agreed Priority: High, Severity: Medium
15:32:14 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
15:32:16 <mhrivnak> #topic The 0023_importer_tls_storage.py migration assumes that Importers always have configs when they do not - http://pulp.plan.io/issues/1929
15:32:16 <pulpbot> 5 issues left to triage: 1929, 1930, 1931, 1932, 1933
15:32:17 <pulpbot> Pulp Issue #1929 [POST] (rbarlow) - Priority: Urgent | Severity: Urgent | Target Release: 2.8.4
15:32:18 <pulpbot> The 0023_importer_tls_storage.py migration assumes that Importers always have configs when they do not - http://pulp.plan.io/issues/1929
15:32:24 <jortel> already at POST
15:32:27 <mhrivnak> Ok, we're over time, so agree to !end ?
15:32:39 <mhrivnak> We previously decided to time-box these sessions.
15:32:51 <bowlofeggs> end
15:32:55 <smyers> end++
15:32:55 <pulpbot> end's karma is now 1
15:32:59 <mhrivnak> #endmeeting
15:32:59 <mhrivnak> !end