14:31:32 <dkliban> #startmeeting Pulp Triage 2016-05-25
14:31:32 <dkliban> #info dkliban has joined triage
14:31:33 <pulpbot> Meeting started Wed May 25 14:31:32 2016 UTC and is due to finish in 60 minutes.  The chair is dkliban. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:33 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:33 <pulpbot> The meeting name has been set to 'pulp_triage_2016_05_25'
14:31:33 <pulpbot> dkliban has joined triage
14:31:47 <pcreech> #info pcreech has joined triage
14:31:47 <pcreech> !here
14:31:47 <pulpbot> pcreech has joined triage
14:31:53 <mhrivnak> !here
14:31:53 <mhrivnak> #info mhrivnak has joined triage
14:31:54 <pulpbot> mhrivnak has joined triage
14:32:07 <ttereshc> !here
14:32:07 <ttereshc> #info ttereshc has joined triage
14:32:08 <pulpbot> ttereshc has joined triage
14:32:24 <dkliban> it looks like we have a quorum
14:32:25 <dalley> quick noob question from the intern: where are these bugs located? I don't see them on pulp/pulp
14:32:39 <mhrivnak> great questions! https://pulp.plan.io/projects/pulp_rpm/issues?query_id=30
14:32:40 <dalley> issues**
14:32:41 <pulpbot> Title: Un-Triaged Bugs - RPM Support - Pulp (at pulp.plan.io)
14:32:42 <dkliban> dalley: https://pulp.plan.io/issues?query_id=30
14:32:44 <pulpbot> Title: Un-Triaged Bugs - Pulp (at pulp.plan.io)
14:32:47 <ipanova> !here
14:32:47 <ipanova> #info ipanova has joined triage
14:32:48 <pulpbot> ipanova has joined triage
14:32:54 <mhrivnak> oops, dkliban 's link is better. :)
14:33:03 <dkliban> !issue 1944
14:33:03 <dkliban> #topic YumMetadataFile copy does not save its new storage_path - http://pulp.plan.io/issues/1944
14:33:04 <pulpbot> RPM Support Issue #1944 [NEW] (unassigned) - Priority: High | Severity: High
14:33:05 <pulpbot> YumMetadataFile copy does not save its new storage_path - http://pulp.plan.io/issues/1944
14:33:08 <preethi> #info preethi has joined triage
14:33:08 <preethi> !here
14:33:08 <pulpbot> preethi has joined triage
14:33:18 <mhrivnak> This is the source of the "productid" trouble we've seen recently.
14:33:26 <dalley> thank you :)
14:33:40 <mhrivnak> So I think we need to address this bug ASAP.
14:33:42 <dalley> !here
14:33:42 <dalley> #info dalley has joined triage
14:33:43 <pulpbot> dalley has joined triage
14:34:07 <bmbouter> #info bmbouter has joined triage
14:34:07 <bmbouter> !here
14:34:07 <pulpbot> bmbouter has joined triage
14:34:26 <pcreech> !propose triage High High
14:34:26 <pulpbot> Error: Unknown Severity
14:34:45 <bmbouter> !propose triage High Normal
14:34:45 <pulpbot> Error: Unknown Severity
14:34:49 <pcreech> (since it was e-mailed that it wasn't an immediate release blocker)
14:35:18 <smyers> lowercase :(
14:35:32 <mhrivnak> I suggest high severity. When the problem occurs, it can be a show-stopper for some use cases.
14:35:40 <smyers> There's an open bug for that, but I haven't fixed it yet. So !propose triage high high instead of High High
14:35:57 <pcreech> !propose triage high high
14:35:57 <pcreech> #idea Proposed for #1944: Priority: High, Severity: High
14:35:58 <pulpbot> Proposed for #1944: Priority: High, Severity: High
14:36:13 <mhrivnak> I thiiiiink one of the consequences is that you can't kickstart from a repo if it's suffered from the effects of this bug.
14:36:34 <mhrivnak> I'm good with high/high and we'll put it on this sprint.
14:36:52 <dkliban> +1
14:37:26 <dkliban> any objections to triaging it and going to the next issue?
14:38:12 <dkliban> mhrivnak: are we adding 2.8.4 platform target reelase/
14:38:14 <dkliban> ?
14:38:24 <mhrivnak> no.
14:38:44 <mhrivnak> We're not making this a release blocker, so 2.8.4 will proceed.
14:38:52 <dkliban> mhrivnak: sounds good
14:38:56 <dkliban> !accept
14:38:56 <dkliban> #agreed Priority: High, Severity: High
14:38:56 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:38:57 <pulpbot> 12 issues left to triage: 1893, 1926, 1930, 1931, 1932, 1933, 1934, 1935, 1936, 1937, 1938, 1943
14:38:58 <dkliban> #topic pulp_docker does not support Docker < 1.10 with manifests that were published from Docker >= 1.10 - http://pulp.plan.io/issues/1893
14:38:58 <pulpbot> Docker Support Issue #1893 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:59 <pulpbot> pulp_docker does not support Docker < 1.10 with manifests that were published from Docker >= 1.10 - http://pulp.plan.io/issues/1893
14:39:39 <dkliban> let's come back to this one in a bit
14:39:44 <dkliban> i will move us to 1935
14:39:49 <dkliban> !issue 1935
14:39:50 <dkliban> #topic yum_repo_metadata_file model is fundementally flawed and leads to data corruption/loss - http://pulp.plan.io/issues/1935
14:39:50 <pulpbot> RPM Support Issue #1935 [NEW] (unassigned) - Priority: Urgent | Severity: High | Target Release: 2.8.4
14:39:51 <pulpbot> yum_repo_metadata_file model is fundementally flawed and leads to data corruption/loss - http://pulp.plan.io/issues/1935
14:40:12 <pcreech> we just did this one?
14:40:24 <mhrivnak> This one is fairly broad and required investigation. That investigation led to #1944, the one we just finished looking at.
14:40:25 <dkliban> pcreech: it's related but not the same
14:40:40 <mhrivnak> jcline, any suggestions on how to handle this one now?
14:41:06 <pcreech> ah, my brain not working today it appears
14:41:09 <mhrivnak> One option is it could become a planning task to figure out a better design for storing and managing metadata files.
14:41:30 <bmbouter> let's defer it so that someone can rewrite it
14:41:35 <rpbarlow> ipanova: i don't have an agenda for the pulp in fedora meeting and it's only three of us, so if you guys want to make it short and sweet that's fine with me
14:41:55 <mhrivnak> I'm ok with deferring, but can we reduce the priority at least?
14:41:57 <jcline> remodel it, I suppose
14:42:04 <mhrivnak> I don't think we have reason to consider it urgent at this point.
14:42:22 <bmbouter> I agree lower than urgent
14:42:29 <bmbouter> High? Medium?
14:42:39 <pcreech> let's keep it as high
14:42:51 <ipanova> rpbarlow: could we postpone it by 15 mins if that is fine with you? pcreech
14:42:53 <dkliban> i think it should be high/high
14:43:01 <pcreech> ipanova: rpbarlow: i'm good with that
14:43:35 <dkliban> !propose triage high high
14:43:35 <dkliban> #idea Proposed for #1935: Priority: High, Severity: High
14:43:35 <pulpbot> Proposed for #1935: Priority: High, Severity: High
14:43:46 <bmbouter> +1 accept
14:43:53 <mhrivnak> I don't feel strongly about the priority. We'll need to take a second look at it regardless after it's changed.
14:43:59 <bmbouter> agreed
14:44:06 <dkliban> alright ... i am accepting
14:44:17 <rpbarlow> ipanova, pcreech: sure, no problem
14:44:32 <dkliban> !accept
14:44:32 <dkliban> #agreed Priority: High, Severity: High
14:44:32 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:44:34 <pulpbot> 11 issues left to triage: 1893, 1926, 1930, 1931, 1932, 1933, 1934, 1936, 1937, 1938, 1943
14:44:34 <dkliban> #topic pulp_docker does not support Docker < 1.10 with manifests that were published from Docker >= 1.10 - http://pulp.plan.io/issues/1893
14:44:35 <pulpbot> Docker Support Issue #1893 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:36 <pulpbot> pulp_docker does not support Docker < 1.10 with manifests that were published from Docker >= 1.10 - http://pulp.plan.io/issues/1893
14:45:18 <dkliban> we discussed this issue yesterday. let's mark keep the priority and severity on it  so that someone can investigate in near future
14:45:20 <mhrivnak> It seems that we at least need to prioritize investigating this one.
14:45:21 <ipanova> rpbarlow: pcreech thanks a lot
14:45:49 <rpbarlow> +1 investigate
14:46:02 <rpbarlow> i say high priority unknown severity
14:46:09 <rpbarlow> but unknown doesn't exist
14:46:12 <rpbarlow> so med?
14:46:14 <mhrivnak> #idea Proposed for #1893: Priority: High, Severity: Medium
14:46:14 <mhrivnak> !propose triage high medium
14:46:14 <pulpbot> Proposed for #1893: Priority: High, Severity: Medium
14:46:30 <ttereshc> should we create a new task for investigation?
14:46:31 <dkliban> that works for me
14:46:50 <dkliban> ttereshc: no ... i think investigation is just part of this issue
14:47:00 <ttereshc> dkliban, ok
14:47:03 <dkliban> any objections to the proposal?
14:47:23 <ttereshc> but when we will need to fix the issue we are going to re-triage it?
14:47:24 <mhrivnak> I agree. If investigation suggest we should re-prioritize, we can re-triage it then.
14:47:30 <ttereshc> ok)
14:47:47 <dkliban> #agreed Priority: High, Severity: Medium
14:47:47 <dkliban> !accept
14:47:47 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
14:47:49 <dkliban> #topic package without epoch in the erratum pkglist is not handled correctly during publish - http://pulp.plan.io/issues/1926
14:47:49 <pulpbot> 10 issues left to triage: 1926, 1930, 1931, 1932, 1933, 1934, 1936, 1937, 1938, 1943
14:47:50 <pulpbot> RPM Support Issue #1926 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:47:51 <pulpbot> package without epoch in the erratum pkglist is not handled correctly during publish - http://pulp.plan.io/issues/1926
14:48:38 <dkliban> so is the bug with the fixtures?
14:48:55 <elyezer> https://pulp.plan.io/issues/1905 should be fixed by https://github.com/pulp/pulp_packaging/pull/168, makes sense including it to the triage?
14:48:57 <pulpbot> Title: Issue #1905: Streamer SSL cert not added to Pulp's trust store on RHEL 6 - Packaging - Pulp (at pulp.plan.io)
14:49:18 <pcreech> dkliban: it appears so
14:49:47 <dkliban> elyezer: it looks like we have already triaged that issue
14:49:53 <elyezer> thanks
14:50:10 * elyezer needs to learn more about the flags and info on the bug
14:50:40 <elyezer> I see the Triaged == Yes on it
14:50:47 <dkliban> any objections to changing the title of the bug?
14:51:01 <dkliban> so it clearly states that the bug is withthe fixtures?
14:51:06 <ttereshc> how sure are we that there will always be an epoch for the packages in the updateinfo?
14:51:07 <mhrivnak> Let's do it.
14:51:18 <ttereshc> because the consequences are not good(
14:51:34 <mhrivnak> ttereshc, "pretty sure" ;) I couldn't find any, but they might be out there.
14:51:48 <mhrivnak> yum has defensive code to turn a "" into "0"
14:51:59 <mhrivnak> And presumably they didn't add that because of our zoo repo. :) Although you never know!
14:52:23 <ttereshc> mhrivnak, ok :) I will fix just fixtures then
14:52:29 <mhrivnak> My suspicion is that there's a small chance anyone will see a problem with this.
14:53:24 <dkliban> i added comments and updated title
14:53:27 <dkliban> !accept
14:53:27 <pulpbot> No action proposed, nothing to accept.
14:53:42 <mhrivnak> hah
14:54:09 <dkliban> #idea Proposed for #1926: Priority: Normal, Severity: Medium
14:54:09 <dkliban> !propose triage normal medium
14:54:09 <pulpbot> Proposed for #1926: Priority: Normal, Severity: Medium
14:54:13 <dkliban> !accept
14:54:13 <dkliban> #agreed Priority: Normal, Severity: Medium
14:54:13 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
14:54:14 <pulpbot> 9 issues left to triage: 1930, 1931, 1932, 1933, 1934, 1936, 1937, 1938, 1943
14:54:15 <dkliban> #topic occasionally unable to browse repos via browser - http://pulp.plan.io/issues/1930
14:54:15 <pulpbot> Pulp Issue #1930 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:54:16 <pulpbot> occasionally unable to browse repos via browser - http://pulp.plan.io/issues/1930
14:54:43 <dkliban> jcline: have you been able to reproduce this issue?
14:56:10 <dkliban> is normal/medium appropriate or do we want high priority so we can investigate sooner?
14:56:18 <mhrivnak> I think high.
14:56:24 <mhrivnak> It's a small thing, but it looks bad.
14:56:33 <dkliban> agreed
14:56:35 <pcreech> this issue should be resolved by 189? (that's on this sprint)
14:56:48 <dkliban> pcreech: link/>
14:56:49 <dkliban> ?
14:57:04 <pcreech> https://pulp.plan.io/issues/189
14:57:06 <mhrivnak> Oh? I thought that was an addional view, but that the current browsing functionality will remain.
14:57:06 <pulpbot> Title: Story #189: Repoview-like functionality for browsing repositories via the web interface - RPM Support - Pulp (at pulp.plan.io)
14:57:08 <jcline> dkliban, yes, I reproduced it
14:57:14 <smyers> I had a similar thought, but even if it'll be fixed in 2.9 the bug still exists in 2.8 and should be corrected.
14:57:17 <jcline> no, it won't be resolved by 189
14:57:33 <mhrivnak> !propose triage high low
14:57:33 <mhrivnak> #idea Proposed for #1930: Priority: High, Severity: Low
14:57:34 <pulpbot> Proposed for #1930: Priority: High, Severity: Low
14:57:48 <jcline> repoview works for a repo, but not for browsing _to_ the repo
14:58:21 <pcreech> aggre with proposal
14:58:24 <pcreech> agree*
14:58:41 <dkliban> mhrivnak: if the urls being presented are wrong, could we run into problems when syncing one pulp to another?
14:58:45 <pcreech> (2 minute warning)
14:58:55 <mhrivnak> dkliban, I don't think so.
14:59:19 <mhrivnak> pulp doesn't try to access any kind of directory index.
14:59:28 <mhrivnak> katello does, but it uses those "listings" files as the index.
14:59:37 <mhrivnak> So I'm pretty sure this is just for humans.
14:59:57 <dkliban> !accept
14:59:57 <dkliban> #agreed Priority: High, Severity: Low
14:59:58 <pulpbot> Current proposal accepted: Priority: High, Severity: Low
14:59:59 <dkliban> #topic FieldDoesNotExist: The field '_rpm_references' does not exist on the document 'Errata' - http://pulp.plan.io/issues/1931
14:59:59 <pulpbot> 8 issues left to triage: 1931, 1932, 1933, 1934, 1936, 1937, 1938, 1943
15:00:00 <pulpbot> RPM Support Issue #1931 [NEW] (unassigned) - Priority: High | Severity: High
15:00:01 <pulpbot> FieldDoesNotExist: The field '_rpm_references' does not exist on the document 'Errata' - http://pulp.plan.io/issues/1931
15:00:10 <dkliban> this will be the last issue we triage today
15:00:36 <bmbouter> this is on a sprint and should be High High
15:00:36 <dkliban> we will continue on Friday with the rest of the issues
15:00:44 <mhrivnak> Is this blocking 2.8.4?
15:00:50 <mhrivnak> should it?
15:01:45 <dkliban> it sounds like a regression
15:01:51 <bmbouter> it's a regression since 2.8.0
15:02:18 <bmbouter> I don't think it should block 2.8.4 but it would be great if someone took it as assigned
15:02:27 <mhrivnak> oops, I think I was looking at the wrong issue.
15:02:33 <mhrivnak> I thought this was on 2.8.4, but I see it's not.
15:02:42 <mhrivnak> I agree it should not block 2.8.4
15:02:49 <dkliban> but we should fix this soon
15:03:00 <dkliban> hopefully for 2.8.5
15:03:00 <mhrivnak> !propose triage high high
15:03:00 <mhrivnak> #idea Proposed for #1931: Priority: High, Severity: High
15:03:01 <pulpbot> Proposed for #1931: Priority: High, Severity: High
15:03:14 <bmbouter> I don't know how to accept but, yes
15:03:15 <dkliban> any objections?
15:03:18 <ttereshc> +1
15:03:22 <dkliban> #agreed Priority: High, Severity: High
15:03:22 <dkliban> !accept
15:03:22 <pulpbot> Current proposal accepted: Priority: High, Severity: High
15:03:23 <dkliban> #topic KeyError: '\xff\xff\xff\xff\xd8\xec2\x05' - http://pulp.plan.io/issues/1932
15:03:24 <pulpbot> 7 issues left to triage: 1932, 1933, 1934, 1936, 1937, 1938, 1943
15:03:25 <pulpbot> RPM Support Issue #1932 [NEW] (unassigned) - Priority: Normal | Severity: High
15:03:26 <pulpbot> KeyError: '\xff\xff\xff\xff\xd8\xec2\x05' - http://pulp.plan.io/issues/1932
15:03:28 <dkliban> i am stopping triage now
15:03:36 <dkliban> we will continue on Friday
15:03:40 <bmbouter> very good
15:03:43 <dkliban> !stop
15:03:43 <pulpbot> Error: "stop" is not a valid command.
15:03:47 <dkliban> !end
15:03:47 <dkliban> #endmeeting