14:30:38 <dkliban> #startmeeting Pulp Triage 2016-06-03
14:30:38 <dkliban> #info dkliban has joined triage
14:30:39 <pulpbot> Meeting started Fri Jun  3 14:30:38 2016 UTC and is due to finish in 60 minutes.  The chair is dkliban. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:39 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:39 <pulpbot> The meeting name has been set to 'pulp_triage_2016_06_03'
14:30:39 <pulpbot> dkliban has joined triage
14:30:45 <jortel> jcline: otherwise, I'll do it shortly
14:31:16 <jcline> jortel, I feel comfortable handling it
14:31:18 <dkliban> Triage has started. Please join if you plan to participate
14:31:19 <ttereshc> #info ttereshc has joined triage
14:31:19 <ttereshc> !here
14:31:19 <pulpbot> ttereshc has joined triage
14:31:26 <preethi> !here
14:31:26 <preethi> #info preethi has joined triage
14:31:27 <pulpbot> preethi has joined triage
14:31:30 <bmbouter> !here
14:31:30 <bmbouter> #info bmbouter has joined triage
14:31:30 <pulpbot> bmbouter has joined triage
14:31:51 <mhrivnak> #info mhrivnak has joined triage
14:31:51 <mhrivnak> !here
14:31:51 <pulpbot> mhrivnak has joined triage
14:31:55 <dkliban> i believe that we have a quorum
14:31:59 <dkliban> !next
14:32:00 <pulpbot> 8 issues left to triage: 1932, 1954, 1955, 1956, 1958, 1962, 1964, 1967
14:32:01 <dkliban> #topic KeyError: '\xff\xff\xff\xff\xd8\xec2\x05' - http://pulp.plan.io/issues/1932
14:32:01 <pulpbot> RPM Support Issue #1932 [NEW] (unassigned) - Priority: Normal | Severity: High
14:32:03 <pulpbot> KeyError: '\xff\xff\xff\xff\xd8\xec2\x05' - http://pulp.plan.io/issues/1932
14:32:05 <dalley> #info dalley has joined triage
14:32:05 <dalley> !here
14:32:05 <pulpbot> dalley has joined triage
14:32:34 <mhrivnak> ttereshc, do you have any more info on this being a CDN problem?
14:33:17 <ttereshc> mhrivnak, I have no additional info but jluza told me earlier that it is likely a CDN problem
14:33:48 <dkliban> do we want to skip it again?
14:33:49 <mhrivnak> Would you mind filing an issue with RCM about it?
14:34:15 <ttereshc> mhrivnak, I will do, just tell me where :)
14:34:26 <mhrivnak> ttereshc, will do.
14:34:35 <dkliban> so are we skipping it?
14:34:59 <mhrivnak> I'd be ok with triaging it so we can handle this case more gracefully.
14:35:10 <dkliban> ok
14:35:37 <dkliban> are we good with keeping Normal priority / High severity?
14:35:40 <mhrivnak> And if ttereshc gets feedback from RCM that they don't think it's their problem, she can un-triage it so we take a second look.
14:35:54 <ttereshc> ok
14:35:55 <mhrivnak> !propose triage normal low
14:35:55 <mhrivnak> #idea Proposed for #1932: Priority: Normal, Severity: Low
14:35:56 <pulpbot> Proposed for #1932: Priority: Normal, Severity: Low
14:36:07 <dkliban> that works for me
14:36:12 <dkliban> anyone object?
14:36:13 <mhrivnak> I think it's low severity because based on our understanding, the core problem is external to pulp.
14:36:25 <mhrivnak> For us, it's just a matter of explaining it more gracefully to the user.
14:36:30 <dkliban> yep
14:36:47 <dkliban> !accept
14:36:47 <dkliban> #agreed Priority: Normal, Severity: Low
14:36:48 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:36:49 <dkliban> #topic The distribution storage path migration fails when variant is not in the document. - http://pulp.plan.io/issues/1954
14:36:49 <pulpbot> 7 issues left to triage: 1954, 1955, 1956, 1958, 1962, 1964, 1967
14:36:51 <pulpbot> RPM Support Issue #1954 [ASSIGNED] (jortel@redhat.com) - Priority: High | Severity: High
14:36:52 <pulpbot> The distribution storage path migration fails when variant is not in the document. - http://pulp.plan.io/issues/1954
14:37:19 <dkliban> it's already being worked on
14:37:24 <alanoe> !here
14:37:24 <alanoe> #info alanoe has joined triage
14:37:25 <pulpbot> alanoe has joined triage
14:37:30 <dkliban> let's just triage it and move to the next one
14:37:39 <mhrivnak> +1
14:37:47 <ttereshc> +1
14:38:03 <dkliban> !propose triage high high
14:38:03 <dkliban> #idea Proposed for #1954: Priority: High, Severity: High
14:38:04 <pulpbot> Proposed for #1954: Priority: High, Severity: High
14:38:06 <dkliban> !accept
14:38:06 <dkliban> #agreed Priority: High, Severity: High
14:38:07 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:38:08 <dkliban> #topic Need a migration to ensure that Distribution units have a default value of '' for variant. - http://pulp.plan.io/issues/1955
14:38:08 <pulpbot> 6 issues left to triage: 1955, 1956, 1958, 1962, 1964, 1967
14:38:09 <pulpbot> RPM Support Issue #1955 [POST] (jortel@redhat.com) - Priority: High | Severity: Medium
14:38:10 <pulpbot> Need a migration to ensure that Distribution units have a default value of '' for variant. - http://pulp.plan.io/issues/1955
14:38:19 <mhrivnak> same
14:38:22 <dkliban> yep
14:38:27 <ttereshc> !propose accept
14:38:27 <ttereshc> #idea Proposed for #1955: Leave the issue as-is, accepting its current state.
14:38:28 <pulpbot> Proposed for #1955: Leave the issue as-is, accepting its current state.
14:38:35 <dkliban> #agreed Leave the issue as-is, accepting its current state.
14:38:35 <dkliban> !accept
14:38:35 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:38:36 <pulpbot> 5 issues left to triage: 1956, 1958, 1962, 1964, 1967
14:38:37 <dkliban> #topic "Cleaning duplicate packages" fails after upgrading from 2.6.0 to 2.8.3. - http://pulp.plan.io/issues/1956
14:38:37 <pulpbot> Pulp Issue #1956 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:38 <pulpbot> "Cleaning duplicate packages" fails after upgrading from 2.6.0 to 2.8.3. - http://pulp.plan.io/issues/1956
14:39:35 <mhrivnak> ah, the good-ole mongo document overflow problem.
14:39:45 <dkliban> !propose triage high high
14:39:45 <dkliban> #idea Proposed for #1956: Priority: High, Severity: High
14:39:46 <pulpbot> Proposed for #1956: Priority: High, Severity: High
14:40:02 <mhrivnak> +1
14:40:14 <ttereshc> +1
14:40:48 <dkliban> !accept
14:40:48 <dkliban> #agreed Priority: High, Severity: High
14:40:49 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:40:50 <dkliban> #topic uninstall causes POSTUN script failure - http://pulp.plan.io/issues/1958
14:40:50 <pulpbot> 4 issues left to triage: 1958, 1962, 1964, 1967
14:40:51 <pulpbot> Crane Issue #1958 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:52 <pulpbot> uninstall causes POSTUN script failure - http://pulp.plan.io/issues/1958
14:41:31 <mhrivnak> I just updated this one.
14:41:35 <mhrivnak> please refresh.
14:41:53 <dkliban> cool. so we can just triage and move on
14:41:58 <mhrivnak> +1
14:42:15 <dkliban> !propose accept
14:42:15 <dkliban> #idea Proposed for #1958: Leave the issue as-is, accepting its current state.
14:42:16 <pulpbot> Proposed for #1958: Leave the issue as-is, accepting its current state.
14:42:20 <dkliban> #agreed Leave the issue as-is, accepting its current state.
14:42:20 <dkliban> !accept
14:42:20 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:42:21 <pulpbot> 3 issues left to triage: 1962, 1964, 1967
14:42:21 <dkliban> #topic invalid string formatting for error message - http://pulp.plan.io/issues/1962
14:42:22 <pulpbot> Docker Support Issue #1962 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Target Release: 2.8.3
14:42:23 <pulpbot> invalid string formatting for error message - http://pulp.plan.io/issues/1962
14:43:15 <dkliban> that's a terrible behavior
14:43:22 <ttereshc> easy fix
14:43:28 <mhrivnak> agreed both
14:43:43 <dkliban> Normal medium ?
14:43:56 <mhrivnak> works for me.
14:43:56 <dkliban> #idea Proposed for #1962: Leave the issue as-is, accepting its current state.
14:43:56 <dkliban> !propose accept
14:43:56 <pulpbot> Proposed for #1962: Leave the issue as-is, accepting its current state.
14:44:06 <ttereshc> +1
14:44:17 <dkliban> !accept
14:44:17 <dkliban> #agreed Leave the issue as-is, accepting its current state.
14:44:17 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:44:18 <pulpbot> 2 issues left to triage: 1964, 1967
14:44:19 <dkliban> #topic Can not create sync for docker repos - http://pulp.plan.io/issues/1964
14:44:19 <pulpbot> Puppet Support Issue #1964 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:20 <pulpbot> Can not create sync for docker repos - http://pulp.plan.io/issues/1964
14:44:48 <ttereshc> dup of rm #1859
14:44:48 <pulpbot> Docker Support Story #1859 [NEW] (unassigned) - Priority: Normal
14:44:49 <pulpbot> As a user, I want to create a scheduled sync using pulp_docker CLI - http://pulp.plan.io/issues/1859
14:45:16 <dkliban> same user
14:45:27 <ttereshc> yes :)
14:45:29 <mhrivnak> heh
14:45:31 <dkliban> we should really fix this
14:45:46 <mhrivnak> Is it just the pulp-admin commands are missing?
14:45:53 <dkliban> i think so
14:45:54 <bmbouter> I think so
14:46:23 <mhrivnak> cool. Should be pretty easy then.
14:46:24 <dkliban> i am closing this one and adding the relationship
14:46:28 <mhrivnak> +1
14:46:37 <ttereshc> +1
14:46:57 <dkliban> !next
14:46:58 <pulpbot> 1 issues left to triage: 1967
14:46:59 <dkliban> #topic Duplicate instances of pulp_celerybeat on the same host will cause some tasks to be dispatched multiple times - http://pulp.plan.io/issues/1967
14:46:59 <pulpbot> Pulp Issue #1967 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:47:00 <pulpbot> Duplicate instances of pulp_celerybeat on the same host will cause some tasks to be dispatched multiple times - http://pulp.plan.io/issues/1967
14:47:59 <dkliban> i think that we should fix this eventually, but i don't know that there is an easy fix for it at the moment
14:48:27 <mhrivnak> Seems reasonable.
14:48:31 <dkliban> i expect users to run the redundant pulp_celerybeat processes on separate machines
14:48:45 <dkliban> but if they do run them on the same machine, this problem will occur
14:48:58 <mhrivnak> Right. We don't make it easy for them to run multiple on the same machine, so they'd have to *really* want to.
14:49:10 <dalley> there definitely is not an easy fix at the moment
14:49:12 <dkliban> yep
14:49:28 <dkliban> !propose triage normal medium
14:49:28 <dkliban> #idea Proposed for #1967: Priority: Normal, Severity: Medium
14:49:29 <pulpbot> Proposed for #1967: Priority: Normal, Severity: Medium
14:49:36 <bmbouter> +1
14:49:48 <dalley> +1
14:49:59 <dkliban> !accept
14:49:59 <dkliban> #agreed Priority: Normal, Severity: Medium
14:49:59 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
14:50:00 <pulpbot> No issues to triage.
14:50:09 <dkliban> record time folks!
14:50:31 <mhrivnak> woot
14:50:33 <dkliban> !end
14:50:33 <dkliban> #endmeeting