14:30:01 <asmacdo> #startmeeting Pulp Triage 2016-06-07
14:30:01 <asmacdo> #info asmacdo has joined triage
14:30:02 <pulpbot> Meeting started Tue Jun  7 14:30:01 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:02 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:02 <pulpbot> The meeting name has been set to 'pulp_triage_2016_06_07'
14:30:02 <pulpbot> asmacdo has joined triage
14:30:25 <jcline> #info jcline has joined triage
14:30:25 <jcline> !here
14:30:26 <pulpbot> jcline has joined triage
14:30:31 <mhrivnak> !here
14:30:31 <mhrivnak> #info mhrivnak has joined triage
14:30:31 <pulpbot> mhrivnak has joined triage
14:30:55 <dkliban> !here
14:30:55 <dkliban> #info dkliban has joined triage
14:30:55 <pulpbot> dkliban has joined triage
14:31:13 <asmacdo> what did we decide was quorum?
14:31:17 <bmbouter> !here
14:31:17 <bmbouter> #info bmbouter has joined triage
14:31:18 <pulpbot> bmbouter has joined triage
14:31:57 <asmacdo> 5 seems like plenty
14:31:58 <asmacdo> !next
14:31:59 <pulpbot> 6 issues left to triage: 1967, 1971, 1977, 1978, 1979, 1980
14:32:00 <asmacdo> #topic Duplicate instances of pulp_celerybeat on the same host will cause some tasks to be dispatched multiple times - http://pulp.plan.io/issues/1967
14:32:00 <pulpbot> Pulp Issue #1967 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:01 <smyers> asmacdo, it's 2. The bot knows, and won't let you !next without it
14:32:01 <pulpbot> Duplicate instances of pulp_celerybeat on the same host will cause some tasks to be dispatched multiple times - http://pulp.plan.io/issues/1967
14:32:10 <asmacdo> thanks smyers
14:32:28 <asmacdo> dalley, would you like to talk about this one?
14:32:28 <dkliban> mhrivnak: i think that's a good suggestion
14:32:53 <dalley> Ok
14:33:15 <dkliban> !propose accept
14:33:15 <dkliban> #idea Proposed for #1967: Leave the issue as-is, accepting its current state.
14:33:15 <pulpbot> Proposed for #1967: Leave the issue as-is, accepting its current state.
14:33:22 <dalley> It's fairly straightforward - we heavily discourage users from running multiple pulp celerybeats on the same machine
14:33:31 <mhrivnak> #idea Proposed for #1967: Priority: Normal, Severity: Low
14:33:31 <mhrivnak> !propose triage normal low
14:33:31 <pulpbot> Proposed for #1967: Priority: Normal, Severity: Low
14:33:45 <dkliban> +1
14:33:53 <bmbouter> +1
14:33:54 <asmacdo> #agreed Priority: Normal, Severity: Low
14:33:54 <asmacdo> !accept
14:33:54 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:33:56 <asmacdo> #topic '--retain-old-count' option not retroactive - http://pulp.plan.io/issues/1971
14:33:56 <pulpbot> 5 issues left to triage: 1971, 1977, 1978, 1979, 1980
14:33:57 <pulpbot> RPM Support Issue #1971 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:33:58 <pulpbot> '--retain-old-count' option not retroactive - http://pulp.plan.io/issues/1971
14:34:07 <dalley> But if they do, both celerybeats will dispatch tasks
14:34:12 <dalley> +1
14:34:19 <asmacdo> oh sorry dally, you are the same color as dkliban
14:34:56 <dalley> that's it really
14:35:05 <mhrivnak> For this one, doing similar work for the importers that we did for distributors should resolve it. Namely...
14:35:16 <mhrivnak> 1) if the config changes, do a full sync next time
14:35:23 <mhrivnak> 2) have an option to force a full sync any time
14:35:43 <mhrivnak> Anyone know off-hand if we have stories for those?
14:36:02 <bmbouter> for rpm we did (2)
14:36:07 <bmbouter> it's merged in 2.9.0
14:36:18 <mhrivnak> oh good. Have an issue #?
14:36:20 <jcline> I think ipanova did them
14:36:31 <bmbouter> https://pulp.plan.io/issues/1158
14:36:33 <pulpbot> Title: Story #1158: As a user, I can force full/fresh publish of rpms and not do an incremental publish - RPM Support - Pulp (at pulp.plan.io)
14:36:42 <bmbouter> and we also did (1)
14:37:10 <mhrivnak> that's publish ^
14:37:24 <ipanova> https://pulp.plan.io/issues/1724
14:37:26 <bmbouter> https://pulp.plan.io/issues/1724
14:37:31 <pulpbot> Title: Story #1724: Publish should be a no-op if no units and no settings have changed since the last successful publish - Pulp (at pulp.plan.io)
14:37:32 <pulpbot> Title: Story #1724: Publish should be a no-op if no units and no settings have changed since the last successful publish - Pulp (at pulp.plan.io)
14:37:49 <mhrivnak> Gotcha. So we need similar work done for sync.
14:37:57 <dkliban> we don't have stories
14:38:17 <bmbouter> oic
14:38:22 <bmbouter> what dkliban said
14:38:49 <mhrivnak> Ok. I'll add stories and make this bug related to one or both.
14:38:56 <dkliban> mhrivnak: thanks
14:39:07 <asmacdo> what about prio for this one?
14:39:25 <mhrivnak> I think we could accept it as-is.
14:39:36 <dkliban> !propose accept
14:39:36 <dkliban> #idea Proposed for #1971: Leave the issue as-is, accepting its current state.
14:39:37 <pulpbot> Proposed for #1971: Leave the issue as-is, accepting its current state.
14:39:48 <bmbouter> +1
14:39:50 <asmacdo> any other thoughts?
14:40:09 <asmacdo> !accept
14:40:09 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:40:09 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:40:11 <asmacdo> #topic basic auth in URL fails when using authenticated proxy - http://pulp.plan.io/issues/1977
14:40:11 <pulpbot> 4 issues left to triage: 1977, 1978, 1979, 1980
14:40:12 <pulpbot> RPM Support Issue #1977 [NEW] (unassigned) - Priority: High | Severity: High
14:40:13 <pulpbot> basic auth in URL fails when using authenticated proxy - http://pulp.plan.io/issues/1977
14:40:56 <jcline> Did this ever work before?
14:41:15 <dkliban> it sounds like it did
14:41:41 <bmbouter> it's an important feature of sync I propose we accept as is
14:41:46 <bmbouter> !propose accept
14:41:46 <bmbouter> #idea Proposed for #1977: Leave the issue as-is, accepting its current state.
14:41:47 <pulpbot> Proposed for #1977: Leave the issue as-is, accepting its current state.
14:41:55 <mhrivnak> +1 (obviously ;) )
14:41:56 <dkliban> +1
14:42:18 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:42:18 <asmacdo> !accept
14:42:18 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:42:19 <pulpbot> 3 issues left to triage: 1978, 1979, 1980
14:42:19 <asmacdo> #topic Change the name of the scheduler worker from "scheduler" to "pulp_celerybeat" - http://pulp.plan.io/issues/1978
14:42:20 <pulpbot> Pulp Issue #1978 [NEW] (unassigned) - Priority: Low | Severity: Low | Target Release: 3.0.0
14:42:21 <pulpbot> Change the name of the scheduler worker from "scheduler" to "pulp_celerybeat" - http://pulp.plan.io/issues/1978
14:42:51 <dkliban> !propose triage normal medium
14:42:51 <dkliban> #idea Proposed for #1978: Priority: Normal, Severity: Medium
14:42:52 <pulpbot> Proposed for #1978: Priority: Normal, Severity: Medium
14:42:53 <mhrivnak> This looks more like a task or refactor than an issue.
14:43:04 <bmbouter> yes a task would be good
14:43:12 <bmbouter> it's visible to the user so it's not a refactor
14:43:21 <bmbouter> I can switch it to a task and leave a comment
14:43:28 <mhrivnak> Works for me.
14:43:37 <asmacdo> bmbouter, would you mark as triaged as well so we dont collide?
14:43:45 <bmbouter> ok let's skip it, and yes
14:43:58 <asmacdo> !skip
14:43:59 <pulpbot> 2 issues left to triage: 1979, 1980
14:44:00 <asmacdo> #topic metadata unit copy action creates incorrect unit count on repo - http://pulp.plan.io/issues/1979
14:44:00 <pulpbot> RPM Support Issue #1979 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:44:01 <pulpbot> metadata unit copy action creates incorrect unit count on repo - http://pulp.plan.io/issues/1979
14:44:56 <mhrivnak> bmbouter, is this new in 2.9?
14:45:10 <asmacdo> im guessing this is because we aren't using the conduit anymore since lazy?
14:45:22 <bmbouter> it's from whenever that code block was introduced
14:45:35 <bmbouter> it's a 1-line fix and I propose I take it as assigned
14:45:37 <ipanova> mhrivnak: i guess this is because with every copy we create a new unit?
14:46:08 <bmbouter> only in cases where the copy destination already has a unit that compares as the same against the unit being copied
14:46:28 <mhrivnak> Gotcha. I'm surprised we haven't noticed it on other types.
14:46:36 <bmbouter> perhaps it's not that old
14:46:50 <asmacdo> !propose high low
14:46:50 <pulpbot> Error: "propose" is not a valid command.
14:47:07 <asmacdo> !propose triage high low
14:47:07 <asmacdo> #idea Proposed for #1979: Priority: High, Severity: Low
14:47:08 <pulpbot> Proposed for #1979: Priority: High, Severity: Low
14:47:18 <bmbouter> +1
14:47:22 <jcline> +1
14:47:27 <bmbouter> and I'll update it and take it as assigned
14:47:32 <mhrivnak> +1
14:47:33 <asmacdo> k thanks bmbouter
14:47:37 <asmacdo> #agreed Priority: High, Severity: Low
14:47:37 <asmacdo> !accept
14:47:37 <pulpbot> Current proposal accepted: Priority: High, Severity: Low
14:47:38 <pulpbot> 1 issues left to triage: 1980
14:47:39 <mhrivnak> Also please verify that it's new in 2.9
14:47:39 <asmacdo> #topic Warning message in Langpacks upload can help  - http://pulp.plan.io/issues/1980
14:47:40 <pulpbot> RPM Support Issue #1980 [NEW] (unassigned) - Priority: Normal | Severity: Low | Target Release: master
14:47:41 <pulpbot> Warning message in Langpacks upload can help  - http://pulp.plan.io/issues/1980
14:47:44 <asmacdo> last one
14:48:33 <bmbouter> this is a good improvement
14:48:34 <mhrivnak> Maybe this should be a story.
14:48:37 <bmbouter> agreed
14:48:46 <mhrivnak> As a user, I see a warning message when...
14:48:48 <bmbouter> and it could be across several types not just langpacks
14:48:57 <mhrivnak> indeed
14:48:59 <bmbouter> preethi: can this be rewritten as a story?
14:49:09 <preethi> bmbouter: sure
14:49:19 <bmbouter> and it can be for several types (all the metadata types)
14:49:25 <bmbouter> which would be great!
14:49:42 <bmbouter> asmacdo we should mark this as a resolution and also for the other skipped one, but I'm not sure how to do that
14:50:13 <asmacdo> !prropose other Change to story
14:50:13 <pulpbot> Error: "prropose" is not a valid command.
14:50:18 <asmacdo> !propose other Change to story
14:50:18 <asmacdo> #idea Proposed for #1980: Change to story
14:50:19 <pulpbot> Proposed for #1980: Change to story
14:50:25 <asmacdo> i guess?
14:50:47 <asmacdo> actually here we go
14:50:53 <preethi> bmbouter: making sure I understand,  are you asking me to write it? ( I can try for sure)
14:51:00 <asmacdo> #action preethi will change this to a story
14:51:00 <asmacdo> !action preethi will change this to a story
14:51:03 <preethi> :)
14:51:08 <preethi> got it
14:51:18 <asmacdo> :)
14:51:50 <asmacdo> bmbouter, do we need to go back to the last one?
14:52:30 <bmbouter> asmacdo: yes 1978
14:52:33 <asmacdo> !issue 1978
14:52:34 <asmacdo> #topic Change the name of the scheduler worker from "scheduler" to "pulp_celerybeat" - http://pulp.plan.io/issues/1978
14:52:34 <pulpbot> Pulp Task #1978 [NEW] (unassigned) - Priority: Low | Target Release: 3.0.0
14:52:35 <pulpbot> Change the name of the scheduler worker from "scheduler" to "pulp_celerybeat" - http://pulp.plan.io/issues/1978
14:52:45 <bmbouter> and add a propose cahnging to type task
14:52:47 <bmbouter> or something like that
14:52:51 <asmacdo> !action bmbouter will change this to a task and leave a comment
14:52:51 <asmacdo> #action bmbouter will change this to a task and leave a comment
14:53:12 <asmacdo> !accept
14:53:12 <asmacdo> #agreed Change to story
14:53:12 <pulpbot> Current proposal accepted: Change to story
14:53:13 <pulpbot> 1 issues left to triage: 1980
14:53:13 <asmacdo> #topic Warning message in Langpacks upload can help  - http://pulp.plan.io/issues/1980
14:53:14 <pulpbot> RPM Support Issue #1980 [NEW] (unassigned) - Priority: Normal | Severity: Low | Target Release: master
14:53:15 <pulpbot> Warning message in Langpacks upload can help  - http://pulp.plan.io/issues/1980
14:53:30 <smyers> heh
14:53:35 <asmacdo> hm.
14:53:45 <asmacdo> !accept
14:53:45 <pulpbot> No action proposed, nothing to accept.
14:54:01 <asmacdo> i dont think "!action" is working smyers?
14:54:10 <smyers> action isn't part of the proposal system
14:54:20 <smyers> Just records an action item
14:54:37 <asmacdo> !ropose other preethi will rewrite as story
14:54:37 <pulpbot> Error: "ropose" is not a valid command.
14:54:40 <asmacdo> !propose other preethi will rewrite as story
14:54:40 <asmacdo> #idea Proposed for #1980: preethi will rewrite as story
14:54:41 <pulpbot> Proposed for #1980: preethi will rewrite as story
14:54:44 <asmacdo> #agreed preethi will rewrite as story
14:54:44 <asmacdo> !accept
14:54:44 <pulpbot> Current proposal accepted: preethi will rewrite as story
14:54:45 <pulpbot> No issues to triage.
14:54:47 <asmacdo> !end
14:54:48 <asmacdo> #endmeeting