14:30:03 <asmacdo> #startmeeting Pulp Triage 2016-06-14
14:30:03 <asmacdo> #info asmacdo has joined triage
14:30:04 <pulpbot> Meeting started Tue Jun 14 14:30:03 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:04 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:04 <pulpbot> The meeting name has been set to 'pulp_triage_2016_06_14'
14:30:04 <pulpbot> asmacdo has joined triage
14:30:15 <preethi> !here
14:30:19 <dalley> !here
14:30:20 <mhrivnak> !here
14:30:28 <smyers> not looking good there, pulpbot
14:30:41 <preethi> #info preethi has joined triage
14:30:41 <dalley> #info dalley has joined triage
14:30:41 <mhrivnak> #info mhrivnak has joined triage
14:30:42 <pulpbot> preethi has joined triage
14:30:43 <pulpbot> dalley has joined triage
14:30:44 <pulpbot> mhrivnak has joined triage
14:30:51 * mhrivnak offers pulpbot a cup of coffee
14:31:00 <asmacdo> !coffeetime
14:31:00 <pulpbot> Error: "coffeetime" is not a valid command.
14:31:05 <smyers> haha
14:31:14 <dalley> lol
14:31:22 <asmacdo> !next
14:31:26 <pulpbot> 6 issues left to triage: 1997, 2004, 2005, 2006, 2007, 2008
14:31:29 <asmacdo> #topic RFE: Need to get distribution info from cdn atomic tree - http://pulp.plan.io/issues/1997
14:31:30 <pulpbot> Pulp Issue #1997 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:30 <pulpbot> RFE: Need to get distribution info from cdn atomic tree - http://pulp.plan.io/issues/1997
14:32:00 <smyers> RFE = Story
14:32:08 <mhrivnak> agreed
14:32:12 <smyers> !propose other Convert #1997 to story
14:32:12 <smyers> #idea Proposed for #1997: Convert #1997 to story
14:32:12 <smyers> #info smyers has joined triage
14:32:13 <pulpbot> smyers has joined triage
14:32:14 <pulpbot> Proposed for #1997: Convert #1997 to story
14:32:30 <bmbouter> !here
14:32:30 <bmbouter> #info bmbouter has joined triage
14:32:31 <pulpbot> bmbouter has joined triage
14:32:50 <mhrivnak> jortel, do you mind working with partha to turn that into a story?
14:32:55 <asmacdo> change subject to "As a user I can get distribution info from cdn atomic tree?
14:33:07 <smyers> That's part of converting it to a story, imo
14:33:18 <dkliban> !here
14:33:18 <dkliban> #info dkliban has joined triage
14:33:19 <pulpbot> dkliban has joined triage
14:33:40 <mhrivnak> Agreed. I think you can just leave a comment on it that triage determined it should be converted to a story.
14:34:00 <dkliban> smyers: i can leave the comment
14:34:04 <asmacdo> can i just convert it to a story but leave it ungroomed?
14:34:04 <dkliban> we can move on to the next issue
14:34:16 <asmacdo> ok
14:34:18 <asmacdo> !next
14:34:19 <smyers> bmbouter, the image rebuild failed, looks like we've got badness raining from the sky today
14:34:50 <smyers> possibly related, even, to why pulpbot is slow
14:35:03 <partha> mhrivnak: i thought jcline on was looking into it
14:35:08 <pulpbot> 5 issues left to triage: 2004, 2005, 2006, 2007, 2008
14:35:11 <asmacdo> #topic Pulp logs many DepreationWarnings - http://pulp.plan.io/issues/2004
14:35:12 <pulpbot> Pulp Issue #2004 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:35:12 <pulpbot> Pulp logs many DepreationWarnings - http://pulp.plan.io/issues/2004
14:35:16 <smyers> The log shows that it received the command instantly, so the slowness is being caused by whatever pulpbot is integrating with (redmine)
14:35:20 <jortel> mhrivnak: sure
14:36:22 <mhrivnak> jortel, thanks.
14:36:33 <smyers> #idea Proposed for #2004: Priority: Low, Severity: Low
14:36:33 <smyers> !propose triage low low
14:36:33 <pulpbot> Proposed for #2004: Priority: Low, Severity: Low
14:36:42 <smyers> These warnings are caused by how we're using mongoengine
14:36:51 <mhrivnak> indeed.
14:36:51 <smyers> We're pretty close to not using mongoengine
14:36:58 <smyers> So I propose "eh."
14:37:05 <asmacdo> +1
14:37:08 <mhrivnak> +1
14:37:14 <asmacdo> other thoughts?
14:37:39 <asmacdo> !accept
14:37:39 <asmacdo> #agreed Priority: Low, Severity: Low
14:37:39 <jalbertson> I love "eh" ... wondering how pulpbot will handle that  :)
14:37:39 <pulpbot> Current proposal accepted: Priority: Low, Severity: Low
14:37:41 <smyers> "pretty close" defined as "only one major version away..."
14:37:53 <pulpbot> 4 issues left to triage: 2005, 2006, 2007, 2008
14:37:56 <asmacdo> #topic unable to publish rpm repository - http://pulp.plan.io/issues/2005
14:37:57 <pulpbot> RPM Support Issue #2005 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:37:57 <pulpbot> unable to publish rpm repository - http://pulp.plan.io/issues/2005
14:38:35 <mhrivnak> oh, I might know why.
14:38:45 <smyers> !suggest for #2004 there's a chance that mongoengine may actually remove these deprecated features, but we'll see them in testing and can pin the mongoengine version til we stop using it
14:38:45 <smyers> #idea for #2004 there's a chance that mongoengine may actually remove these deprecated features, but we'll see them in testing and can pin the mongoengine version til we stop using it
14:39:16 <mhrivnak> pulp-admin sets and expects specific distributor IDs that might not match what katello (or any other tool) uses.
14:39:29 <dkliban> mhrivnak: that is exactly correct
14:39:33 <dkliban> i've run into this problem before
14:39:45 <asmacdo> smyers, can you please add that as a comment on #2004?
14:39:45 <dkliban> i had to use the API directly
14:39:54 <smyers> asmacdo, good call, will do
14:40:37 <mhrivnak> So should this be an enhancement to make pulp-admin not require its specific known distributor id?
14:41:05 <smyers> Or is it a bug that pulp-admin requires it?
14:41:38 * jcline grumbles about re-writing pulp-admin
14:41:38 <dkliban> i think pulp-admin should take a distributor id as an optional argument
14:41:47 <dkliban> so it's an RFE
14:42:26 <mhrivnak> Works for me.
14:42:50 <asmacdo> ok so switch to story that distributor_id is optional?
14:43:21 <mhrivnak> yes, that distributor_id can be optionally specified
14:43:42 <jcline> I think it's a bug, you can't publish/sync repos that got created via the api
14:44:12 <smyers> If you can work around this by using the API directly, I interpret that to mean that pulp-admin is using the API incorrectly
14:44:16 <smyers> Still sounds like a bug to me
14:44:19 <mhrivnak> Perhaps it's a docs failing, but pulp-admin's goal has never been to manage repos created by some other tool.
14:44:39 <mhrivnak> That in itself could be a bug depending on how you look at it. :)
14:45:27 <smyers> That's more than just a docs failing, if so
14:45:33 <mhrivnak> But it gets to the scope of pulp-admin.
14:45:42 <smyers> Those repos were created by pulp, by some use of pulp's api
14:46:17 <mhrivnak> Right. Is pulp-admin a 100% generic API client? Currently it is not.
14:46:35 <mhrivnak> It makes other assumptions, for example about which distributor types are on a repo.
14:46:37 <dkliban> i say it's a normal/medium bug
14:47:06 <jcline> dkliban, +1
14:47:11 <smyers> +1
14:47:32 <asmacdo> can we elaborate on what the problem is?
14:47:56 <asmacdo> if the repo is generated by the API, it doesn't set the distributor? is that the problem?
14:48:12 <asmacdo> because that doesnt seem like a bug to me
14:48:29 <jcline> asmacdo, no it's that you can't publish a repo with pulp-admin unless it has a specific distributor id
14:48:31 <mhrivnak> When adding a distributor, pulp expects a unique ID to be provided for that instance of the distributor. It can be anything.
14:48:44 <mhrivnak> pulp-admin has its own schema, and katello has a different one.
14:48:56 <mhrivnak> Other API clients can make their own choices.
14:49:14 <jsherrill> instead of using type_id of the distributor, pulp-admin uses the id
14:49:16 <jsherrill> which can be anything
14:49:19 <mhrivnak> So pulp-admin tries to publish with the expectation that it was the one who created the repo, and expects to find the unique IDs it knows about.
14:49:53 <asmacdo> ok.
14:50:11 <asmacdo> !propose triage normal medium
14:50:11 <asmacdo> #idea Proposed for #2005: Priority: Normal, Severity: Medium
14:50:12 <pulpbot> Proposed for #2005: Priority: Normal, Severity: Medium
14:50:20 <asmacdo> mhrivnak?
14:51:12 <mhrivnak> I still think it's more of an enhancement, but I'm happy to treat it as a bug. I suggest low severity.
14:51:42 <asmacdo> Im ok with that. ill put the workaround in a comment
14:51:54 <mhrivnak> jsherrill, do you think it should be prioritized any higher than normal/low?
14:52:06 <smyers> It is an enhancement, but one that fixes a bug. Bugfixes are enhancements. It's not adding a new feature to pulp, it's adding support for an existing feature to the pulp CLI, which really should do what it can to be a generic API client for pulp.
14:52:21 <jsherrill> mhrivnak: i think that's fine
14:52:50 <mhrivnak> I do think it's adding a new use case for pulp-admin to cover that it never attempted to cover before.
14:53:25 <mhrivnak> We should probably move on and talk about pulp-admin's general role in life another time. :)
14:53:39 <asmacdo> !propose normal low
14:53:39 <pulpbot> Error: "propose" is not a valid command.
14:53:44 <asmacdo> !propose triage normal low
14:53:44 <asmacdo> #idea Proposed for #2005: Priority: Normal, Severity: Low
14:53:45 <pulpbot> Proposed for #2005: Priority: Normal, Severity: Low
14:53:54 <asmacdo> good for everyone?
14:53:58 <mhrivnak> works for me
14:54:27 <dkliban> yep
14:54:40 <asmacdo> !accept
14:54:40 <asmacdo> #agreed Priority: Normal, Severity: Low
14:54:40 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:55:07 * smyers kicks pulpbot
14:55:22 * smyers kicks pulpbut harder
14:55:36 <asmacdo> #topic iso importer fails without useful error message - http://pulp.plan.io/issues/2006
14:55:36 <pulpbot> 3 issues left to triage: 2006, 2007, 2008
14:55:37 <pulpbot> Pulp Issue #2006 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:55:38 <pulpbot> iso importer fails without useful error message - http://pulp.plan.io/issues/2006
14:56:10 <smyers> loadavg on the bot box is currently a shocking 0.00...I wonder if there are general network failures occurring
14:56:55 <asmacdo> mhrivnak, do you happen to know why the sync failed?
14:57:01 <smyers> heh
14:57:02 <mhrivnak> nope
14:57:03 <smyers> {"name"=>"Red_Hat_Enterprise_Linux_5.xml", "error"=>{}
14:57:12 <smyers> Is the issue that there should be something in that {} ?
14:57:15 <mhrivnak> Oh yes, of course! It failed because of {}
14:57:20 <smyers> hahaha
14:57:24 <jortel> heh
14:57:25 <mhrivnak> yes.:)
14:57:44 <smyers> I kinda like it as-is, then
14:57:47 <smyers> !propose accept
14:57:47 <smyers> #idea Proposed for #2006: Leave the issue as-is, accepting its current state.
14:57:48 <pulpbot> Proposed for #2006: Leave the issue as-is, accepting its current state.
14:57:51 <smyers> (and mark as triaged)
14:57:55 <mhrivnak> works for me.
14:58:11 <asmacdo> last call
14:58:24 <asmacdo> !accept
14:58:24 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:58:24 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:58:28 <smyers> y'know, it'd be so trivia to just change that message. I could do it with a github edit, even.
14:58:30 <smyers> I might just.
14:58:45 * smyers kicks the network
14:58:49 <pulpbot> 2 issues left to triage: 2007, 2008
14:58:53 <asmacdo> #topic Errata install API should expect 'id' as part of unit key - http://pulp.plan.io/issues/2007
14:58:53 <pulpbot> RPM Support Issue #2007 [MODIFIED] (unassigned) - Priority: High | Severity: High
14:58:53 <pulpbot> Errata install API should expect 'id' as part of unit key - http://pulp.plan.io/issues/2007
14:59:02 <asmacdo> modified
14:59:10 <asmacdo> #idea Proposed for #2007: Leave the issue as-is, accepting its current state.
14:59:10 <asmacdo> !propose accept
14:59:10 <pulpbot> Proposed for #2007: Leave the issue as-is, accepting its current state.
14:59:11 <smyers> !propose accept
14:59:12 <dkliban> yeah ... i already fixed it
14:59:14 <mhrivnak> +1
14:59:16 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:59:16 <asmacdo> !accept
14:59:16 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:59:20 <pulpbot> 1 issues left to triage: 2008
14:59:24 <asmacdo> #topic qpidd exceeded 2000 connections limit - http://pulp.plan.io/issues/2008
14:59:24 <smyers> aw, asmacdo beat me to it and pulpbot yelled at me
14:59:24 <pulpbot> Pulp Issue #2008 [NEW] (unassigned) - Priority: High | Severity: Medium
14:59:24 <pulpbot> qpidd exceeded 2000 connections limit - http://pulp.plan.io/issues/2008
14:59:33 <bmbouter> I've been commenting on this one
14:59:49 <mhrivnak> Oh, another snuck in just in time!
15:00:38 <asmacdo> bmbouter, should we leave untriaged for friday?
15:00:53 <bmbouter> I think that would be fine. I'm going to keep commenting on it either way
15:00:55 <mhrivnak> I was thinking the same.
15:01:06 <asmacdo> cool
15:01:14 <asmacdo> !skip
15:01:27 <pulpbot> No issues to triage.
15:01:30 <smyers> weeeee
15:01:35 <asmacdo> !gavelgavel
15:01:35 <pulpbot> Error: "gavelgavel" is not a valid command.
15:01:37 <asmacdo> !end
15:01:37 <asmacdo> #endmeeting