14:32:25 <asmacdo> #startmeeting Pulp Triage 2016-06-17
14:32:26 <asmacdo> #info asmacdo has joined triage
14:32:26 <pulpbot> Meeting started Fri Jun 17 14:32:25 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:27 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:32:27 <pulpbot> The meeting name has been set to 'pulp_triage_2016_06_17'
14:32:27 <pulpbot> asmacdo has joined triage
14:32:30 <dkliban> !here
14:32:30 <dkliban> #info dkliban has joined triage
14:32:30 <pulpbot> dkliban has joined triage
14:32:34 <preethi> !here
14:32:34 <preethi> #info preethi has joined triage
14:32:35 <pulpbot> preethi has joined triage
14:32:44 <ipanova> !here
14:32:44 <ipanova> #info ipanova has joined triage
14:32:44 <pulpbot> ipanova has joined triage
14:33:18 <asmacdo> !next
14:33:19 <pulpbot> 8 issues left to triage: 2008, 2009, 2010, 2011, 2012, 2013, 2016, 2019
14:33:20 <asmacdo> #topic qpidd exceeded 2000 connections limit - http://pulp.plan.io/issues/2008
14:33:21 <pulpbot> Pulp Issue #2008 [NEW] (unassigned) - Priority: High | Severity: Medium
14:33:22 <pulpbot> qpidd exceeded 2000 connections limit - http://pulp.plan.io/issues/2008
14:33:45 <jcline> !here
14:33:45 <jcline> #info jcline has joined triage
14:33:45 <pulpbot> jcline has joined triage
14:34:07 <asmacdo> bmbouter, can you weigh in on this one?
14:34:24 <dkliban> bmbouter: is not available right now
14:34:28 <dkliban> let's skip it for now
14:34:39 <dkliban> perhaps we can ocme back to it at the end
14:34:40 <asmacdo> good with me
14:34:46 <asmacdo> !skip
14:34:47 <pulpbot> 7 issues left to triage: 2009, 2010, 2011, 2012, 2013, 2016, 2019
14:34:47 <asmacdo> #topic 404s for pulp apache static content process unless there is a trailing slash in the URL - http://pulp.plan.io/issues/2009
14:34:48 <pulpbot> Pulp Issue #2009 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:49 <pulpbot> 404s for pulp apache static content process unless there is a trailing slash in the URL - http://pulp.plan.io/issues/2009
14:35:05 <jcline> this is a duplicate of 1930
14:35:13 <jcline> I'll handle closing it and stuff
14:35:25 <dkliban> jcline: thanks
14:35:45 <asmacdo> !propose other jcline will close as a dupe of 1930
14:35:45 <asmacdo> #idea Proposed for #2009: jcline will close as a dupe of 1930
14:35:46 <pulpbot> Proposed for #2009: jcline will close as a dupe of 1930
14:36:05 <asmacdo> !accept
14:36:05 <asmacdo> #agreed jcline will close as a dupe of 1930
14:36:05 <pulpbot> Current proposal accepted: jcline will close as a dupe of 1930
14:36:07 <asmacdo> #topic group_export_distributor is not listed by /pulp/api/v2/plugins/distributors - http://pulp.plan.io/issues/2010
14:36:07 <pulpbot> 6 issues left to triage: 2010, 2011, 2012, 2013, 2016, 2019
14:36:08 <pulpbot> Pulp Issue #2010 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:09 <pulpbot> group_export_distributor is not listed by /pulp/api/v2/plugins/distributors - http://pulp.plan.io/issues/2010
14:36:37 <dkliban> !propose triage normal medium
14:36:37 <dkliban> #idea Proposed for #2010: Priority: Normal, Severity: Medium
14:36:38 <pulpbot> Proposed for #2010: Priority: Normal, Severity: Medium
14:37:20 <asmacdo> dkliban, does this seem like a docs bug?
14:37:26 <ipanova> +1
14:37:36 <dkliban> asmacdo: no ... i think it's the api returning not a full list
14:37:43 <asmacdo> ah ok
14:37:46 <ipanova> asmacdo: nope, seems like api bug
14:37:53 <asmacdo> cool
14:38:01 <asmacdo> !accept
14:38:01 <asmacdo> #agreed Priority: Normal, Severity: Medium
14:38:02 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
14:38:03 <asmacdo> #topic docker_distributor_web "protected" documentation is wrong - http://pulp.plan.io/issues/2011
14:38:03 <pulpbot> 5 issues left to triage: 2011, 2012, 2013, 2016, 2019
14:38:04 <pulpbot> Docker Support Issue #2011 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:38:05 <pulpbot> docker_distributor_web "protected" documentation is wrong - http://pulp.plan.io/issues/2011
14:38:48 <ipanova> !propose normal medium
14:38:49 <pulpbot> Error: "propose" is not a valid command.
14:39:08 <dkliban> !propose triage normal medium
14:39:08 <dkliban> #idea Proposed for #2011: Priority: Normal, Severity: Medium
14:39:09 <pulpbot> Proposed for #2011: Priority: Normal, Severity: Medium
14:39:09 <ipanova> !propose tirage normal medium
14:39:09 <pulpbot> Error: "propose" is not a valid command.
14:39:21 <ipanova> jesus
14:39:31 <asmacdo> lol
14:39:39 <asmacdo> is the default wrong or the docs?
14:39:47 <ipanova> more likely a doc bug
14:39:56 <dkliban> yep
14:39:59 <ipanova> looking at the code, docs are wrong
14:40:02 <dkliban> easy fix
14:40:28 <asmacdo> !accept
14:40:28 <asmacdo> #agreed Priority: Normal, Severity: Medium
14:40:28 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
14:40:29 <asmacdo> #topic alternate content source refresh fails with json serialization error - http://pulp.plan.io/issues/2012
14:40:30 <pulpbot> 4 issues left to triage: 2012, 2013, 2016, 2019
14:40:31 <pulpbot> Pulp Issue #2012 [NEW] (unassigned) - Priority: High | Severity: High
14:40:32 <pulpbot> alternate content source refresh fails with json serialization error - http://pulp.plan.io/issues/2012
14:41:04 <dkliban> i propose we accept this as is
14:41:20 <jcline> +1
14:42:00 <bmbouter> !join
14:42:00 <pulpbot> Error: You don't have the admin capability. If you think that you should have this capability, be sure that you are identified before trying again. The 'whoami' command can tell you if you're identified.
14:42:10 <bmbouter> asmacdo: I'm here now
14:42:23 <asmacdo> !accept
14:42:24 <pulpbot> No action proposed, nothing to accept.
14:42:29 <asmacdo> oh
14:42:38 <dkliban> bmbouter: you need to say !here
14:42:44 <bmbouter> !here
14:42:44 <bmbouter> #info bmbouter has joined triage
14:42:45 <pulpbot> bmbouter has joined triage
14:42:46 <asmacdo> !propose triage high high
14:42:46 <asmacdo> #idea Proposed for #2012: Priority: High, Severity: High
14:42:47 <pulpbot> Proposed for #2012: Priority: High, Severity: High
14:42:47 <bmbouter> I am here!
14:42:57 <asmacdo> !accept
14:42:57 <asmacdo> #agreed Priority: High, Severity: High
14:42:58 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:42:58 <asmacdo> #topic SSL certs are created at install time, but should be at setup runtime - http://pulp.plan.io/issues/2013
14:42:59 <pulpbot> 3 issues left to triage: 2013, 2016, 2019
14:43:00 <pulpbot> Pulp Issue #2013 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:43:01 <pulpbot> SSL certs are created at install time, but should be at setup runtime - http://pulp.plan.io/issues/2013
14:43:58 <jcline> Severity High, I think. Duplicate private keys isn't good.
14:44:03 <dkliban> yeah
14:44:46 <asmacdo> priority?
14:45:07 <jcline> I guess High as well?
14:45:18 <ipanova> !prpose triage high high
14:45:18 <pulpbot> Error: "prpose" is not a valid command.
14:45:32 <ipanova> not my day today :D
14:45:48 <ipanova> !propose triage high high
14:45:48 <ipanova> #idea Proposed for #2013: Priority: High, Severity: High
14:45:49 <pulpbot> Proposed for #2013: Priority: High, Severity: High
14:45:52 <ipanova> yay
14:45:57 <asmacdo> ipanova++
14:45:57 <pulpbot> ipanova's karma is now 12
14:46:11 <asmacdo> im good with that, any other thoughts?
14:46:22 <asmacdo> !accept
14:46:22 <asmacdo> #agreed Priority: High, Severity: High
14:46:22 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:46:23 <pulpbot> 2 issues left to triage: 2016, 2019
14:46:23 <asmacdo> #topic pulp-admin : The specified user does not have permission to execute the given command - http://pulp.plan.io/issues/2016
14:46:24 <pulpbot> Pulp Issue #2016 [NEW] (unassigned) - Priority: Normal | Severity: High
14:46:25 <pulpbot> pulp-admin : The specified user does not have permission to execute the given command - http://pulp.plan.io/issues/2016
14:46:36 <ipanova> i think it is notabug
14:46:40 <ipanova> and we should close it
14:47:05 <dkliban> ipanova: it's a duplicate
14:47:12 <dkliban> you get that message if you are not loggedi n
14:47:26 <dkliban> i just dont' know what the other issue number is
14:47:57 <ipanova> dkliban: yes i know, but i don't see here any issue?
14:49:29 <ipanova> dkliban: we have in the logs "Authentication with username None failed: invalid SSL certificate." because noone is logged in
14:49:47 <ipanova> dkliban:  everything is clear from my point of view i.e --> you need to login
14:50:09 <dkliban> so what do we want to say? that this is not a bug?
14:50:17 <asmacdo> i think notabug is fine
14:50:37 <ipanova> i think that it is notabug
14:50:52 <asmacdo> !propose other close-notabug
14:50:52 <asmacdo> #idea Proposed for #2016: close-notabug
14:50:53 <pulpbot> Proposed for #2016: close-notabug
14:51:03 <ipanova> the bug would be if the guy would login and still have this error dkliban
14:51:03 <dkliban> i don't think so ... i think the message is wrong
14:51:05 <dkliban> and that is a bug
14:51:50 <dkliban> you can't say the following user doesn't have permission to do something when the user is not even logged in
14:52:03 <asmacdo> fair enough
14:52:46 <dkliban> pulp should clearly tell th user that a usrname and password need to provided or a session should be started by using login command
14:53:25 <asmacdo> got it #1079
14:53:30 <asmacdo> https://pulp.plan.io/issues/1079
14:53:32 <pulpbot> Title: Issue #1079: Wrong error message when performing operation without logging in - Pulp (at pulp.plan.io)
14:53:50 <dkliban> asmacdo: i'll close the new one as a duplicate of 1079
14:53:58 <asmacdo> cool,
14:54:09 <ipanova> dkliban: sweet
14:54:18 <asmacdo> !propose other close as duplicate of #1079
14:54:18 <asmacdo> #idea Proposed for #2016: close as duplicate of #1079
14:54:19 <pulpbot> Proposed for #2016: close as duplicate of #1079
14:54:23 <asmacdo> !accept
14:54:23 <asmacdo> #agreed close as duplicate of #1079
14:54:23 <pulpbot> Current proposal accepted: close as duplicate of #1079
14:54:25 <asmacdo> #topic Repo sync/publish with ----generate-sqlite true errors out on the demo repo - http://pulp.plan.io/issues/2019
14:54:25 <pulpbot> 1 issues left to triage: 2019
14:54:26 <pulpbot> Pulp Issue #2019 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Target Release: 2.9.0
14:54:27 <pulpbot> Repo sync/publish with ----generate-sqlite true errors out on the demo repo - http://pulp.plan.io/issues/2019
14:55:18 <asmacdo> preethi, i see that target platform release is 2.9.0?
14:55:41 <preethi> asmacdo: not sure I set it right
14:55:53 <beav> is it possible to update a distributor config by POSTing directly to the distributor? or do i need to update the repo itself and use distributor_config
14:56:17 <preethi> and also not sure if its an issue with the demo repo
14:56:18 <ipanova> beav: yes, but with PUT
14:56:49 <ipanova> beav:
14:56:53 <ipanova> http://pulp.readthedocs.io/en/latest/dev-guide/integration/rest-api/repo/cud.html#update-a-distributor-associated-with-a-repository beav
14:56:53 <preethi> asmacdo: if it is actually an issue then, yes it should be fixed in 2.9
14:56:53 <pulpbot> Title: Creation, Deletion, and Configuration — Pulp Project 2.8.4 documentation (at pulp.readthedocs.io)
14:57:11 <beav> oh! i was not using delta
14:57:19 <beav> ipanova: thx, i was looking at the wrong page
14:57:20 <smyers> If it's an issue it will be, but it shouldn't target 2.9.0 unless it's a release blocker.
14:57:21 <asmacdo> preethi, so this is a regression then?
14:57:33 <dkliban> asmacdo: this is new in 2.9
14:58:01 <dkliban> we just demoed the feature yesterday
14:58:01 <jcline> It looks like the XML in the repository is not considered to be well-formed by createrepo_c
14:58:04 <beav> ipanova: success, thx:)
14:58:09 <jcline> That seems... ominous
14:58:12 <asmacdo> ok. so i dont think we have fully ironed out how we handle this, but i think we do URGENT without a target release?
14:58:22 <ipanova> dkliban: i don't think it is related to the repoview, but to the sqlite files generation
14:59:07 <preethi> asmacdo: It was an error on my part to set the target, it should have been the version
14:59:47 <dkliban> ipanova: is the sqlite generation new also?
14:59:52 <ipanova> dkliban: no
15:00:54 <ipanova> !propose triage high high
15:00:54 <ipanova> #idea Proposed for #2019: Priority: High, Severity: High
15:00:54 <pulpbot> Proposed for #2019: Priority: High, Severity: High
15:01:01 <dkliban> +1
15:01:13 <jcline> Fine with me
15:01:16 <ipanova> i think we need to investigate first if it is related to the new feature or not
15:01:21 <dkliban> yeah
15:01:26 <preethi> if its an actual issue, I think it needs to be in 2.9
15:02:05 <ipanova> dkliban: Tanya will be back on Monday, i guess she could say right away where stand the issue
15:02:14 <dkliban> asmacdo: let's accept it as high/high and move to issue 2008
15:02:22 <dkliban> move on to issue 2008
15:02:32 <smyers> Please remove the 2.9.0 target release until it's determined to be a blocker. Also, someone needs to own making sure the blocker meeting happens.
15:02:47 <asmacdo> dkliban, ok works for me. ipanova could you leave a comment after im done with it?
15:03:18 <asmacdo> !accept
15:03:18 <asmacdo> #agreed Priority: High, Severity: High
15:03:19 <pulpbot> Current proposal accepted: Priority: High, Severity: High
15:03:19 <pulpbot> No issues to triage.
15:03:23 <asmacdo> !issue 2008
15:03:24 <asmacdo> #topic qpidd exceeded 2000 connections limit - http://pulp.plan.io/issues/2008
15:03:24 <pulpbot> Pulp Issue #2008 [NEW] (unassigned) - Priority: High | Severity: Medium
15:03:25 <pulpbot> qpidd exceeded 2000 connections limit - http://pulp.plan.io/issues/2008
15:03:28 <dkliban> bmbouter: ^
15:03:37 <ipanova> asmacdo: yes
15:03:46 <asmacdo> ipanova, im done with it go ahead
15:05:20 <asmacdo> bmbouter, you there?
15:05:34 <dkliban> bmbouter: do you want to weigh in on #2008 ? or should we just mark it as triaged with High/Medium ?
15:05:50 <smyers> asmacdo, I'm at least one of his distractions
15:06:06 <asmacdo> smyers, quit it :)
15:06:13 <bmbouter> hey
15:06:17 <smyers> it's probably reasonable to wait a lil' bit :)
15:06:23 <smyers> sorry!
15:06:38 <bmbouter> 2008 we should traige it as High/High I think
15:06:44 <bmbouter> it is very severe
15:06:49 <asmacdo> !propose triage high high
15:06:49 <asmacdo> #idea Proposed for #2008: Priority: High, Severity: High
15:06:50 <pulpbot> Proposed for #2008: Priority: High, Severity: High
15:06:52 <bmbouter> +1
15:06:54 <dkliban> +1
15:06:58 <asmacdo> !accept
15:06:58 <asmacdo> #agreed Priority: High, Severity: High
15:06:59 <pulpbot> Current proposal accepted: Priority: High, Severity: High
15:07:00 <pulpbot> No issues to triage.
15:07:04 <dkliban> awesome
15:07:08 <asmacdo> !end
15:07:08 <asmacdo> #endmeeting