14:30:27 <asmacdo> #startmeeting Pulp Triage 2016-06-21
14:30:27 <asmacdo> #info asmacdo has joined triage
14:30:27 <pulpbot> Meeting started Tue Jun 21 14:30:27 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:27 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:27 <pulpbot> The meeting name has been set to 'pulp_triage_2016_06_21'
14:30:27 <pulpbot> asmacdo has joined triage
14:30:32 <bmbouter> !here
14:30:32 <bmbouter> #info bmbouter has joined triage
14:30:33 <pulpbot> bmbouter has joined triage
14:30:55 <dkliban> !here
14:30:55 <dkliban> #info dkliban has joined triage
14:30:56 <pulpbot> dkliban has joined triage
14:31:07 <ttereshc> !here
14:31:07 <ttereshc> #info ttereshc has joined triage
14:31:08 <pulpbot> ttereshc has joined triage
14:31:24 <pcreech> !here
14:31:24 <pcreech> #info pcreech has joined triage
14:31:24 <pulpbot> pcreech has joined triage
14:31:26 <asmacdo> !next
14:31:27 <pulpbot> 6 issues left to triage: 2020, 2021, 2023, 2024, 2025, 2027
14:31:27 <asmacdo> #topic Cannot provide multiple checksums when uploading an erratum - http://pulp.plan.io/issues/2020
14:31:28 <pulpbot> RPM Support Issue #2020 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:28 <pulpbot> Cannot provide multiple checksums when uploading an erratum - http://pulp.plan.io/issues/2020
14:32:21 <dkliban> it sounds important
14:32:42 <dkliban> jluza: do you ever upload errata that have multiple checksum types specified?
14:32:49 <ipanova> !here
14:32:49 <ipanova> #info ipanova has joined triage
14:32:49 <pulpbot> ipanova has joined triage
14:32:57 <dalley> !here
14:32:57 <dalley> #info dalley has joined triage
14:32:58 <pulpbot> dalley has joined triage
14:34:10 <dkliban> i am not sure if this issue should be high priority
14:34:25 <bmbouter> me neither
14:34:30 <bmbouter> I'm trying to find the docs
14:34:40 <jluza> dkliban, hmm, I think we had errata like that
14:35:00 <dkliban> bmbouter: i think we should make this high priority
14:35:24 <bmbouter> if pulp supports it then ok, but does pulp support it?
14:35:32 <dkliban> errata can reference packages in multiple repos
14:35:44 <dkliban> and the two repos might have different checksums
14:35:55 <dkliban> so i think it's a valid case ...
14:36:12 <dkliban> ichimonji10: did you try using two checksums because the docs on errata tool say that is possible?
14:36:35 <asmacdo> the data structure there looks odd to me.
14:36:37 <bmbouter> it could also be an rfe
14:36:37 <ichimonji10> dkliban: internal?
14:36:43 <ichimonji10> No, it's not an RFE
14:36:47 <ichimonji10> And it's not theoretical
14:36:52 <ichimonji10> It's happening right now in production
14:37:19 <asmacdo> a list where the first element is the checksum type and the second is the checksum doesn't seem right
14:37:29 <ichimonji10> Aye. I agree it's silly
14:37:47 <ichimonji10> There's other stilly things about the erratum structure
14:37:56 <ichimonji10> I'm with you there.
14:37:56 <bmbouter> so there are existing errata who have multiple checksums specified this way?
14:38:00 <ichimonji10> bmbouter: yes.
14:38:05 <bmbouter> and you're saying Pulp needs to do this because content does this
14:38:34 <ichimonji10> bmbouter: Sorry, accidentally quit and lost that last bit
14:38:46 <bmbouter> ichimonji10: a link to an errata which pulp cannot handle as an upload would be good
14:39:09 <ichimonji10> bmbouter: I'll leave a private comment?
14:39:13 <bmbouter> that is good
14:39:51 <asmacdo> anyone have ideas for priority/severity?
14:40:10 <dkliban> !propose triage high medium
14:40:10 <dkliban> #idea Proposed for #2020: Priority: High, Severity: Medium
14:40:11 <pulpbot> Proposed for #2020: Priority: High, Severity: Medium
14:40:30 <bmbouter> +1
14:40:56 <asmacdo> !accept
14:40:56 <asmacdo> #agreed Priority: High, Severity: Medium
14:40:56 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
14:40:58 <asmacdo> #topic Pulp drops "release" field from uploaded erraum - http://pulp.plan.io/issues/2021
14:40:58 <pulpbot> 5 issues left to triage: 2021, 2023, 2024, 2025, 2027
14:40:58 <pulpbot> RPM Support Issue #2021 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:59 <pulpbot> Pulp drops "release" field from uploaded erraum - http://pulp.plan.io/issues/2021
14:41:32 <bmbouter> I think this can be traiged as-is
14:41:48 <ichimonji10> This is another one of those "it's happening in production right now" issues.
14:42:17 <ttereshc> ichimonji10, is it only in 2.9?
14:42:23 <ichimonji10> ttereshc: 2.8 and 2.9
14:42:38 <ichimonji10> Same with issue 2020
14:42:48 <ttereshc> ok
14:42:53 <ttereshc> !propose accept
14:42:53 <ttereshc> #idea Proposed for #2021: Leave the issue as-is, accepting its current state.
14:42:54 <pulpbot> Proposed for #2021: Leave the issue as-is, accepting its current state.
14:43:02 <asmacdo> sounds like low severity to me
14:43:20 <dkliban> not low severity ... errata are being published without a release field for the package
14:43:28 <dkliban> sometimes the only thing that changes is the release field
14:43:47 <dkliban> if we are going for correctness, we are getting it wrong here
14:43:57 <asmacdo> ah, i thought there were 2 release fields, and it was using one but not the other
14:43:58 <ttereshc> dkliban, I think it is realese field for the erratum
14:44:35 <ttereshc> not for the package
14:44:40 <dkliban> ichimonji10: is it packages release field or erratum release field?
14:45:08 <dkliban> i think it's the package that is part of the erratum that has the release field missing
14:45:30 <ichimonji10> dkliban: The erratum['unit_metadata']['release'] field
14:45:38 <ichimonji10> The one with a value of "0" in the example given
14:45:43 <dkliban> gotcha
14:45:48 <dkliban> ok ... let's accept as is then
14:45:53 <asmacdo> agreed
14:45:58 <asmacdo> !accept
14:45:58 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:45:59 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:45:59 <asmacdo> #topic Error while login in pulp-admin - http://pulp.plan.io/issues/2023
14:46:00 <pulpbot> 4 issues left to triage: 2023, 2024, 2025, 2027
14:46:00 <pulpbot> Pulp Issue #2023 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:46:01 <pulpbot> Error while login in pulp-admin - http://pulp.plan.io/issues/2023
14:46:35 <dkliban> i don't even know what juicer is
14:46:41 <dkliban> i think we should ask for more info
14:47:10 <bmbouter> perhaps juicer's pymongo requirement is incompatible with pulp's
14:48:23 <bmbouter> I can comment on it if we want to skip it
14:48:25 <bmbouter> just let me know
14:48:35 <dkliban> bmbouter: please leave a comment and we will not triage it at this time
14:48:43 <bmbouter> ok
14:48:45 <asmacdo> sounds good to me
14:49:03 <asmacdo> !propose other bmbouter will leave a comment and we will defer
14:49:03 <asmacdo> #idea Proposed for #2023: bmbouter will leave a comment and we will defer
14:49:03 <pulpbot> Proposed for #2023: bmbouter will leave a comment and we will defer
14:49:14 <asmacdo> !accept
14:49:14 <asmacdo> #agreed bmbouter will leave a comment and we will defer
14:49:14 <pulpbot> Current proposal accepted: bmbouter will leave a comment and we will defer
14:49:15 <pulpbot> 3 issues left to triage: 2024, 2025, 2027
14:49:15 <asmacdo> #topic Summary listing of RPM repos appears to be broken - http://pulp.plan.io/issues/2024
14:49:16 <pulpbot> Pulp Issue #2024 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:49:16 <pulpbot> Summary listing of RPM repos appears to be broken - http://pulp.plan.io/issues/2024
14:51:05 <asmacdo> unless this is because he put -vvv, id say this is a pretty clear regression
14:52:18 <ttereshc> !propose triage h m
14:52:18 <ttereshc> #idea Proposed for #2024: Priority: High, Severity: Medium
14:52:18 <pulpbot> Proposed for #2024: Priority: High, Severity: Medium
14:52:30 <asmacdo> other thoughts?
14:52:41 <dkliban> +1
14:52:51 <asmacdo> !accept
14:52:51 <asmacdo> #agreed Priority: High, Severity: Medium
14:52:52 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
14:52:53 <asmacdo> #topic remove_missing option does not work unless repository is updated - http://pulp.plan.io/issues/2027
14:52:53 <pulpbot> 1 issues left to triage: 2027
14:52:53 <pulpbot> RPM Support Issue #2027 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:52:54 <pulpbot> remove_missing option does not work unless repository is updated - http://pulp.plan.io/issues/2027
14:53:23 <dkliban> this one should be a story
14:53:34 <dkliban> i'll update it and we can move on
14:54:10 <dalley> It skipped #2025?  I just edited it to make it a story instead of an issue, maybe that's why
14:54:26 <dkliban> oh ok
14:54:28 <asmacdo> !skip
14:54:28 <dkliban> cool
14:54:29 <pulpbot> No issues to triage.
14:54:39 <asmacdo> did you want to talk about 2025 dkliban ?
14:54:44 <dalley> yeah I do
14:54:45 <dalley> We should discuss what the scope of this one should be - whether "active: true|false" is good enough or whether we want something more along the lines of "state: active|inactive|etc."
14:54:50 <bmbouter> FYI, 2023 is getting closed as NOTABUG
14:54:50 <dkliban> asmacdo: no ... i wanted to talk about 2027
14:54:50 <asmacdo> !issue 2025
14:54:51 <asmacdo> #topic View the state ("active", "inactive", etc.) of various pulp processes via the status API - http://pulp.plan.io/issues/2025
14:54:51 <pulpbot> Pulp Story #2025 [NEW] (unassigned) - Priority: Normal
14:54:52 <pulpbot> View the state ("active", "inactive", etc.) of various pulp processes via the status API - http://pulp.plan.io/issues/2025
14:54:57 <bmbouter> so we won't see it next week
14:55:20 <dkliban> asmacdo: i wanted to talk about 2027, i thought we were looking at 2025 when i said to skip it
14:55:28 <asmacdo> aha
14:55:31 <asmacdo> !issue 2027
14:55:32 <asmacdo> #topic remove_missing option does not work unless repository is updated - http://pulp.plan.io/issues/2027
14:55:32 <pulpbot> RPM Support Issue #2027 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:55:32 <pulpbot> remove_missing option does not work unless repository is updated - http://pulp.plan.io/issues/2027
14:55:41 <dkliban> dalley: let's talk about your story after triage
14:55:54 <ipanova> dkliban: w/r to #2027, #1983 can be updated to include that case
14:55:57 <dalley> acknowledged
14:56:33 <asmacdo> ipanova, so would you like to close 2027 as a dupe and update 1983?
14:57:29 <ipanova> asmacdo: i'd out it as related, because 1971 is similar case
14:57:34 <ipanova> s/out/put
14:59:12 <asmacdo> ipanova, do you have a priority proposal
14:59:40 <dkliban> i think this is medium/normal
14:59:47 <ipanova> agree
14:59:55 <dkliban> let's triage it as is
15:00:08 <asmacdo> !propose accept
15:00:08 <asmacdo> #idea Proposed for #2027: Leave the issue as-is, accepting its current state.
15:00:09 <pulpbot> Proposed for #2027: Leave the issue as-is, accepting its current state.
15:00:26 <asmacdo> !accept
15:00:26 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
15:00:26 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:00:27 <dkliban> awesome
15:00:28 <pulpbot> No issues to triage.
15:00:36 <dkliban> and we are done
15:00:41 <asmacdo> dkliban, did you want to talk about 2025 before we end?
15:00:49 <dkliban> asmacdo: it's a story
15:00:54 <asmacdo> !end
15:00:54 <asmacdo> #endmeeting