14:29:54 <asmacdo> #startmeeting Pulp Triage 2016-06-28
14:29:54 <asmacdo> #info asmacdo has joined triage
14:29:55 <pulpbot> Meeting started Tue Jun 28 14:29:54 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:55 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:55 <pulpbot> The meeting name has been set to 'pulp_triage_2016_06_28'
14:29:55 <pulpbot> asmacdo has joined triage
14:30:01 <dkliban> !here
14:30:01 <dkliban> #info dkliban has joined triage
14:30:02 <pulpbot> dkliban has joined triage
14:30:08 <dalley> !here
14:30:08 <dalley> #info dalley has joined triage
14:30:08 <pulpbot> dalley has joined triage
14:30:15 <preethi> !here
14:30:15 <preethi> #info preethi has joined triage
14:30:16 <pulpbot> preethi has joined triage
14:30:17 <asmacdo> !next
14:30:18 <pulpbot> 4 issues left to triage: 2035, 2036, 2037, 2038
14:30:19 <asmacdo> #topic Errata are published incrementally - http://pulp.plan.io/issues/2035
14:30:19 <pulpbot> RPM Support Issue #2035 [ASSIGNED] (ttereshc) - Priority: Normal | Severity: Medium
14:30:19 <pulpbot> Errata are published incrementally - http://pulp.plan.io/issues/2035
14:30:21 <ttereshc> asmacdo, it was a right second to start :)
14:30:25 <ttereshc> !here
14:30:25 <ttereshc> #info ttereshc has joined triage
14:30:26 <pulpbot> ttereshc has joined triage
14:30:39 <asmacdo> lol ttereshc, ive got a lot i want to do today :)
14:30:43 <pcreech> !here
14:30:43 <pcreech> #info pcreech has joined triage
14:30:43 <pulpbot> pcreech has joined triage
14:30:43 <ipanova> !here
14:30:43 <ipanova> #info ipanova has joined triage
14:30:44 <pulpbot> ipanova has joined triage
14:31:04 <smyers> !here
14:31:04 <smyers> #info smyers has joined triage
14:31:05 <pulpbot> smyers has joined triage
14:31:31 <jcline> !here
14:31:31 <jcline> #info jcline has joined triage
14:31:32 <pulpbot> jcline has joined triage
14:32:27 <jortel> !here
14:32:27 <jortel> #info jortel has joined triage
14:32:28 <pulpbot> jortel has joined triage
14:32:58 <ttereshc> I think it is really bad that errata is published incrementally and repomd.xml points to the recently added errata only, but maybe I miss something..
14:33:26 <jluza> dkliban, here's my finished basic test for rpm http://pastebin.test.redhat.com/388013
14:33:28 <bmbouter> !here
14:33:28 <bmbouter> #info bmbouter has joined triage
14:33:29 <pulpbot> bmbouter has joined triage
14:33:43 <asmacdo> ttereshc, im not sure that i understand the problem
14:33:57 <smyers> I still don't know how things like yum handle multiple updateinfo.xml files. Do they?
14:34:10 <ttereshc> in 2.8 updateifo was regenerated with every publish
14:34:15 <jcline> smyers, it doesn't
14:34:22 <mhrivnak> !here
14:34:22 <mhrivnak> #info mhrivnak has joined triage
14:34:23 <pulpbot> mhrivnak has joined triage
14:34:27 <jcline> (as far as I know)
14:34:32 <bmbouter> I also think that
14:34:38 * mhrivnak somehow wasn't getting any messages and doesn't have history. :(
14:34:40 <jcline> It leaves old metadata files around since caches
14:34:51 <bmbouter> mhrivnak:  https://pulp.plan.io/issues/2035
14:34:53 <pulpbot> Title: Issue #2035: Errata are published incrementally - RPM Support - Pulp (at pulp.plan.io)
14:35:04 <jluza> dkliban, and here are my latest changes for pulp_rpm http://pastebin.test.redhat.com/388013
14:35:55 <mhrivnak> The commit ttereshc identified was intended to do incremental *export* of errata, but should not have affected normal publishes.
14:36:07 <bmbouter> ttereshc: so this is a problem with that specific distributor option
14:36:17 <bmbouter> mhrivnak: agreed
14:36:28 <ttereshc> bmbouter, it happens to every publish
14:36:43 <jcline> It's already assigned, but if we still want to triage I'd say high/high
14:36:50 <bmbouter> ttereshc: yes I agree, you are correct
14:36:52 <jcline> Losing errata is very bad
14:36:56 <bmbouter> +1 to that
14:36:59 <ipanova> +1
14:36:59 <bmbouter> high/high
14:37:02 <mhrivnak> What about urgent to block 2.9?
14:37:08 <mhrivnak> It's a bad regression.
14:37:09 <smyers> Maybe Urgent, if the bug is that publishing errata twice makes the second one empty
14:37:14 <bmbouter> +1 to that
14:37:22 <bmbouter> it is very serious
14:37:24 <jcline> Yeah I'm fine with urgent too
14:37:28 <mhrivnak> !propose triage urgent high
14:37:28 <mhrivnak> #idea Proposed for #2035: Priority: Urgent, Severity: High
14:37:29 <pulpbot> Proposed for #2035: Priority: Urgent, Severity: High
14:37:32 <jortel> +1
14:37:34 <ttereshc> +1
14:37:34 <dkliban> +1
14:37:56 <asmacdo> anyone else?
14:38:19 <asmacdo> !accept
14:38:19 <asmacdo> #agreed Priority: Urgent, Severity: High
14:38:19 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
14:38:21 <pulpbot> 3 issues left to triage: 2036, 2037, 2038
14:38:22 <asmacdo> #topic determine how to re-enable RHEL 5 unit test runner  - http://pulp.plan.io/issues/2036
14:38:22 <pulpbot> Pulp Issue #2036 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:22 <pulpbot> determine how to re-enable RHEL 5 unit test runner  - http://pulp.plan.io/issues/2036
14:38:30 <mhrivnak> This looks like a task.
14:38:36 <mhrivnak> dkliban, do you agree?
14:38:49 <dkliban> mhrivnak: it is
14:39:05 <dkliban> mhrivnak: i just wanted to file it as an issue so we could set a priority on it
14:39:05 <mhrivnak> !propose other make it a task
14:39:05 <mhrivnak> #idea Proposed for #2036: make it a task
14:39:06 <pulpbot> Proposed for #2036: make it a task
14:39:15 <asmacdo> i think this should be high priority as well
14:39:22 <asmacdo> we need this to stay on our radar until we can do it
14:39:29 <mhrivnak> agreed for high priority.
14:39:41 <dkliban> asmacdo: i'll update it
14:39:50 <asmacdo> sounds good, any other thoughts?
14:39:55 <mhrivnak> none here.
14:40:04 <asmacdo> k go ahead dkliban
14:40:07 <asmacdo> !accept
14:40:07 <asmacdo> #agreed make it a task
14:40:08 <pulpbot> Current proposal accepted: make it a task
14:40:09 <asmacdo> #topic Migration failing after 2.9 upgrade - http://pulp.plan.io/issues/2037
14:40:09 <pulpbot> 2 issues left to triage: 2037, 2038
14:40:09 <pulpbot> RPM Support Issue #2037 [NEW] (unassigned) - Priority: High | Severity: Medium
14:40:10 <pulpbot> Migration failing after 2.9 upgrade - http://pulp.plan.io/issues/2037
14:40:21 <asmacdo> sounds urgent to me
14:40:24 <smyers> superbad
14:40:55 <smyers> This is the example case we use when talking about what sort of issue should block a release
14:40:57 <asmacdo> !propose triage urgent hight
14:40:57 <asmacdo> !propose triage urgent high
14:40:57 <pulpbot> Error: Unknown Severity
14:40:57 <asmacdo> #idea Proposed for #2037: Priority: Urgent, Severity: High
14:40:58 <bmbouter> +1 to urgent and this should be easy to fix
14:40:58 <pulpbot> Proposed for #2037: Priority: Urgent, Severity: High
14:41:03 <mhrivnak> I spent a lot of time yesterday trying to reproduce this, but couldn't. I'm going to try today with el6.
14:41:03 <mhrivnak> definitely superbad.
14:41:05 <jcline> Fine with me
14:41:32 <mhrivnak> +1
14:41:36 <jortel> +1
14:41:38 <pcreech> +1
14:41:40 <asmacdo> well, glad we've got QE
14:41:45 <asmacdo> thanks preethi :)
14:41:45 <mhrivnak> heck ya
14:41:53 <asmacdo> !accept
14:41:53 <asmacdo> #agreed Priority: Urgent, Severity: High
14:41:53 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
14:41:55 <asmacdo> #topic The nectar config pulp_streamer gets doesn't seem to include plugin-level settings - http://pulp.plan.io/issues/2038
14:41:55 <pulpbot> 1 issues left to triage: 2038
14:41:55 <pulpbot> Pulp Issue #2038 [NEW] (unassigned) - Priority: High | Severity: High
14:41:56 <pulpbot> The nectar config pulp_streamer gets doesn't seem to include plugin-level settings - http://pulp.plan.io/issues/2038
14:42:32 <mhrivnak> This one's interesting. It could be challenging to resolve, since each plugin is basically on its own to load its config file.
14:42:55 <jcline> It was speculation so I'm not sure if that's the root cause
14:43:33 <jcline> Either way proxy support seems to have issues
14:43:37 <mhrivnak> Indeed, but it seems quite plausible.
14:43:42 <smyers> I don't understand enough to triage
14:44:13 <mhrivnak> It's basically: if you put proxy settings in a config file (or likely any other settings for an importer), the streamer won't use those settings.
14:44:21 <pcreech> I agree with the fact it's plugin-specific... as I recently played with yum's importer settings and it worked with various config settings
14:44:24 <jortel> streamer get's the downloader from the plugin so should not be too hard to fix, right?
14:44:45 <jcline> jortel, yeah, that's my hope
14:45:10 <jortel> either way, for triage it's high/high
14:45:21 <asmacdo> !propose accept
14:45:21 <asmacdo> #idea Proposed for #2038: Leave the issue as-is, accepting its current state.
14:45:22 <pulpbot> Proposed for #2038: Leave the issue as-is, accepting its current state.
14:45:31 <asmacdo> (its already high/high)
14:45:32 <mhrivnak> oh you know, the importer does hand its config to the platform at start. Maybe this won't be bad, assuming that's the problem.
14:45:43 <mhrivnak> +1
14:45:48 <pcreech> +1
14:46:04 <asmacdo> !accept
14:46:04 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:46:05 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:46:06 <pulpbot> No issues to triage.
14:46:16 <asmacdo> !end
14:46:16 <asmacdo> #endmeeting