14:30:06 <asmacdo> #startmeeting Pulp Triage 2016-07-05
14:30:06 <asmacdo> #info asmacdo has joined triage
14:30:07 <pulpbot> Meeting started Tue Jul  5 14:30:06 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:07 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:07 <pulpbot> The meeting name has been set to 'pulp_triage_2016_07_05'
14:30:07 <pulpbot> asmacdo has joined triage
14:30:12 <bmbouter> !here
14:30:12 <bmbouter> #info bmbouter has joined triage
14:30:12 <pulpbot> bmbouter has joined triage
14:30:16 <mhrivnak> !here
14:30:16 <mhrivnak> #info mhrivnak has joined triage
14:30:16 <pulpbot> mhrivnak has joined triage
14:30:17 <dkliban> !here
14:30:17 <dkliban> #info dkliban has joined triage
14:30:18 <pulpbot> dkliban has joined triage
14:30:19 <pcreech> !here
14:30:19 <pcreech> #info pcreech has joined triage
14:30:20 <pulpbot> pcreech has joined triage
14:30:34 <jcline> !here
14:30:34 <jcline> #info jcline has joined triage
14:30:34 <pulpbot> jcline has joined triage
14:30:37 <dalley> !here
14:30:37 <dalley> #info dalley has joined triage
14:30:37 <pulpbot> dalley has joined triage
14:30:44 <asmacdo> !next
14:30:46 <asmacdo> #topic updateinfo.xml is missing checksums - http://pulp.plan.io/issues/2042
14:30:46 <pulpbot> 4 issues left to triage: 2042, 2053, 2054, 2055
14:30:46 <pulpbot> RPM Support Issue #2042 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:47 <pulpbot> updateinfo.xml is missing checksums - http://pulp.plan.io/issues/2042
14:32:20 <mhrivnak> The behavior we got in a recent change had a surprise, which ichimonji10 pointed out. I think it's high priority to at least answer the questions raised in the issue and figure out what to do.
14:33:23 <asmacdo> think its ready to be triaged?
14:33:43 <dkliban> it sounds like high/high ?
14:33:53 <mhrivnak> I'm good with high/high
14:34:02 <jcline> It does seem like an backwards-incompatible change at the least, and surprising behavior anyway
14:34:11 <ichimonji10> There's lots of information in that issue. Definitely triage-ready.
14:34:17 <ichimonji10> IMO
14:34:28 <jcline> Yeah I'm fine with high/high
14:34:29 <asmacdo> !propose triage high high
14:34:29 <asmacdo> #idea Proposed for #2042: Priority: High, Severity: High
14:34:29 <pulpbot> Proposed for #2042: Priority: High, Severity: High
14:34:52 <asmacdo> anyone else?
14:35:25 <asmacdo> !accept
14:35:25 <asmacdo> #agreed Priority: High, Severity: High
14:35:25 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:35:26 <pulpbot> 3 issues left to triage: 2053, 2054, 2055
14:35:27 <asmacdo> #topic Deleted /var/lib/pulp/sn.dat  by mistake and pulp-admin fails to login - http://pulp.plan.io/issues/2053
14:35:27 <pulpbot> Pulp Issue #2053 [NEW] (unassigned) - Priority: Normal | Severity: High
14:35:27 <pulpbot> Deleted /var/lib/pulp/sn.dat  by mistake and pulp-admin fails to login - http://pulp.plan.io/issues/2053
14:36:09 <dkliban> is this even a bug?
14:36:18 <asmacdo> i think we should close as notabug, and invite him to join irc to get help
14:36:36 <jcline> No, but I'll leave a comment pointing him the right direction
14:36:39 <mhrivnak> agreed, although leaving a comment there would be helpful too.
14:36:49 <dkliban> jcline: thanks
14:36:56 <bmbouter> +1
14:37:19 <asmacdo> jcline, will you close it when you leave the comment?
14:37:24 <jcline> Yup
14:37:32 <asmacdo> !propose other close-notabug
14:37:32 <asmacdo> #idea Proposed for #2053: close-notabug
14:37:32 <pulpbot> Proposed for #2053: close-notabug
14:38:03 <mhrivnak> +1
14:38:14 <asmacdo> !accept
14:38:14 <asmacdo> #agreed close-notabug
14:38:14 <pulpbot> Current proposal accepted: close-notabug
14:38:15 <pulpbot> 2 issues left to triage: 2054, 2055
14:38:16 <asmacdo> #topic Can't filter by version - http://pulp.plan.io/issues/2054
14:38:16 <pulpbot> Pulp Issue #2054 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:16 <pulpbot> Can't filter by version - http://pulp.plan.io/issues/2054
14:38:32 <asmacdo> i looked at this briefly, and I think this should probably be a story
14:39:12 <asmacdo> he linked me to a blog from like 2012 that showed a preview demo of this functionality, but im not sure if it ever worked in a release
14:39:39 <jcline> It looks like a bug to me
14:40:11 <mhrivnak> I agree it's a bug.
14:41:19 <mhrivnak> Although the exact nature might be up for debate. The use case is questionably. If it did "work", it would be doing alphabetical string sorting, which is probably not what he wants.
14:41:40 <mhrivnak> None the less, it should work without raising that client-side exception.
14:41:49 <asmacdo> --str-gt could do alphabetical sorting
14:42:06 <asmacdo> but we should have custom comparitors for version
14:42:43 <mhrivnak> yes. We have a special field on RPMs that has a serialized version that can be sorted as strings for this reason.
14:43:07 <mhrivnak> We could add something similar to other types.
14:43:16 <mhrivnak> but those would be stories I think.
14:43:32 <asmacdo> aha. then im ok with bug. thoughts on priority?
14:43:37 <asmacdo> oh wait this is puppet
14:44:05 <mhrivnak> yes, it needs to be moved to the puppet project.
14:44:44 <mhrivnak> I'd go with normal/medium or normal/low
14:44:59 <jcline> +1 normal/medium
14:45:03 <mhrivnak> perhaps low severity, since the thing he's trying to do isn't actually a good idea. :)
14:45:30 <dkliban> +1 normal/medium
14:45:58 <asmacdo> !propose triage normal medium
14:45:58 <asmacdo> #idea Proposed for #2054: Priority: Normal, Severity: Medium
14:45:59 <pulpbot> Proposed for #2054: Priority: Normal, Severity: Medium
14:46:23 <asmacdo> think we are agreed
14:46:23 <mhrivnak> +1
14:46:26 <asmacdo> !aceept
14:46:26 <pulpbot> Error: "aceept" is not a valid command.
14:46:31 <asmacdo> !accept
14:46:31 <asmacdo> #agreed Priority: Normal, Severity: Medium
14:46:32 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
14:46:33 <asmacdo> #topic Sorting and filtering by version broken for puppet modules - http://pulp.plan.io/issues/2055
14:46:33 <pulpbot> 1 issues left to triage: 2055
14:46:34 <pulpbot> Pulp Issue #2055 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:46:35 <pulpbot> Sorting and filtering by version broken for puppet modules - http://pulp.plan.io/issues/2055
14:46:44 <mhrivnak> Speaking of the serialized version field...
14:47:11 <mhrivnak> This could be a story. "As a user, I can sort puppet modules by version."
14:47:42 <asmacdo> mhrivnak, would you mind converting to a story?
14:47:51 <mhrivnak> I'm happy to.
14:48:05 <asmacdo> !propose other convert to story
14:48:05 <asmacdo> #idea Proposed for #2055: convert to story
14:48:06 <pulpbot> Proposed for #2055: convert to story
14:48:34 <asmacdo> !accept
14:48:34 <asmacdo> #agreed convert to story
14:48:35 <pulpbot> Current proposal accepted: convert to story
14:48:36 <pulpbot> No issues to triage.
14:48:42 <asmacdo> !end
14:48:42 <asmacdo> #endmeeting