14:30:00 <asmacdo> #startmeeting Pulp Triage 2016-07-12
14:30:00 <pulpbot> Meeting started Tue Jul 12 14:30:00 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:00 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:00 <pulpbot> The meeting name has been set to 'pulp_triage_2016_07_12'
14:30:00 <asmacdo> #info asmacdo has joined triage
14:30:00 <pulpbot> asmacdo has joined triage
14:30:07 <dalley> !here
14:30:07 <dalley> #info dalley has joined triage
14:30:08 <pulpbot> dalley has joined triage
14:30:08 <mhrivnak> !here
14:30:08 <mhrivnak> #info mhrivnak has joined triage
14:30:08 <pulpbot> mhrivnak has joined triage
14:30:47 * smyers lurks, busy building stuff
14:30:47 <ttereshc> !here
14:30:47 <ttereshc> #info ttereshc has joined triage
14:30:48 <pulpbot> ttereshc has joined triage
14:31:23 <jcline> !here
14:31:23 <jcline> #info jcline has joined triage
14:31:24 <pulpbot> jcline has joined triage
14:31:30 <pcreech> !here
14:31:30 <pcreech> #info pcreech has joined triage
14:31:31 <pulpbot> pcreech has joined triage
14:31:44 <dkliban> !here
14:31:44 <dkliban> #info dkliban has joined triage
14:31:45 <pulpbot> dkliban has joined triage
14:31:54 <asmacdo> !next
14:31:55 <pulpbot> 6 issues left to triage: 2063, 2066, 2068, 2069, 2071, 2072
14:31:55 <asmacdo> #topic Trouble connecting to LDAP(Active Directory) Server Whole API Authentication - http://pulp.plan.io/issues/2063
14:31:56 <pulpbot> Pulp Issue #2063 [NEW] (unassigned) - Priority: Normal | Severity: High
14:31:57 <pulpbot> Trouble connecting to LDAP(Active Directory) Server Whole API Authentication - http://pulp.plan.io/issues/2063
14:32:48 <mhrivnak> Looks like we didn't get any helpful info.
14:33:11 <asmacdo> !propose skip
14:33:11 <asmacdo> #idea Proposed for #2063: Skip this issue for this triage session.
14:33:11 <pulpbot> Proposed for #2063: Skip this issue for this triage session.
14:33:35 <mhrivnak> I'll ask him to run pulp-admin with -vv
14:33:44 <bmbouter> #info bmbouter has joined triage
14:33:44 <bmbouter> !here
14:33:44 <pulpbot> bmbouter has joined triage
14:34:14 <jcline> skip +1
14:34:15 <ttereshc> +1 to skip
14:34:22 <pcreech> +1
14:34:25 <asmacdo> !accept
14:34:25 <asmacdo> #agreed Skip this issue for this triage session.
14:34:25 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:34:26 <pulpbot> 5 issues left to triage: 2066, 2068, 2069, 2071, 2072
14:34:27 <asmacdo> #topic rsync distributor - retry on failed rsync commands - http://pulp.plan.io/issues/2066
14:34:27 <pulpbot> Pulp Issue #2066 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:28 <pulpbot> rsync distributor - retry on failed rsync commands - http://pulp.plan.io/issues/2066
14:35:36 <mhrivnak> dkliban, any thoughts on his last comment?
14:35:59 <dkliban> mhrivnak: yeha ... we should accept it as normal/medium
14:36:04 <asmacdo> is this a bug against unmerged code?
14:36:27 <dkliban> mhrivnak: i don't know when we will get to it though
14:36:49 <ttereshc> is it a bug or more like a story?
14:36:52 <dkliban> it would be better to have some logs that show the problem actually occuring
14:37:12 <dkliban> it's a bug that will occur in the future
14:37:24 <dkliban> however, it is only theoretical for now
14:37:31 <jcline> Well, I mean... That sounds like a problem now, it's just no one has used it yet.
14:38:26 <asmacdo> !propose normal medium
14:38:26 <pulpbot> Error: "propose" is not a valid command.
14:38:31 <asmacdo> !propose triage normal medium
14:38:31 <asmacdo> #idea Proposed for #2066: Priority: Normal, Severity: Medium
14:38:31 <pulpbot> Proposed for #2066: Priority: Normal, Severity: Medium
14:38:54 <mhrivnak> works for me
14:38:59 <dkliban> +1
14:39:09 <asmacdo> !accept
14:39:09 <asmacdo> #agreed Priority: Normal, Severity: Medium
14:39:09 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
14:39:10 <pulpbot> 4 issues left to triage: 2068, 2069, 2071, 2072
14:39:10 <asmacdo> #topic HTTP 404: When trying to run yum update from a pulp-consumer - http://pulp.plan.io/issues/2068
14:39:11 <pulpbot> Pulp Issue #2068 [NEW] (unassigned) - Priority: Normal | Severity: High
14:39:12 <pulpbot> HTTP 404: When trying to run yum update from a pulp-consumer - http://pulp.plan.io/issues/2068
14:40:03 <mhrivnak> Looks like the problem was resolved on the user's end.
14:40:08 <asmacdo> think we should close notabug
14:40:14 <mhrivnak> oh, but it came back.
14:40:17 <asmacdo> invite to reopen if it is still an issue
14:40:18 <dkliban> lol
14:40:29 <jcline> I suspect he updated to permissive in the config after the boot
14:40:44 <jcline> I vote NOTABUG
14:40:46 <asmacdo> #idea Proposed for #2068: close-notabug
14:40:46 <asmacdo> !propose other close-notabug
14:40:46 <pulpbot> Proposed for #2068: close-notabug
14:41:01 <dalley> +1
14:41:31 <bmbouter> he shows it is running in permisive in comment 5
14:41:50 <bmbouter> but I'm not sure what can be done that is better than closing as not a bug
14:41:58 <bmbouter> we can't accept this bug as it's currently described
14:42:13 <smyers> is that WONTFIX?
14:43:01 <mhrivnak> I think WONTFIX means we should agree a bug is present, but are choosing not to fix it.
14:43:11 <mhrivnak> which is not the case here.
14:43:21 <smyers> cool
14:43:27 <pcreech> it's recent... so perhaps a comment requesting an update with a punt till next triage?  Looks like it might be environmental
14:43:34 <mhrivnak> I'm good with NOTABUG or WORKSFORME
14:43:38 <pcreech> (or i could be way off base)
14:43:52 <mhrivnak> the behavior he is trying, which is "yum update", does get tested regularly and works.
14:44:23 <asmacdo> im going to close with a comment
14:44:29 <asmacdo> !accept
14:44:29 <asmacdo> #agreed close-notabug
14:44:30 <pulpbot> Current proposal accepted: close-notabug
14:44:31 <asmacdo> #topic How do you execute search queries - http://pulp.plan.io/issues/2069
14:44:31 <pulpbot> 3 issues left to triage: 2069, 2071, 2072
14:44:33 <pulpbot> Pulp Issue #2069 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:34 <pulpbot> How do you execute search queries - http://pulp.plan.io/issues/2069
14:45:51 <jcline> Maybe make this a documentation bug?
14:46:20 <mhrivnak> seems reasonable.
14:46:49 <dkliban> yep
14:48:09 <asmacdo> prio/sev?
14:48:31 <mhrivnak> normal/low ?
14:48:32 <jcline> ehhhhhhhh. normal/medium?
14:49:01 <mhrivnak> I'm also fine with normal/medium
14:49:17 <pcreech> +1
14:49:19 <dalley> +1
14:49:25 <asmacdo> !propose triage normal medium
14:49:25 <asmacdo> #idea Proposed for #2069: Priority: Normal, Severity: Medium
14:49:26 <pulpbot> Proposed for #2069: Priority: Normal, Severity: Medium
14:49:42 <bmbouter> +1
14:49:55 <dkliban> +1
14:49:56 <asmacdo> !accept
14:49:56 <asmacdo> #agreed Priority: Normal, Severity: Medium
14:49:56 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
14:49:57 <pulpbot> 2 issues left to triage: 2071, 2072
14:49:57 <asmacdo> #topic Creating yum distributor without https, http keys in config crashes - http://pulp.plan.io/issues/2071
14:49:58 <pulpbot> RPM Support Issue #2071 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:49:59 <pulpbot> Creating yum distributor without https, http keys in config crashes - http://pulp.plan.io/issues/2071
14:50:44 <mhrivnak> normal/low since there is a real easy workaround?
14:51:04 <jcline> It seems like this is a recent breakage?
14:51:15 <smyers> The potential API change is worrisome, but the complete lack of detail in the bug report is frustrating
14:51:16 <mhrivnak> Oh, is it?
14:51:17 <pcreech> looks like, though, it's breaking their code due to an api change
14:51:19 <ttereshc> a year ago...
14:51:20 <jcline> Suddenly our API is handing out 500 instead of 400
14:51:31 <asmacdo> ive seen this
14:51:43 <smyers> In what version? :)
14:52:04 <asmacdo> pretty sure i saw this when doing the django conversion
14:52:23 <asmacdo> my understanding was that those keys were mandatory
14:52:55 <mhrivnak> ah, the reporter thinks this commit broke it on a little more than 1 year ago: https://github.com/pulp/pulp_rpm/commit/23d9c0934bac
14:52:56 <pulpbot> Title: Adding validation that http and https cannot be set both to false. · pulp/pulp_rpm@23d9c09 · GitHub (at github.com)
14:53:01 <ttereshc> 2.7 I think
14:53:12 <bmbouter> yeah that is how I read this too
14:53:42 <smyers> Yeah, git branch --contains 23d9c0934bac shows that in 2.8-dev
14:54:01 <ttereshc> easy fix
14:54:09 <mhrivnak> I also like how github shows all the tags it is in.
14:54:35 <mhrivnak> I'm still thinking normal/low
14:54:48 <jcline> Well... Didn't our API change?
14:54:56 <mhrivnak> it broke
14:54:56 <asmacdo> i don't think the reporter is correct
14:55:03 <asmacdo> i think it always returned a 500
14:55:29 <mhrivnak> hah, then it's always been broken. :)
14:55:49 <asmacdo> !propose triage normal low
14:55:49 <asmacdo> #idea Proposed for #2071: Priority: Normal, Severity: Low
14:55:49 <pulpbot> Proposed for #2071: Priority: Normal, Severity: Low
14:57:16 <asmacdo> !accept
14:57:16 <asmacdo> #agreed Priority: Normal, Severity: Low
14:57:16 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:57:16 <dalley> lol
14:57:17 <pulpbot> 1 issues left to triage: 2072
14:57:17 <asmacdo> #topic changing yum distributor to not publish via http leaves broken symlink - http://pulp.plan.io/issues/2072
14:57:18 <pulpbot> RPM Support Issue #2072 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:57:19 <pulpbot> changing yum distributor to not publish via http leaves broken symlink - http://pulp.plan.io/issues/2072
14:59:08 <mhrivnak> normal/low?
15:00:17 <asmacdo> !propose triage normal low
15:00:17 <asmacdo> #idea Proposed for #2072: Priority: Normal, Severity: Low
15:00:17 <pulpbot> Proposed for #2072: Priority: Normal, Severity: Low
15:00:59 <asmacdo> !accept
15:00:59 <asmacdo> #agreed Priority: Normal, Severity: Low
15:00:59 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
15:01:00 <pulpbot> No issues to triage.
15:04:42 <smyers> asmacdo, !end?
15:06:09 <asmacdo> !end!
15:06:09 <pulpbot> Error: "end!" is not a valid command.
15:06:12 <asmacdo> !end
15:06:12 <asmacdo> #endmeeting