14:29:59 <asmacdo> #startmeeting Pulp Triage 2016-07-15
14:29:59 <asmacdo> #info asmacdo has joined triage
14:30:00 <pulpbot> Meeting started Fri Jul 15 14:29:59 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:00 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:00 <pulpbot> The meeting name has been set to 'pulp_triage_2016_07_15'
14:30:00 <pulpbot> asmacdo has joined triage
14:30:03 <dalley> !here
14:30:03 <dalley> #info dalley has joined triage
14:30:03 <pulpbot> dalley has joined triage
14:30:04 <ipanova> !here
14:30:04 <ipanova> #info ipanova has joined triage
14:30:05 <pulpbot> ipanova has joined triage
14:30:06 <mhrivnak> !here
14:30:06 <mhrivnak> #info mhrivnak has joined triage
14:30:06 <pulpbot> mhrivnak has joined triage
14:30:09 <dkliban> !here
14:30:09 <dkliban> #info dkliban has joined triage
14:30:10 <pulpbot> dkliban has joined triage
14:30:18 <asmacdo> !next
14:30:19 <pulpbot> 8 issues left to triage: 2063, 2074, 2076, 2077, 2078, 2079, 2080, 2081
14:30:20 <asmacdo> #topic Trouble connecting to LDAP(Active Directory) Server Whole API Authentication - http://pulp.plan.io/issues/2063
14:30:20 <pulpbot> Pulp Issue #2063 [NEW] (unassigned) - Priority: Normal | Severity: High
14:30:21 <pulpbot> Trouble connecting to LDAP(Active Directory) Server Whole API Authentication - http://pulp.plan.io/issues/2063
14:31:07 <fdobrovo> !here
14:31:07 <fdobrovo> #info fdobrovo has joined triage
14:31:08 <pulpbot> fdobrovo has joined triage
14:31:27 <mhrivnak> Well, it looks at least like this user is getting a 401 Unauthorized.
14:31:47 <asmacdo> its really hard to say why, i dont think there is enough information yet
14:31:56 <ipanova> agree with asmacdo
14:31:57 <mhrivnak> pulp-admin is blowing up trying to deal with that, which is another issue.
14:32:17 <mhrivnak> But ya, I think this is an issue of troubleshooting that user's ldap setup.
14:32:37 <pcreech> !here
14:32:37 <pcreech> #info pcreech has joined triage
14:32:38 <pulpbot> pcreech has joined triage
14:32:56 <asmacdo> should we close and invite to IRC or skip?
14:33:00 <jcline> !here
14:33:00 <jcline> #info jcline has joined triage
14:33:00 <pulpbot> jcline has joined triage
14:33:07 <mhrivnak> I think we should close as not a bug.
14:33:12 <ipanova> +1
14:33:16 <mhrivnak> and invite this person to email and IRC.
14:33:29 <asmacdo> !propose other close-notabug
14:33:29 <asmacdo> #idea Proposed for #2063: close-notabug
14:33:30 <pulpbot> Proposed for #2063: close-notabug
14:33:47 <asmacdo> other thoughts?
14:34:05 <ipanova> works for me
14:34:10 <PulpGuest> what about: AttributeError: 'str' object has no attribute 'pop'
14:34:34 <mhrivnak> That's a separate bug we could file.
14:34:41 <PulpGuest> there is some unhandeled exception
14:34:42 <PulpGuest> ok
14:35:07 <asmacdo> !accept
14:35:07 <asmacdo> #agreed close-notabug
14:35:07 <pulpbot> Current proposal accepted: close-notabug
14:35:07 <mhrivnak> It's a failure on the client side to parse the error.
14:35:08 <pulpbot> 6 issues left to triage: 2076, 2077, 2078, 2079, 2080, 2081
14:35:09 <asmacdo> #topic distributor update fails trying to remove already-missing key - http://pulp.plan.io/issues/2076
14:35:09 <pulpbot> Pulp Issue #2076 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:35:10 <pulpbot> distributor update fails trying to remove already-missing key - http://pulp.plan.io/issues/2076
14:36:08 <mhrivnak> easy fix
14:36:30 <dkliban> !propose triage accept
14:36:31 <pulpbot> (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
14:36:48 <pcreech> +1 to keeping as is (prio/sev)
14:36:53 <mhrivnak> !propose accept
14:36:53 <mhrivnak> #idea Proposed for #2076: Leave the issue as-is, accepting its current state.
14:36:54 <pulpbot> Proposed for #2076: Leave the issue as-is, accepting its current state.
14:36:56 <ipanova> !propose triage normal medium
14:36:56 <ipanova> #idea Proposed for #2076: Priority: Normal, Severity: Medium
14:36:57 <pulpbot> Proposed for #2076: Priority: Normal, Severity: Medium
14:37:18 <fdobrovo> +1
14:37:46 <asmacdo> anyone else?
14:37:51 <dkliban> +1
14:37:57 <jcline> Let's move on
14:37:57 <asmacdo> !accept
14:37:57 <asmacdo> #agreed Priority: Normal, Severity: Medium
14:37:57 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
14:37:58 <pulpbot> 5 issues left to triage: 2077, 2078, 2079, 2080, 2081
14:37:59 <asmacdo> #topic publish fails if Django Template Syntax in changelog - http://pulp.plan.io/issues/2077
14:37:59 <pulpbot> Pulp Issue #2077 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:00 <pulpbot> publish fails if Django Template Syntax in changelog - http://pulp.plan.io/issues/2077
14:38:10 * mhrivnak facepalms
14:38:14 <dkliban> this seems bad
14:38:29 <mhrivnak> and it was jortel who made that entry!
14:38:38 <jcline> Uhoh
14:38:38 <mhrivnak> how funny is that.
14:38:44 <dkliban> lol
14:38:55 <dalley> that's hilarious
14:39:23 <jcline> Does this have to do with the fix for 1618?
14:39:34 <mhrivnak> yes.
14:40:20 <mhrivnak> So it'll be potentially tough to deal with. Maybe django has a setting where we can tell it to ignore template variables that we aren't defining.
14:40:49 <dkliban> high priority?
14:40:55 <jcline> That still has the potential to corrupt the metadata if they use the same variable
14:41:30 <jcline> High/high? You can't publish some RPMs.
14:41:47 <mhrivnak> I'm good with high/high
14:41:57 <asmacdo> !propose triage high high
14:41:57 <asmacdo> #idea Proposed for #2077: Priority: High, Severity: High
14:41:57 <pulpbot> Proposed for #2077: Priority: High, Severity: High
14:42:07 <pcreech> +1
14:42:18 <dalley> +1
14:42:24 <dkliban> +1
14:42:26 <asmacdo> #agreed Priority: High, Severity: High
14:42:26 <asmacdo> !accept
14:42:26 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:42:28 <asmacdo> #topic Updating auto-publish value in the repo update does not influence the behaviour. - http://pulp.plan.io/issues/2078
14:42:28 <pulpbot> 4 issues left to triage: 2078, 2079, 2080, 2081
14:42:29 <pulpbot> Docker Support Issue #2078 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:30 <pulpbot> Updating auto-publish value in the repo update does not influence the behaviour. - http://pulp.plan.io/issues/2078
14:42:53 <ipanova> there is the same issue in python plugin
14:43:30 <jcline> I feel like this might be a duplicate
14:43:41 <asmacdo> i think auto-publish is special and is handled by core
14:43:51 <jcline> Maybe not, though
14:44:14 <ipanova> asmacdo: it is not, other plugins like rpm is fine
14:44:25 <dkliban> yeah ... i think each plugin implements it
14:44:26 <ipanova> asmacdo: i bet it is plugin specific issue
14:44:55 <ipanova> !proposo triage normal medium
14:44:55 <pulpbot> Error: "proposo" is not a valid command.
14:45:10 <ipanova> !propose triage normal medium
14:45:10 <ipanova> #idea Proposed for #2078: Priority: Normal, Severity: Medium
14:45:10 <pulpbot> Proposed for #2078: Priority: Normal, Severity: Medium
14:45:28 <mhrivnak> +1
14:45:29 <fdobrovo> +1
14:45:36 <asmacdo> +1
14:45:39 <jcline> works for me
14:45:47 <dkliban> +1
14:45:48 <asmacdo> !accept
14:45:48 <asmacdo> #agreed Priority: Normal, Severity: Medium
14:45:48 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
14:45:49 <pulpbot> 3 issues left to triage: 2079, 2080, 2081
14:45:50 <asmacdo> #topic Fails to sync EPEL 7.x repository with Pulp 2.9.0 - http://pulp.plan.io/issues/2079
14:45:50 <pulpbot> Pulp Issue #2079 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:45:50 <pulpbot> Fails to sync EPEL 7.x repository with Pulp 2.9.0 - http://pulp.plan.io/issues/2079
14:47:09 <mhrivnak> I'm not sure where the error message is coming from.
14:47:21 <jcline> Should be quick and easy to reproduce
14:47:30 <ipanova> let's at least try to reproduce it
14:47:42 <dkliban> yep
14:48:24 <dkliban> high priority
14:48:37 <mhrivnak> !propose triage high high
14:48:37 <mhrivnak> #idea Proposed for #2079: Priority: High, Severity: High
14:48:38 <pulpbot> Proposed for #2079: Priority: High, Severity: High
14:48:42 <ipanova> +1
14:49:18 <asmacdo> works for me, accepting unless someone speaks up
14:49:40 <asmacdo> !accept
14:49:40 <asmacdo> #agreed Priority: High, Severity: High
14:49:40 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:49:41 <pulpbot> 2 issues left to triage: 2080, 2081
14:49:42 <asmacdo> #topic All steps in "lazy" role are skipped for Pulp 2.10 - http://pulp.plan.io/issues/2080
14:49:42 <pulpbot> Packaging Issue #2080 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:49:43 <pulpbot> All steps in "lazy" role are skipped for Pulp 2.10 - http://pulp.plan.io/issues/2080
14:49:46 <PulpGuest> pulp-admin with verbose / debug mode option that would help to track the process
14:49:54 <PulpGuest> (my proposal)
14:50:41 <ipanova> PulpGuest:  we do have it, the reporter just did not use it
14:51:15 <PulpGuest> ipanova: so it would be nice to ask him/her that you don't need to do it again
14:52:37 <PulpGuest> ipanova: maybe proposal for some "howto file a bug for Pulp" documentation ;)
14:52:39 <dkliban> so lets mark this as high priority and have someone try to figure out what is going on
14:52:46 <jcline> Works for me
14:52:56 <jcline> I really wish we didn't have two sets of ansible roles
14:53:10 <asmacdo> !propose triage high low
14:53:10 <asmacdo> #idea Proposed for #2080: Priority: High, Severity: Low
14:53:11 <pulpbot> Proposed for #2080: Priority: High, Severity: Low
14:53:17 <asmacdo> since its just for dev setup
14:53:23 <fdobrovo> +1
14:53:24 <smyers> no
14:53:32 <smyers> It's the ci repo ansible playbook, right?
14:53:40 <dkliban> yeah ... it for our nightly testing
14:53:40 <asmacdo> oh shoot
14:53:46 <dkliban> we are getting false failures
14:53:53 <asmacdo> thats annoying
14:54:03 <smyers> It's not a pulp dev problem at this point, not even sure the bug belongs in plan.io
14:54:36 <dkliban> smyers: i tend to agree. though i still think one of us should assist in resolving this.
14:54:48 <smyers> Yeah, definitely
14:54:49 <ipanova> PulpGuest: docs are available also, though not every bug report can be ideal
14:54:55 <dkliban> we can move the issue to pulp-smash github
14:55:15 <smyers> And since 2.10 is coming up, it's pretty important (imo), just wanted to make it clear what it was about
14:56:06 <dkliban> ichimonji10: we'd like to close 2080
14:56:28 <dkliban> ichimonji10: and file it against pulp-smash or somewhere else. and one of use will help resolve it
14:56:57 <dkliban> s/use/us devs/
14:57:02 <jcline> FYI I reproduced https://pulp.plan.io/issues/2079 and it's a templating problem
14:57:04 <pulpbot> Title: Issue #2079: Fails to sync EPEL 7.x repository with Pulp 2.9.0 - Pulp (at pulp.plan.io)
14:57:24 <dkliban> jcline: that was quick
14:57:25 <asmacdo> jcline, do you think it needs to be a different prio?
14:57:33 <asmacdo> yeah jcline++
14:57:37 <jcline> It's high/high so I think that's fine
14:57:54 <smyers> #2080 this falls into the weird "meta bug" hole where elyezer and I spend a lot of time...it's not a pulp issue per se, nor is it a smash issue
14:58:03 <dkliban> let's skip 2080 for now
14:58:07 <smyers> +1
14:58:09 <ipanova> +1
14:58:09 <asmacdo> agree
14:58:10 <smyers> !propose skip
14:58:10 <smyers> #idea Proposed for #2080: Skip this issue for this triage session.
14:58:10 <smyers> #info smyers has joined triage
14:58:11 <asmacdo> !skip
14:58:11 <pulpbot> smyers has joined triage
14:58:12 <pulpbot> Proposed for #2080: Skip this issue for this triage session.
14:58:13 <pulpbot> 1 issues left to triage: 2081
14:58:13 <asmacdo> #topic All of repo's distributors are updated at end of publish - http://pulp.plan.io/issues/2081
14:58:14 <pulpbot> Pulp Issue #2081 [MODIFIED] (dkliban@redhat.com) - Priority: Normal | Severity: Medium | Target Release: 2.9.1
14:58:14 <pulpbot> All of repo's distributors are updated at end of publish - http://pulp.plan.io/issues/2081
14:58:27 <jcline> It's modified so... skip?
14:58:27 <dkliban> i already fixed this so we can just triage it
14:58:31 <asmacdo> k
14:58:34 <asmacdo> !next
14:58:35 <pulpbot> No issues to triage.
14:58:40 <asmacdo> !end
14:58:40 <asmacdo> #endmeeting