14:33:41 <asmacdo> #startmeeting Pulp Triage 2016-07-22
14:33:41 <asmacdo> !start
14:33:41 <pulpbot> Meeting started Fri Jul 22 14:33:41 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:33:41 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:33:41 <pulpbot> The meeting name has been set to 'pulp_triage_2016_07_22'
14:33:41 <asmacdo> #info asmacdo has joined triage
14:33:41 <pulpbot> asmacdo has joined triage
14:34:00 <ipanova> !present
14:34:00 <pulpbot> Error: "present" is not a valid command.
14:34:04 <ipanova> !here
14:34:04 <ipanova> #info ipanova has joined triage
14:34:05 <pulpbot> ipanova has joined triage
14:34:07 <smyers> heh
14:34:10 <smyers> !here
14:34:10 <smyers> #info smyers has joined triage
14:34:11 <pulpbot> smyers has joined triage
14:34:17 <smyers> Don't break my bot :)
14:34:27 <ipanova> smyers: that's still habit from school :D
14:34:30 * asmacdo raises hand
14:35:02 <asmacdo> !next
14:35:03 <pulpbot> 8 issues left to triage: 2082, 2084, 2093, 2094, 2095, 2096, 2097, 2099
14:35:04 <asmacdo> #topic Cannot add importer to the repository - http://pulp.plan.io/issues/2082
14:35:04 <pulpbot> Pulp Issue #2082 [ASSIGNED] (ipanova@redhat.com) - Priority: Normal | Severity: Medium
14:35:04 <pulpbot> Cannot add importer to the repository - http://pulp.plan.io/issues/2082
14:35:19 <ttereshc> !here
14:35:19 <ttereshc> #info ttereshc has joined triage
14:35:20 <pulpbot> ttereshc has joined triage
14:35:35 <smyers> onoes
14:35:49 <ipanova> that one is an easy fix
14:35:53 <smyers> It's already assigned, and seem pretty crappy
14:35:58 <smyers> !propose high high
14:35:58 <pulpbot> Error: "propose" is not a valid command.
14:36:03 * smyers breaks his own bot
14:36:06 <ipanova> appered after another bugfix.  i wil ltake care of it
14:36:10 <smyers> !propose triage high high
14:36:10 <smyers> #idea Proposed for #2082: Priority: High, Severity: High
14:36:10 <pulpbot> Proposed for #2082: Priority: High, Severity: High
14:36:17 <jortel> !here
14:36:17 <jortel> #info jortel has joined triage
14:36:17 <pulpbot> jortel has joined triage
14:36:29 <asmacdo> seems reasonable, dissenting opinion?
14:36:30 <smyers> It's obviously high if you're already working on it, and the lack of a workaround makes it also high severity, I think
14:36:41 <ipanova> +1
14:36:46 <asmacdo> !accept
14:36:46 <asmacdo> #agreed Priority: High, Severity: High
14:36:46 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:36:48 <asmacdo> #topic updating to --auto-publish false has unexpected result - http://pulp.plan.io/issues/2084
14:36:48 <pulpbot> 7 issues left to triage: 2084, 2093, 2094, 2095, 2096, 2097, 2099
14:36:48 <pulpbot> Docker Support Issue #2084 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:49 <bmbouter> !here
14:36:49 <bmbouter> #info bmbouter has joined triage
14:36:49 <pulpbot> updating to --auto-publish false has unexpected result - http://pulp.plan.io/issues/2084
14:36:50 <pulpbot> bmbouter has joined triage
14:37:07 <dalley> !here
14:37:07 <dalley> #info dalley has joined triage
14:37:08 <pulpbot> dalley has joined triage
14:37:17 <smyers> hahaha dkliban nice bug :)
14:37:23 <ttereshc> it looks like a dup
14:37:31 <ipanova> that's dup of #2078
14:38:09 <ttereshc> rm #2078
14:38:09 <pulpbot> Docker Support Issue #2078 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:10 <pulpbot> Updating auto-publish value in the repo update does not influence the behaviour. - http://pulp.plan.io/issues/2078
14:38:17 <dkliban> let's close it as a duplicate
14:38:37 <asmacdo> #idea Proposed for #2084: close as duplicate of 2078
14:38:37 <asmacdo> !propose other close as duplicate of 2078
14:38:37 <pulpbot> Proposed for #2084: close as duplicate of 2078
14:38:39 <ttereshc> I can do thay
14:39:23 <bmbouter> ietingof: thanks for the FYI I'm fixing the links now
14:39:36 <asmacdo> ttereshc, sold.
14:39:39 <asmacdo> !accept
14:39:39 <asmacdo> #agreed close as duplicate of 2078
14:39:39 <pulpbot> Current proposal accepted: close as duplicate of 2078
14:39:40 <pulpbot> 6 issues left to triage: 2093, 2094, 2095, 2096, 2097, 2099
14:39:40 <smyers> whoa, someone else used rm #<bug> trigger. woot.
14:39:40 <asmacdo> #topic errors importing some rpms after upgrading to pulp 2.9 - http://pulp.plan.io/issues/2093
14:39:41 <pulpbot> Pulp Issue #2093 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:41 <pulpbot> errors importing some rpms after upgrading to pulp 2.9 - http://pulp.plan.io/issues/2093
14:40:19 <bmbouter> this needs to go onto the current sprint
14:40:22 <bmbouter> per discussion yesterday
14:40:31 <bmbouter> this is a Y stream regression
14:40:48 <pcreech> #info pcreech has joined triage
14:40:48 <pcreech> !here
14:40:49 <pulpbot> pcreech has joined triage
14:40:55 * pcreech had to reboot
14:40:59 <asmacdo> #idea Proposed for #2093: Priority: Urgent, Severity: High
14:40:59 <asmacdo> !propose triage urgent high
14:40:59 <pulpbot> Proposed for #2093: Priority: Urgent, Severity: High
14:41:00 <ipanova> i was able to reproduce that on 2.9
14:41:09 <smyers> high prio/high sev? maybe 2.10 blocker?
14:41:29 <asmacdo> smyers, 2.10 blocker==urgent
14:42:03 <bmbouter> yes 2.10 blocker
14:42:06 <ipanova> that's a regression so probably yes
14:42:06 <jortel> +1
14:42:08 <ipanova> +1
14:42:08 <smyers> Yeah, I'm somewhere between high and urgent on prio. We've blocked releases for less impactful bugs, and it seems appropriate to block for this
14:42:16 <smyers> #idea Proposed for #2093: Priority: Urgent, Severity: High
14:42:16 <smyers> !propose triage urgent high
14:42:16 <pulpbot> Proposed for #2093: Priority: Urgent, Severity: High
14:42:43 <pcreech> +1
14:42:47 <bmbouter> +1
14:42:51 <dalley> +1
14:42:52 <asmacdo> #agreed Priority: Urgent, Severity: High
14:42:52 <asmacdo> !accept
14:42:52 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
14:42:53 <pulpbot> 5 issues left to triage: 2094, 2095, 2096, 2097, 2099
14:42:54 <asmacdo> #topic Most DRPMs are missing after a sync - http://pulp.plan.io/issues/2094
14:42:55 <pulpbot> RPM Support Issue #2094 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:42:55 <pulpbot> Most DRPMs are missing after a sync - http://pulp.plan.io/issues/2094
14:43:55 <smyers> As seen in mh's comment (#3), we've been doing this wrong for a while
14:44:09 <bmbouter> agreed so not a new regression
14:44:17 <bmbouter> also not present in the comments but on IRC at the time, jcline did reproduce this
14:45:35 <bmbouter> I think this is high/high
14:45:40 <ipanova> agree
14:45:40 <dalley> it's mentioned in the description that he did repro
14:45:41 <pcreech> +1
14:45:48 <asmacdo> #idea Proposed for #2094: Priority: High, Severity: High
14:45:48 <asmacdo> !propose triage high high
14:45:48 <pulpbot> Proposed for #2094: Priority: High, Severity: High
14:45:49 <smyers> So it's pretty bad, but as far as prioritization I'm not sure how to call it. I'd like DRPMs to work, but if they don't work the workaround is that the package just gets upgraded completely
14:45:59 <ipanova> #idea Proposed for #2094: Priority: High, Severity: High
14:45:59 <ipanova> !propose triage high high
14:45:59 <pulpbot> Proposed for #2094: Priority: High, Severity: High
14:46:02 <ipanova> heh
14:46:08 <smyers> Because there's a workaround, I think the sev is medium.
14:46:20 <bmbouter> dalley: oh right I forgot that jcline also filed it after the IRC
14:46:26 <smyers> The impact is you (the yum user) download and install a whole package instead of the delta
14:46:27 <bmbouter> smyers: agreed
14:46:32 <smyers> It's annoying, but nothing breaks
14:46:32 <jortel> agreed
14:46:34 <bmbouter> I had not considered that
14:46:38 <smyers> #idea Proposed for #2094: Priority: High, Severity: Medium
14:46:38 <smyers> !propose triage high med
14:46:38 <pulpbot> Proposed for #2094: Priority: High, Severity: Medium
14:46:44 <bmbouter> +1 to that
14:46:46 <asmacdo> +1
14:46:47 <ttereshc> +1
14:46:49 <jortel> +1
14:46:51 <fdobrovo> +1
14:46:52 <pcreech> +1
14:47:03 <ipanova> recently fdobrovo did the rfe for upload of DRPMs he maybe could take a look and could put this one on the sprint
14:47:33 <bmbouter> that's true but it's not that severe
14:47:42 <bmbouter> I'm ok if we do want to do that though
14:47:54 <bmbouter> I value pulp 3.0 over fixing this though
14:48:04 <smyers> I was about to say the same thing
14:48:10 <jortel> me too
14:48:43 <smyers> This could be tagged as a pulp 3 "prefactor", so we could potentially fix the model in pulp 2 to prepare for 3.
14:48:43 <asmacdo> lets leave off the sprint, but that won't prevent him from working on it if it's a logical next step
14:48:56 <jalbertson> asmacdo, agreed
14:49:05 <smyers> It's a good candidate for future sprints in the 2.11+ range, imo
14:49:21 <ttereshc> I think it will make 2.x more complete
14:49:38 <asmacdo> so high/medium prefactor
14:49:46 <asmacdo> ready to accept?
14:49:48 <ipanova> yep, let's triage it
14:49:51 <jortel> yep
14:49:52 <bmbouter> yup
14:49:53 * smyers is sold
14:49:54 <asmacdo> #agreed Priority: High, Severity: Medium
14:49:54 <asmacdo> !accept
14:49:54 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
14:49:56 <pulpbot> 4 issues left to triage: 2095, 2096, 2097, 2099
14:49:56 <asmacdo> #topic Publishing with the rpm_rsync_distributor without first publishing with the yum_distributor causes a traceback - http://pulp.plan.io/issues/2095
14:49:57 <pulpbot> RPM Support Issue #2095 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:49:57 <pulpbot> Publishing with the rpm_rsync_distributor without first publishing with the yum_distributor causes a traceback - http://pulp.plan.io/issues/2095
14:50:18 <smyers> !suggest #2094 Is probably a good Pulp 3 prefactor target
14:50:18 <smyers> #idea #2094 Is probably a good Pulp 3 prefactor target
14:50:29 <bmbouter> this is something I discovered with the rsync distributor and filed it because we are not going to fix it before releasing the rsync distributor
14:50:38 <bmbouter> it's not severe but I wanted to capture it
14:51:11 * smyers needs a "known issue" redmine field
14:51:28 <smyers> I can call this out in the release notes, and it's great that there's an easy workaround
14:51:46 <bmbouter> smyers: ic what you mean
14:52:01 <bmbouter> I think norm/med or norm/low
14:52:04 <bmbouter> for triage
14:52:39 <jortel> med/med because it causes a trace
14:52:47 <ipanova> makes sense
14:52:56 <bmbouter> good call
14:53:02 <asmacdo> #idea Proposed for #2095: Priority: Normal, Severity: Medium
14:53:02 <asmacdo> !propose triage normal medium
14:53:02 <pulpbot> Proposed for #2095: Priority: Normal, Severity: Medium
14:53:08 <ipanova> +!
14:53:09 <ipanova> +1
14:53:13 <ttereshc> +1
14:53:15 <smyers> +1
14:53:39 <asmacdo> !accept
14:53:39 <asmacdo> #agreed Priority: Normal, Severity: Medium
14:53:39 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
14:53:40 <pulpbot> 3 issues left to triage: 2096, 2097, 2099
14:53:41 <asmacdo> #topic Additional updateinfo.xml after second publish - http://pulp.plan.io/issues/2096
14:53:41 <pulpbot> RPM Support Issue #2096 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:53:41 <pulpbot> Additional updateinfo.xml after second publish - http://pulp.plan.io/issues/2096
14:54:12 <bmbouter> this is another thing I saw in my testing
14:54:32 <asmacdo> does this cause any problems?
14:54:38 <ipanova> bmbouter: i am not sure if it is correct but it was like this for a long time
14:54:38 <bmbouter> none
14:54:45 <bmbouter> I agree it's not new
14:54:54 <ipanova> with every publish there a new updateinfo.xml
14:54:58 <bmbouter> it's true
14:55:13 <bmbouter> which if you imagine someone publishing a lot and then rsyncing those files other places lots
14:55:31 <bmbouter> but it's still not severe, just not correct
14:55:41 <asmacdo> med/low?
14:55:48 <bmbouter> I'm good w/ that
14:56:03 <asmacdo> !propose triage normal low
14:56:03 <asmacdo> #idea Proposed for #2096: Priority: Normal, Severity: Low
14:56:03 <pulpbot> Proposed for #2096: Priority: Normal, Severity: Low
14:56:05 <ipanova> me as well
14:56:06 <jortel> so long at the correct one is referenced in the repomd, I don't think this is bad
14:56:18 <jortel> +1
14:56:22 <pcreech> +1
14:56:31 <ttereshc> jortel, yes the correct one us referenced
14:56:32 <smyers> I think I've seen this in fedora and rhel repos not made by pulp; I'm not sure it's a bug
14:56:40 <smyers> I think we might even do it on purpose?
14:56:40 <ipanova> jortel: yeah, in repomd everything is fine
14:56:48 <jortel> yeah, so just sloppy.
14:57:05 <ttereshc> smyers, I have the same impression but I can't recall why
14:57:11 <smyers> But I'm happy with the current proposal
14:57:14 <bmbouter> it is a bug because it's not listed in the repomd
14:57:31 <bmbouter> although maybe it's there for clients who still have old copied of the repomd
14:57:33 <bmbouter> ....
14:57:41 <jortel> agreed.  it's a bug
14:57:46 <bmbouter> anyways med/low
14:58:07 <asmacdo> #agreed Priority: Normal, Severity: Low
14:58:07 <asmacdo> !accept
14:58:07 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:58:08 <pulpbot> 2 issues left to triage: 2097, 2099
14:58:09 <asmacdo> #topic Copyright out of date in docs - http://pulp.plan.io/issues/2097
14:58:09 <pulpbot> Pulp Issue #2097 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:58:09 <pulpbot> Copyright out of date in docs - http://pulp.plan.io/issues/2097
14:58:47 <asmacdo> med/low easyfix?
14:59:05 <smyers> NOTABUG
14:59:29 <asmacdo> smyers, why not?
14:59:30 <smyers> Well, not true
14:59:56 <smyers> Copyright start when the content is made, so having it at 2012 is fine
15:00:08 <smyers> PUtting the 2012-2014 is confusing, but still technically correct
15:00:20 <asmacdo> but it's 2016?
15:00:26 <smyers> Just because we don't list 2015 or 2016 doesn't mean we don't still have copyright
15:00:39 <bmbouter> it's true
15:01:08 <asmacdo> so close?
15:01:13 <smyers> But triage is prolly not the place to talk about copyright law?
15:01:19 <pcreech> +1 med/low easyfix
15:01:24 <smyers> It shoul dbe fixed, so yeah
15:01:32 <smyers> !propose triage normal low
15:01:32 <smyers> #idea Proposed for #2097: Priority: Normal, Severity: Low
15:01:32 <pulpbot> Proposed for #2097: Priority: Normal, Severity: Low
15:01:40 <ipanova> +1
15:01:41 <bmbouter> +1
15:01:42 <ttereshc> +1
15:01:44 <asmacdo> !accept
15:01:44 <asmacdo> #agreed Priority: Normal, Severity: Low
15:01:44 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
15:01:46 <dalley> +1
15:01:46 <pulpbot> 1 issues left to triage: 2099
15:01:46 <asmacdo> #topic Does not provide v2 schema 2 images - http://pulp.plan.io/issues/2099
15:01:47 <pulpbot> Crane Issue #2099 [NEW] (unassigned) - Priority: Normal | Severity: Urgent
15:01:47 <pulpbot> Does not provide v2 schema 2 images - http://pulp.plan.io/issues/2099
15:02:57 <smyers> Can I just say that this docker v1/v2 stuff is completely baffling to me, and while I wish I understood it better, I'm afraid to go near it?
15:03:09 <smyers> Or should I not say that? :)
15:03:10 <dkliban> so i think this is a story
15:03:17 <asmacdo> this isnt v1/v2 smyers
15:03:27 <asmacdo> its schema 1 vs schema 2
15:03:29 <ipanova> dkliban: why it is the story?
15:03:34 <smyers> But it's v2 schema 2?
15:03:42 <smyers> Because they're versioned, and also versioned?
15:03:46 <asmacdo> v2 schema 1 vs v2 schema 2
15:03:47 <ipanova> dkliban: the comment #2 refers to the investigation i've been doing recently
15:03:47 <smyers> Like what the crap is that?
15:03:50 <dkliban> ipanova: because this is a feature request to support v2 schema
15:03:55 <asmacdo> smyers, :)
15:03:57 <smyers> Not v2.1? That was too hard?
15:04:12 <ttereshc> :)
15:04:22 <smyers> But like I said, I'm afraid to go near this stuff, and can't even guess at the severity of this
15:04:30 <asmacdo> lets leave this untriaged and get more info
15:04:39 <ipanova> dkliban: that needs to be discussed with jalbertson and mhrivnak depends on that sat
15:04:42 <smyers> !propose needinfo
15:04:42 <smyers> #idea Proposed for #2099: This issue cannot be triaged without more info.
15:04:42 <pulpbot> Proposed for #2099: This issue cannot be triaged without more info.
15:04:51 <asmacdo> im not sure if we want to actually implement schema 2 or not
15:05:05 * smyers makes a note to change that response to "...without more information."
15:05:06 <jortel> agreed.  I'd like to get more of mike's thoughts on that one too
15:05:13 <ipanova> agree
15:05:22 <asmacdo> !accept
15:05:22 <asmacdo> #agreed This issue cannot be triaged without more info.
15:05:22 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
15:05:23 <pulpbot> No issues to triage.
15:05:38 <asmacdo> !end
15:05:38 <asmacdo> #endmeeting