14:30:10 <asmacdo> #startmeeting Pulp Triage 2016-07-26
14:30:10 <asmacdo> #info asmacdo has joined triage
14:30:10 <asmacdo> !start
14:30:10 <pulpbot> Meeting started Tue Jul 26 14:30:10 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:10 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:10 <pulpbot> The meeting name has been set to 'pulp_triage_2016_07_26'
14:30:10 <pulpbot> asmacdo has joined triage
14:31:35 <ttereshc> !here
14:31:35 <ttereshc> #info ttereshc has joined triage
14:31:36 <pulpbot> ttereshc has joined triage
14:31:50 <fdobrovo> !here
14:31:50 <fdobrovo> #info fdobrovo has joined triage
14:31:50 <pulpbot> fdobrovo has joined triage
14:31:50 <mhrivnak> #info mhrivnak has joined triage
14:31:50 <mhrivnak> !here
14:31:51 <pulpbot> mhrivnak has joined triage
14:31:59 <dkliban> !here
14:31:59 <dkliban> #info dkliban has joined triage
14:32:00 <pulpbot> dkliban has joined triage
14:32:00 <ipanova> !here
14:32:00 <ipanova> #info ipanova has joined triage
14:32:01 <pulpbot> ipanova has joined triage
14:32:07 <asmacdo> !next
14:32:08 <pulpbot> 6 issues left to triage: 2099, 2100, 2101, 2103, 2104, 2105
14:32:08 <asmacdo> #topic Does not provide v2 schema 2 images - http://pulp.plan.io/issues/2099
14:32:09 <pulpbot> Crane Issue #2099 [NEW] (unassigned) - Priority: Normal | Severity: Urgent
14:32:09 <pulpbot> Does not provide v2 schema 2 images - http://pulp.plan.io/issues/2099
14:32:13 <pcreech> !here
14:32:13 <pcreech> #info pcreech has joined triage
14:32:14 <pulpbot> pcreech has joined triage
14:32:35 <dalley> !here
14:32:35 <dalley> #info dalley has joined triage
14:32:35 <pulpbot> dalley has joined triage
14:32:39 <asmacdo> mhrivnak, did you have an idea of what you wanted to do with this one?
14:32:50 <jortel> !here
14:32:50 <jortel> #info jortel has joined triage
14:32:50 <pulpbot> jortel has joined triage
14:32:52 <asmacdo> we skipped this on friday
14:32:54 <mhrivnak> asmacdo, needs more discussion, but it's not a bug.
14:33:04 <mhrivnak> We could change it to a story.
14:33:11 <dkliban> mhrivnak: i would like to do tht
14:33:23 <dkliban> i can update the ticket
14:34:03 <asmacdo> #action dkliban will change to a story
14:34:03 <asmacdo> !action dkliban will change to a story
14:34:08 <mhrivnak> thanks!
14:34:32 <asmacdo> smyers ^
14:34:43 <asmacdo> !propose other dkliban will change to story
14:34:43 <asmacdo> #idea Proposed for #2099: dkliban will change to story
14:34:44 <pulpbot> Proposed for #2099: dkliban will change to story
14:35:02 <asmacdo> #agreed dkliban will change to story
14:35:02 <asmacdo> !accept
14:35:02 <pulpbot> Current proposal accepted: dkliban will change to story
14:35:04 <asmacdo> #topic Repositories with repo-id "search" cannot be updated or deleted - http://pulp.plan.io/issues/2100
14:35:04 <pulpbot> 5 issues left to triage: 2100, 2101, 2103, 2104, 2105
14:35:04 <pulpbot> Pulp Issue #2100 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:35:05 <pulpbot> Repositories with repo-id "search" cannot be updated or deleted - http://pulp.plan.io/issues/2100
14:35:29 <asmacdo> a community user found this the other day
14:36:04 <dalley> nice
14:36:27 <smyers> No decent fix for that in pulp 2, imo, since that repo's API endpoint is obscured by the search view
14:36:30 <mhrivnak> low/low ?
14:37:02 <smyers> wontfix? (cantfix in pulp 2?)
14:37:17 <asmacdo> we could at least prevent the creation of repos with that repo_id
14:37:29 <asmacdo> #lamefix
14:37:32 <dkliban> !triage propose low low
14:37:32 <pulpbot> Error: "triage" is not a valid command.
14:37:43 <dkliban> !propose triage low low
14:37:43 <dkliban> #idea Proposed for #2100: Priority: Low, Severity: Low
14:37:43 <pulpbot> Proposed for #2100: Priority: Low, Severity: Low
14:37:44 <asmacdo> !propose triage low low
14:37:59 <mhrivnak> It sounds like we already prevent them from creating it.
14:38:03 <asmacdo> no
14:38:06 <asmacdo> it gets created
14:38:10 <mhrivnak> oh, I see.
14:38:11 <asmacdo> but it cannot be deleted or updated
14:38:15 <mhrivnak> can't delete it.
14:38:26 <asmacdo> and it isn't obvious why
14:38:32 <asmacdo> it returns http 405s
14:38:55 <mhrivnak> I see. I could be talked into low/medium then if anyone wants to raise it.
14:39:04 <jortel> +1
14:39:15 <dalley> +1
14:39:16 <asmacdo> !propose triage low medium
14:39:16 <asmacdo> #idea Proposed for #2100: Priority: Low, Severity: Medium
14:39:16 <pulpbot> Proposed for #2100: Priority: Low, Severity: Medium
14:39:16 <fdobrovo> +1
14:40:05 <asmacdo> note to self: we should consider this issue when redesigning the api for pulp 3 as well.
14:40:29 <asmacdo> !accept
14:40:29 <asmacdo> #agreed Priority: Low, Severity: Medium
14:40:29 <pulpbot> Current proposal accepted: Priority: Low, Severity: Medium
14:40:31 <asmacdo> #topic 'pulp-admin iso repo create' command does not set default --serve-http config - http://pulp.plan.io/issues/2101
14:40:31 <pulpbot> 4 issues left to triage: 2101, 2103, 2104, 2105
14:40:32 <pulpbot> RPM Support Issue #2101 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:33 <pulpbot> 'pulp-admin iso repo create' command does not set default --serve-http config - http://pulp.plan.io/issues/2101
14:41:03 <mhrivnak> dkliban, is the bug just that iso extensions aren't consistent with rpm?
14:41:50 <mhrivnak> Looking at iso by itself, I don't see a need to explicitly set the value if it has a default.
14:41:55 <dkliban> the bug is that it defaults to serving on https without it being explicitly stated in any of the repo configs
14:42:16 <mhrivnak> Do the docs say that the setting has a default?
14:42:32 <mhrivnak> If not, we could just update the docs to state the default.
14:42:48 <asmacdo> dkliban, if it doesn't have a default, it should be a required arg. http or https must be true
14:42:50 <dkliban> i don't see that in the docs
14:43:13 <dkliban> mhrivnak: the help text from pulp-admin does not state the default behavior
14:43:35 <ipanova> we can also add that to pulp-admin's option description info
14:43:36 <mhrivnak> Sounds like it does have a default, but it's just not documented in pulp-admin help text or in API docs.
14:43:55 <dkliban> yeah ... shohuld we make it a docs bug?
14:44:07 <jortel> yes
14:44:08 <mhrivnak> I like that approach.
14:44:11 <dkliban> !propose triage low low
14:44:11 <dkliban> #idea Proposed for #2101: Priority: Low, Severity: Low
14:44:12 <pulpbot> Proposed for #2101: Priority: Low, Severity: Low
14:44:20 <ttereshc> +1
14:44:21 <jortel> +1
14:44:25 <ipanova> i just checked api call on get of importer
14:44:25 <asmacdo> i disagree i think
14:44:25 <dalley> +1
14:44:35 <dkliban> asmacdo: ?
14:44:45 <ipanova> the config is empty but should show how the iso will be served
14:44:55 <asmacdo> ipanova++
14:44:55 <pulpbot> ipanova's karma is now 13
14:45:01 <asmacdo> thats what i was thinking
14:45:20 <mhrivnak> that would be a big change.
14:45:44 <mhrivnak> We would need to show all default values for all settings that have one.
14:46:01 <mhrivnak> I see that it could be useful, but is a substantial change.
14:46:02 <jortel> I don't think that plugin default behavior needs to be reflected in default values in the config.  just documented.
14:46:12 <mhrivnak> I agree.
14:46:15 <asmacdo> ok im on board
14:46:30 <asmacdo> ipanova?
14:47:01 <ipanova> and if i have bad memory i have to go everytime to check docs instead of making an API call?
14:47:18 <mhrivnak> Yes.
14:47:27 <mhrivnak> The same applies to most config files in /etc/ for example.
14:47:46 <ipanova> ok, then no objections
14:47:56 <asmacdo> i do wish that the plugins were consistent with each other... but thats not really relevant
14:47:58 <asmacdo> !accept
14:47:58 <asmacdo> #agreed Priority: Low, Severity: Low
14:47:58 <pulpbot> Current proposal accepted: Priority: Low, Severity: Low
14:47:59 <pulpbot> 3 issues left to triage: 2103, 2104, 2105
14:47:59 <asmacdo> #topic Provide documentation and release notes for issue #1156 (signature attribute for RPMs, SRPMs, and DRPMs) - http://pulp.plan.io/issues/2103
14:48:00 <pulpbot> RPM Support Issue #2103 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:48:00 <pulpbot> Provide documentation and release notes for issue #1156 (signature attribute for RPMs, SRPMs, and DRPMs) - http://pulp.plan.io/issues/2103
14:48:36 <ipanova> i think we can close that, once 1991 will be done it will contain all the docs
14:49:03 <ipanova> because the #1156 does not actually do anything by itself
14:49:29 <asmacdo> ill close as a duplicate, stating that the release notes are a check box in 1991
14:49:50 <ipanova> works for me
14:49:50 <asmacdo> !propose other close-duplicate of 1991
14:49:50 <asmacdo> #idea Proposed for #2103: close-duplicate of 1991
14:49:51 <pulpbot> Proposed for #2103: close-duplicate of 1991
14:50:23 <mhrivnak> fine with me.
14:50:45 <asmacdo> !accept
14:50:45 <asmacdo> #agreed close-duplicate of 1991
14:50:45 <pulpbot> Current proposal accepted: close-duplicate of 1991
14:50:47 <pulpbot> 2 issues left to triage: 2104, 2105
14:50:47 <asmacdo> #topic Cannot sync repo from root of host - http://pulp.plan.io/issues/2104
14:50:48 <pulpbot> RPM Support Issue #2104 [NEW] (unassigned) - Priority: Normal | Severity: High
14:50:48 <pulpbot> Cannot sync repo from root of host - http://pulp.plan.io/issues/2104
14:51:16 <mhrivnak> Interesting edge cae.
14:51:18 <mhrivnak> case
14:51:54 <dkliban> you have to provide a --relative-url in that case
14:52:07 <mhrivnak> Indeed. That would let you do a sync.
14:52:29 <mhrivnak> I don't think this is a bug, except that the error message could be more helpful.
14:52:47 <asmacdo> mhrivnak, it returns a 500
14:52:49 <asmacdo> thats a bug
14:53:18 <mhrivnak> oh I see, that's a good point.
14:53:48 <asmacdo> #idea Proposed for #2104: Priority: Normal, Severity: Low
14:53:48 <asmacdo> !propose triage medium low
14:53:48 <pulpbot> Proposed for #2104: Priority: Normal, Severity: Low
14:53:59 <jortel> +1
14:54:02 <mhrivnak> works for me.
14:54:05 <dkliban> +1
14:54:08 <ttereshc> +1
14:54:27 <fdobrovo> +1
14:54:36 <dalley> +1
14:54:36 <asmacdo> dkliban, could you update the bug and incluke the workaround?
14:55:06 <dkliban> sure
14:55:30 <asmacdo> !action dkliban will add a workaround as a comment
14:55:30 <asmacdo> #action dkliban will add a workaround as a comment
14:55:33 <asmacdo> !accept
14:55:33 <asmacdo> #agreed Priority: Normal, Severity: Low
14:55:33 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:55:35 <pulpbot> 1 issues left to triage: 2105
14:55:35 <asmacdo> #topic Importing iso content without cleaning up orphan from previous import fails - http://pulp.plan.io/issues/2105
14:55:36 <pulpbot> RPM Support Issue #2105 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:55:36 <pulpbot> Importing iso content without cleaning up orphan from previous import fails - http://pulp.plan.io/issues/2105
14:56:26 <dkliban> yeah ... the file is a duplicate so it fails before making the unit associated with the repo
14:56:47 <asmacdo> do we not have the equivalent of the GetLocalUnitsStep for import?
14:57:23 <dkliban> it's probably not used there
14:57:28 <dkliban> but should be
14:57:31 <mhrivnak> I think we do, but perhaps it has a bug.
14:57:48 <asmacdo> !propose triage medium low
14:57:48 <asmacdo> #idea Proposed for #2105: Priority: Normal, Severity: Low
14:57:48 <dkliban> !propose triage noram medium
14:57:48 <pulpbot> Proposed for #2105: Priority: Normal, Severity: Low
14:57:49 <pulpbot> Error: Unknown Priority
14:58:13 <mhrivnak> +1
14:58:16 <dkliban> +1
14:58:23 <asmacdo> i proposed low severity because there is are workaround (delete the orphan or just associate the unit)
14:59:06 <jortel> I'd propose med severity because it causes a traceback
14:59:45 * mhrivnak read that as "mad severity" and laughed
15:00:00 <asmacdo> !propose triage normal mad
15:00:00 <pulpbot> Error: Unknown Severity
15:00:05 <mhrivnak> heh
15:00:12 <mhrivnak> medium severity is fine with me.
15:00:19 <asmacdo> !propose triage normal medium
15:00:19 <asmacdo> #idea Proposed for #2105: Priority: Normal, Severity: Medium
15:00:20 <pulpbot> Proposed for #2105: Priority: Normal, Severity: Medium
15:00:50 <asmacdo> !accept
15:00:50 <asmacdo> #agreed Priority: Normal, Severity: Medium
15:00:50 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
15:00:52 <pulpbot> No issues to triage.
15:01:01 <jortel> \o/
15:01:02 <asmacdo> #endmeeting
15:01:02 <asmacdo> !end