14:29:53 <asmacdo> #startmeeting Pulp Triage 2016-07-29
14:29:53 <asmacdo> #info asmacdo has joined triage
14:29:54 <pulpbot> Meeting started Fri Jul 29 14:29:53 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:54 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:54 <pulpbot> The meeting name has been set to 'pulp_triage_2016_07_29'
14:29:54 <pulpbot> asmacdo has joined triage
14:29:58 <mhrivnak> !here
14:29:58 <mhrivnak> #info mhrivnak has joined triage
14:29:59 <pulpbot> mhrivnak has joined triage
14:30:17 <dalley> P!here
14:30:21 <dalley> !here
14:30:21 <dalley> #info dalley has joined triage
14:30:21 <pulpbot> dalley has joined triage
14:31:18 <ttereshc> #info ttereshc has joined triage
14:31:18 <ttereshc> !here
14:31:18 <pulpbot> ttereshc has joined triage
14:31:22 <dkliban> !here
14:31:22 <dkliban> #info dkliban has joined triage
14:31:23 <pulpbot> dkliban has joined triage
14:31:33 <asmacdo> !next
14:31:34 <pulpbot> 7 issues left to triage: 2106, 2107, 2109, 2110, 2111, 2112, 2115
14:31:35 <asmacdo> #topic Pin to flake8 2.6.2 - http://pulp.plan.io/issues/2106
14:31:35 <pcreech> #info pcreech has joined triage
14:31:35 <pcreech> !here
14:31:35 <pulpbot> Pulp Issue #2106 [POST] (amacdona@redhat.com) - Priority: Normal | Severity: Medium
14:31:36 <pulpbot> Pin to flake8 2.6.2 - http://pulp.plan.io/issues/2106
14:31:37 <pulpbot> pcreech has joined triage
14:31:43 <asmacdo> the first 1 should be looked at together
14:31:51 <asmacdo> actually this one should be in MODIFIED
14:32:18 <asmacdo> I'll fix that, but I left this untriaged just so the team could be aware of it
14:32:29 <mhrivnak> #idea Proposed for #2106: Leave the issue as-is, accepting its current state.
14:32:29 <mhrivnak> !propose accept
14:32:29 <pulpbot> Proposed for #2106: Leave the issue as-is, accepting its current state.
14:32:31 <fdobrovo> #info fdobrovo has joined triage
14:32:31 <fdobrovo> !here
14:32:32 <pulpbot> fdobrovo has joined triage
14:32:43 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:32:43 <asmacdo> !accept
14:32:43 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:32:44 <pulpbot> 6 issues left to triage: 2107, 2109, 2110, 2111, 2112, 2115
14:32:45 <asmacdo> #topic Unpin flake8 version from testing requirements - http://pulp.plan.io/issues/2107
14:32:45 <pulpbot> Pulp Issue #2107 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:46 <pulpbot> Unpin flake8 version from testing requirements - http://pulp.plan.io/issues/2107
14:33:12 <mhrivnak> This is a task.
14:33:23 <asmacdo> ah yeah
14:33:23 <mhrivnak> !propose other convert it to a task
14:33:23 <mhrivnak> #idea Proposed for #2107: convert it to a task
14:33:24 <pulpbot> Proposed for #2107: convert it to a task
14:33:35 <asmacdo> +1
14:33:38 <fdobrovo> +1
14:33:41 <pcreech> +1
14:33:55 <asmacdo> #agreed convert it to a task
14:33:55 <asmacdo> !accept
14:33:55 <pulpbot> Current proposal accepted: convert it to a task
14:33:56 <pulpbot> 5 issues left to triage: 2109, 2110, 2111, 2112, 2115
14:33:56 <asmacdo> #topic Load Django DB settings from server.conf - http://pulp.plan.io/issues/2109
14:33:57 <pulpbot> Pulp Issue #2109 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:58 <pulpbot> Load Django DB settings from server.conf - http://pulp.plan.io/issues/2109
14:34:17 <mhrivnak> This also looks like either a task or story.
14:34:26 <dkliban> it's a story for 3.0
14:34:39 <dkliban> smyers: right?
14:34:45 <mhrivnak> As a user, my postgres settings are loaded from server.conf?
14:34:46 * smyers isn't sure
14:34:48 <ipanova> !here
14:34:48 <ipanova> #info ipanova has joined triage
14:34:49 <pulpbot> ipanova has joined triage
14:34:50 <jortel> #info jortel has joined triage
14:34:50 <jortel> !here
14:34:50 <pulpbot> jortel has joined triage
14:34:58 <smyers> Ah, I read the "before" subject
14:35:20 <smyers> We already load the settings for mongo from there, so probably refactor?
14:35:31 <smyers> But not Issue, that's for sure
14:36:17 <mhrivnak> I could see refactor.
14:36:42 <mhrivnak> !propose other convert it to a refactor
14:36:42 <mhrivnak> #idea Proposed for #2109: convert it to a refactor
14:36:43 <pulpbot> Proposed for #2109: convert it to a refactor
14:36:58 <smyers> Or story, or task...Almost all make sense for converting mongo-related behaviors to their postgressy counterpart. But yeha, refactor works for me
14:37:32 <asmacdo> seems like it doesnt matter much either way, last call?
14:37:51 <pcreech> +1
14:37:54 <asmacdo> !accept
14:37:54 <asmacdo> #agreed convert it to a refactor
14:37:54 <pulpbot> Current proposal accepted: convert it to a refactor
14:37:55 <pulpbot> 4 issues left to triage: 2110, 2111, 2112, 2115
14:37:56 <asmacdo> #topic Support for first class 'generic' or 'file' content type - http://pulp.plan.io/issues/2110
14:37:56 <pulpbot> Pulp Issue #2110 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:37:57 <pulpbot> Support for first class 'generic' or 'file' content type - http://pulp.plan.io/issues/2110
14:38:26 <dkliban> also a story
14:38:27 <ttereshc> story
14:38:33 <smyers> story++
14:38:34 <mhrivnak> definitely a story, and likely a dup
14:38:49 <smyers> I was also thinking dup, but don't have the issue handy
14:39:50 <mhrivnak> 119
14:39:59 <mhrivnak> https://pulp.plan.io/issues/119
14:40:00 <pulpbot> Title: Refactor #119: Rename the ISO plugins to be "File" plugins - RPM Support - Pulp (at pulp.plan.io)
14:40:11 <dalley> this one maybe? https://pulp.plan.io/issues/1656\
14:40:13 <pulpbot> Title: Story #1656: generic file functionality is hidden inside ISO repo type, which is inside RPM plugin - RPM Support - Pulp (at pulp.plan.io)
14:40:17 <smyers> that's the one!
14:40:24 <smyers> #119 is what I was thinking of
14:40:55 <asmacdo> !propose other close as duplicate of #119
14:40:55 <asmacdo> #idea Proposed for #2110: close as duplicate of #119
14:40:56 <pulpbot> Proposed for #2110: close as duplicate of #119
14:41:02 <mhrivnak> I was also looking at 1656, which I think is also probably a dup of 119
14:41:20 <asmacdo> ill get them both
14:41:28 <mhrivnak> thanks.
14:41:44 <asmacdo> !accept
14:41:44 <asmacdo> #agreed close as duplicate of #119
14:41:44 <pulpbot> Current proposal accepted: close as duplicate of #119
14:41:46 <asmacdo> #topic pulp streamer keep proxy for all repos - http://pulp.plan.io/issues/2111
14:41:46 <pulpbot> 3 issues left to triage: 2111, 2112, 2115
14:41:47 <pulpbot> Pulp Issue #2111 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:41:48 <pulpbot> pulp streamer keep proxy for all repos - http://pulp.plan.io/issues/2111
14:42:42 <mhrivnak> I wonder if the new urllib3 improvements help with this.
14:43:42 <mhrivnak> Most users with a proxy want to proxy all traffic, but this is a valid use case that should work.
14:43:51 <mhrivnak> !propose triage high low
14:43:51 <mhrivnak> #idea Proposed for #2111: Priority: High, Severity: Low
14:43:52 <pulpbot> Proposed for #2111: Priority: High, Severity: Low
14:44:02 <dkliban> +1
14:44:08 <ttereshc> +1
14:44:11 <ipanova> +1
14:44:12 <fdobrovo> +1
14:44:20 <mhrivnak> I'm sure jcline will be able to add some insight when he gets back.
14:44:46 <asmacdo> !accept
14:44:46 <asmacdo> #agreed Priority: High, Severity: Low
14:44:46 <pulpbot> Current proposal accepted: Priority: High, Severity: Low
14:44:47 <pulpbot> 2 issues left to triage: 2112, 2115
14:44:47 <asmacdo> #topic Status API does not log Qpid errors - http://pulp.plan.io/issues/2112
14:44:48 <pulpbot> Pulp Issue #2112 [POST] (bmbouter) - Priority: Normal | Severity: Medium | Target Release: 2.9.2
14:44:49 <pulpbot> Status API does not log Qpid errors - http://pulp.plan.io/issues/2112
14:45:05 <dkliban> already in post
14:45:28 <ttereshc> !propose accept
14:45:28 <ttereshc> #idea Proposed for #2112: Leave the issue as-is, accepting its current state.
14:45:29 <pulpbot> Proposed for #2112: Leave the issue as-is, accepting its current state.
14:45:33 <mhrivnak> +1
14:45:46 <ipanova> +1
14:45:51 <fdobrovo> +1
14:45:56 <asmacdo> !accept
14:45:56 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:45:56 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:45:57 <pulpbot> 1 issues left to triage: 2115
14:45:57 <asmacdo> #topic The 'skip_fast_forward' in RPM rsync config should be renamed to 'force_full' - http://pulp.plan.io/issues/2115
14:45:58 <pulpbot> RPM Support Issue #2115 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Target Release: 2.10.0
14:45:59 <pulpbot> The 'skip_fast_forward' in RPM rsync config should be renamed to 'force_full' - http://pulp.plan.io/issues/2115
14:46:37 <asmacdo> dkliban, did you set target release deliberately?
14:46:46 <dkliban> yes, i'll have a PR shortly
14:47:15 <mhrivnak> A sentence or two about why would be very helpful.
14:47:29 <mhrivnak> why this is a bug that is.
14:47:57 <dkliban> it's a bug because the behavior is the same as force_full on the yum distributor
14:48:06 <dkliban> and this should be consistent
14:48:12 <dkliban> i'll add it to the ticket now
14:48:28 <asmacdo> dkliban, is this backwards compatible?
14:48:28 <mhrivnak> Gotcha. Can you add a description to the bug that includes that?
14:48:34 <mhrivnak> Thanks.
14:48:45 <mhrivnak> asmacdo, doesn't matter since none of it has been released yet.
14:48:46 <asmacdo> oh rsync. its new
14:48:48 <dkliban> asmacdo: it is  ... we haven't released this yet
14:49:00 <asmacdo> gotcha.
14:49:07 <asmacdo> #idea Proposed for #2115: Leave the issue as-is, accepting its current state.
14:49:07 <asmacdo> !propose accept
14:49:08 <pulpbot> Proposed for #2115: Leave the issue as-is, accepting its current state.
14:49:11 <ttereshc> +1
14:49:12 <dalley> +1
14:49:19 <asmacdo> dkliban, will you triage when you update?
14:49:47 <dkliban> asmacdo: yes
14:49:54 <asmacdo> !accept
14:49:54 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:49:54 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:49:55 <pulpbot> No issues to triage.
14:50:13 <asmacdo> !end
14:50:13 <asmacdo> #endmeeting