14:43:19 <asmacdo> #startmeeting Pulp Triage 2016-08-09
14:43:19 <asmacdo> !start
14:43:19 <asmacdo> #info asmacdo has joined triage
14:43:19 <pulpbot> Meeting started Tue Aug  9 14:43:19 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:43:19 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:43:19 <pulpbot> The meeting name has been set to 'pulp_triage_2016_08_09'
14:43:19 <pulpbot> asmacdo has joined triage
14:43:35 <jcline> My opinion is it would make my life /slightly/ easier if everyone chipped in with their specfile changes, but not that much easier. I mean, in the time we've had this discussion, I probably could have reconciled whatever changes needed to be reconciled.
14:43:58 <jcline> !here
14:43:58 <jcline> #info jcline has joined triage
14:43:59 <pulpbot> jcline has joined triage
14:44:02 <pcreech> good point, jcline
14:44:03 <pcreech> !here
14:44:03 <pcreech> #info pcreech has joined triage
14:44:03 <pulpbot> pcreech has joined triage
14:44:05 <fdobrovo|wfh> #info fdobrovo|wfh has joined triage
14:44:05 <fdobrovo|wfh> !here
14:44:05 <pulpbot> fdobrovo|wfh has joined triage
14:44:28 <mhrivnak> #info mhrivnak has joined triage
14:44:28 <mhrivnak> !here
14:44:28 <pulpbot> mhrivnak has joined triage
14:45:05 <asmacdo> !next
14:45:07 <asmacdo> #topic Permissions docs should include some info on /v2/  - http://pulp.plan.io/issues/2133
14:45:07 <pulpbot> 5 issues left to triage: 2133, 2134, 2136, 2137, 2142
14:45:08 <pulpbot> Pulp Issue #2133 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:45:09 <pulpbot> Permissions docs should include some info on /v2/  - http://pulp.plan.io/issues/2133
14:45:25 <mhrivnak> !propose accept
14:45:25 <mhrivnak> #idea Proposed for #2133: Leave the issue as-is, accepting its current state.
14:45:26 <pulpbot> Proposed for #2133: Leave the issue as-is, accepting its current state.
14:45:38 <pcreech> +1
14:46:04 <jcline> works for me
14:46:21 <asmacdo> !accept
14:46:21 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:46:22 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:46:23 <asmacdo> #topic Updating a repo without specifying checksum_type causes KeyError - http://pulp.plan.io/issues/2134
14:46:23 <pulpbot> 4 issues left to triage: 2134, 2136, 2137, 2142
14:46:24 <pulpbot> RPM Support Issue #2134 [ASSIGNED] (fdobrovo) - Priority: High | Severity: Medium
14:46:25 <pulpbot> Updating a repo without specifying checksum_type causes KeyError - http://pulp.plan.io/issues/2134
14:47:26 <dalley> #info dalley has joined triage
14:47:26 <dalley> !here
14:47:26 <pulpbot> dalley has joined triage
14:47:31 <fdobrovo|wfh> It's from bugzilla and there is not enough info to reproduce it ...
14:48:02 <pcreech> mhrivnak: it states from bugzilla, is there a BZ to associate?
14:48:10 <jcline> Seems like a regression with the REST API so high/medium or high/high?
14:48:13 <mhrivnak> pcreech, it's associated. maybe you're not logged in?
14:48:22 <pcreech> (ah, that could be)
14:48:33 * pcreech shakes fist at 'stay logged in'
14:49:06 <mhrivnak> There is a straight-forward work-around, so I think severity can be medium or low. But I do like high priority.
14:49:27 <mhrivnak> Or we could wait a few days for more info on reproducibility.
14:49:48 <mhrivnak> any preference on waiting vs. triaging now? I'm happy either way.
14:49:48 <fdobrovo|wfh> _
14:49:57 <jortel> !here
14:49:57 <jortel> #info jortel has joined triage
14:49:58 <fdobrovo|wfh> I'm for waiting
14:49:58 <pulpbot> jortel has joined triage
14:50:01 <pcreech> !propose skip
14:50:01 <pcreech> #idea Proposed for #2134: Skip this issue for this triage session.
14:50:02 <pulpbot> Proposed for #2134: Skip this issue for this triage session.
14:50:33 <smyers> skip, or needinfo?
14:50:52 <jcline> needinfo I'd think
14:50:57 <asmacdo> i think we could needinfo
14:51:24 <mhrivnak> BZ already has needinfo.
14:51:52 <asmacdo> id like to see the pulp apicalls
14:52:17 <ichimonji10> elyezer: https://github.com/PulpQE/pulp-fixtures/pull/24#issuecomment-238578609
14:52:18 <pulpbot> Title: Sign all RPMs with Pulp QE GPG key by elyezer · Pull Request #24 · PulpQE/pulp-fixtures · GitHub (at github.com)
14:52:19 <dalley> so, looking at the code, the cause is that the config being passed into update(...) contains keys not included in the distributor config
14:52:29 <dalley> and there's no handling for that
14:52:33 <elyezer> ichimonji10++
14:52:33 <pulpbot> ichimonji10's karma is now 34
14:52:39 <ichimonji10> (:
14:53:03 <asmacdo> !accept
14:53:03 <asmacdo> #agreed Skip this issue for this triage session.
14:53:04 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:53:05 <asmacdo> #topic publish step error handling incorrectly assumes open file - http://pulp.plan.io/issues/2136
14:53:05 <pulpbot> 3 issues left to triage: 2136, 2137, 2142
14:53:06 <pulpbot> Pulp Issue #2136 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:53:07 <pulpbot> publish step error handling incorrectly assumes open file - http://pulp.plan.io/issues/2136
14:53:43 <mhrivnak> jsherrill, any guidance on priority from your side?
14:55:18 <mhrivnak> I think this is largely a case of unclear error reporting.
14:55:25 <mhrivnak> from the user perspective.
14:55:48 <mhrivnak> The bug is only triggered if some other problem already occurred.
14:56:25 <asmacdo> !propose skip
14:56:25 <asmacdo> #idea Proposed for #2136: Skip this issue for this triage session.
14:56:26 <pulpbot> Proposed for #2136: Skip this issue for this triage session.
14:56:42 <mhrivnak> I in-person-pinged jsherrill :)
14:57:07 <mhrivnak> who is looking at it now.
14:57:09 <asmacdo> ah, ok, ill hold off then
14:57:41 <jsherrill> mhrivnak: has 2 customer issues attached, but got moved to backlog as well.. so medium?
14:58:19 <mhrivnak> #idea Proposed for #2136: Leave the issue as-is, accepting its current state.
14:58:19 <mhrivnak> !propose accept
14:58:19 <pulpbot> Proposed for #2136: Leave the issue as-is, accepting its current state.
14:58:56 <asmacdo> im not opposed to accepting
14:59:09 <pcreech> +1
14:59:09 <asmacdo> but im not sure that there is enough here to reproduce it
15:00:00 <asmacdo> unless there are other thoughts, ill accept it
15:00:32 <asmacdo> !acceot
15:00:32 <pulpbot> Error: "acceot" is not a valid command.
15:00:36 <asmacdo> !accept
15:00:36 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
15:00:36 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:00:38 <asmacdo> #topic Can't delete task agent_unbind - http://pulp.plan.io/issues/2137
15:00:38 <pulpbot> 2 issues left to triage: 2137, 2142
15:00:39 <pulpbot> Pulp Issue #2137 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:00:40 <pulpbot> Can't delete task agent_unbind - http://pulp.plan.io/issues/2137
15:01:03 <mhrivnak> This is pretty unfortunate.
15:01:29 <mhrivnak> Cancellation shouldn't require the consumer to still exist.
15:01:45 <jortel> agreed
15:02:04 <asmacdo> workaround is probably to create a consumer of the same name
15:02:06 <jcline> I thought there was a --force?
15:02:27 <mhrivnak> I think there is, but maybe in this case they already did unbind without the --force option?
15:02:28 <jcline> That told pulp to not sync up with the consumer when unbinding, but maybe not
15:03:06 <jcline> Oh yeah I see. That's not good.
15:03:25 <mhrivnak> Maybe I'm just uninspired regarding consumer stuff, but I'm not sure this is worth prioritizing.
15:04:15 <mhrivnak> Any other thoughts on priority?
15:04:35 * jortel thinking on how it would affect satellite
15:04:36 <jcline> Yeah. It's surprising you can get uncancelable tasks, though, maybe that should be the real issue
15:05:06 <mhrivnak> It's worth noting that these are not celery tasks.
15:05:20 <mhrivnak> So at least it's not impacting that whole system.
15:05:43 <jortel> right, they are agent tasks.  this will not affect satellite because they don't use bind/unbind
15:05:45 <mhrivnak> It's just an annoying record in the DB at this point I think.
15:06:00 <jortel> rather, the katello agent does not impl bind/unbind.
15:06:32 <jortel> I think I agree this is just annoying.
15:06:38 <asmacdo> med/low sounds good to me from what you all have said
15:06:47 <mhrivnak> works for me.
15:06:52 <jcline> works for me, too
15:07:06 <asmacdo> !propose triage normal low
15:07:06 <asmacdo> #idea Proposed for #2137: Priority: Normal, Severity: Low
15:07:07 <pulpbot> Proposed for #2137: Priority: Normal, Severity: Low
15:07:37 <jortel> +1
15:07:42 <asmacdo> #agreed Priority: Normal, Severity: Low
15:07:42 <asmacdo> !accept
15:07:42 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
15:07:43 <pulpbot> 1 issues left to triage: 2142
15:07:44 <asmacdo> #topic Units created with 0-byte files when sync runs out of disk space - http://pulp.plan.io/issues/2142
15:07:44 <pulpbot> Docker Support Issue #2142 [NEW] (unassigned) - Priority: High | Severity: High
15:07:45 <pulpbot> Units created with 0-byte files when sync runs out of disk space - http://pulp.plan.io/issues/2142
15:08:23 <mhrivnak> I think this one is pretty bad.
15:08:30 <dkliban> i agree
15:08:47 <mhrivnak> It caused jluza a lot of pain yesterday.
15:08:58 <dkliban> it has caused him a lot of pain for over a week
15:09:36 <dkliban> there is a related issue https://pulp.plan.io/issues/753
15:09:38 <pulpbot> Title: Issue #753: Sync just hangs when running out of diskspace - Pulp (at pulp.plan.io)
15:09:54 <mhrivnak> I tried reproducing 753 the same way and could not.
15:10:01 <dkliban> oh ok
15:10:19 <jcline> High/High I guess? Or Urgent? Serving corrupt files seems bad.
15:10:34 <jluza> mhrivnak, dkliban, I'm used to pain from pulp, but Tim was all bad from this
15:11:37 <dkliban> i think this one should be urgent
15:11:42 <elyezer> ichimonji10: that PR is ready for final review, will flip the labels on it
15:11:45 <mhrivnak> Since we're using "urgent" to signify release blockers, and I don't think this should block a release necessarily, I'd stick with high/high.
15:12:15 <mhrivnak> It seems likely that this bug has existed for a lot of releases.
15:12:15 <jortel> +1
15:12:20 <smyers> Yep
15:12:26 <mhrivnak> I do think we should fix it ASAP though.
15:12:27 <asmacdo> dkliban, do you think this should block a release?
15:12:32 <dkliban> asmacdo: no
15:12:39 <asmacdo> !propose triage high high
15:12:39 <asmacdo> #idea Proposed for #2142: Priority: High, Severity: High
15:12:40 <pulpbot> Proposed for #2142: Priority: High, Severity: High
15:13:10 <dkliban> mhrivnak: we don't have to set the release on it now, but I think we should try to release it was part of 2.8.8
15:13:38 <mhrivnak> dkliban, sounds reasonable. Let's add a note that a fix should go on 2.8-dev.
15:13:47 <mhrivnak> er, I guess it's 2.0-dev
15:14:07 <mhrivnak> which is the only option for pulp_docker, so we don't need a note. :)
15:14:30 <asmacdo> !accept
15:14:30 <asmacdo> #agreed Priority: High, Severity: High
15:14:30 <pulpbot> Current proposal accepted: Priority: High, Severity: High
15:14:32 <pulpbot> No issues to triage.
15:14:44 <jortel> \o/
15:15:07 <asmacdo> !end
15:15:07 <asmacdo> #endmeeting