14:31:48 <asmacdo> #startmeeting Pulp Triage 2016-08-12
14:31:48 <asmacdo> #info asmacdo has joined triage
14:31:49 <pulpbot> Meeting started Fri Aug 12 14:31:48 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:49 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:49 <pulpbot> The meeting name has been set to 'pulp_triage_2016_08_12'
14:31:49 <pulpbot> asmacdo has joined triage
14:33:03 <dalley> !here
14:33:03 <dalley> #info dalley has joined triage
14:33:04 <pulpbot> dalley has joined triage
14:33:07 <preethi> !here
14:33:07 <preethi> #info preethi has joined triage
14:33:07 <pulpbot> preethi has joined triage
14:33:23 <ttereshc> !here
14:33:23 <ttereshc> #info ttereshc has joined triage
14:33:23 <pulpbot> ttereshc has joined triage
14:33:37 <asmacdo> !nex
14:33:37 <pulpbot> Error: "nex" is not a valid command.
14:33:40 <asmacdo> !next
14:33:41 <pulpbot> 3 issues left to triage: 2134, 2136, 2170
14:33:41 <asmacdo> #topic Updating a repo without specifying checksum_type causes KeyError - http://pulp.plan.io/issues/2134
14:33:42 <pulpbot> RPM Support Issue #2134 [ASSIGNED] (fdobrovo) - Priority: High | Severity: Medium
14:33:43 <pulpbot> Updating a repo without specifying checksum_type causes KeyError - http://pulp.plan.io/issues/2134
14:33:52 <mhrivnak> #info mhrivnak has joined triage
14:33:52 <mhrivnak> !here
14:33:53 <pulpbot> mhrivnak has joined triage
14:34:17 <ipanova> afaik, Filip is not able to reproduce the bug, still
14:34:21 <jortel> !here
14:34:21 <jortel> #info jortel has joined triage
14:34:21 <pulpbot> jortel has joined triage
14:34:21 <pcreech> !here
14:34:21 <pcreech> #info pcreech has joined triage
14:34:22 <pulpbot> pcreech has joined triage
14:34:52 <mhrivnak> has there been help from katello on reproducing it?
14:35:16 <ipanova> i don't think so
14:35:27 <asmacdo> none on the BZ either
14:35:47 <asmacdo> !propose skip
14:35:47 <asmacdo> #idea Proposed for #2134: Skip this issue for this triage session.
14:35:48 <pulpbot> Proposed for #2134: Skip this issue for this triage session.
14:36:01 <mhrivnak> +1 I'll inquire about it with them.
14:36:04 <bmbouter> #info bmbouter has joined triage
14:36:04 <bmbouter> !here
14:36:04 <pulpbot> bmbouter has joined triage
14:36:09 <asmacdo> thanks mhrivnak
14:36:14 <dkliban> !here
14:36:14 <dkliban> #info dkliban has joined triage
14:36:14 <asmacdo> !accept
14:36:14 <asmacdo> #agreed Skip this issue for this triage session.
14:36:14 <pulpbot> dkliban has joined triage
14:36:15 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:36:16 <asmacdo> #topic publish step error handling incorrectly assumes open file - http://pulp.plan.io/issues/2136
14:36:16 <pulpbot> 2 issues left to triage: 2136, 2170
14:36:17 <pulpbot> Pulp Issue #2136 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:18 <pulpbot> publish step error handling incorrectly assumes open file - http://pulp.plan.io/issues/2136
14:37:36 <asmacdo> wow that is some scary looking code
14:37:38 <mhrivnak> Did we skip this one on purpose last time?
14:37:58 <mhrivnak> And if so, what were we waiting for?
14:38:01 * mhrivnak starts scrolling
14:38:34 <mhrivnak> we accepted it last time.
14:38:54 <mhrivnak> We accepted "as-is", so I think the triaged flag just didn't get set.
14:38:59 <asmacdo> my fault
14:39:24 <asmacdo> though i remember not thinking we could reproduce this
14:39:34 <asmacdo> Step 1 to reproduce:"Somehow let damage primar / other / filelist gzip for some repo (not sure on this step)"
14:40:48 <mhrivnak> I agree it's not easy to reproduce, but the error handling is definitely not as robust as it should be.
14:41:08 <asmacdo> ok ill accept as is (since we agreed to that last time)
14:41:10 <asmacdo> !accept
14:41:10 <pulpbot> No action proposed, nothing to accept.
14:41:17 <asmacdo> #idea Proposed for #2136: Leave the issue as-is, accepting its current state.
14:41:17 <asmacdo> !propose accept
14:41:18 <pulpbot> Proposed for #2136: Leave the issue as-is, accepting its current state.
14:41:20 <asmacdo> !accept
14:41:20 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:41:21 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:41:21 <asmacdo> #topic Getting a 500 instead of 400 when using a string in criteria instead of dict - http://pulp.plan.io/issues/2170
14:41:22 <pulpbot> 1 issues left to triage: 2170
14:41:23 <pulpbot> Pulp Issue #2170 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:41:24 <pulpbot> Getting a 500 instead of 400 when using a string in criteria instead of dict - http://pulp.plan.io/issues/2170
14:41:43 <mhrivnak> !propose triage normal low
14:41:43 <mhrivnak> #idea Proposed for #2170: Priority: Normal, Severity: Low
14:41:44 <pulpbot> Proposed for #2170: Priority: Normal, Severity: Low
14:41:51 <smyers> +1
14:42:04 <smyers> bad requests should recive bad request :)
14:42:13 <mhrivnak> I'm happy just letting 3.0 make this irrelevant.
14:42:59 <asmacdo> That will probably happen in 3.0
14:43:50 <ttereshc> +1
14:43:59 <asmacdo> #agreed Priority: Normal, Severity: Low
14:43:59 <asmacdo> !accept
14:43:59 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:44:00 <pulpbot> No issues to triage.
14:44:09 <asmacdo> wow. easy triage
14:44:25 <pcreech> \o/
14:44:52 <bmbouter> this is so great
15:07:59 <dalley> mhrivnak: I will leave the RPM PR unmerged so that the PR test runner will have a chance to run on it.  The tests will fail until the test runner updates to the up-to-date version of the platform
15:08:30 <dalley> ipanova left, but on Monday someone can just "ok test" it and merge
15:09:09 <dalley> All the tests should pass but for the sake of thoroughness :)
15:47:35 <bmbouter> smyers: so for putting things into all the pulp/packaging branches do we do 1 PR or a PR for each branch?
15:48:45 <smyers> I'm thinking 1 PR and "merge backward"
15:50:49 <bmbouter> good deal and that is just what I had started doing :-)
15:53:40 <dalley> so I'm trying to recreate my vagrant box, but I'm getting errors
15:54:14 <dalley> `path` for shell provisioner does not exist on the host system: /home/dalley/Devel/pulp/playpen/bootstrap-ansible.sh
15:54:24 <bmbouter> are you using the Vagrant file from pulp/devel ?
15:54:34 <dalley> `playbook` does not exist on the host: /home/dalley/Devel/pulp/playpen/ansible/vagrant-playbook.yml
15:55:02 <dalley> It's the same modified one I've been using since the beginning
15:58:28 <bmbouter> I think I had errors with the one from playpen
15:58:42 <bmbouter> use the one from pulp/packaging
15:58:50 <bmbouter> pulp/devel rather
15:58:55 <bmbouter> https://github.com/pulp/devel
15:58:56 <pulpbot> Title: GitHub - pulp/devel (at github.com)
16:00:45 <dalley> I had no issues with it a couple weeks back, but oh well :/
16:03:38 <bmbouter> yeah I remember the same I was using it and then it wouldn't work for me anymore
16:03:46 <dalley> the one in devel doesn't work for me either, same errors
16:04:22 <bmbouter> smyers here is my fix if you have any interest in reviewing it
16:04:24 <bmbouter> https://github.com/pulp/packaging/pull/32
16:04:25 <pulpbot> Title: Adds fix to spec file from issue 2121 by bmbouter · Pull Request #32 · pulp/packaging · GitHub (at github.com)
16:04:35 <bmbouter> or we can wait for jcline on monday
16:07:01 <dalley> well, I can't wait until monday :)
16:07:06 <dalley> today is my last day
16:07:41 <bmbouter> dalley: that was for smyers
16:07:53 <dalley> ah sorry
16:07:57 <dalley> didn't read up far enough
16:08:19 <bmbouter> dalley: so the vagrant up is blocking you?
16:09:44 <dalley> It's blocking me so far as the next 4 hours are concerned.  I'll try to figure out what happened, I just wanted to know if anyone immediately recognized the issue
16:09:53 <dalley> Don't worry about troubleshooting
16:15:02 <bmbouter> I think it's just the repo you're using really
16:15:19 <bmbouter> that thing is about to be deleted from pulp/pulp I thought
16:16:07 <smyers> bmbouter, lgtm
16:16:20 <bmbouter> smyers thanks
16:16:36 <bmbouter> smyers also for pulp/packaging what happens with external_deps.json
16:22:22 <jcline> dalley, did you copy your Vagrantfile over from pulp/pulp?
16:22:40 <jcline> Or did you take Vagrantfile.example from pulp/devel and copy it to Vagrantfile?
16:23:03 <dalley> jcline: yes
16:23:11 <dalley> brb lunch
16:30:09 <jcline> Erm. Yes to which question?
16:50:47 <dalley> jcline: Both failed with the same errors.  I tried both.
16:52:05 <smyers> bmbouter, in the new packaging, external deps are actually part of the release config
16:52:29 <smyers> That might be a pain in the ass, but maybe not? I think it's a soft thing right now worthy of scrutiny
16:52:31 <jcline> I see. Well, the error is due to a provisioner in the Vagrantfile that references a file from the old setup. dalley, can you fpaste your Vagrantfile?
16:54:43 <dalley> https://paste.fedoraproject.org/407018/02085714/
16:54:53 <dalley> jcline, which is the same as the one in pulp/devel
16:54:57 <dalley> that's the one I copied
16:56:08 <smyers> But if you're getting a failure that has the word "playpen" in it, it's incorrect...
16:56:29 <jcline> The only thing I can think of is Vagrant is keeping weird state around
16:57:22 <dalley> don't worry about it, I'll just do a bit of troubleshooting
17:02:34 * smyers shutsdown IRC, send an email if you need sommat :)
17:05:55 <bmbouter> smyers: the external_deps.json sounds fine for now thanks
17:21:15 <preethi> smyers: 2.9.2 issues are verified and upgrade automation jobs completed
17:25:38 <bmbouter> yay
17:37:16 <pcreech> before I go on vacation, i'll be submitting the task model PR.  I will try my best to make updates next week, but it's not guarunteed.  Anyone interested in being my backup for that?
17:39:10 <bmbouter> pcreech: I would be happy to
17:41:20 <pcreech> bmbouter: awesome!  Thanks!
18:29:15 <dalley> how do you change the default config for a distributor
18:29:52 <dalley> I gather that it can be done with an API call but i haven't found a resource that demos the CLI process
18:55:18 <bmbouter> smyers: you still offline?
18:55:28 <bmbouter> I'm try to build an srpm of python-kombu without tito and I'm looking for pointers
19:00:10 <pcreech> bmbouter: rpmbuild -bs {specfile}.spec ??
19:01:00 * pcreech could be way off base
19:11:00 <bmbouter> pcreech: no that is the same thing mine produced
19:11:17 <bmbouter> but I have this error when I run that
19:11:44 <bmbouter> https://paste.fedoraproject.org/407107/14710291/raw/
19:12:10 <pcreech> probably have to follow start-finish of rpm building here:  https://fedoraproject.org/wiki/How_to_create_an_RPM_package#Building_the_binary_package
19:12:34 <bmbouter> pcreech: good idea let me try that
19:12:36 <pcreech> er, without the #{stuff} part
19:38:04 <mhrivnak> I made a script that sets all of the right github branches to be protected. Any suggestions where to put it?
19:38:29 <mhrivnak> There's always the playpen, but maybe we have a better place now.
19:39:01 <mhrivnak> maybe here? https://github.com/pulp/devel/tree/master/scripts
19:39:02 <pulpbot> Title: devel/scripts at master · pulp/devel · GitHub (at github.com)
19:39:30 <bmbouter> yeah we should get rid of playpen
19:39:40 <bmbouter> that looks like exactly the right place
19:39:44 <bmbouter> how did you do it with a script?
19:39:53 <mhrivnak> I used github's API.
19:40:19 <mhrivnak> I realized how much clicking it takes to mark one branch as protected, and then saw we had about 70 branches to do it for.
19:40:27 <mhrivnak> And it was a lot more clicking than I wanted to do. :)
19:41:06 <mhrivnak> It took a little more time to script it, but not a lot.
19:49:30 <bmbouter> great
19:51:10 <mhrivnak> Should the "devel" repo have protected branches?
19:52:11 <bmbouter> I think so
19:52:24 <bmbouter> for the some kind of protection against deltion and force-push
20:01:30 <mhrivnak> bmbouter, in case you're curious: https://github.com/pulp/devel/pull/3
20:01:31 <pulpbot> Title: adding a script to set github branches as protected by mhrivnak · Pull Request #3 · pulp/devel · GitHub (at github.com)
20:11:01 <mhrivnak> smyers, do you have a suggestion for where I should document how to mark branches as protected?
20:28:24 <bmbouter> our topic is still from triag ein this channel
20:29:41 <bmbouter> here is my updated pulp/packaging PR for python-kombu
20:29:43 <bmbouter> https://github.com/pulp/packaging/pull/33
20:29:44 <pulpbot> Title: Updates kombu to a new release by bmbouter · Pull Request #33 · pulp/packaging · GitHub (at github.com)
20:30:24 <asmacdo> !end
20:30:24 <asmacdo> #endmeeting