14:30:24 <asmacdo> #startmeeting Pulp Triage 2016-08-19
14:30:24 <asmacdo> #info asmacdo has joined triage
14:30:25 <pulpbot> Meeting started Fri Aug 19 14:30:24 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:25 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:25 <pulpbot> The meeting name has been set to 'pulp_triage_2016_08_19'
14:30:25 <pulpbot> asmacdo has joined triage
14:30:30 <mhrivnak> #info mhrivnak has joined triage
14:30:30 <mhrivnak> !here
14:30:30 <pulpbot> mhrivnak has joined triage
14:30:37 <ttereshc> !here
14:30:37 <ttereshc> #info ttereshc has joined triage
14:30:37 <pulpbot> ttereshc has joined triage
14:31:13 <asmacdo> !next
14:31:14 <pulpbot> 4 issues left to triage: 2172, 2173, 2177, 2190
14:31:15 <asmacdo> #topic Reduce memory leaks - http://pulp.plan.io/issues/2172
14:31:15 <pulpbot> Pulp Issue #2172 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:15 <pulpbot> Reduce memory leaks - http://pulp.plan.io/issues/2172
14:31:23 <jortel> !here
14:31:23 <jortel> #info jortel has joined triage
14:31:23 <pulpbot> jortel has joined triage
14:31:38 <asmacdo> ttereshc, you snuck one in :)
14:31:45 <ttereshc> asmacdo, :P
14:32:37 <mhrivnak> As noted on the bug, I think this is more of a refactor or enhancement request.
14:32:41 <asmacdo> mhrivnak, when we convert this one to a story, do you have a suggestion for a new more descriptive name?
14:33:34 <mhrivnak> depends. If we go with that setting, it could be "as a user, I can set a value for the celery $MAX_WHATEVER setting".
14:34:53 <mhrivnak> I could also see it as a refactor, since it's not adding a new behavior that directly affects the user.
14:35:49 <mhrivnak> Also to be clear, I'm not sure we should make any changes based on this request, but I do want to capture it at least.
14:36:58 <mhrivnak> anyone else have thoughts? :)
14:37:06 <ttereshc> maybe it is a story if more investigation is needed
14:37:31 <asmacdo> I am not sure how I'd like to approach this then. I don't want a dev to spend time trying to understand and make this change, so whatever we do, we should add a comment that some team discussion should happen before work begins.
14:38:27 <mhrivnak> I think our process should facilitate that already.
14:38:27 <asmacdo> I propose Task: investigate memory usage improvements
14:38:41 <mhrivnak> It needs to be groomed and put on a sprint before anyone should be making the change.
14:39:01 <mhrivnak> That seems reasonable.
14:39:04 <asmacdo> mhrivnak, only if it is a story, refactors don't need to be groomed.
14:39:27 <asmacdo> !propose other Convert to task
14:39:27 <asmacdo> #idea Proposed for #2172: Convert to task
14:39:28 <pulpbot> Proposed for #2172: Convert to task
14:39:30 <ttereshc> +1 for task
14:39:32 <mhrivnak> asmacdo, hm. Perhaps I need to re-read the policy then.
14:39:51 <asmacdo> mhrivnak, I might be wrong too, I should re-read it also.
14:39:55 <mhrivnak> in any case, it still neds to be put on a sprint first.
14:40:00 <mhrivnak> And we have a process for that. :)
14:40:19 <jcline> !here
14:40:19 <jcline> #info jcline has joined triage
14:40:19 <pulpbot> jcline has joined triage
14:40:31 <asmacdo> jcline, you want a word in here before I accept?
14:41:01 <smyers> I'm fine with the task, it's not ever clear that memory's actually leaking
14:41:04 <smyers> even
14:41:05 <jortel> +1 task
14:41:14 <asmacdo> !accept
14:41:14 <asmacdo> #agreed Convert to task
14:41:15 <pulpbot> Current proposal accepted: Convert to task
14:41:16 <asmacdo> #topic /bin/systemctl status  pulp_celerybeat.service fails to start and will fail until several attempts have been tried - http://pulp.plan.io/issues/2173
14:41:16 <pulpbot> 3 issues left to triage: 2173, 2177, 2190
14:41:16 <pulpbot> Pulp Issue #2173 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:41:17 <pulpbot> /bin/systemctl status  pulp_celerybeat.service fails to start and will fail until several attempts have been tried - http://pulp.plan.io/issues/2173
14:41:25 <smyers> Still waiting on logs for this
14:41:29 <smyers> #idea Proposed for #2173: Skip this issue for this triage session.
14:41:29 <smyers> !propose skip
14:41:29 <smyers> #info smyers has joined triage
14:41:29 <pulpbot> smyers has joined triage
14:41:30 <pulpbot> Proposed for #2173: Skip this issue for this triage session.
14:41:36 <mhrivnak> +1 skip
14:41:40 <jortel> +1
14:41:50 <jcline> +1
14:41:57 <smyers> haha, I refereshed my tab and they were posted 2 minutes ago
14:42:00 <ttereshc> they are there
14:42:03 <smyers> But still, not gonna read those now
14:42:50 <asmacdo> yeah, its a tarball, lets crack that open before tuesday
14:43:03 <asmacdo> !accept
14:43:03 <asmacdo> #agreed Skip this issue for this triage session.
14:43:03 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:43:03 <jcline> Yeah
14:43:04 <asmacdo> #topic download_repo task fails to mark some units as downloaded - http://pulp.plan.io/issues/2177
14:43:05 <pulpbot> 2 issues left to triage: 2177, 2190
14:43:05 <pulpbot> Pulp Issue #2177 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:43:06 <pulpbot> download_repo task fails to mark some units as downloaded - http://pulp.plan.io/issues/2177
14:43:47 <jcline> I'm fine with normal/medium
14:43:58 <mhrivnak> Me too.
14:44:20 <mhrivnak> This is a somewhat unusual use case. For now, it's mostly katello devs who care about it.
14:44:32 <ttereshc> !propose accept
14:44:32 <ttereshc> #idea Proposed for #2177: Leave the issue as-is, accepting its current state.
14:44:33 <pulpbot> Proposed for #2177: Leave the issue as-is, accepting its current state.
14:44:43 <jortel> fine
14:44:52 <asmacdo> !accept
14:44:52 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:44:52 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:44:53 <pulpbot> 1 issues left to triage: 2190
14:44:54 <asmacdo> #topic Unit is associated with the repo before it is copied to the final location - http://pulp.plan.io/issues/2190
14:44:54 <pulpbot> RPM Support Issue #2190 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:54 <pulpbot> Unit is associated with the repo before it is copied to the final location - http://pulp.plan.io/issues/2190
14:45:43 <jcline> Seems pretty bad
14:45:56 <jcline> High/High?
14:46:32 <jcline> Is this a result of the investigation into missing/corrupt files even with validate=True?
14:47:11 <mhrivnak> Agreed. It seems quite reasonable that the files should be in their final location before adding the unit to the DB.
14:47:13 <ipanova> what version is this reported against?
14:47:18 <ttereshc> kinda) I tried to do post copy validation and hitted this bug
14:47:30 <asmacdo> Wait a second, ttereshc can this occur in the wild?
14:47:36 <asmacdo> "raise Exception('bla-bla')" catches my eye
14:47:36 <mhrivnak> I suspect this is in 2.8+
14:48:06 <jortel> me to.  probably early 2.8
14:48:07 <ttereshc> asmacdo, if shutil.copy will fail for some reason
14:48:14 <jcline> asmacdo, it's just a demo that an Exception gets through
14:48:51 <jcline> Also presumably if the worker was killed
14:49:17 <asmacdo> Ok, I just wanted to make sure it wasn't purely hypothetical.
14:49:28 <mhrivnak> #idea Proposed for #2190: Priority: High, Severity: High
14:49:28 <mhrivnak> !propose triage high high
14:49:28 <pulpbot> Proposed for #2190: Priority: High, Severity: High
14:49:38 <ipanova> oh, looking into the code i thinnk in rpm sync it was like this all the time, it is not a regression
14:50:16 <jcline> ttereshc++ good find
14:50:30 <asmacdo> !accept
14:50:30 <asmacdo> #agreed Priority: High, Severity: High
14:50:30 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:50:31 <pulpbot> No issues to triage.
14:50:34 <ttereshc> ipanova, but it is still quite bad
14:50:37 <ipanova> it is
14:50:50 <ipanova> bit fortunately it is an easy fix
14:50:59 <ipanova> s/bit/but
14:51:16 <ttereshc> mmm, we'll see ;)
14:51:44 <jcline> So few things are really easy fixes :(
14:53:05 <ttereshc> asmacdo, !end?
14:53:10 <asmacdo> !end
14:53:10 <asmacdo> #endmeeting