14:30:01 <pcreech> #startmeeting Pulp Triage 2016-08-26
14:30:01 <pcreech> #info pcreech has joined triage
14:30:01 <pcreech> !start
14:30:01 <pulpbot> Meeting started Fri Aug 26 14:30:01 2016 UTC and is due to finish in 60 minutes.  The chair is pcreech. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:01 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:01 <pulpbot> The meeting name has been set to 'pulp_triage_2016_08_26'
14:30:01 <pulpbot> pcreech has joined triage
14:30:24 <mhrivnak> !here
14:30:24 <mhrivnak> #info mhrivnak has joined triage
14:30:25 <pulpbot> mhrivnak has joined triage
14:30:29 <dkliban> !here
14:30:29 <dkliban> #info dkliban has joined triage
14:30:30 <pulpbot> dkliban has joined triage
14:30:36 <bizhang> !here
14:30:36 <bizhang> #info bizhang has joined triage
14:30:37 <pulpbot> bizhang has joined triage
14:30:38 <fdobrovo> !here
14:30:38 <fdobrovo> #info fdobrovo has joined triage
14:30:39 <pulpbot> fdobrovo has joined triage
14:31:24 <pcreech> !next
14:31:25 <pulpbot> 9 issues left to triage: 2191, 2201, 2203, 2204, 2206, 2207, 2208, 2209, 2210
14:31:26 <pcreech> #topic The RPM rsync distributor's "predistributor_id" config option isn't validated - http://pulp.plan.io/issues/2191
14:31:26 <pulpbot> RPM Support Issue #2191 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:26 <pulpbot> The RPM rsync distributor's "predistributor_id" config option isn't validated - http://pulp.plan.io/issues/2191
14:31:33 <jortel> #info jortel has joined triage
14:31:33 <jortel> !here
14:31:33 <pulpbot> jortel has joined triage
14:31:44 <dkliban> i agreee that this is a bug
14:31:50 <preethi> !here
14:31:50 <preethi> #info preethi has joined triage
14:31:51 <pulpbot> preethi has joined triage
14:31:55 <dkliban> normal / medium is good with me
14:32:07 <pcreech> !propose accept
14:32:07 <pcreech> #idea Proposed for #2191: Leave the issue as-is, accepting its current state.
14:32:07 <pulpbot> Proposed for #2191: Leave the issue as-is, accepting its current state.
14:32:08 <mhrivnak> maybe even low severity?
14:32:26 <ipanova> #info ipanova has joined triage
14:32:26 <ipanova> !here
14:32:26 <pulpbot> ipanova has joined triage
14:32:31 <dkliban> mhrivnak: yeah ... there is validation later
14:32:39 <mhrivnak> I think we may want to just let this get fixed in 3.0 by virtue of postgres.
14:32:50 <ipanova> yeah good idea
14:32:51 <mhrivnak> #idea Proposed for #2191: Priority: Normal, Severity: Low
14:32:51 <mhrivnak> !propose triage normal low
14:32:51 <pulpbot> Proposed for #2191: Priority: Normal, Severity: Low
14:32:56 <ipanova> +1
14:32:59 <jortel> +1
14:33:13 <pcreech> !accept
14:33:13 <pcreech> #agreed Priority: Normal, Severity: Low
14:33:13 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:33:14 <pulpbot> 8 issues left to triage: 2201, 2203, 2204, 2206, 2207, 2208, 2209, 2210
14:33:15 <pcreech> #topic The dev-setup.sh script fails to find and run bootstrap-ansible.sh - http://pulp.plan.io/issues/2201
14:33:15 <pulpbot> Pulp Issue #2201 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:15 <pulpbot> The dev-setup.sh script fails to find and run bootstrap-ansible.sh - http://pulp.plan.io/issues/2201
14:34:24 <mhrivnak> #idea Proposed for #2201: Priority: High, Severity: High
14:34:24 <mhrivnak> !propose triage high high
14:34:25 <pulpbot> Proposed for #2201: Priority: High, Severity: High
14:34:43 <mhrivnak> Even if this only impacts developers, we need our dev environments to work and be easy to setup.
14:34:56 <dkliban> yeah
14:35:36 <fdobrovo> +1
14:35:43 <jortel> no objection
14:35:59 <pcreech> !accept
14:35:59 <pcreech> #agreed Priority: High, Severity: High
14:35:59 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:36:00 <pulpbot> 7 issues left to triage: 2203, 2204, 2206, 2207, 2208, 2209, 2210
14:36:00 <pcreech> #topic Cannot install nightly build on Fedora 24 - http://pulp.plan.io/issues/2203
14:36:01 <pulpbot> OSTree Support Issue #2203 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:36:01 <pulpbot> Cannot install nightly build on Fedora 24 - http://pulp.plan.io/issues/2203
14:36:35 <dkliban> that's not good
14:36:39 <mhrivnak> oh interesting.
14:36:55 <mhrivnak> Is this related to changing from "python-" to "python2-" ?
14:37:21 <mhrivnak> Maybe the python2- packages need to explicitly obsolete the python- counterparts.
14:37:41 <ipanova> dkliban: remember you updated spec files?
14:37:48 <ipanova> dkliban: for platform and rpm plugin
14:37:56 <ipanova> dkliban:  did you do same for all plugins?
14:38:07 <ipanova> dkliban: (when were trying to fix jenkins builds)\
14:38:07 <dkliban> ipanova: there is a chance i forgot to push some of them
14:38:14 <ipanova> dkliban: exactly
14:38:21 <ipanova> i think this could cause that issue
14:38:25 <mhrivnak> !propose triage high high
14:38:25 <mhrivnak> #idea Proposed for #2203: Priority: High, Severity: High
14:38:25 <pulpbot> Proposed for #2203: Priority: High, Severity: High
14:39:37 <dkliban> ipanova: but that was for 2.11
14:39:44 <dkliban> ipanova: anyway, i will look into tihs
14:39:45 <pcreech> any +1's?
14:39:49 <dkliban> +1
14:39:58 <fdobrovo> +1
14:40:02 <ipanova> dkliban: cool
14:40:04 <ipanova> +1
14:40:14 <pcreech> #agreed Priority: High, Severity: High
14:40:14 <pcreech> !accept
14:40:14 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:40:16 <pcreech> #topic missing release notes for Pulp 2.8.6 and 2.8.7 - http://pulp.plan.io/issues/2204
14:40:16 <pulpbot> 6 issues left to triage: 2204, 2206, 2207, 2208, 2209, 2210
14:40:16 <pulpbot> Pulp Issue #2204 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:40:17 <pulpbot> missing release notes for Pulp 2.8.6 and 2.8.7 - http://pulp.plan.io/issues/2204
14:43:07 <mhrivnak> should be real easy. I think just adding the auto-generated links to fixed bugs would be a big help to them.
14:44:52 * mhrivnak wonders if his connection failed, or if everyone is just quiet
14:44:58 <dkliban> we are quiet
14:45:03 <dkliban> normal medium is good with me
14:45:06 <jortel> just quite
14:45:08 <jortel> +1
14:45:16 <pcreech> Looks like we don't have release notes for any 2.8 > .5 on any of the branches
14:45:23 <dkliban> yeah
14:46:40 <dkliban> are we ready for the next issue
14:46:42 <dkliban> ?
14:46:52 <pcreech> no proposals for this one yet... accept as is?
14:46:56 <pcreech> !propose accept
14:46:56 <pcreech> #idea Proposed for #2204: Leave the issue as-is, accepting its current state.
14:46:57 <pulpbot> Proposed for #2204: Leave the issue as-is, accepting its current state.
14:47:28 <ipanova> yep, let's triage it
14:47:30 <mhrivnak> +1
14:47:46 <pcreech> !accept
14:47:46 <pcreech> #agreed Leave the issue as-is, accepting its current state.
14:47:47 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:47:48 <pcreech> #topic SELinux denials when puppet distributor writing to Puppet 4 AIO directories - http://pulp.plan.io/issues/2206
14:47:48 <jortel> +1
14:47:48 <pulpbot> 5 issues left to triage: 2206, 2207, 2208, 2209, 2210
14:47:48 <pulpbot> Pulp Issue #2206 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:47:49 <pulpbot> SELinux denials when puppet distributor writing to Puppet 4 AIO directories - http://pulp.plan.io/issues/2206
14:48:30 <mhrivnak> looks like bmbouter suggests this is not a pulp bug.
14:49:14 <dkliban> i agree
14:49:14 <mhrivnak> Perhaps we should wait for stbenjam to confirm and give his thoughts.
14:49:15 <pcreech> !propose other "CLOSED - NOT A BUG"
14:49:15 <pcreech> #idea Proposed for #2206: CLOSED - NOT A BUG
14:49:16 <pulpbot> Proposed for #2206: CLOSED - NOT A BUG
14:49:29 <pcreech> per bmbouter's suggestion in ticket
14:49:45 <mhrivnak> I'm happy either way. close now, or let stephen close it.
14:50:09 <pcreech> anyone else have thoughs?
14:50:25 <dkliban> but someone needs to file a bug with fedora selinux team so that another policy applies the right label
14:50:37 <dkliban> it seems like this is just an oversight
14:51:09 <dkliban> and we do want to have a proper security label on the /etc/puppetlabs/code/environments directory
14:51:42 <mhrivnak> Should we leave it as-is until the conversation agrees on next steps?
14:51:54 <dkliban> i think so
14:52:01 <mhrivnak> #idea Proposed for #2206: Skip this issue for this triage session.
14:52:01 <mhrivnak> !propose skip
14:52:01 <pulpbot> Proposed for #2206: Skip this issue for this triage session.
14:52:06 <pcreech> !accpet
14:52:06 <pulpbot> Error: "accpet" is not a valid command.
14:52:10 <pcreech> #agreed Skip this issue for this triage session.
14:52:10 <pcreech> !accept
14:52:10 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:52:12 <pcreech> #topic 2 broken unit tests on EL6 - http://pulp.plan.io/issues/2207
14:52:12 <pulpbot> 4 issues left to triage: 2207, 2208, 2209, 2210
14:52:12 <pulpbot> Pulp Issue #2207 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:52:13 <pulpbot> 2 broken unit tests on EL6 - http://pulp.plan.io/issues/2207
14:52:36 <dkliban> yeah ... there are a couple of unit tests for the storage path migration that are failing on EL6
14:52:50 <dkliban> so PR builder is always failing on EL6
14:53:00 <mhrivnak> !propose triage high high
14:53:00 <mhrivnak> #idea Proposed for #2207: Priority: High, Severity: High
14:53:01 <pulpbot> Proposed for #2207: Priority: High, Severity: High
14:53:04 <mhrivnak> should be an easy fix.
14:53:28 <jortel> +1
14:53:45 <fdobrovo> +1
14:54:08 <pcreech> !accept
14:54:08 <pcreech> #agreed Priority: High, Severity: High
14:54:08 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:54:09 <pulpbot> 3 issues left to triage: 2208, 2209, 2210
14:54:10 <pcreech> #topic pulpproject.org link to github is not clickable - http://pulp.plan.io/issues/2208
14:54:10 <pulpbot> Pulp Issue #2208 [NEW] (unassigned) - Priority: Normal | Severity: Low
14:54:10 <pulpbot> pulpproject.org link to github is not clickable - http://pulp.plan.io/issues/2208
14:57:26 * mhrivnak buys a round of espresso shots for the team
14:57:41 <pcreech> \o/
14:57:49 <pcreech> #idea Proposed for #2208: Leave the issue as-is, accepting its current state.
14:57:49 <pcreech> !propose accept
14:57:49 <pulpbot> Proposed for #2208: Leave the issue as-is, accepting its current state.
14:57:54 <dkliban> +1
14:57:55 <mhrivnak> +1
14:58:03 <fdobrovo> +1
14:58:10 <pcreech> !accept
14:58:10 <pcreech> #agreed Leave the issue as-is, accepting its current state.
14:58:11 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:58:12 <pcreech> #topic The RPM rsync distributor documentation doesn't explain how to pass config options to Pulp - http://pulp.plan.io/issues/2209
14:58:12 <pulpbot> 2 issues left to triage: 2209, 2210
14:58:12 <pulpbot> RPM Support Issue #2209 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Target Release: master
14:58:13 <pulpbot> The RPM rsync distributor documentation doesn't explain how to pass config options to Pulp - http://pulp.plan.io/issues/2209
14:58:39 <mhrivnak> I just added a comment to this one.
15:00:07 <mhrivnak> I wouldn't mind waiting to get feedback from ich<tab>  ich<TAB>  QE Jeremy.
15:00:17 <dkliban> lol
15:00:22 <dkliban> yeah ... let's skip todya
15:00:40 <mhrivnak> #idea Proposed for #2209: Skip this issue for this triage session.
15:00:40 <mhrivnak> !propose skip
15:00:40 <pulpbot> Proposed for #2209: Skip this issue for this triage session.
15:01:21 <dkliban> +1
15:01:26 <pcreech> !accept
15:01:26 <pcreech> #agreed Skip this issue for this triage session.
15:01:26 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
15:01:27 <pulpbot> 1 issues left to triage: 2210
15:01:28 <pcreech> #topic The RPM rsync distributor accepts the remote_units_path in a non-obvious place - http://pulp.plan.io/issues/2210
15:01:28 <pulpbot> RPM Support Issue #2210 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:01:28 <pulpbot> The RPM rsync distributor accepts the remote_units_path in a non-obvious place - http://pulp.plan.io/issues/2210
15:01:45 <dkliban> we can accept as is
15:01:50 <dkliban> i plan on fixing this
15:01:57 <pcreech> !propose accept
15:01:57 <pcreech> #idea Proposed for #2210: Leave the issue as-is, accepting its current state.
15:01:58 <pulpbot> Proposed for #2210: Leave the issue as-is, accepting its current state.
15:02:16 <mhrivnak> +1
15:02:21 <dkliban> +1
15:02:35 <pcreech> !accept
15:02:35 <pcreech> #agreed Leave the issue as-is, accepting its current state.
15:02:36 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:02:37 <pulpbot> No issues to triage.
15:02:56 <pcreech> \o/  Thanks everyone!
15:03:08 <pcreech> #endmeeting
15:03:08 <pcreech> !end