14:30:11 <asmacdo> #startmeeting Pulp Triage 2016-08-30
14:30:11 <asmacdo> #info asmacdo has joined triage
14:30:12 <pulpbot> Meeting started Tue Aug 30 14:30:11 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:12 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:12 <pulpbot> The meeting name has been set to 'pulp_triage_2016_08_30'
14:30:12 <pulpbot> asmacdo has joined triage
14:30:16 <pcreech> !here
14:30:16 <pcreech> #info pcreech has joined triage
14:30:17 <pulpbot> pcreech has joined triage
14:30:45 <dkliban> !here
14:30:45 <dkliban> #info dkliban has joined triage
14:30:46 <pulpbot> dkliban has joined triage
14:30:51 <bizhang> !here
14:30:51 <bizhang> #info bizhang has joined triage
14:30:51 <bmbouter> !here
14:30:51 <bmbouter> #info bmbouter has joined triage
14:30:51 <pulpbot> bizhang has joined triage
14:30:52 <pulpbot> bmbouter has joined triage
14:31:01 <preethi> !here
14:31:01 <preethi> #info preethi has joined triage
14:31:02 <pulpbot> preethi has joined triage
14:31:52 <asmacdo> !next
14:31:54 <pulpbot> 7 issues left to triage: 2206, 2209, 2214, 2216, 2219, 2220, 2221
14:31:54 <asmacdo> #topic SELinux denials when puppet distributor writing to Puppet 4 AIO directories - http://pulp.plan.io/issues/2206
14:31:55 <ttereshc> !here
14:31:55 <pulpbot> Pulp Issue #2206 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:55 <ttereshc> #info ttereshc has joined triage
14:31:55 <pulpbot> SELinux denials when puppet distributor writing to Puppet 4 AIO directories - http://pulp.plan.io/issues/2206
14:31:56 <pulpbot> ttereshc has joined triage
14:32:27 <pcreech> We skipped this one from last triage
14:32:52 <asmacdo> !propose other close-notabug
14:32:52 <asmacdo> #idea Proposed for #2206: close-notabug
14:32:53 <pulpbot> Proposed for #2206: close-notabug
14:33:01 <asmacdo> bmbouter, is that still waht you think?
14:33:14 <bmbouter> yes I do
14:33:33 <pcreech> ^ and that's why we skipped it friday, for that opinion
14:33:38 <pcreech> so, +1
14:33:46 <dkliban> bmbouter: so the BZ in that issue is for RHEL only
14:33:59 <dkliban> bmbouter: i think there needs to be a BZ for fedora as well
14:34:22 <bmbouter> I'm not sure which distros are affected but it's not a pulp bug
14:34:57 <dkliban> asmacdo: ok... let's close it as not bug
14:35:05 <asmacdo> !accept
14:35:05 <asmacdo> #agreed close-notabug
14:35:05 <pulpbot> Current proposal accepted: close-notabug
14:35:06 <pulpbot> 6 issues left to triage: 2209, 2214, 2216, 2219, 2220, 2221
14:35:07 <asmacdo> #topic The RPM rsync distributor documentation doesn't explain how to pass config options to Pulp - http://pulp.plan.io/issues/2209
14:35:07 <pulpbot> RPM Support Issue #2209 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Target Release: master
14:35:07 <pulpbot> The RPM rsync distributor documentation doesn't explain how to pass config options to Pulp - http://pulp.plan.io/issues/2209
14:36:31 <dkliban> i think we tiaged this one last time
14:36:40 <asmacdo> I personally think this sounds like a problem with the structure of our docs. This is a problem with most of the distributors
14:36:42 <pcreech> iirc, we skipped it for a reason
14:36:50 * smyers checks the logs
14:37:33 <asmacdo> <mhrivnak> I wouldn't mind waiting to get feedback from ich<tab>  ich<TAB>  QE Jeremy.
14:37:52 <smyers> yep
14:38:04 <smyers> so he commented, and I agree with ichimonji10 on that one
14:38:11 <pcreech> ditto
14:38:13 <ichimonji10> hi
14:38:29 <preethi> i agree with ichimonji10 as well
14:38:49 <asmacdo> I also agree, though I am not sure where these docs would live right now.
14:39:06 <smyers> But for triage, I'm not sure. Probably it's normal or high prio to at least address this, severity is probably low...maybe? Iunno.
14:39:37 <ichimonji10> A simple solution to that bug would be to just expand the sample dict of options listed in https://github.com/pulp/pulp_rpm/blob/master/docs/tech-reference/rsync-distributor.rst
14:39:39 <pulpbot> Title: pulp_rpm/rsync-distributor.rst at master · pulp/pulp_rpm · GitHub (at github.com)
14:40:08 * smyers just goes for it
14:40:12 <smyers> !propose triage high low
14:40:12 <smyers> #idea Proposed for #2209: Priority: High, Severity: Low
14:40:12 <smyers> #info smyers has joined triage
14:40:13 <pulpbot> smyers has joined triage
14:40:14 <pulpbot> Proposed for #2209: Priority: High, Severity: Low
14:40:17 <smyers> !suggest add docs tag
14:40:17 <smyers> #idea add docs tag
14:40:18 <asmacdo> +1
14:40:21 <dkliban> +1
14:40:23 <jcline> !here
14:40:23 <jcline> #info jcline has joined triage
14:40:23 <pulpbot> jcline has joined triage
14:40:52 <pcreech> +1
14:41:03 <asmacdo> !accept
14:41:03 <asmacdo> #agreed Priority: High, Severity: Low
14:41:03 <pulpbot> Current proposal accepted: Priority: High, Severity: Low
14:41:06 <pulpbot> 5 issues left to triage: 2214, 2216, 2219, 2220, 2221
14:41:07 <asmacdo> #topic relative_repo_path is not found in code of docker plugins. - http://pulp.plan.io/issues/2214
14:41:08 <pulpbot> Docker Support Issue #2214 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Target Release: 2.10.1
14:41:08 <pulpbot> relative_repo_path is not found in code of docker plugins. - http://pulp.plan.io/issues/2214
14:42:51 <asmacdo> !propose triage normal low
14:42:51 <asmacdo> #idea Proposed for #2214: Priority: Normal, Severity: Low
14:42:52 <pulpbot> Proposed for #2214: Priority: Normal, Severity: Low
14:42:57 <dkliban> jluza: can you elaborate?
14:42:59 <asmacdo> !suggest add docs tag
14:42:59 <asmacdo> #idea add docs tag
14:43:15 <asmacdo> https://github.com/pulp/pulp_docker/blob/master/docs/tech-reference/distributor.rst
14:43:16 <pulpbot> Title: pulp_docker/distributor.rst at master · pulp/pulp_docker · GitHub (at github.com)
14:43:20 <jcline> Did maybe a commit get lost?
14:43:48 <jluza> dkliban, some is not clear?
14:43:58 <jluza> dkliban, *something
14:44:19 <asmacdo> https://github.com/pulp/pulp_docker/blob/c71d9f9cf6de1ac83937f95f899732cb29ee413b/plugins/pulp_docker/plugins/distributors/configuration.py#L232
14:44:20 <pulpbot> Title: pulp_docker/configuration.py at c71d9f9cf6de1ac83937f95f899732cb29ee413b · pulp/pulp_docker · GitHub (at github.com)
14:44:34 <dkliban> jluza: issue 2214 ... are you saying that the relative_repo_path does not work for docker rsync distributor?
14:45:30 <asmacdo> ah
14:45:31 <jluza> dkliban, I can't say that because I didn't test it, but I'm almost sure it doesn't. Because you don't have code for it
14:46:01 <dkliban> jluza: i think you were looking in the wrong repo
14:46:05 <asmacdo> jluza, is this not the code? https://github.com/pulp/pulp_docker/blob/2.1-dev/plugins/pulp_docker/plugins/distributors/configuration.py#L248
14:46:06 <pulpbot> Title: pulp_docker/configuration.py at 2.1-dev · pulp/pulp_docker · GitHub (at github.com)
14:46:50 <jluza> dkliban, ah, I see so it's relative_repo_path vs repo_relative_path
14:46:56 <pcreech> !propose skip
14:46:56 <pcreech> #idea Proposed for #2214: Skip this issue for this triage session.
14:46:57 <pulpbot> Proposed for #2214: Skip this issue for this triage session.
14:47:06 <asmacdo> !propose other close-notabug
14:47:06 <asmacdo> #idea Proposed for #2214: close-notabug
14:47:07 <pulpbot> Proposed for #2214: close-notabug
14:47:14 <smyers> +1
14:47:15 <ttereshc> +1 for notabug
14:47:16 <pcreech> or that
14:47:18 <pcreech> +1
14:47:21 <jcline> +1
14:47:27 <bmbouter> +1
14:47:29 <asmacdo> !accept
14:47:29 <asmacdo> #agreed close-notabug
14:47:30 <pulpbot> Current proposal accepted: close-notabug
14:47:31 <pulpbot> 4 issues left to triage: 2216, 2219, 2220, 2221
14:47:31 <asmacdo> #topic Devel - pulp 3.0 ansible provisioning script does not install mod_ssl therefore fails - http://pulp.plan.io/issues/2216
14:47:32 <pulpbot> Pulp Issue #2216 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:47:32 <pulpbot> Devel - pulp 3.0 ansible provisioning script does not install mod_ssl therefore fails - http://pulp.plan.io/issues/2216
14:47:38 <jcline> I've already got a PR for this
14:47:44 <jluza> it is a bug, but only in documentation
14:48:16 <jcline> I'll just assign it to myself and put it in post, so I say we can skip this
14:48:21 <bmbouter> +1
14:48:23 <pcreech> +1
14:48:29 <pcreech> !propose skip
14:48:29 <pcreech> #idea Proposed for #2216: Skip this issue for this triage session.
14:48:30 <pulpbot> Proposed for #2216: Skip this issue for this triage session.
14:48:32 <ttereshc> +1
14:48:33 <asmacdo> I think jluza is right
14:48:40 <asmacdo> !accept
14:48:40 <asmacdo> #agreed Skip this issue for this triage session.
14:48:40 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:48:41 <pulpbot> 3 issues left to triage: 2219, 2220, 2221
14:48:41 <asmacdo> #topic Erratum pkglists are not validated during upload - http://pulp.plan.io/issues/2219
14:48:42 <pulpbot> RPM Support Issue #2219 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:48:42 <pulpbot> Erratum pkglists are not validated during upload - http://pulp.plan.io/issues/2219
14:48:52 <asmacdo> !issue 2214
14:48:53 <asmacdo> #topic relative_repo_path is not found in code of docker plugins. - http://pulp.plan.io/issues/2214
14:48:53 <pulpbot> Docker Support Issue #2214 [CLOSED - NOTABUG] (unassigned) - Priority: Normal | Severity: Medium | Target Release: 2.10.1
14:48:54 <pulpbot> relative_repo_path is not found in code of docker plugins. - http://pulp.plan.io/issues/2214
14:49:06 <asmacdo> !propose triage medium low
14:49:06 <asmacdo> #idea Proposed for #2214: Priority: Normal, Severity: Low
14:49:07 <pulpbot> Proposed for #2214: Priority: Normal, Severity: Low
14:49:14 <bmbouter> add docs tag?
14:49:23 <jluza> bmbouter, +1
14:49:26 <asmacdo> !suggest add documentation bug relative_repo_path vs repo_relative_path
14:49:26 <asmacdo> #idea add documentation bug relative_repo_path vs repo_relative_path
14:49:41 <bmbouter> +1 to reopen if it's a docs bug
14:50:11 <dkliban> +1
14:50:15 <jortel> jcline: you want to discuss content model vs catalog?
14:50:18 <jcline> works for me
14:50:28 <asmacdo> !accept
14:50:28 <asmacdo> #agreed Priority: Normal, Severity: Low
14:50:28 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:50:30 <pulpbot> 3 issues left to triage: 2219, 2220, 2221
14:50:30 <asmacdo> #topic Erratum pkglists are not validated during upload - http://pulp.plan.io/issues/2219
14:50:31 <pulpbot> RPM Support Issue #2219 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:50:31 <pulpbot> Erratum pkglists are not validated during upload - http://pulp.plan.io/issues/2219
14:50:52 <jcline> jortel, not unless you want to. I pretty much talked myself into having a catalog model by the end of that comment, but I wanted to see what everyone else thought
14:51:20 <asmacdo> !propose skip
14:51:20 <asmacdo> #idea Proposed for #2219: Skip this issue for this triage session.
14:51:21 <pulpbot> Proposed for #2219: Skip this issue for this triage session.
14:51:36 <smyers> why the skip?
14:51:38 <ttereshc> asmacdo, why?
14:51:40 <asmacdo> whoops, transposed the number (unpropose)
14:51:44 <dkliban> asmacdo: why? i think just accept as is
14:51:45 <smyers> heh
14:51:51 <asmacdo> I read that as 2216, thinking we had gone back to jclines bug
14:52:00 <smyers> hahaha, that's great
14:52:10 <pcreech> !propose accept
14:52:10 <pcreech> #idea Proposed for #2219: Leave the issue as-is, accepting its current state.
14:52:11 <pulpbot> Proposed for #2219: Leave the issue as-is, accepting its current state.
14:52:15 <ttereshc> maybe low prio?
14:52:23 <dkliban> yeah
14:52:30 <ttereshc> there was no validation for upload for a long time
14:52:33 <smyers> !propose triage normal low
14:52:33 <smyers> #idea Proposed for #2219: Priority: Normal, Severity: Low
14:52:34 <pulpbot> Proposed for #2219: Priority: Normal, Severity: Low
14:52:38 <jalbertson> dkliban, how quickly did jsherrill need the fix?
14:52:38 <dkliban> low priority is good. i wanted  this issue filed so we were aware of the problem
14:52:40 <smyers> I'm thinking drop the severity too, since the workaround is to fix the config
14:52:47 <smyers> "workaround" :)
14:52:51 <jortel> jcline: nope. I'm good the.
14:52:56 <jalbertson> dkliban, nevermind - wrong one
14:52:56 <pcreech> !propose triage low normal
14:52:56 <pcreech> #idea Proposed for #2219: Priority: Low, Severity: Medium
14:52:57 <jortel> jcline: nope. I'm good then.
14:52:57 <pulpbot> Proposed for #2219: Priority: Low, Severity: Medium
14:53:00 <dkliban> jalbertson: in the next couple of weeks ... so sometime during this sprint
14:53:04 <smyers> +1
14:53:11 <ttereshc> +1
14:53:16 <jcline> +1
14:53:18 <smyers> but yeah, definitly good to have that tracked because lol
14:53:33 <asmacdo> !accept
14:53:33 <asmacdo> #agreed Priority: Low, Severity: Medium
14:53:33 <pulpbot> Current proposal accepted: Priority: Low, Severity: Medium
14:53:35 <pulpbot> 2 issues left to triage: 2220, 2221
14:53:36 <asmacdo> #topic Copying units between repositories hits DocumentTooLarge: BSON document too large, if source repo contains > 345,000 units of same type - http://pulp.plan.io/issues/2220
14:53:36 <pulpbot> Pulp Issue #2220 [NEW] (unassigned) - Priority: Normal | Severity: High
14:53:36 <pulpbot> Copying units between repositories hits DocumentTooLarge: BSON document too large, if source repo contains > 345,000 units of same type - http://pulp.plan.io/issues/2220
14:54:51 <smyers> This frakker
14:55:18 <smyers> #idea Proposed for #2220: Priority: High, Severity: High
14:55:18 <smyers> !propose triage high high
14:55:18 <pulpbot> Proposed for #2220: Priority: High, Severity: High
14:55:23 <jcline> +1
14:55:24 <pcreech> +4
14:55:27 <pcreech> er...
14:55:28 <pcreech> +1
14:55:35 <ttereshc> I do not think it is an issue for newer Pulp
14:55:43 <ttereshc> at least for most of the repos
14:55:57 <jcline> Hopefully, but I think we should verify
14:56:02 <bmbouter> I think this could reproduce on any 2.7+ that is also < 3.0
14:56:11 <smyers> ^agree
14:56:43 <ttereshc> I agree that we should verify
14:57:07 <bmbouter> high high would be good
14:57:16 <smyers> !suggest verify this bug still exists in more recent pulps
14:57:16 <smyers> #idea verify this bug still exists in more recent pulps
14:57:20 <asmacdo> jcline, ttereshc do you think we should skip until verified or would high high be cool
14:57:20 <ttereshc> but this search path is not used in most cases
14:57:31 <preethi> smyers: why dont you put in on-qa
14:57:37 <preethi> for 2.10
14:57:51 <ttereshc> I agree with high/high even just for verification
14:58:10 <smyers> preethi, because I'm terrible at remembering to do that, despite explicitly documenting to do that so I don't forget :(
14:58:30 <preethi> :)
14:58:39 <jcline> I agree with ttereshc
14:58:43 <ttereshc> !propose high high
14:58:43 <pulpbot> Error: "propose" is not a valid command.
14:58:48 <ttereshc> !propose triage high high
14:58:48 <ttereshc> #idea Proposed for #2220: Priority: High, Severity: High
14:58:48 <pulpbot> Proposed for #2220: Priority: High, Severity: High
14:58:59 <dkliban> +1
14:59:16 <asmacdo> sounds like a consensus to me
14:59:18 <asmacdo> !accept
14:59:18 <asmacdo> #agreed Priority: High, Severity: High
14:59:18 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:59:20 <pulpbot> 1 issues left to triage: 2221
14:59:20 <asmacdo> #topic rsync distributor doesn't remove files from remote when rsyncing empty repository with --delete - http://pulp.plan.io/issues/2221
14:59:21 <pulpbot> RPM Support Issue #2221 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Target Release: 2.10.1
14:59:21 <smyers> preethi, 2.10 issues have been fixed, sorry about that
14:59:21 <pulpbot> rsync distributor doesn't remove files from remote when rsyncing empty repository with --delete - http://pulp.plan.io/issues/2221
14:59:36 <dkliban> this one should also be high/high
14:59:56 <jcline> Works for me
15:00:02 <ttereshc> +1
15:00:07 <pcreech> +1
15:00:15 <ttereshc> !propose triage high high
15:00:15 <ttereshc> #idea Proposed for #2221: Priority: High, Severity: High
15:00:16 <pulpbot> Proposed for #2221: Priority: High, Severity: High
15:00:40 <asmacdo> !accept
15:00:40 <asmacdo> #agreed Priority: High, Severity: High
15:00:40 <pulpbot> Current proposal accepted: Priority: High, Severity: High
15:00:41 <pulpbot> No issues to triage.
15:00:50 <smyers> asmacdo++
15:00:50 <pulpbot> asmacdo's karma is now 11
15:00:57 <bmbouter> thanks asmacdo
15:01:16 <asmacdo> thanks smyers for building this thing
15:03:14 <ttereshc> smyers, asmacdo how about !end auto-reminder after "no issues to triage"? ;)
15:03:47 <asmacdo> !end
15:03:47 <asmacdo> #endmeeting