14:29:53 <asmacdo> #startmeeting Pulp Triage 2016-09-02
14:29:53 <asmacdo> #info asmacdo has joined triage
14:29:54 <pulpbot> Meeting started Fri Sep  2 14:29:53 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:54 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:54 <pulpbot> The meeting name has been set to 'pulp_triage_2016_09_02'
14:29:54 <pulpbot> asmacdo has joined triage
14:29:57 <bmbouter> !here
14:29:57 <bmbouter> #info bmbouter has joined triage
14:29:58 <pulpbot> bmbouter has joined triage
14:30:14 <smyers> !here
14:30:14 <smyers> #info smyers has joined triage
14:30:15 <pulpbot> smyers has joined triage
14:30:34 <bizhang> !here
14:30:34 <bizhang> #info bizhang has joined triage
14:30:35 <pulpbot> bizhang has joined triage
14:30:47 <jcline> !here
14:30:47 <jcline> #info jcline has joined triage
14:30:47 <pulpbot> jcline has joined triage
14:30:50 <asmacdo> !next
14:30:52 <asmacdo> #topic Relative_url validation does not allow to create a repo with mirrorlists - http://pulp.plan.io/issues/2224
14:30:52 <pulpbot> 2 issues left to triage: 2224, 2225
14:30:52 <pulpbot> RPM Support Issue #2224 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:30:53 <pulpbot> Relative_url validation does not allow to create a repo with mirrorlists - http://pulp.plan.io/issues/2224
14:31:50 <smyers> This is a regresssion introduced in a 2.11 change, so it's not currently affecting anyone. It should be fixed before 2.11 is released.
14:31:58 <bmbouter> agreed
14:32:11 <bmbouter> but the original title suggests that it is a new feature (separate from the regressions issue)
14:32:36 <smyers> which part is the new feature?
14:33:50 <bmbouter> I thought it suggested that mirrorlists would be configured by parsing the feed
14:33:55 <bmbouter> but in reading it now I don't think it suggests that
14:34:08 <smyers> I think the breaking behavior is in the linked line (link at bottom of comment #4). We used to skip, now we fail.
14:34:40 <smyers> Yeah, mirrorlists do work that way. We look at the feed URL, and if there's a text file full of URLs, there, it's a mirrorlist
14:35:04 <smyers> From that point, a random one is chosen (at least I think we go randomly there, not sure), and used as the "actual" feed URL.
14:35:10 <bmbouter> that makes sense
14:35:19 <bmbouter> so this is an issue stating there is a regressions
14:35:38 <smyers> But that's been in pulp for...longer than I've been working on pulp. not sure what version that is, maybe 2.6 or 2.7
14:36:04 <smyers> So yeah, I'm interpreting that as a regression :)
14:36:08 <asmacdo> #idea Proposed for #2224: Priority: Urgent, Severity: High
14:36:08 <asmacdo> !propose triage urgent high
14:36:08 <pulpbot> Proposed for #2224: Priority: Urgent, Severity: High
14:36:35 <smyers> severity is none, given that this is unreleased pulp, but I guess it *would be* high if we let this out the door in 2.11
14:36:37 <asmacdo> the sev could probably be lower,
14:36:38 <jcline> I also view it as a regression
14:37:36 <smyers> I'm fine to leave the severity at the value that it would be if we were to release the code in its current state. This would break funcitonality with no workaround that I can see, so severity of High is correct
14:37:37 <bmbouter> +1 to this
14:37:58 <jcline> Maybe do high/high and mark it as a sprint candidate?
14:38:00 <ipanova> it is a regression
14:38:11 <smyers> also: excellent diagnosis by ipanova
14:38:19 <smyers> +1 to current proposal
14:38:24 <ipanova> +1
14:38:49 <asmacdo> jcline, i would be opposed to that since we are using the urgent prio as blocking the release
14:38:59 <jcline> Okay, that's fine as well
14:39:06 <asmacdo> !accept
14:39:06 <asmacdo> #agreed Priority: Urgent, Severity: High
14:39:06 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
14:39:07 <pulpbot> 1 issues left to triage: 2225
14:39:07 <asmacdo> #topic errors when sync plans fire off many concurrent syncs - http://pulp.plan.io/issues/2225
14:39:08 <pulpbot> Pulp Issue #2225 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:08 <pulpbot> errors when sync plans fire off many concurrent syncs - http://pulp.plan.io/issues/2225
14:39:14 <smyers> !propose needinfo
14:39:14 <smyers> #idea Proposed for #2225: This issue cannot be triaged without more info.
14:39:15 <pulpbot> Proposed for #2225: This issue cannot be triaged without more info.
14:39:30 <smyers> bmbouter has already asked for info on the issue to get more specifics
14:39:46 <jcline> +1 needinfo
14:40:00 <smyers> and beav is awesome, so I expect we'll be able to get a better sense of this for next triage
14:40:06 <ipanova> yeah, let's wait for more info
14:40:13 <asmacdo> !suggest beav is awesome
14:40:13 <asmacdo> #idea beav is awesome
14:40:15 <jcline> I wonder if these are all to the same host and it's getting upset that we're opening 3000 TCP connections at once
14:40:44 <jcline> Or well. However many workers there are.
14:41:08 <jcline> So maybe 40-50, but that's still more than most hosts like
14:42:04 <bmbouter> agreed
14:42:04 <asmacdo> jcline, since we are going to skip this one would you mind leaving that as a comment?
14:42:23 <jcline> That's just wild speculation I felt like sharing, I'll let beav fill us in
14:42:29 <asmacdo> !accept
14:42:29 <asmacdo> #agreed This issue cannot be triaged without more info.
14:42:30 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
14:42:31 <pulpbot> No issues to triage.
14:42:37 <asmacdo> !end
14:42:37 <asmacdo> #endmeeting