14:31:29 <asmacdo> #startmeeting Pulp Triage 2016-09-06
14:31:29 <asmacdo> #info asmacdo has joined triage
14:31:30 <pulpbot> Meeting started Tue Sep  6 14:31:29 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:30 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:30 <pulpbot> The meeting name has been set to 'pulp_triage_2016_09_06'
14:31:30 <pulpbot> asmacdo has joined triage
14:31:43 <bmbouter> !here
14:31:43 <bmbouter> #info bmbouter has joined triage
14:31:44 <pulpbot> bmbouter has joined triage
14:31:48 <pcreech> !here
14:31:48 <pcreech> #info pcreech has joined triage
14:31:48 <pulpbot> pcreech has joined triage
14:32:06 <dkliban> !here
14:32:06 <dkliban> #info dkliban has joined triage
14:32:07 <pulpbot> dkliban has joined triage
14:32:08 <ttereshc> !here
14:32:08 <ttereshc> #info ttereshc has joined triage
14:32:09 <bizhang> !here
14:32:09 <bizhang> #info bizhang has joined triage
14:32:09 <pulpbot> ttereshc has joined triage
14:32:10 <pulpbot> bizhang has joined triage
14:32:36 <asmacdo> !next
14:32:37 <pulpbot> 4 issues left to triage: 2225, 2229, 2230, 2231
14:32:38 <asmacdo> #topic errors when sync plans fire off many concurrent syncs - http://pulp.plan.io/issues/2225
14:32:38 <pulpbot> Pulp Issue #2225 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:32:39 <pulpbot> errors when sync plans fire off many concurrent syncs - http://pulp.plan.io/issues/2225
14:32:51 <bmbouter> we should defer this issue, it likely will be closed
14:32:56 <dkliban> beav said eh might close this
14:33:04 <asmacdo> !propose skip
14:33:04 <asmacdo> #idea Proposed for #2225: Skip this issue for this triage session.
14:33:04 <pulpbot> Proposed for #2225: Skip this issue for this triage session.
14:33:08 <dkliban> +1
14:33:11 <ttereshc> +1
14:33:12 <bmbouter> +1
14:33:22 <asmacdo> !accept
14:33:22 <asmacdo> #agreed Skip this issue for this triage session.
14:33:22 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:33:23 <pulpbot> 3 issues left to triage: 2229, 2230, 2231
14:33:23 <asmacdo> #topic Unhelpful error message when attempting to sync api/v1 from api/v2 endpoint - http://pulp.plan.io/issues/2229
14:33:24 <pulpbot> Docker Support Issue #2229 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Target Release: 2.10.1
14:33:25 <pulpbot> Unhelpful error message when attempting to sync api/v1 from api/v2 endpoint - http://pulp.plan.io/issues/2229
14:34:03 <asmacdo> I think that this has to do with dockerhub being weird
14:34:25 <asmacdo> IIRC a v2 only registry responds like it is a v1 registry until it fails
14:35:03 <dkliban> asmacdo: no ... i think it's a validation problem with the feed url.
14:35:06 <jortel> !here
14:35:06 <jortel> #info jortel has joined triage
14:35:06 <pulpbot> jortel has joined triage
14:35:27 <asmacdo> dkliban, what do you mean?
14:35:35 <dkliban> asmacdo: if we see v2 in the feed URL we should probably make sure that enable v2 is set to true
14:35:59 <bmbouter> also if asmacdo is right we could catch the exception and give a more informative error message
14:36:04 <bmbouter> so in both cases we could triage this bug
14:36:11 <dkliban> normal medium
14:36:14 <bmbouter> +1
14:36:14 <asmacdo> dkliban, v2 isnt in the url
14:36:26 <pcreech> i'm not seeing anything that states v2 for docker
14:36:27 <asmacdo> v2 is added by pulp when enable-v2= 2
14:36:28 <bmbouter> agreed I don't think you'll be able to tell the difference
14:36:32 <asmacdo> true not 2
14:36:40 <dkliban> haha
14:36:51 <dkliban> ok ... let's triage it and move on
14:36:56 <bmbouter> +1
14:37:08 <asmacdo> !propose accept
14:37:08 <asmacdo> #idea Proposed for #2229: Leave the issue as-is, accepting its current state.
14:37:08 <pulpbot> Proposed for #2229: Leave the issue as-is, accepting its current state.
14:37:16 <dkliban> +1
14:37:21 <asmacdo> !accept
14:37:21 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:37:21 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:37:22 <pulpbot> 2 issues left to triage: 2230, 2231
14:37:22 <asmacdo> #topic sync operation accepts invalid upstream_name - http://pulp.plan.io/issues/2230
14:37:23 <pulpbot> Docker Support Issue #2230 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Target Release: 2.10.1
14:37:24 <pulpbot> sync operation accepts invalid upstream_name - http://pulp.plan.io/issues/2230
14:38:25 <jcline> !propose accept
14:38:25 <jcline> #idea Proposed for #2230: Leave the issue as-is, accepting its current state.
14:38:25 <jcline> #info jcline has joined triage
14:38:26 <pulpbot> jcline has joined triage
14:38:27 <pulpbot> Proposed for #2230: Leave the issue as-is, accepting its current state.
14:38:29 <asmacdo> i think that the upstream name is properly validated when it is created, but we dont run all the validations when they are overridden in the sync command
14:38:43 <asmacdo> so i think low severity
14:39:01 <asmacdo> but accept is fine with me
14:39:33 <asmacdo> !accept
14:39:33 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:39:33 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:39:34 <pulpbot> 1 issues left to triage: 2231
14:39:34 <asmacdo> #topic Vagrant up is missing PyYaml package - http://pulp.plan.io/issues/2231
14:39:35 <pulpbot> Pulp Issue #2231 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:36 <pulpbot> Vagrant up is missing PyYaml package - http://pulp.plan.io/issues/2231
14:39:53 <bmbouter> this is something I found w/ the pulp 3 stuff
14:39:59 <bmbouter> with our recent introduciton of yaml
14:40:06 <jcline> I can and will fix this in a few seconds today, so it doesn't matter what you triage it as
14:40:12 <bmbouter> thanks jcline
14:40:24 <asmacdo> !propose accept
14:40:24 <asmacdo> #idea Proposed for #2231: Leave the issue as-is, accepting its current state.
14:40:24 <pulpbot> Proposed for #2231: Leave the issue as-is, accepting its current state.
14:40:28 <jortel> +1
14:40:37 <asmacdo> !accept
14:40:37 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:40:37 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:40:38 <pulpbot> No issues to triage.
14:40:49 <pcreech> \o/
14:40:57 <asmacdo> !end
14:40:57 <asmacdo> #endmeeting