14:30:03 <asmacdo> #startmeeting Pulp Triage 2016-09-09
14:30:03 <asmacdo> #info asmacdo has joined triage
14:30:03 <pulpbot> Meeting started Fri Sep  9 14:30:03 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:03 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:03 <pulpbot> The meeting name has been set to 'pulp_triage_2016_09_09'
14:30:03 <pulpbot> asmacdo has joined triage
14:30:27 <jcline> !here
14:30:27 <jcline> #info jcline has joined triage
14:30:27 <pulpbot> jcline has joined triage
14:30:36 <dkliban> !here
14:30:36 <dkliban> #info dkliban has joined triage
14:30:36 <pulpbot> dkliban has joined triage
14:30:37 <mhrivnak> !here
14:30:37 <mhrivnak> #info mhrivnak has joined triage
14:30:38 <pulpbot> mhrivnak has joined triage
14:30:39 <bizhang> !here
14:30:39 <bizhang> #info bizhang has joined triage
14:30:40 <pulpbot> bizhang has joined triage
14:30:45 <pcreech> #info pcreech has joined triage
14:30:45 <pcreech> !here
14:30:45 <pulpbot> pcreech has joined triage
14:31:11 <asmacdo> !next
14:31:13 <pulpbot> 6 issues left to triage: 2234, 2235, 2236, 2240, 2241, 2242
14:31:13 <asmacdo> #topic Upgrading to pulp 2.9 causes sync of repos with SRPM's with a filelist field to fail. - http://pulp.plan.io/issues/2234
14:31:14 <pulpbot> RPM Support Issue #2234 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:31:14 <pulpbot> Upgrading to pulp 2.9 causes sync of repos with SRPM's with a filelist field to fail. - http://pulp.plan.io/issues/2234
14:31:35 <ipanova> !here
14:31:35 <ipanova> #info ipanova has joined triage
14:31:36 <pulpbot> ipanova has joined triage
14:32:01 <dkliban> we already had a migration to fix this for RPMs but forgot SRPMS
14:32:08 <asmacdo> !propose triage urgent high
14:32:08 <asmacdo> #idea Proposed for #2234: Priority: Urgent, Severity: High
14:32:08 <pulpbot> Proposed for #2234: Priority: Urgent, Severity: High
14:32:14 <pcreech> +1
14:32:16 <ipanova> and DRPMS forgot also
14:32:24 <ttereshc> !here
14:32:24 <ttereshc> #info ttereshc has joined triage
14:32:24 <pulpbot> ttereshc has joined triage
14:32:36 <jcline> +1
14:32:39 <ipanova> +1
14:32:47 <mhrivnak> +1
14:32:48 <asmacdo> !accept
14:32:48 <asmacdo> #agreed Priority: Urgent, Severity: High
14:32:48 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
14:32:50 <pulpbot> 5 issues left to triage: 2235, 2236, 2240, 2241, 2242
14:32:51 <pulpbot> An error has occurred and has been logged. Please contact this bot's administrator for more information.
14:33:20 <asmacdo> smyers, ^
14:33:26 <asmacdo> !issue1952
14:33:26 <pulpbot> Error: "issue1952" is not a valid command.
14:33:29 <asmacdo> !issue 1952
14:33:30 <asmacdo> #topic Repo sync fails after upgrade to 2.8.3. - http://pulp.plan.io/issues/1952
14:33:30 <pulpbot> Pulp Issue #1952 [CLOSED - CURRENTRELEASE] (ipanova@redhat.com) - Priority: Urgent | Severity: High | Target Release: 2.8.4
14:33:30 <pulpbot> Repo sync fails after upgrade to 2.8.3. - http://pulp.plan.io/issues/1952
14:33:45 <asmacdo> !issue 2235
14:33:46 <pulpbot> An error has occurred and has been logged. Please contact this bot's administrator for more information.
14:33:52 <bmbouter> !here
14:33:52 <bmbouter> #info bmbouter has joined triage
14:33:52 <pulpbot> bmbouter has joined triage
14:33:55 <asmacdo> !issue 2236
14:33:56 <asmacdo> #topic Upgrading to pulp 2.9 causes sync of repos with DRPM' with a "relativepath" field to fail. - http://pulp.plan.io/issues/2236
14:33:56 <pulpbot> RPM Support Issue #2236 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:33:56 <pulpbot> Upgrading to pulp 2.9 causes sync of repos with DRPM' with a "relativepath" field to fail. - http://pulp.plan.io/issues/2236
14:34:25 <asmacdo> ok that was just pulpbot debuggin
14:34:28 <smyers> "KeyError: 'value'" when trying to get the value of a custom field
14:34:31 <asmacdo> https://pulp.plan.io/issues/2235
14:34:33 <pulpbot> Title: Issue #2235: Download progress won't stream to clients - Nectar - Pulp (at pulp.plan.io)
14:35:09 <pcreech> Looks like someone cloned nectar master to use in their pulp install...
14:35:10 <asmacdo> I wasn't able to understand this one. jcline?
14:35:14 <mhrivnak> are we triaging 2236? or waiting to figure out this pulpbot issue?
14:35:25 <jcline> High/High? I'm surprised by this because stream is set to true on the session, but maybe something is overriding it during the request?
14:35:32 <asmacdo> we are triaging 2235
14:35:44 <mhrivnak> ok.
14:36:30 <smyers> asmacdo, looks like you worked around it iterating to 2235, I'll find and fix the custom field lookup problem after. :)
14:36:45 <asmacdo> cool :)
14:37:07 <asmacdo> accepting jcline's proposal
14:37:09 <jcline> !propose triage High High
14:37:09 <jcline> #idea Proposed for #2236: Priority: High, Severity: High
14:37:10 <pulpbot> Proposed for #2236: Priority: High, Severity: High
14:37:10 <mhrivnak> high/high seems appropriate so we can at least investigate soon.
14:37:17 <dkliban> yep
14:37:19 <dkliban> +1
14:37:24 <pcreech> don't accept...
14:37:24 <mhrivnak> note that pulpbot thinks we're on a different issue.
14:37:40 <asmacdo> now we are on 2236
14:37:42 <pcreech> although, 2236 should probably match sev/prio with the srpm issue
14:37:50 <bmbouter> +1 to that
14:37:53 <mhrivnak> +1
14:37:58 <pcreech> !propose ugent high
14:37:58 <pulpbot> Error: "propose" is not a valid command.
14:38:02 <ipanova> pcreech: yeah
14:38:12 <jcline> !propose triage Urgent High
14:38:12 <jcline> #idea Proposed for #2236: Priority: Urgent, Severity: High
14:38:12 <pulpbot> Proposed for #2236: Priority: Urgent, Severity: High
14:38:17 <ipanova> +1
14:38:21 <pcreech> +1
14:38:21 <ttereshc> +1
14:38:25 <asmacdo> !accept
14:38:25 <asmacdo> #agreed Priority: Urgent, Severity: High
14:38:25 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
14:38:26 <pulpbot> 3 issues left to triage: 2240, 2241, 2242
14:38:26 <asmacdo> #topic Can't export rpm repo - http://pulp.plan.io/issues/2240
14:38:27 <pulpbot> Pulp Issue #2240 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:38:27 <pulpbot> Can't export rpm repo - http://pulp.plan.io/issues/2240
14:38:29 * pcreech fails at commands
14:39:28 <mhrivnak> !propose triage high high
14:39:28 <mhrivnak> #idea Proposed for #2240: Priority: High, Severity: High
14:39:28 <pulpbot> Proposed for #2240: Priority: High, Severity: High
14:39:36 <bmbouter> +1
14:39:37 <ipanova> +1
14:39:39 <mhrivnak> It's broken pretty hard.
14:39:40 <pcreech> +1
14:39:51 <jcline> +1
14:39:55 <asmacdo> !accept
14:39:55 <asmacdo> #agreed Priority: High, Severity: High
14:39:56 <pulpbot> Current proposal accepted: Priority: High, Severity: High
14:39:58 <pulpbot> 2 issues left to triage: 2241, 2242
14:39:59 <asmacdo> #topic When running repo download pulp streamer logs each rpm download  - http://pulp.plan.io/issues/2241
14:39:59 <pulpbot> Pulp Issue #2241 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:39:59 <pulpbot> When running repo download pulp streamer logs each rpm download  - http://pulp.plan.io/issues/2241
14:40:50 <asmacdo> we probably ought to come up with an official pulp style guide for what belongs in each log level
14:41:05 <pcreech> +1
14:41:12 <asmacdo> but I am ok with this behavior
14:41:38 <mhrivnak> I can see this both ways. Some other types of apps do log this much about traffic, like email MTAs.
14:41:47 <jcline> Ehhh, I think it's always such a judgment call the guide would be "do what you think is right and adjust accordingly"
14:41:56 <mhrivnak> I can also imagine users being annoyed at the change.
14:42:07 <bmbouter> it makes the logs hard to use I think
14:42:18 <bmbouter> we could move it to debug so that users could turn it on
14:42:21 <jcline> Only on el6, but you can still filter it
14:42:34 <pcreech> info is meant to be pretty verbose, iirc
14:42:37 <jcline> Apache logs every request and no one is bothered about that
14:43:10 <jcline> If they don't like it, crank up the log level to warning for the streamer
14:43:46 <bmbouter> is info the default or warning?
14:43:56 <dkliban> info is the default
14:44:03 <bmbouter> then we should not log all this at the defualt
14:44:05 <bmbouter> default
14:44:09 <jcline> info, but that's common. And it's common for info to be loudish
14:44:19 <pcreech> perhaps the real issue then is info being the default
14:44:32 <pcreech> iirc, many many things i've installed have suggested changing log levels for this reason
14:44:51 <pcreech> it's a syadmin's choice for log levels
14:46:07 <asmacdo> i suggest that we accept this issue, demote it to debug, and get some proposals for general logging practice. the discussion would probably be better in that venue than for this specific issue.
14:46:10 <jcline> !propose close close NOTABUG or WONTFIX
14:46:10 <pulpbot> Error: "propose" is not a valid command.
14:46:21 <pcreech> !propose other "CLOSED-NOTABUG"
14:46:21 <pcreech> #idea Proposed for #2241: CLOSED-NOTABUG
14:46:22 <pulpbot> Proposed for #2241: CLOSED-NOTABUG
14:46:33 <mhrivnak> I think in theory it's fine and appropriate to log all of this at info, but there will be some users who won't like it. If we go with this behavior, we'll just need to be prepared to explain and suggest changing the log level.
14:46:48 <pcreech> which is a common action to take
14:46:54 <mhrivnak> yep.
14:47:01 <bmbouter> that sound sok to me
14:48:04 <asmacdo> bmbouter, sorry, what did you agree with?
14:48:40 <asmacdo> is there a consensus to close?
14:49:09 <bmbouter> I'm ok with either path
14:49:38 <asmacdo> #agreed CLOSED-NOTABUG
14:49:38 <asmacdo> !accept
14:49:38 <pulpbot> Current proposal accepted: CLOSED-NOTABUG
14:49:39 <pulpbot> 1 issues left to triage: 2242
14:49:40 <asmacdo> #topic Package signature ID checking is broken when syncing in packages - http://pulp.plan.io/issues/2242
14:49:40 <pulpbot> RPM Support Issue #2242 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:49:40 <pulpbot> Package signature ID checking is broken when syncing in packages - http://pulp.plan.io/issues/2242
14:50:59 <mhrivnak> ipanova, any thoughts on this?
14:51:17 <ttereshc> this is because of my merge forward
14:51:27 <ipanova> the signature filter works and fails, but the unit gets associated anyway
14:51:33 <ttereshc> and it should be fixed in 2.10-dev
14:52:02 <mhrivnak> Gotcha. So would last night's nightly contain the fix? Or wait for tonight's?
14:52:16 <ipanova> !propose triage high high
14:52:16 <ipanova> #idea Proposed for #2242: Priority: High, Severity: High
14:52:17 <pulpbot> Proposed for #2242: Priority: High, Severity: High
14:52:21 <ttereshc> sorry, I meant we should fix it in 2.10-dev
14:52:25 <mhrivnak> ah, ok.
14:52:30 <ttereshc> +1 for high/high
14:52:37 <asmacdo> sounds like a regression? urgent?
14:52:38 <mhrivnak> Does this affect 2.10.0 ?
14:52:42 <ttereshc> no
14:52:47 <ttereshc> 2.10.1 only
14:52:51 <mhrivnak> oh good. :)
14:52:51 <ipanova> mhrivnak: nope
14:53:12 <ipanova> ttereshc: i think we should also check copy operation, that units gets associated correctly as well
14:53:33 <jcline> So that sounds like Urgent/High if it regressed in 2.10.1?
14:53:36 <mhrivnak> This should definitely block 2.10.1, so I agree urgent is fine.
14:53:46 <asmacdo> !propose triage urgent medium
14:53:46 <asmacdo> #idea Proposed for #2242: Priority: Urgent, Severity: Medium
14:53:46 <pulpbot> Proposed for #2242: Priority: Urgent, Severity: Medium
14:54:49 <asmacdo> !propose triage urgent high
14:54:49 <asmacdo> #idea Proposed for #2242: Priority: Urgent, Severity: High
14:54:50 <pulpbot> Proposed for #2242: Priority: Urgent, Severity: High
14:54:59 <mhrivnak> +1
14:55:01 <asmacdo> !accept
14:55:01 <asmacdo> #agreed Priority: Urgent, Severity: High
14:55:01 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
14:55:03 <pulpbot> No issues to triage.
14:56:51 <asmacdo> !end
14:56:51 <asmacdo> #endmeeting