14:30:13 <asmacdo> #startmeeting Pulp Triage 2016-09-13
14:30:13 <asmacdo> #info asmacdo has joined triage
14:30:13 <asmacdo> !start
14:30:13 <pulpbot> Meeting started Tue Sep 13 14:30:13 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:13 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:13 <pulpbot> The meeting name has been set to 'pulp_triage_2016_09_13'
14:30:13 <pulpbot> asmacdo has joined triage
14:30:20 <mhrivnak> !here
14:30:20 <mhrivnak> #info mhrivnak has joined triage
14:30:21 <pulpbot> mhrivnak has joined triage
14:30:23 <pcreech> !here
14:30:23 <pcreech> #info pcreech has joined triage
14:30:23 <pulpbot> pcreech has joined triage
14:30:23 <ipanova> !here
14:30:23 <ipanova> #info ipanova has joined triage
14:30:23 <pulpbot> ipanova has joined triage
14:30:45 <jcline> !here
14:30:45 <jcline> #info jcline has joined triage
14:30:46 <pulpbot> jcline has joined triage
14:30:50 <ttereshc> !here
14:30:50 <ttereshc> #info ttereshc has joined triage
14:30:51 <pulpbot> ttereshc has joined triage
14:31:14 <asmacdo> !next
14:31:15 <asmacdo> #topic last_published field should not be updated when the publish is skipped - http://pulp.plan.io/issues/2244
14:31:16 <pulpbot> 5 issues left to triage: 2244, 2248, 2249, 2250, 2251
14:31:17 <pulpbot> Pulp Issue #2244 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:31:17 <fdobrovo> !here
14:31:17 <fdobrovo> #info fdobrovo has joined triage
14:31:17 <pulpbot> last_published field should not be updated when the publish is skipped - http://pulp.plan.io/issues/2244
14:31:18 <pulpbot> fdobrovo has joined triage
14:31:59 <asmacdo> dkliban, is this a regression?
14:32:31 <ipanova> asmacdo: not really
14:33:05 <ipanova> i think this somehow infuencies rsync logic, dkliban is it a requirement for rcm?
14:33:08 <mhrivnak> Is it blocking the rsync distributor's completion?
14:33:35 <bmbouter> !here
14:33:35 <bmbouter> #info bmbouter has joined triage
14:33:35 <pulpbot> bmbouter has joined triage
14:34:19 <ipanova> can we skip it and return to it later?
14:34:22 <bmbouter> dkliban knows better, but I believe it is blocking them
14:34:31 <asmacdo> !propose skip
14:34:31 <asmacdo> #idea Proposed for #2244: Skip this issue for this triage session.
14:34:31 <pulpbot> Proposed for #2244: Skip this issue for this triage session.
14:34:38 <bmbouter> +1 to skip
14:34:41 <mhrivnak> works for me.
14:34:41 <ipanova> +1
14:34:42 <fdobrovo> +1
14:34:42 <asmacdo> !accept
14:34:42 <asmacdo> #agreed Skip this issue for this triage session.
14:34:42 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:34:44 <asmacdo> #topic metadata file copy results in error 'Content import of FILENAME failed - must be an existing file' - http://pulp.plan.io/issues/2248
14:34:44 <pulpbot> 4 issues left to triage: 2248, 2249, 2250, 2251
14:34:45 <pulpbot> RPM Support Issue #2248 [NEW] (unassigned) - Priority: Normal | Severity: High | Severity: High
14:34:46 <pulpbot> metadata file copy results in error 'Content import of FILENAME failed - must be an existing file' - http://pulp.plan.io/issues/2248
14:35:24 <dkliban> !here
14:35:24 <dkliban> #info dkliban has joined triage
14:35:25 <pulpbot> dkliban has joined triage
14:35:51 <asmacdo> I have seen this error before, but I think we need a reproducer to triage
14:36:03 <ipanova> asmacdo: i left a comment
14:36:09 <pcreech> reproducer is listed
14:36:11 <mhrivnak> looks like ipanova added reproducer steps.
14:36:19 <pcreech> O.o
14:36:24 <asmacdo> ipanova++
14:36:24 <pulpbot> ipanova's karma is now 21
14:36:35 <pcreech> !propose accept
14:36:35 <pcreech> #idea Proposed for #2248: Leave the issue as-is, accepting its current state.
14:36:36 <pulpbot> Proposed for #2248: Leave the issue as-is, accepting its current state.
14:36:55 <asmacdo> +1
14:37:05 <ipanova> i am not sure what to do about that, because i do not see any solution for that
14:37:27 <mhrivnak> Right.
14:37:47 <mhrivnak> Seems like we at least need to provide guidance on how to get out of that situation.
14:38:08 <ipanova> mhrivnak: yeah, re-sync if repo with feed
14:38:19 <ipanova> if repo without feed than user is screwed up
14:38:51 <mhrivnak> jsherrill, any guidance?
14:39:02 <pcreech> is it hard to add a storage path check in the orphan cleanup?
14:39:10 <jsherrill> reading
14:39:26 <mhrivnak> pcreech, I'm not sure what it would check.
14:39:41 <mhrivnak> pcreech, maybe it could check to see if any other units reference the same file path.
14:39:49 <pcreech> that was my thinking
14:39:49 <mhrivnak> But that could get expensive quickly.
14:40:17 <ipanova> pcreech: if the user got upgraded to 2.8. no check of storage path would help i gues
14:40:20 <ipanova> guess
14:40:21 <jsherrill> mhrivnak: ipanova so the reproducer steps seems to conflict slightly with what the user claimed.  they said that they were able to do step 9 successfully after step 7
14:40:23 <pcreech> theoretically expensive or real-world expensive?  (I'm not familiar enough, but this is also digressing into details of a solution not neccissarily appropriate for triate)
14:40:37 <jsherrill> mhrivnak: ipanova but then later on it failed with this error
14:40:39 <pcreech> triage*
14:40:42 <ipanova> pcreech: 2.8.6
14:41:17 <ipanova> jsherrill: there could be successful copies for units that before the upgrade where not copied, then copy removed and orphans cleaned
14:41:21 <mhrivnak> pcreech, I think it theoretically would be n^2 performance.
14:41:26 <ipanova> jsherrill: or successful copied for newly arrived content into pulp after upgrade
14:42:09 <mhrivnak> !propose other skip for now and discuss with jsherrill more specifically what can be done for users who encounter this
14:42:09 <mhrivnak> #idea Proposed for #2248: skip for now and discuss with jsherrill more specifically what can be done for users who encounter this
14:42:10 <pulpbot> Proposed for #2248: skip for now and discuss with jsherrill more specifically what can be done for users who encounter this
14:42:18 <ipanova> +1
14:42:30 <asmacdo> !accept
14:42:30 <asmacdo> #agreed skip for now and discuss with jsherrill more specifically what can be done for users who encounter this
14:42:31 <pulpbot> Current proposal accepted: skip for now and discuss with jsherrill more specifically what can be done for users who encounter this
14:42:32 <asmacdo> #topic Document platform Django app layout - http://pulp.plan.io/issues/2249
14:42:32 <pulpbot> 3 issues left to triage: 2249, 2250, 2251
14:42:32 <pulpbot> Pulp Issue #2249 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:42:33 <pulpbot> Document platform Django app layout - http://pulp.plan.io/issues/2249
14:42:43 <ipanova> jsherrill: not sure if what i said makes sense
14:42:54 <mhrivnak> sounds like a task, and not an issue?
14:43:06 <jsherrill> ipanova: not sure i quite understand it, but that is likely not your fault :)
14:43:26 <mhrivnak> bmbouter, do you agree this should be a task?
14:43:26 <asmacdo> mhrivnak, i agree
14:43:28 <ttereshc> +1 for the task
14:43:31 <mhrivnak> !propose other make it a task
14:43:31 <mhrivnak> #idea Proposed for #2249: make it a task
14:43:32 <pulpbot> Proposed for #2249: make it a task
14:43:43 <ipanova> jsherrill: we will discuss that later
14:43:50 <ipanova> +1
14:44:36 <asmacdo> !accept
14:44:36 <asmacdo> #agreed make it a task
14:44:37 <pulpbot> Current proposal accepted: make it a task
14:44:37 <asmacdo> #topic Add a new Jenkins job to run pulp-smash against Fedora-provided packages - http://pulp.plan.io/issues/2250
14:44:38 <pulpbot> 2 issues left to triage: 2250, 2251
14:44:39 <pulpbot> Packaging Issue #2250 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:44:40 <pulpbot> Add a new Jenkins job to run pulp-smash against Fedora-provided packages - http://pulp.plan.io/issues/2250
14:45:00 <mhrivnak> !propose other make it a task
14:45:00 <mhrivnak> #idea Proposed for #2250: make it a task
14:45:00 <ttereshc> also a task?
14:45:00 <pulpbot> Proposed for #2250: make it a task
14:45:15 <asmacdo> +1
14:45:32 <pcreech> +1
14:45:46 <fdobrovo> +1
14:45:54 <asmacdo> !accept
14:45:54 <asmacdo> #agreed make it a task
14:45:54 <pulpbot> Current proposal accepted: make it a task
14:45:55 <pulpbot> 1 issues left to triage: 2251
14:45:56 <asmacdo> #topic Error on sync: sequence item 0: expected string, NoneType found - http://pulp.plan.io/issues/2251
14:45:56 <pulpbot> Pulp Issue #2251 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:45:57 <pulpbot> Error on sync: sequence item 0: expected string, NoneType found - http://pulp.plan.io/issues/2251
14:46:42 * mhrivnak scrolls forever to the right
14:47:16 <mhrivnak> sounds like maybe the proxy isn't configured correctly.
14:47:24 <ipanova> traceback leads to proxy issue
14:47:31 <ttereshc> _add_proxy(session, config)\n  File \"/usr/lib/python2.7/site-packages/nectar/downloaders/threaded.py\", line 400, in _add_proxy\n    url = ':'.join((host, str(config.proxy_port)))\nTypeError: sequence item 0: expected string, NoneType found\n"
14:47:50 <jcline> That code path is dead on the master branch
14:48:23 <jcline> So it's fixed. It sounds like a work around would be to explicitly define a proxy port
14:48:37 <mhrivnak> Sounds good.
14:49:13 <mhrivnak> Should we put the issue at MODIFIED?
14:49:20 <jcline> I'll leave a comment on the work-around
14:49:27 <asmacdo> !suggest jcline closes and adds comment for work around
14:49:27 <asmacdo> #idea jcline closes and adds comment for work around
14:49:38 <jcline> I don't think it should be MODIFIED
14:49:52 <mhrivnak> closed as a duplicate?
14:50:05 <mhrivnak> or maybe worksforme ?
14:50:10 <jcline> No, the code is still broken, it's just not used by us anymore
14:50:17 <mhrivnak> ok, what do you suggest?
14:50:18 <jcline> CLOSED - WONTFIX
14:50:36 <asmacdo> the bug is filed against pulp, the problem is in nectar
14:50:39 <jcline> I left the function as the nectar API isn't really defined
14:50:44 <asmacdo> the pulp code no longer uses this nectar code
14:50:49 <asmacdo> so i think closed-current realease
14:50:52 <jcline> I'll fix that as well
14:50:56 <asmacdo> jcline, am I wrong?
14:51:44 <jcline> The bug in the code is still there. We just aren't going to fix it because we don't use that function or any function that does use it.
14:51:50 <mhrivnak> I see. Either of those seems reasonable.
14:51:55 <asmacdo> !propose other close-wontfix
14:51:55 <asmacdo> #idea Proposed for #2251: close-wontfix
14:51:56 <pulpbot> Proposed for #2251: close-wontfix
14:52:33 <asmacdo> !accept
14:52:33 <asmacdo> #agreed close-wontfix
14:52:33 <pulpbot> Current proposal accepted: close-wontfix
14:52:35 <pulpbot> No issues to triage.
14:52:52 <dkliban> !issue 2244
14:53:01 <asmacdo> !issue 2244
14:53:01 <asmacdo> #topic last_published field should not be updated when the publish is skipped - http://pulp.plan.io/issues/2244
14:53:02 <pulpbot> Pulp Issue #2244 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:53:03 <pulpbot> last_published field should not be updated when the publish is skipped - http://pulp.plan.io/issues/2244
14:54:06 <dkliban> i filed this issue because jluza was experiencing a problem related to this ... however, i was not able to actually reproduce a problem with this
14:54:27 <asmacdo> ah, suggestion?
14:54:45 <dkliban> asmacdo: we can close it as not a bug
14:54:46 <ipanova> dkliban: i think it would be good if jluza would provide some exact steps and context
14:55:02 <dkliban> ipanova: he emailed me yesterday saying that he could not reproduce the problem on 2.10
14:55:10 <mhrivnak> Sounds good.
14:55:19 <asmacdo> !propose other close-notabug
14:55:19 <asmacdo> #idea Proposed for #2244: close-notabug
14:55:20 <pulpbot> Proposed for #2244: close-notabug
14:55:45 <ipanova> dkliban:  if he was not able to reproduce it then let's close it
14:55:56 <asmacdo> !accept
14:55:56 <pulpbot> Current proposal accepted: close-notabug
14:55:56 <asmacdo> #agreed close-notabug
14:55:57 <pulpbot> No issues to triage.
14:56:05 <dkliban> ipanova: i agree
14:57:12 <asmacdo> thanks everyone!
14:57:23 <ipanova> ttereshc: back to you https://github.com/pulp/pulp_rpm/pull/985
14:57:24 <pulpbot> Title: Fix unit association if unit was downloaded for the second time by goosemania · Pull Request #985 · pulp/pulp_rpm · GitHub (at github.com)
14:57:28 <asmacdo> !end
14:57:28 <asmacdo> #endmeeting