15:40:27 <pcreech> #startmeeting Pulp Triage 2016-09-23
15:40:27 <pcreech> #info pcreech has joined triage
15:40:27 <pulpbot> Meeting started Fri Sep 23 15:40:27 2016 UTC and is due to finish in 60 minutes.  The chair is pcreech. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:40:27 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:40:27 <pulpbot> The meeting name has been set to 'pulp_triage_2016_09_23'
15:40:27 <pulpbot> pcreech has joined triage
15:40:40 <dkliban> !here
15:40:40 <dkliban> #info dkliban has joined triage
15:40:40 <pulpbot> dkliban has joined triage
15:40:43 <mhrivnak> !here
15:40:43 <mhrivnak> #info mhrivnak has joined triage
15:40:44 <pulpbot> mhrivnak has joined triage
15:41:09 <bmbouter> !here
15:41:09 <bmbouter> #info bmbouter has joined triage
15:41:10 <pulpbot> bmbouter has joined triage
15:41:23 <pcreech> !next
15:41:29 <pulpbot> 8 issues left to triage: 2252, 2272, 2274, 2276, 2277, 2278, 2279, 2280
15:41:34 <pcreech> #topic Repo sync with "epoch" related error message. - http://pulp.plan.io/issues/2252
15:41:35 <pulpbot> RPM Support Issue #2252 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
15:41:35 <pulpbot> Repo sync with "epoch" related error message. - http://pulp.plan.io/issues/2252
15:41:40 <mhrivnak> ipanova, jortel preethi smyers ttereshc ^ in case you didn't see triage starting
15:41:59 <ipanova> #info ipanova has joined triage
15:41:59 <ipanova> !here
15:41:59 <pulpbot> ipanova has joined triage
15:42:03 <ttereshc> !here
15:42:03 <ttereshc> #info ttereshc has joined triage
15:42:03 <pulpbot> ttereshc has joined triage
15:42:04 <pcreech> looks like this one seems to be user environemtn, and his last comment was that it's resolved
15:42:13 <pcreech> !propose other CLOSED
15:42:13 <pcreech> #idea Proposed for #2252: CLOSED
15:42:13 <pulpbot> Proposed for #2252: CLOSED
15:42:21 <bmbouter> agreed
15:42:23 <mhrivnak> +1
15:42:29 <bmbouter> WONTFIX?
15:42:33 <jortel> !here
15:42:33 <jortel> #info jortel has joined triage
15:42:34 <pulpbot> jortel has joined triage
15:42:39 <mhrivnak> or WORKSFORME ?
15:42:41 <bmbouter> it is a bug and we aren't fixing it
15:42:47 <ipanova> i'd vote for worksforme
15:42:50 <mhrivnak> Is it a bug?
15:43:03 <bmbouter> if you upgraded from old versions of pulp
15:43:11 <bmbouter> and synced with an old version, I'm not sure how old
15:43:33 <bmbouter> before mongoengine it was the wild west in the database
15:44:05 <mhrivnak> yes, but these unit types have always had an epoch.
15:44:09 <pcreech> Ok.  So, did he just go from "too old version" to "too new version"  without intermediates?
15:44:21 <bmbouter> yes but pulp failed to store it at some point in time
15:44:28 <ipanova> we cannot really be sure if it is a bug or the user just screwed up the db
15:44:30 <mhrivnak> do we know that for sure?
15:44:38 <bmbouter> we do know that he didn't mess up his db
15:44:48 <ipanova> let;s close it as works for me and if that happens again we can re-open it
15:44:49 <bmbouter> and has backups
15:44:54 <pcreech> Ok, so, we can discuss the finer points later.  accepting
15:45:02 <pcreech> !accept
15:45:02 <pcreech> #agreed CLOSED
15:45:02 <pulpbot> Current proposal accepted: CLOSED
15:45:02 <fdobrovo> !here
15:45:08 <pulpbot> 7 issues left to triage: 2272, 2274, 2276, 2277, 2278, 2279, 2280
15:45:13 <pcreech> #topic Downloading on_demand repositories silently fails - http://pulp.plan.io/issues/2272
15:45:13 <fdobrovo> #info fdobrovo has joined triage
15:45:13 <pulpbot> RPM Support Issue #2272 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Target Release: 2.10.1
15:45:13 <pulpbot> Downloading on_demand repositories silently fails - http://pulp.plan.io/issues/2272
15:45:14 <pulpbot> fdobrovo has joined triage
15:45:53 <pcreech> This one seems to be an issue with the on_demand failing
15:46:06 <bmbouter> we've been working on this a lot today
15:46:22 <bmbouter> jortel is working on it it's a recent regression
15:46:39 <mhrivnak> Is this also caused by the move vs copy selinux issue?
15:46:40 <bmbouter> urgent, high
15:46:43 <pcreech> regression?  === so blocker?
15:46:58 <pcreech> !propose triage ugent high
15:46:58 <pulpbot> Error: Unknown Priority
15:47:06 <bmbouter> oh we have two of them?
15:47:22 <pcreech> !propose triage urgent high
15:47:22 <pcreech> #idea Proposed for #2272: Priority: Urgent, Severity: High
15:47:23 <pulpbot> Proposed for #2272: Priority: Urgent, Severity: High
15:47:46 <mhrivnak> I'm not sure if it's been reported twice. But the smash failures we looked at yesterday were about accessing published yum repos.
15:48:04 <mhrivnak> +1
15:48:20 <mhrivnak> assign to jortel?
15:48:27 <bmbouter> no this looks different
15:48:35 <jortel> yeah, this looks different
15:48:43 <bmbouter> I thought this was the selinux one ichimonji filed
15:48:59 <jortel> no, that's 2277
15:49:07 <dkliban> this does look serious though
15:49:56 <mhrivnak> yep. urgent/high is appropriate I think.
15:50:04 <ipanova> +1
15:50:09 <dkliban> +1
15:50:14 <pcreech> !accept
15:50:14 <pcreech> #agreed Priority: Urgent, Severity: High
15:50:14 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
15:50:21 <pulpbot> 6 issues left to triage: 2274, 2276, 2277, 2278, 2279, 2280
15:50:26 <pcreech> #topic Uploading duplicate content results in ambiguous error message - http://pulp.plan.io/issues/2274
15:50:26 <pulpbot> Pulp Issue #2274 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
15:50:26 <pulpbot> Uploading duplicate content results in ambiguous error message - http://pulp.plan.io/issues/2274
15:51:08 <dkliban> i filed this
15:51:35 <dkliban> ttereshc points out in the comments that if you look at the API output, you can actually tell that it's a duplicate content
15:51:57 <pcreech> so, it just sounds like some pulp-admin error reporting robustness is needed?
15:52:18 <mhrivnak> Or the "summary" should go where the "description" is.
15:52:41 <ttereshc> I think it is not only the iso case, this way error reported for upload of rpm/drpm/srpm as well
15:52:58 <mhrivnak> either way, it's just a change to how the error is presented.
15:53:06 <dkliban> Normal medium is good with me
15:53:11 <mhrivnak> sounds good.
15:53:19 <pcreech> !propose accept
15:53:19 <pcreech> #idea Proposed for #2274: Leave the issue as-is, accepting its current state.
15:53:19 <pulpbot> Proposed for #2274: Leave the issue as-is, accepting its current state.
15:53:49 <ttereshc> +1
15:53:59 <pcreech> !accept
15:53:59 <pcreech> #agreed Leave the issue as-is, accepting its current state.
15:53:59 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:54:11 <pulpbot> 5 issues left to triage: 2276, 2277, 2278, 2279, 2280
15:54:16 <pcreech> #topic Can't kickstart against an on_demand file:// repo  - http://pulp.plan.io/issues/2276
15:54:16 <pulpbot> RPM Support Issue #2276 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
15:54:16 <pulpbot> Can't kickstart against an on_demand file:// repo  - http://pulp.plan.io/issues/2276
15:54:46 <mhrivnak> This is a somewhat unusual use case, but it would be good to make sure we handle it more gracefully.
15:56:13 <mhrivnak> !propose triage normal high
15:56:13 <mhrivnak> #idea Proposed for #2276: Priority: Normal, Severity: High
15:56:13 <pulpbot> Proposed for #2276: Priority: Normal, Severity: High
15:57:07 <ttereshc> +1
15:57:46 <pcreech> any other +1 ?
15:58:11 <ipanova> +1
15:58:18 <pcreech> !accept
15:58:18 <pcreech> #agreed Priority: Normal, Severity: High
15:58:18 <pulpbot> Current proposal accepted: Priority: Normal, Severity: High
15:58:24 <pulpbot> 4 issues left to triage: 2277, 2278, 2279, 2280
15:58:29 <pcreech> #topic Repository publishes silently fail - http://pulp.plan.io/issues/2277
15:58:30 <pulpbot> Pulp Issue #2277 [NEW] (unassigned) - Priority: High | Severity: High | Severity: High
15:58:30 <pulpbot> Repository publishes silently fail - http://pulp.plan.io/issues/2277
15:58:47 <bmbouter> I was confused by the name similarity
15:58:55 <bmbouter> this is the bug that jortel is working on
15:59:08 <pcreech> !propose triage urgent high
15:59:08 <pcreech> #idea Proposed for #2277: Priority: Urgent, Severity: High
15:59:09 <pulpbot> Proposed for #2277: Priority: Urgent, Severity: High
15:59:10 <jortel> yes
15:59:17 <mhrivnak> +1
15:59:55 <ipanova> +1
15:59:55 <pcreech> assuming silence = +1
15:59:55 <ttereshc> maybe it is also worth to rename it a little bit?
16:00:18 <fdobrovo> +1
16:00:24 <ttereshc> +1 for urgent
16:00:32 <pcreech> !suggest Renaming 2277 for clarity
16:00:32 <pcreech> #idea Renaming 2277 for clarity
16:00:39 <mhrivnak> Good point. Since we know more about it now, adding something about selinux to the title would be valuable.
16:01:11 <mhrivnak> jortel, want to handle renaming it?
16:01:19 <jortel> mhrivnak: sure
16:01:22 <mhrivnak> thanks!
16:01:25 <pcreech> !accept
16:01:25 <pcreech> #agreed Priority: Urgent, Severity: High
16:01:25 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
16:01:32 <pulpbot> 3 issues left to triage: 2278, 2279, 2280
16:01:37 <pcreech> #topic 2.7 -> 2.8 Validation - http://pulp.plan.io/issues/2278
16:01:38 <pulpbot> Pulp Issue #2278 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
16:01:38 <pulpbot> 2.7 -> 2.8 Validation - http://pulp.plan.io/issues/2278
16:01:57 <mhrivnak> It's nice that this person took the time to file a report!
16:02:20 * smyers finds it funny that a ticket dealing with 2.7 -> 2.8 is number 2278
16:02:29 <mhrivnak> However it looks like something went wrong in either the DB dump or restore. The error appears to be for duplicate repo_id entries in the repo collection.
16:02:45 <pcreech> !propose accept
16:02:45 <pcreech> #idea Proposed for #2278: Leave the issue as-is, accepting its current state.
16:02:45 <pulpbot> Proposed for #2278: Leave the issue as-is, accepting its current state.
16:02:51 <ttereshc> scientific linux :)
16:03:08 <mhrivnak> I don't think we have anything here we can take action on.
16:03:43 <bmbouter> what if we don't triage this
16:03:47 <bmbouter> and ask some questions
16:03:52 <pcreech> Looks like he's just looking for some help with what went wrong, at least.  how about skipping and someone follows up?
16:04:09 <smyers> But he is doing exactly what we said to do in the readme, and it'd be nice to help a brotha out. So if we need more info to take action...
16:04:12 <smyers> !propose needinfo
16:04:12 <smyers> #idea Proposed for #2278: This issue cannot be triaged without more info.
16:04:12 <smyers> #info smyers has joined triage
16:04:13 <pulpbot> smyers has joined triage
16:04:14 <pulpbot> Proposed for #2278: This issue cannot be triaged without more info.
16:04:16 <bmbouter> yeah needs info
16:04:20 <mhrivnak> Sounds good.
16:04:39 <dkliban> +1
16:04:42 <fdobrovo> +1
16:04:59 <mhrivnak> someone want to volunteer?
16:05:33 <bmbouter> I wanted to write but don't know what to say
16:05:44 <bmbouter> we can come back to this
16:05:58 <pcreech> do we need a who before accepting?
16:06:08 <bmbouter> needsinfo would be to not accept
16:06:21 <pcreech> was more on "accepting the needinfo proposal"
16:06:22 <bmbouter> or in terms of accepting deferment maybe
16:06:24 <smyers> he means to !accept the needinfo proposal :)
16:06:50 <pcreech> accepting, we can figure out who after triage
16:06:54 <mhrivnak> I accept your definition of accept ;)
16:07:06 <pcreech> !accept
16:07:06 <pcreech> #agreed This issue cannot be triaged without more info.
16:07:06 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
16:07:19 <pulpbot> 2 issues left to triage: 2279, 2280
16:07:23 <mhrivnak> Those of you not sitting near pcreech unfortunately can't appreciate the audible vigor with which he is hitting <enter> to accept issues. ;)
16:07:24 <pcreech> #topic Pulp yum_importer fails when syncing SuSE repositories - http://pulp.plan.io/issues/2279
16:07:25 <pulpbot> Pulp Issue #2279 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
16:07:25 <pulpbot> Pulp yum_importer fails when syncing SuSE repositories - http://pulp.plan.io/issues/2279
16:07:44 <pcreech> that's just more my commanding control over my keyboard
16:08:05 <mhrivnak> gotta keep it in line! ok back on task...
16:08:46 <mhrivnak> looks like we need to investigate this for sure.
16:09:04 <smyers> This one's a little weird. I'd think it wouldn't try to download srpms unless they're listed in the repodata, but why are the in the repodata if they aren't in the repo? Also you can't --skip srpm?
16:09:07 <pcreech> sounds like a 2.9-2.10 regression maybe?  In the sense of "SuSE worked, now it doesn't"
16:09:13 <mhrivnak> agreed
16:09:31 <smyers> I'm thinking...
16:09:35 <smyers> !propose needinfo
16:09:35 <smyers> #idea Proposed for #2279: This issue cannot be triaged without more info.
16:09:35 <mhrivnak> yep, it does seem like it could be a regression based on the description.
16:09:35 <pulpbot> Proposed for #2279: This issue cannot be triaged without more info.
16:09:44 <pcreech> +1
16:09:44 <smyers> And I can ask some questions
16:09:48 <ipanova> +1
16:09:49 <mhrivnak> +1
16:09:55 <ttereshc> +1
16:09:57 <mhrivnak> Thanks smyers .
16:09:57 <dkliban> +1 and thank smyers
16:09:58 <pcreech> !suggest smeyers follows up on 2279
16:09:58 <pcreech> #idea smeyers follows up on 2279
16:10:07 <pcreech> !accept
16:10:07 <pcreech> #agreed This issue cannot be triaged without more info.
16:10:07 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
16:10:11 * smyers does not know this smeyers person
16:10:13 <pulpbot> 1 issues left to triage: 2280
16:10:18 <pcreech> #topic Error is not reported correctly when size verification for DRPM unit fails - http://pulp.plan.io/issues/2280
16:10:18 <pulpbot> RPM Support Issue #2280 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
16:10:18 <pulpbot> Error is not reported correctly when size verification for DRPM unit fails - http://pulp.plan.io/issues/2280
16:10:39 <pcreech> oops... i do that a lot actually, and usually tend to catch it
16:10:59 <smyers> <tab><tab>
16:12:01 <mhrivnak> !propose accept
16:12:01 <mhrivnak> #idea Proposed for #2280: Leave the issue as-is, accepting its current state.
16:12:01 <pulpbot> Proposed for #2280: Leave the issue as-is, accepting its current state.
16:12:49 <ttereshc> +1
16:12:54 <fdobrovo> +1
16:12:57 <ipanova> +1
16:13:13 <ttereshc> Brno is in agreement here :)
16:13:18 <smyers> heh
16:13:20 <ipanova> \0/
16:13:28 <smyers> The Brnobles have spoken.
16:13:34 <pcreech> !accept
16:13:34 <pcreech> #agreed Leave the issue as-is, accepting its current state.
16:13:34 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
16:13:40 <pulpbot> No issues to triage.
16:13:53 <ipanova> pcreech++
16:13:53 <pulpbot> pcreech's karma is now 7
16:13:56 <pcreech> Thanks everyone!  Sorry if it felt rushed
16:14:03 <mhrivnak> jortel, I assigned 2277 to you.
16:14:03 <smyers> nope
16:14:06 <mhrivnak> pcreech++
16:14:06 <pulpbot> pcreech's karma is now 8
16:14:10 <smyers> don't forget to !end it, though
16:14:13 <mhrivnak> Thanks for driving.
16:14:14 <pcreech> !end
16:14:14 <pcreech> #endmeeting