14:29:49 <asmacdo> #startmeeting Pulp Triage 2016-10-04
14:29:49 <asmacdo> #info asmacdo has joined triage
14:29:50 <pulpbot> Meeting started Tue Oct  4 14:29:49 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:50 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:50 <pulpbot> The meeting name has been set to 'pulp_triage_2016_10_04'
14:29:50 <pulpbot> asmacdo has joined triage
14:30:11 <smyers> !here
14:30:11 <smyers> #info smyers has joined triage
14:30:12 <pulpbot> smyers has joined triage
14:30:14 <mhrivnak> !here
14:30:14 <mhrivnak> #info mhrivnak has joined triage
14:30:14 <pulpbot> mhrivnak has joined triage
14:30:25 <bizhang> !here
14:30:25 <bizhang> #info bizhang has joined triage
14:30:25 <pulpbot> bizhang has joined triage
14:30:49 <bmbouter> !here
14:30:49 <bmbouter> #info bmbouter has joined triage
14:30:50 <pulpbot> bmbouter has joined triage
14:30:57 <asmacdo> !next
14:30:59 <pulpbot> 6 issues left to triage: 2278, 2279, 2287, 2288, 2289, 2317
14:30:59 <asmacdo> #topic 2.7 -> 2.8 Validation - http://pulp.plan.io/issues/2278
14:31:00 <pulpbot> Pulp Issue #2278 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:31:00 <pulpbot> 2.7 -> 2.8 Validation - http://pulp.plan.io/issues/2278
14:31:28 <pcreech> !here
14:31:28 <pcreech> #info pcreech has joined triage
14:31:29 <pulpbot> pcreech has joined triage
14:31:32 <asmacdo> I haven't had a chance to look at the new logs he posted
14:31:36 <bmbouter> I have
14:31:42 <bmbouter> I recommend we punt and I'll add another comment
14:31:50 <mhrivnak> Sounds good.
14:31:52 <preethi> !here
14:31:52 <preethi> #info preethi has joined triage
14:31:53 <pulpbot> preethi has joined triage
14:31:53 <bmbouter> I was just posting on this actually
14:31:56 <asmacdo> !propose needinfo
14:31:56 <asmacdo> #idea Proposed for #2278: This issue cannot be triaged without more info.
14:31:57 <pulpbot> Proposed for #2278: This issue cannot be triaged without more info.
14:32:19 <jortel> !here
14:32:19 <jortel> #info jortel has joined triage
14:32:20 <pulpbot> jortel has joined triage
14:32:23 <asmacdo> !accept
14:32:23 <asmacdo> #agreed This issue cannot be triaged without more info.
14:32:23 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
14:32:25 <asmacdo> #topic Pulp yum_importer fails when syncing SuSE repositories - http://pulp.plan.io/issues/2279
14:32:25 <pulpbot> 5 issues left to triage: 2279, 2287, 2288, 2289, 2317
14:32:25 <pulpbot> Pulp Issue #2279 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:32:26 <pulpbot> Pulp yum_importer fails when syncing SuSE repositories - http://pulp.plan.io/issues/2279
14:33:11 <smyers> Those repos are authorized, so it's really tough to test :\
14:33:26 <mhrivnak> bummer.
14:33:29 <smyers> So I don't think we can triage without more info, and this reminds me to ask for more info.
14:33:41 <mhrivnak> Sounds good.
14:33:54 <asmacdo> !propose needinfo
14:33:54 <asmacdo> #idea Proposed for #2279: This issue cannot be triaged without more info.
14:33:54 <pulpbot> Proposed for #2279: This issue cannot be triaged without more info.
14:34:12 <jortel> +1
14:34:17 <asmacdo> !accept
14:34:17 <asmacdo> #agreed This issue cannot be triaged without more info.
14:34:17 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
14:34:18 <pulpbot> 4 issues left to triage: 2287, 2288, 2289, 2317
14:34:18 <asmacdo> #topic Cannot get v2 repo tags list - http://pulp.plan.io/issues/2287
14:34:18 <mhrivnak> we may have access to a subscription also.
14:34:18 <pulpbot> Docker Support Issue #2287 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:34:19 <pulpbot> Cannot get v2 repo tags list - http://pulp.plan.io/issues/2287
14:35:29 <smyers> mhrivnak, that's the info we need. I'm asking for that info now and will update the issue accordingly.
14:35:59 <mhrivnak> jortel, is this the selinux move vs copy issue you were working on?
14:36:39 <jortel> mhrivnak: looks like it
14:36:49 <jortel> er, likely
14:37:03 <mhrivnak> should we request a re-test with your fix?
14:37:26 <jortel> yes
14:37:31 <jortel> it merged yesterday
14:37:43 <jortel> so should be in last nightly
14:37:54 <mhrivnak> sweet. Can you comment on the bug and ping ichimonji10 about it?
14:38:24 <mhrivnak> !propose other jortel will request a re-test
14:38:24 <mhrivnak> #idea Proposed for #2287: jortel will request a re-test
14:38:25 <pulpbot> Proposed for #2287: jortel will request a re-test
14:38:28 <jortel> doing it now
14:38:33 <mhrivnak> thanks!
14:38:44 <asmacdo> !accept
14:38:44 <asmacdo> #agreed jortel will request a re-test
14:38:44 <pulpbot> Current proposal accepted: jortel will request a re-test
14:38:45 <pulpbot> 3 issues left to triage: 2288, 2289, 2317
14:38:46 <asmacdo> #topic unable to access pulp-admin or repositories - http://pulp.plan.io/issues/2288
14:38:46 <pulpbot> Pulp Issue #2288 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:38:47 <pulpbot> unable to access pulp-admin or repositories - http://pulp.plan.io/issues/2288
14:38:58 <bmbouter> I asked this user for more info
14:39:03 <asmacdo> !propose needinfo
14:39:03 <asmacdo> #idea Proposed for #2288: This issue cannot be triaged without more info.
14:39:03 <pulpbot> Proposed for #2288: This issue cannot be triaged without more info.
14:39:22 <ipanova> !here
14:39:22 <ipanova> #info ipanova has joined triage
14:39:23 <pulpbot> ipanova has joined triage
14:39:33 <asmacdo> !accept
14:39:33 <asmacdo> #agreed This issue cannot be triaged without more info.
14:39:33 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
14:39:34 <pulpbot> 2 issues left to triage: 2289, 2317
14:39:34 <asmacdo> #topic Getting Error on pulp installation and configuration - http://pulp.plan.io/issues/2289
14:39:35 <pulpbot> Pulp Issue #2289 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:39:35 <pulpbot> Getting Error on pulp installation and configuration - http://pulp.plan.io/issues/2289
14:39:38 <asmacdo> !propose needinfo
14:39:38 <asmacdo> #idea Proposed for #2289: This issue cannot be triaged without more info.
14:39:39 <pulpbot> Proposed for #2289: This issue cannot be triaged without more info.
14:39:46 <asmacdo> I also asked this user for more info
14:40:08 <mhrivnak> hang on
14:40:18 <mhrivnak> we did split out repo auth into a separate RPM at some point.
14:40:27 <mhrivnak> python-pulp-repoauth
14:40:41 <mhrivnak> maybe it's just not installed, and maybe we forgot a Requires: statement?
14:41:19 <bmbouter> perhaps
14:41:49 <mhrivnak> looks like that change happened in 2.7.
14:41:51 <asmacdo> I was able to replicate this exact traceback by deleting the conf file and replacing it with verify_ssl = False
14:42:54 <pcreech> asmacdo: did you have [server] in there?  or just an empty with verify_ssl = False ?
14:43:03 <smyers> I think +1 needinfo, since it looks so much like the conf file has been mangled somehow.
14:43:03 <asmacdo> just empty verify_ssl = False
14:43:11 <mhrivnak> asmacdo, the traceback is client-side and is just the client failing to render the error. There's a good chance the two errors are unrelated, except that pulp-admin has an equally hard time parsing them.
14:43:12 <ipanova> agree with smyers
14:43:15 <smyers> If that's the case, we can dig into how/why it got mangled
14:43:28 <pcreech> yeah, sounds like a boched conf file to me
14:43:50 <asmacdo> i think i see what you mean though mhrivnak
14:44:10 <mhrivnak> oh wait, I thought we were still on 2288.
14:44:18 <asmacdo> lol
14:44:27 <asmacdo> i was guessing that the rpm install wasn'
14:44:29 <mhrivnak> I see, we flew past it. :)
14:44:37 <asmacdo> wasnt creating the conf file
14:44:38 <mhrivnak> Everything I just said applied to 2288. :)
14:44:41 <pcreech> "ConfigParser.MissingSectionHeaderError: File contains no section headers."
14:45:38 <ipanova> so let's move on with conclusion of needinfo?
14:45:59 <elyezer> smyers: good morning, do you have any guess about what could be causing "java.lang.NullPointerException: Cannot invoke method toComputer() on null object"
14:46:15 <elyezer> maybe the slaves are being removed or jenkins is misbehaving
14:46:21 <asmacdo> !accept
14:46:21 <asmacdo> #agreed This issue cannot be triaged without more info.
14:46:22 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
14:46:23 <asmacdo> #topic Build of Docker Images failed due to relocated Dockerfiles  - http://pulp.plan.io/issues/2317
14:46:24 <pulpbot> 1 issues left to triage: 2317
14:46:24 <pulpbot> Pulp Issue #2317 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:46:25 <pulpbot> Build of Docker Images failed due to relocated Dockerfiles  - http://pulp.plan.io/issues/2317
14:46:41 <asmacdo> mhrivnak, want to go back to 2288?
14:47:15 <mhrivnak> asmacdo, I don't think we should change the conclusion, but someone should ask for info related to the installation of that package.
14:48:01 <mhrivnak> we can go back to it to get this officially on the record as being discussed for 2288, or just move on. I'm happy either way.
14:48:23 <asmacdo> !issue 2288
14:48:24 <asmacdo> #topic unable to access pulp-admin or repositories - http://pulp.plan.io/issues/2288
14:48:24 <pulpbot> Pulp Issue #2288 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:48:24 <pulpbot> unable to access pulp-admin or repositories - http://pulp.plan.io/issues/2288
14:49:01 <asmacdo> !propose other ask user for instal info for python-pulp-repoauth
14:49:01 <asmacdo> #idea Proposed for #2288: ask user for instal info for python-pulp-repoauth
14:49:01 <pulpbot> Proposed for #2288: ask user for instal info for python-pulp-repoauth
14:49:14 <asmacdo> #agreed ask user for instal info for python-pulp-repoauth
14:49:14 <asmacdo> !accept
14:49:14 <pulpbot> Current proposal accepted: ask user for instal info for python-pulp-repoauth
14:49:16 <asmacdo> #topic Build of Docker Images failed due to relocated Dockerfiles  - http://pulp.plan.io/issues/2317
14:49:16 <pulpbot> 1 issues left to triage: 2317
14:49:16 <pulpbot> Pulp Issue #2317 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:49:17 <pulpbot> Build of Docker Images failed due to relocated Dockerfiles  - http://pulp.plan.io/issues/2317
14:50:24 <elyezer> bmbouter: I see two tabs on Jenkins "Docs Builders" and "docs builders". They apparently have the same set of jobs. Could you take a look and tell me if we are safe to remove one view in favor of having only one please?
14:50:27 <mhrivnak> !propose triage normal low
14:50:27 <mhrivnak> #idea Proposed for #2317: Priority: Normal, Severity: Low
14:50:27 <pulpbot> Proposed for #2317: Priority: Normal, Severity: Low
14:50:36 <jortel> +1
14:50:39 <mhrivnak> These images are only for testing and demo purposes.
14:50:57 <elyezer> bmbouter: just realized triage is going on. there is no need to rush on this
14:50:58 <mhrivnak> and they probably need a fresh look anyway. I don't think they've been touched since 2.8
14:51:15 <asmacdo> ah that explains why that build failed last week
14:51:40 <asmacdo> +1
14:51:47 <smyers> !suggest add easy fix tag to #2317
14:51:47 <smyers> #idea add easy fix tag to #2317
14:51:52 <smyers> pfft
14:51:54 <smyers> it's already there
14:52:06 <asmacdo> :)
14:52:09 <asmacdo> !accept
14:52:09 <asmacdo> #agreed Priority: Normal, Severity: Low
14:52:09 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:52:10 <pulpbot> No issues to triage.
14:52:16 <asmacdo> !end
14:52:16 <asmacdo> #endmeeting