14:29:46 <asmacdo> #startmeeting Pulp Triage 2016-10-07
14:29:46 <asmacdo> #info asmacdo has joined triage
14:29:47 <pulpbot> Meeting started Fri Oct  7 14:29:46 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:47 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:47 <pulpbot> The meeting name has been set to 'pulp_triage_2016_10_07'
14:29:47 <pulpbot> asmacdo has joined triage
14:30:00 <pcreech> !here
14:30:00 <pcreech> #info pcreech has joined triage
14:30:01 <pulpbot> pcreech has joined triage
14:30:22 <bmbouter> !here
14:30:22 <bmbouter> #info bmbouter has joined triage
14:30:23 <pulpbot> bmbouter has joined triage
14:30:36 <mhrivnak> !here
14:30:36 <mhrivnak> #info mhrivnak has joined triage
14:30:36 <pulpbot> mhrivnak has joined triage
14:30:41 <bizhang> !here
14:30:41 <bizhang> #info bizhang has joined triage
14:30:42 <pulpbot> bizhang has joined triage
14:30:51 <asmacdo> !next
14:30:52 <pulpbot> 8 issues left to triage: 2278, 2279, 2287, 2288, 2289, 2321, 2323, 2326
14:30:53 <asmacdo> #topic Remove checksum_type from the srpm and drpm collections - http://pulp.plan.io/issues/2278
14:30:53 <pulpbot> Pulp Issue #2278 [NEW] (unassigned) - Priority: High | Severity: High | Severity: High
14:30:53 <pulpbot> Remove checksum_type from the srpm and drpm collections - http://pulp.plan.io/issues/2278
14:31:08 <smyers> This looks to be resolved
14:31:11 <bmbouter> I upped this to high/high
14:31:19 <bmbouter> it's resolved for them but we need to write a migraiton
14:31:21 <asmacdo> smyers, there is a workaround, but not resolved
14:31:35 <asmacdo> we probably out to call this urgent/high
14:31:36 <bmbouter> I also think this should go into a sprint
14:31:38 <asmacdo> it is a regression
14:31:46 <smyers> I see, the update didn't make sense ti I read the whole ticket
14:31:48 <asmacdo> !propose triage urgent high
14:31:48 <asmacdo> #idea Proposed for #2278: Priority: Urgent, Severity: High
14:31:49 <pulpbot> Proposed for #2278: Priority: Urgent, Severity: High
14:31:56 <bmbouter> I don't think this should block releases
14:32:16 <bmbouter> the regression-ness occured in the 2.8 release
14:32:19 <mhrivnak> I also don't think this should block releases, but I do agree it should be done very soon.
14:32:26 <bmbouter> and this use is just upgrading at this point in time
14:32:30 <bmbouter> s/use/user/
14:32:43 <smyers> And there's clearly a workaround :)
14:32:49 <asmacdo> !propose accept
14:32:49 <asmacdo> #idea Proposed for #2278: Leave the issue as-is, accepting its current state.
14:32:50 <pulpbot> Proposed for #2278: Leave the issue as-is, accepting its current state.
14:32:54 <pcreech> +1
14:32:54 <bmbouter> if we could put it on the sprint that would be great
14:32:55 <mhrivnak> I suggest high/high
14:32:55 <smyers> +1
14:33:04 <mhrivnak> adding to the sprint works for me.
14:33:05 <pcreech> it is high/high
14:33:05 <bmbouter> +1 to high/high
14:33:06 <smyers> It's current state is high/high
14:33:09 <smyers> its
14:33:12 <asmacdo> !suggest add to spritn
14:33:12 <asmacdo> #idea add to spritn
14:33:20 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:33:20 <asmacdo> !accept
14:33:20 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:33:21 <pulpbot> 7 issues left to triage: 2279, 2287, 2288, 2289, 2321, 2323, 2326
14:33:22 <asmacdo> #topic Pulp yum_importer fails when syncing SuSE repositories - http://pulp.plan.io/issues/2279
14:33:22 <pulpbot> Pulp Issue #2279 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:33:22 <pulpbot> Pulp yum_importer fails when syncing SuSE repositories - http://pulp.plan.io/issues/2279
14:34:13 <pcreech> This looks like it's still being investigated
14:34:23 <mhrivnak> need to keep waiting on suse access?
14:34:28 <smyers> We've punted this with needinfo for a while, and I'm still waiting on getting access
14:34:31 <smyers> Yeah, I don't know if we do
14:34:57 <smyers> I think I'm going to take it and work it as soon as I get access to those repos, at least to repro it
14:35:23 <smyers> Not sure what th ebest way to proceed is, though
14:35:23 <mhrivnak> Sounds good. Skip again then?
14:35:38 <smyers> Maybe? :)
14:35:45 <mhrivnak> !propose skip
14:35:45 <mhrivnak> #idea Proposed for #2279: Skip this issue for this triage session.
14:35:46 <pulpbot> Proposed for #2279: Skip this issue for this triage session.
14:36:01 <asmacdo> !accept
14:36:01 <asmacdo> #agreed Skip this issue for this triage session.
14:36:01 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:36:02 <pulpbot> 6 issues left to triage: 2287, 2288, 2289, 2321, 2323, 2326
14:36:03 <asmacdo> #topic Cannot get v2 repo tags list - http://pulp.plan.io/issues/2287
14:36:03 <pulpbot> Docker Support Issue #2287 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:36:03 <pulpbot> Cannot get v2 repo tags list - http://pulp.plan.io/issues/2287
14:36:05 <smyers> :!
14:37:16 <mhrivnak> still selinux issues to resolve?
14:37:34 <smyers> If this really is the same sort of thing as #2277, then it's urgent prio
14:38:03 <mhrivnak> agreed. I wonder if it's just a duplicate though.
14:38:22 <smyers> same here
14:38:24 <mhrivnak> same problem, slightly different symptom.
14:38:56 <mhrivnak> bmbouter, any thoughts?
14:39:25 <asmacdo> it looks like he reproduced on systems that have a fix for 2277
14:40:01 <smyers> #2277 isn't POST or MODIFIED, so I'm not sure we have a fix for that yet (it went back to ASSIGNED 2 days ago)
14:40:05 <mhrivnak> Right, but I think it was extablished on #2277 that the fix was insufficient.
14:40:23 <asmacdo> oh ok, i was just looking at the pr which was merged
14:40:53 <pcreech> Yeah, i's still an issue on 2.10 from what I can see
14:40:58 <mhrivnak> Lacking input from anyone who is more familiar with this...
14:41:00 <mhrivnak> !propose skip
14:41:00 <mhrivnak> #idea Proposed for #2287: Skip this issue for this triage session.
14:41:01 <pulpbot> Proposed for #2287: Skip this issue for this triage session.
14:41:04 <pcreech> +1
14:41:20 <asmacdo> !accept
14:41:20 <asmacdo> #agreed Skip this issue for this triage session.
14:41:20 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:41:22 <asmacdo> #topic unable to access pulp-admin or repositories - http://pulp.plan.io/issues/2288
14:41:22 <pulpbot> 5 issues left to triage: 2288, 2289, 2321, 2323, 2326
14:41:22 <pulpbot> Pulp Issue #2288 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:41:23 <smyers> +1 sadface
14:41:23 <pulpbot> unable to access pulp-admin or repositories - http://pulp.plan.io/issues/2288
14:42:05 <bmbouter> I'm not sure what to say about this bug
14:42:43 <pcreech> Looks like a bad upgrade situation to me... stuf still seems to be referencing /srv instead uf /usr/share/pulp
14:42:48 <mhrivnak> ya, me either.
14:43:05 <mhrivnak> Maybe they had custom apache config that conflicted with what we provided?
14:43:12 <pcreech> ^ my thought
14:43:23 <smyers> I suspect it's related to upgrading conffiles (specifically the apache config)...well alright then.
14:43:38 <bmbouter> I wonder if another user will experience this?
14:43:51 <smyers> They might, but this is experience is effectively the correct one
14:43:55 <pcreech> if they modified the apache conf files... amost assuredly
14:43:58 <smyers> (If it's related to modified apache configs)
14:43:59 <bmbouter> oic
14:44:04 <asmacdo> i wonder if he ran migrations as root
14:44:10 <bmbouter> close as notabug?
14:44:16 <elyezer> pcreech: have not got the change to work on that yet
14:44:19 <smyers> I think it's notabug. +1
14:44:24 <elyezer> hopefully later today
14:44:29 <pcreech> elyezer: cool, just curious :)
14:44:45 <elyezer> pcreech: I am going to let you know when I do
14:44:55 <mhrivnak> someone should add a little explanation before it gets closed.
14:44:56 <elyezer> that is getting higher on the task list though
14:45:07 <pcreech> mhrivnak: agreed
14:45:13 <mhrivnak> volunteer? :)
14:45:14 <bmbouter> I can post about the selinux stuff, but not the conf file snaffu
14:45:36 * pcreech reluctantly volunteers... will find a godd conf file as example
14:45:45 <pcreech> s/godd/good/
14:45:49 <mhrivnak> thanks!
14:46:05 <mhrivnak> !propose other pcreech comment and close as notabug
14:46:05 <mhrivnak> #idea Proposed for #2288: pcreech comment and close as notabug
14:46:06 <pulpbot> Proposed for #2288: pcreech comment and close as notabug
14:46:07 <smyers> might be good to make sure there's actually an rpmnew file that can be used for diffing
14:46:28 <bmbouter> yeah perhaps we aren't doing it right but close it now and invite to reopen maybe?
14:46:39 <smyers> sounds fair
14:47:05 <asmacdo> cool. are we ready to move on?
14:47:26 <bmbouter> I think so
14:47:40 <asmacdo> !accept
14:47:40 <asmacdo> #agreed pcreech comment and close as notabug
14:47:41 <pulpbot> Current proposal accepted: pcreech comment and close as notabug
14:47:41 <asmacdo> #topic Getting Error on pulp installation and configuration - http://pulp.plan.io/issues/2289
14:47:42 <pulpbot> 4 issues left to triage: 2289, 2321, 2323, 2326
14:47:42 <pulpbot> Pulp Issue #2289 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:47:43 <pulpbot> Getting Error on pulp installation and configuration - http://pulp.plan.io/issues/2289
14:48:07 <mhrivnak> The traceback doesn't match the file they provided.
14:48:09 <asmacdo> oh yeah this is his fault
14:48:18 <asmacdo> line 10
14:48:22 <asmacdo> he did that in the wrong place
14:48:27 <asmacdo> ill comment and close as not a bug
14:48:31 <mhrivnak> sounds good.
14:48:51 <asmacdo> !propose other close not a bug
14:48:51 <asmacdo> #idea Proposed for #2289: close not a bug
14:48:52 <pulpbot> Proposed for #2289: close not a bug
14:48:59 <bmbouter> +1
14:48:59 <pulpbot> bmbouter: That's Numberwang!
14:49:03 <smyers> :D
14:49:07 <bmbouter> haha yes
14:49:08 <asmacdo> !accept
14:49:08 <asmacdo> #agreed close not a bug
14:49:08 <pulpbot> Current proposal accepted: close not a bug
14:49:10 <asmacdo> #topic Pulp can't handle mirrorlists with invalid entries - http://pulp.plan.io/issues/2321
14:49:10 <pulpbot> 3 issues left to triage: 2321, 2323, 2326
14:49:11 <pulpbot> RPM Support Issue #2321 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:49:12 <pulpbot> Pulp can't handle mirrorlists with invalid entries - http://pulp.plan.io/issues/2321
14:49:46 <smyers> But...if they're invalid...
14:49:49 * smyers read the bug
14:50:52 <mhrivnak> I'd rephrase and say that they are valid URLs that do not contain yum repos.
14:51:46 <mhrivnak> This looks like a regression on master based on his comment.
14:53:00 <smyers> So...
14:53:01 <pcreech> any suggests?
14:53:04 <pcreech> or proposals?
14:53:11 <smyers> !propose triage high medium
14:53:11 <smyers> #idea Proposed for #2321: Priority: High, Severity: Medium
14:53:11 <smyers> #info smyers has joined triage
14:53:12 <pulpbot> smyers has joined triage
14:53:12 <smyers> ?
14:53:12 <pulpbot> Proposed for #2321: Priority: High, Severity: Medium
14:53:22 <mhrivnak> Do we have a way to express that it should block 2.11.0 but not 2.10.z ?
14:53:33 <smyers> Prio: Urgent, Version 2.11
14:53:37 <smyers> (.0)
14:53:53 <mhrivnak> Seems reasonable.
14:54:01 <smyers> Then when I look at the blocker report, it looks like this: https://pulp.plan.io/issues?query_id=75
14:54:03 <pulpbot> Title: Open Blockers - Pulp (at pulp.plan.io)
14:54:49 <asmacdo> !accept
14:54:49 <asmacdo> #agreed Priority: High, Severity: Medium
14:54:49 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
14:54:51 <asmacdo> #topic Support skipping the standard storage path migration. - http://pulp.plan.io/issues/2323
14:54:51 <pulpbot> 2 issues left to triage: 2323, 2326
14:54:51 <pulpbot> Pulp Issue #2323 [NEW] (unassigned) - Priority: High | Severity: Medium | Severity: Medium
14:54:52 <pulpbot> Support skipping the standard storage path migration. - http://pulp.plan.io/issues/2323
14:54:54 <mhrivnak> but
14:55:01 <smyers> If it should block 2.11.0 (and that makes sense)...
14:55:14 <smyers> We should revisit 2321 :)
14:55:22 <mhrivnak> yes please. :)
14:55:38 <asmacdo> !issue 2321
14:55:38 <asmacdo> #topic Pulp can't handle mirrorlists with invalid entries - http://pulp.plan.io/issues/2321
14:55:39 <pulpbot> RPM Support Issue #2321 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:55:39 <pulpbot> Pulp can't handle mirrorlists with invalid entries - http://pulp.plan.io/issues/2321
14:55:43 <smyers> !propose urgent high
14:55:43 <pulpbot> Error: "propose" is not a valid command.
14:55:51 <smyers> dammit who wrote this crap
14:55:55 <smyers> !propose triage urgent high
14:55:55 <smyers> #idea Proposed for #2321: Priority: Urgent, Severity: High
14:55:56 <pulpbot> Proposed for #2321: Priority: Urgent, Severity: High
14:56:02 <mhrivnak> +1
14:56:02 <pcreech> some guy who didn't nkow what he was doing... i guess
14:56:04 <pcreech> +1
14:56:12 <asmacdo> version is going to have to me master
14:56:16 <asmacdo> is that cool smyers?
14:56:30 <smyers> asmacdo, why? Does the field need to be updated?
14:56:32 <mhrivnak> "urgent" feels weird since there's not actual time pressure to do this real soon, but it does fit our process correctly.
14:56:50 <bmbouter> agreed and agreed
14:57:10 <smyers> asmacdo, field updated
14:57:10 <asmacdo> smyers, there is no 2.11 version, unless you mean target platform release
14:57:23 <smyers> Nope, set the version to 2.11.0
14:57:30 <smyers> You may have to refresh the page
14:57:44 <asmacdo> !accept
14:57:44 <asmacdo> #agreed Priority: Urgent, Severity: High
14:57:44 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
14:57:46 <asmacdo> #topic Support skipping the standard storage path migration. - http://pulp.plan.io/issues/2323
14:57:46 <pulpbot> 2 issues left to triage: 2323, 2326
14:57:46 <pulpbot> Pulp Issue #2323 [NEW] (unassigned) - Priority: High | Severity: Medium | Severity: Medium
14:57:47 <pulpbot> Support skipping the standard storage path migration. - http://pulp.plan.io/issues/2323
14:58:20 <mhrivnak> not a bug
14:58:24 <mhrivnak> maybe a task?
14:59:03 <smyers> This is being handled effectively as an urgent task, but given what I know of it is not a release blocker.
14:59:11 <asmacdo> do we need to do anything? sounds like they were going to do it downstream?
14:59:34 <mhrivnak> we do need to provide one or more patches
14:59:45 <mhrivnak> !propose other change to a task
14:59:45 <mhrivnak> #idea Proposed for #2323: change to a task
14:59:45 <pulpbot> Proposed for #2323: change to a task
14:59:54 <smyers> works for me
15:00:00 <bmbouter> that would be good
15:00:05 <bmbouter> and yes we should provide some patches
15:00:08 <asmacdo> do we need to add to this sprint?
15:00:11 <bmbouter> I think so
15:00:30 <bmbouter> I could make the patches it will be easy
15:00:57 <asmacdo> ok, im marking it as groomed also
15:01:07 <asmacdo> !accept
15:01:07 <asmacdo> #agreed change to a task
15:01:07 <pulpbot> Current proposal accepted: change to a task
15:01:08 <pulpbot> 1 issues left to triage: 2326
15:01:09 <asmacdo> #topic Publishes fail - http://pulp.plan.io/issues/2326
15:01:09 <pulpbot> RPM Support Issue #2326 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
15:01:09 <pulpbot> Publishes fail - http://pulp.plan.io/issues/2326
15:02:57 <mhrivnak> seems also related to or a dup of 2277
15:03:02 <smyers> What'd we do for the last one? Skip because we don't know if it's a dupe of 2277?
15:03:16 <pcreech> based on comments in 2277, this is a new situation affecting 2.11+
15:03:16 <mhrivnak> yes. And I commented on it asking if it's a dup of 2277.
15:03:32 <bmbouter> that is the new codepath that was recently added
15:03:49 <pcreech> https://pulp.plan.io/issues/2277#note-7
15:03:51 <pulpbot> Title: Issue #2277: Content published using move (instead of copy) causes 404 due to selinux denial. - Pulp (at pulp.plan.io)
15:04:11 <pcreech> "(Downloading published content on Pulp 2.11 still fails with an HTTP 404, but due to a different permissions issue, which I'll file a bug for shortly.)"
15:04:18 <mhrivnak> hm, ok.
15:05:08 <mhrivnak> I still think it's all probably related, and that #2326 might be a flaw in the fix for #2277.
15:05:18 <mhrivnak> But there's no hurry to mark as a dup either, so we can keep it separate.
15:05:26 <smyers> That's what it looks like to me as well
15:05:36 <smyers> But, y'know, from the peanut gallery.
15:05:59 * mhrivnak passes the popcorn to smyers
15:06:35 <asmacdo> !propose skip
15:06:35 <asmacdo> #idea Proposed for #2326: Skip this issue for this triage session.
15:06:36 <pulpbot> Proposed for #2326: Skip this issue for this triage session.
15:06:45 <asmacdo> !suggest mark as related to 2277
15:06:45 <asmacdo> #idea mark as related to 2277
15:06:48 <mhrivnak> +1
15:07:08 * bmbouter grabs a handful of popcorn from smyers
15:07:19 <smyers> :(
15:07:25 * pcreech holds on to his peanut bag
15:07:40 * asmacdo only has soylent :(
15:07:53 <smyers> So !accept and !end? :)
15:07:56 <asmacdo> !ccept
15:07:56 <pulpbot> Error: "ccept" is not a valid command.
15:07:59 <asmacdo> !accept
15:07:59 <asmacdo> #agreed Skip this issue for this triage session.
15:07:59 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
15:08:00 <asmacdo> #endmeeting
15:08:00 <asmacdo> !end