14:29:46 <asmacdo> #startmeeting Pulp Triage 2016-10-18
14:29:46 <asmacdo> #info asmacdo has joined triage
14:29:46 <pulpbot> Meeting started Tue Oct 18 14:29:46 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:46 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:46 <pulpbot> The meeting name has been set to 'pulp_triage_2016_10_18'
14:29:46 <pulpbot> asmacdo has joined triage
14:29:51 <dkliban> !here
14:29:51 <dkliban> #info dkliban has joined triage
14:29:52 <pulpbot> dkliban has joined triage
14:29:52 <asmacdo> !next
14:29:54 <asmacdo> #topic Python egg uploads fail - http://pulp.plan.io/issues/2334
14:29:54 <pulpbot> 5 issues left to triage: 2334, 2339, 2340, 2342, 2346
14:29:55 <pulpbot> Python Support Issue #2334 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:29:56 <pcreech> !here
14:29:56 <pcreech> #info pcreech has joined triage
14:29:56 <pulpbot> Python egg uploads fail - http://pulp.plan.io/issues/2334
14:29:57 <pulpbot> pcreech has joined triage
14:30:08 <daviddavis> !here
14:30:08 <daviddavis> #info daviddavis has joined triage
14:30:08 <pulpbot> daviddavis has joined triage
14:30:13 <bizhang> !here
14:30:13 <bizhang> #info bizhang has joined triage
14:30:14 <pulpbot> bizhang has joined triage
14:30:21 <jortel> !here
14:30:21 <jortel> #info jortel has joined triage
14:30:22 <pulpbot> jortel has joined triage
14:30:54 <asmacdo> I looked into this a bit, and I am really not sure which way to go. it brings up valid concerns, but I am not sure what needs to be done. I think we should accept the bug, it should block 2.12 platform.
14:31:01 <ttereshc> !here
14:31:01 <ttereshc> #info ttereshc has joined triage
14:31:01 <pulpbot> ttereshc has joined triage
14:31:02 <asmacdo> !propose triage high medium
14:31:02 <asmacdo> #idea Proposed for #2334: Priority: High, Severity: Medium
14:31:02 <pulpbot> Proposed for #2334: Priority: High, Severity: Medium
14:31:09 <smyers> Isn't it broken in 2.11?
14:31:31 <asmacdo> smyers, this is in python plugin master
14:31:43 <asmacdo> which we decided not to release with 2.11 yesterday
14:32:37 <asmacdo> so assuming that current python master goes out with 2.12 it should block 2.12.
14:32:45 <bmbouter> !here
14:32:45 <bmbouter> #info bmbouter has joined triage
14:32:45 <pulpbot> bmbouter has joined triage
14:33:31 <pcreech> is this not a regression in 2.11, since the issue clearly states what he was doing has worked in 2.8-2.10 ??
14:33:44 <pcreech> or am i way off base?
14:34:20 <asmacdo> it is a regression, but it lives in the python master branch, which will become pulp_python 2.0
14:34:35 <asmacdo> 2.11 will contain pulp_python 1.1
14:34:50 <pcreech> so, werid mismatching of versions then :)
14:35:22 <mhrivnak> !here
14:35:22 <mhrivnak> #info mhrivnak has joined triage
14:35:23 <pulpbot> mhrivnak has joined triage
14:35:33 <asmacdo> yes, we had planned on releasing pulp_python 2.0 with 2.11, but it wasn't worth holding platform for these features
14:35:51 <ttereshc> if it is a blocker, then maybe we can set it as Urgent and set Target release for Python plugin as 2.0 and figure out platform target release later.
14:36:06 <pcreech> ^
14:36:12 <asmacdo> ttereshc++
14:36:12 <pulpbot> ttereshc's karma is now 10
14:36:25 <asmacdo> !propose triage urgent medium
14:36:25 <asmacdo> #idea Proposed for #2334: Priority: Urgent, Severity: Medium
14:36:26 <pulpbot> Proposed for #2334: Priority: Urgent, Severity: Medium
14:36:33 <pcreech> +1
14:36:51 <smyers-nopower> Something exploded outside, and now I have no power
14:36:55 <smyers-nopower> So that's fun
14:37:09 <pcreech> O.O
14:37:15 <asmacdo> !accept
14:37:15 <asmacdo> #agreed Priority: Urgent, Severity: Medium
14:37:16 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: Medium
14:37:17 <asmacdo> #topic httpd fails to start if AMQP bus for consumers is unavailable - http://pulp.plan.io/issues/2339
14:37:17 <pulpbot> 4 issues left to triage: 2339, 2340, 2342, 2346
14:37:18 <pulpbot> Pulp Issue #2339 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:37:19 <pulpbot> httpd fails to start if AMQP bus for consumers is unavailable - http://pulp.plan.io/issues/2339
14:37:29 * mhrivnak notes that we should consider something besides "urgent" to block future releases
14:38:02 <asmacdo> mhrivnak, I was thinking that
14:38:10 <smyers-nopower> I've been thinking it'd be good to have a "Blocks Platform Release" field, specifically
14:38:15 <mhrivnak> yep
14:38:21 <asmacdo> ooh, I like that
14:38:27 <smyers-nopower> It's one of the RFCs I've got lined up, but I'm trying to not send more than two or so a week. :)
14:38:35 <bmbouter> so this is a bug that ichimonji10 and I discovered on friday
14:38:48 <bmbouter> it's an availability problem with Pulp
14:38:54 <mhrivnak> is "rabbitmq" an invalid value for that setting?
14:39:00 <bmbouter> I think normal/med is what we submitted
14:39:11 <bmbouter> rabbitmq is valid
14:39:40 <mhrivnak> Ok. I read the bug report as saying it's invalid, so that would be good to clarify.
14:40:00 <mhrivnak> "edit the [messaging] section, and set transport to something invalid. For example, try this:"
14:40:13 <asmacdo> !propose triage high low
14:40:13 <asmacdo> #idea Proposed for #2339: Priority: High, Severity: Low
14:40:13 <pulpbot> Proposed for #2339: Priority: High, Severity: Low
14:40:15 <pcreech> It might have been referencing invalid for the current setup
14:40:26 <pcreech> so, while a valid value... it's invalid on that server
14:40:28 <mhrivnak> that would just be incorrect.
14:41:00 <bmbouter> this is the main part: " httpd will not start if the consumer messaging bus is unavailable."
14:41:04 <pcreech> ^
14:41:13 <ichimonji10> You could set "transport: foo" and the bug report would read the same.
14:41:31 <bmbouter> I'm not good at making this clearer because it's already clear to me
14:41:55 <ichimonji10> I'm unable to edit bug reports. If someone else with the right priveliges wants to make that change, please do.
14:41:59 <ichimonji10> *privileges
14:42:06 * bmbouter fixes ichi's perms
14:42:09 <ichimonji10> ty
14:42:22 <bmbouter> in terms of triage: I think normal / med or high / med
14:42:49 <mhrivnak> For me, it comes down to this: If the bug is "pulp won't start if the transport is set to "foo", that's a reasonable behavior. If the bug is "pulp won't start if it can't connect to a message broker", that's a problem.
14:43:04 <mhrivnak> So I think focusing on the latter part, and not focusing on validity of a setting, would be helpful.
14:43:46 <mhrivnak> It's not a big deal, but would be a small improvement.
14:44:08 <asmacdo> !propose triage high medium
14:44:08 <asmacdo> #idea Proposed for #2339: Priority: High, Severity: Medium
14:44:09 <pulpbot> Proposed for #2339: Priority: High, Severity: Medium
14:44:28 <asmacdo> any other thoughts on prio before I accept?
14:44:43 <mhrivnak> I feel like maybe it's too high, but not sure why.
14:45:03 <asmacdo> i think its important that it is easy to switch to rabbitmq
14:45:14 <bmbouter> so this isn't really about the broker type
14:45:34 <bmbouter> the issue is that consumer features are optional, but httpd requires you to correctly configure them in order to start
14:45:36 <asmacdo> right, but ichimonji10 mentioned users would hit this when switching?
14:46:19 <bmbouter> I'm fine with either norm or high prio
14:46:21 <ichimonji10> That's when I hit this issue: when switching from qpid to rabbitmq.
14:46:32 <bmbouter> actually let's go with normal
14:46:39 <asmacdo> !propose normal medium
14:46:39 <pulpbot> Error: "propose" is not a valid command.
14:46:42 <asmacdo> !propose triage normal medium
14:46:42 <asmacdo> #idea Proposed for #2339: Priority: Normal, Severity: Medium
14:46:43 <pulpbot> Proposed for #2339: Priority: Normal, Severity: Medium
14:46:50 <pcreech> !propose triage accept
14:46:51 <pulpbot> (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
14:46:55 <mhrivnak> +1
14:46:56 <pcreech> !propose accept
14:46:56 <pcreech> #idea Proposed for #2339: Leave the issue as-is, accepting its current state.
14:46:57 <pulpbot> Proposed for #2339: Leave the issue as-is, accepting its current state.
14:47:00 <asmacdo> !accept
14:47:00 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:47:00 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:47:02 <pulpbot> 3 issues left to triage: 2340, 2342, 2346
14:47:02 <asmacdo> #topic `pulp-admin status` tells the health of the wrong AMQP message bus - http://pulp.plan.io/issues/2340
14:47:03 <pulpbot> Pulp Issue #2340 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:47:04 <pulpbot> `pulp-admin status` tells the health of the wrong AMQP message bus - http://pulp.plan.io/issues/2340
14:47:13 <smyers-nopower> heh
14:47:13 <pcreech> oops... didn't mean to do that there :)
14:47:22 <pcreech> although, outcome is the same i belive :)
14:47:38 <bmbouter> this is another that we discovered on friday
14:48:16 <smyers-nopower> ichimonji10's all up in the consumer business
14:48:24 <mhrivnak> heh
14:48:48 <bmbouter> so this would be to switch which connection settings we use when checking the message bus
14:48:53 <smyers-nopower> That one seems pretty severe, assuming folks use the status view as a main method for monitoring pulp.
14:49:07 <mhrivnak> agreed.
14:49:17 <bmbouter> I would be fine with high / med
14:49:27 <smyers-nopower> Also sounds like not a blocker, not a regression, etc
14:49:29 <bmbouter> and putting it on a sprint if we want
14:49:36 <bmbouter> it's not a blocker, correct
14:49:48 <smyers-nopower> So it's a big deal, by my hair has not caught fire
14:49:52 <bmbouter> it's worked this way since /status/ was created
14:50:02 <smyers-nopower> !propose triage high med
14:50:02 <smyers-nopower> #idea Proposed for #2340: Priority: High, Severity: Medium
14:50:02 <smyers-nopower> #info smyers-nopower has joined triage
14:50:03 <pulpbot> smyers-nopower has joined triage
14:50:04 <pulpbot> Proposed for #2340: Priority: High, Severity: Medium
14:50:14 <mhrivnak> +1
14:50:22 <ttereshc> +1
14:50:43 <pcreech> +1
14:50:47 <asmacdo> !accept
14:50:47 <asmacdo> #agreed Priority: High, Severity: Medium
14:50:47 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
14:50:48 <pulpbot> 2 issues left to triage: 2342, 2346
14:50:48 <asmacdo> #topic Vagrant setup does not allow to checkout the code in anywhere except $HOME/devel  - http://pulp.plan.io/issues/2342
14:50:49 <pulpbot> Pulp Issue #2342 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:50:50 <pulpbot> Vagrant setup does not allow to checkout the code in anywhere except $HOME/devel  - http://pulp.plan.io/issues/2342
14:51:04 <asmacdo> this isnt true
14:51:09 <bmbouter> ina and I learned this
14:51:15 <asmacdo> https://github.com/pulp/devel/blob/master/Vagrantfile.example#L13
14:51:16 <pulpbot> Title: devel/Vagrantfile.example at master · pulp/devel · GitHub (at github.com)
14:51:25 <asmacdo> it goes up one level from wherever the code lives
14:51:26 <bmbouter> her setup would not work until we made it ~/devel/
14:51:35 <asmacdo> my code on my host lives in ~/code
14:51:53 <smyers-nopower> but the docs say to use ~/devel
14:52:04 <asmacdo> the docs check it out into devel on the vagrant machine
14:52:12 <asmacdo> but it doens't actually matter
14:52:23 <bmbouter> asmacdo: we couldn't get it to work for us
14:52:34 <bmbouter> how should we proceed?
14:52:42 <asmacdo> hmm, interesting.
14:52:52 <smyers-nopower> I don't think it matters if some can get ~/code to work or not...only ~/devel is what I'd consider supported
14:53:03 <smyers-nopower> If you don't put the code there and it doesn't work...not a bug
14:53:14 <mhrivnak> hm, it's always worked for me living in a directory not called "devel".
14:53:16 <asmacdo> fair enough.
14:53:26 <asmacdo> !propose other close-notabug
14:53:26 <asmacdo> #idea Proposed for #2342: close-notabug
14:53:26 <pcreech> which folder are we talking about, host os or guest os?
14:53:26 <pulpbot> Proposed for #2342: close-notabug
14:53:42 <smyers-nopower> I'm talking about ~/devel on the vagrant guest
14:53:50 <asmacdo> oh on the guest?
14:53:54 <asmacdo> you can change that
14:53:57 <bmbouter> can we not close this and instead discuss more on the bug
14:54:04 <bmbouter> we obviously have things to discuss
14:54:27 <mhrivnak> before we move on, bmbouter do you the answer to pcreech 's question?
14:54:33 <bmbouter> sure
14:54:36 <bmbouter> host
14:54:50 <asmacdo> Agree with bmbouter. I think this will be quickly resolved on the bug, and we can probably close after that discussion
14:54:55 <asmacdo> !propose skip
14:54:55 <asmacdo> #idea Proposed for #2342: Skip this issue for this triage session.
14:54:56 <pulpbot> Proposed for #2342: Skip this issue for this triage session.
14:55:00 <mhrivnak> Thanks.
14:55:00 <pcreech> +1
14:55:02 <bmbouter> until her checkouts lived on the host machine at ~/devel/<checkouts> it would not work
14:55:11 <mhrivnak> I'm ok skipping.
14:55:24 <bmbouter> cool
14:55:28 <asmacdo> !accept
14:55:28 <asmacdo> #agreed Skip this issue for this triage session.
14:55:29 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
14:55:29 <asmacdo> #topic repoview decode errors - http://pulp.plan.io/issues/2346
14:55:30 <pulpbot> 1 issues left to triage: 2346
14:55:31 <pulpbot> Pulp Issue #2346 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:55:32 <pulpbot> repoview decode errors - http://pulp.plan.io/issues/2346
14:55:51 <smyers-nopower> Yeah, it sounds like I interpreted it incorrectly, maybe some clarification about htis happening on the host machine would help there because wat that shouldn't matter at all
14:57:08 <smyers-nopower> This one's fun, the error comes when trying to encode the exception message. So maybe something *else* is failing, but it's being stomped by an inability to log the actual exception?
14:57:28 <mhrivnak> That's my reading as well.
14:57:48 <asmacdo> this guy had a weird problem before, related to attempting to log an exception
14:57:48 <mhrivnak> It's calling str(e) on an exception, whose message apparently contains a non-ascii character. Which is reasonable.
14:57:55 <asmacdo> I think hes on a weird linux
14:58:17 <mhrivnak> he's syncing scientific linux FWIW.
14:58:26 <mhrivnak> But the bug is still legit I suspect.
15:00:02 <mhrivnak> !propose accept
15:00:02 <mhrivnak> #idea Proposed for #2346: Leave the issue as-is, accepting its current state.
15:00:02 <pulpbot> Proposed for #2346: Leave the issue as-is, accepting its current state.
15:00:20 <smyers-nopower> works for me
15:00:22 <asmacdo> could it be that we are assuming an incorrect encoding?
15:00:31 <mhrivnak> asmacdo, yes. We're assuming ascii
15:00:34 <ttereshc> location_href contains a lot of weird stuff but it's strange that we do not handle it well, for some reason I thought we had such bug in hte past
15:00:58 <ttereshc> +1 to accept it as-is
15:01:09 <asmacdo> !accept
15:01:09 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
15:01:09 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:01:11 <pulpbot> No issues to triage.
15:01:27 <asmacdo> !end
15:01:27 <asmacdo> #endmeeting