14:31:31 <asmacdo> #startmeeting Pulp Triage 2016-10-21
14:31:31 <asmacdo> #info asmacdo has joined triage
14:31:31 <pulpbot> Meeting started Fri Oct 21 14:31:31 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:31:31 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:31 <pulpbot> The meeting name has been set to 'pulp_triage_2016_10_21'
14:31:31 <pulpbot> asmacdo has joined triage
14:31:43 <smyers> treeagggge
14:31:44 <mhrivnak> !here
14:31:44 <mhrivnak> #info mhrivnak has joined triage
14:31:45 <pulpbot> mhrivnak has joined triage
14:31:46 <smyers> !here
14:31:46 <smyers> #info smyers has joined triage
14:31:47 <pulpbot> smyers has joined triage
14:31:56 <jortel> !here
14:31:56 <jortel> #info jortel has joined triage
14:31:57 <pulpbot> jortel has joined triage
14:32:09 <pcreech> !here
14:32:09 <pcreech> #info pcreech has joined triage
14:32:10 <pulpbot> pcreech has joined triage
14:32:13 <bmbouter> !here
14:32:14 <bmbouter> #info bmbouter has joined triage
14:32:15 <pulpbot> bmbouter has joined triage
14:32:21 <asmacdo> !next
14:32:22 <pulpbot> 6 issues left to triage: 2340, 2342, 2349, 2353, 2363, 2364
14:32:22 <asmacdo> #topic `pulp-admin status` tells the health of the wrong AMQP message bus - http://pulp.plan.io/issues/2340
14:32:23 <pulpbot> Pulp Issue #2340 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:32:23 <pulpbot> `pulp-admin status` tells the health of the wrong AMQP message bus - http://pulp.plan.io/issues/2340
14:32:59 <mhrivnak> Did we skip this last time?
14:33:01 <smyers> I remember that we deferred this, but I don't remember why. We should put that on the issue
14:33:12 <smyers> s/the issue/issues we skip/
14:33:14 <mhrivnak> agreed.
14:33:16 <ttereshc> !here
14:33:16 <ttereshc> #info ttereshc has joined triage
14:33:17 <pulpbot> ttereshc has joined triage
14:34:20 <bmbouter> I thought we did not skip it
14:34:38 * smyers checks the logs
14:34:42 <daviddavis> !here
14:34:42 <daviddavis> #info daviddavis has joined triage
14:34:43 <pulpbot> daviddavis has joined triage
14:34:54 <asmacdo> i might have gotten distracted :)
14:35:03 <smyers> AGREED: Leave the issue as-is, accepting its current state. (asmacdo, 14:47:00)
14:35:07 <smyers> Just needs the triage check
14:35:09 <asmacdo> !accept
14:35:10 <pulpbot> No action proposed, nothing to accept.
14:35:19 <asmacdo> !propose accept
14:35:19 <asmacdo> #idea Proposed for #2340: Leave the issue as-is, accepting its current state.
14:35:19 <pulpbot> Proposed for #2340: Leave the issue as-is, accepting its current state.
14:35:21 <asmacdo> !accept
14:35:21 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:35:21 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:35:22 <asmacdo> #topic Vagrant setup does not allow to checkout the code in anywhere except $HOME/devel  - http://pulp.plan.io/issues/2342
14:35:23 <pulpbot> 5 issues left to triage: 2342, 2349, 2353, 2363, 2364
14:35:23 <pulpbot> Pulp Issue #2342 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:35:24 <pulpbot> Vagrant setup does not allow to checkout the code in anywhere except $HOME/devel  - http://pulp.plan.io/issues/2342
14:35:24 <smyers> asmacdo, I'd say just !skip it
14:35:40 <smyers> No need to re-propose. If you !skip and hit the triage check, we'll never see it again
14:35:45 <asmacdo> did we accept this one too?
14:36:13 <smyers> ugh I pasted the wrong agreement, but I'll fix up #2340 accordingly. Sorry about that.
14:36:19 <smyers> We did skip #2342
14:36:41 <mhrivnak> we accepted this: Proposed for #2340: Priority: High, Severity: Medium
14:36:51 <bmbouter> yes for 2340
14:36:53 <smyers> mhrivnak, already on it
14:36:59 <mhrivnak> sweet.
14:37:01 <bmbouter> for 2342 we did skip it, but today I think we should accept it
14:37:17 <bmbouter> since last time we I think all agreed that if the claim was correct that it was a bug
14:37:25 <bmbouter> and the claim is about the host machine
14:37:31 <mhrivnak> sounds good.
14:37:33 <asmacdo> !propose accept
14:37:33 <asmacdo> #idea Proposed for #2342: Leave the issue as-is, accepting its current state.
14:37:33 <pulpbot> Proposed for #2342: Leave the issue as-is, accepting its current state.
14:37:42 <ttereshc> +1
14:37:53 <bmbouter> smyers, asmacdo what do you think?
14:38:08 <smyers> bmbouter, I have a comment to that effect on the ticket, yes
14:38:14 <asmacdo> im good with that.
14:38:26 <asmacdo> !accept
14:38:26 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:38:27 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:38:28 <asmacdo> #topic Repoview left in place even when not requested - http://pulp.plan.io/issues/2349
14:38:28 <pulpbot> 4 issues left to triage: 2349, 2353, 2363, 2364
14:38:29 <pulpbot> RPM Support Issue #2349 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:38:30 <pulpbot> Repoview left in place even when not requested - http://pulp.plan.io/issues/2349
14:38:49 <fdobrovo> !here
14:38:49 <fdobrovo> #info fdobrovo has joined triage
14:38:50 <pulpbot> fdobrovo has joined triage
14:39:37 <mhrivnak> I'm not sure I fully understand this one.
14:40:20 <mhrivnak> Maybe step 3 in the first reproducer is providing those settings just in the override_config
14:40:34 <mhrivnak> so that step 4 does not use those settings.
14:41:18 <mhrivnak> It could be that since incremental publish copies over repo metadata from the previous publish, it may copy over the repoview stuff whether you want it or not, just because it was there.
14:42:03 <smyers> I still don't get it either, though I don't think it's the bug report's fault
14:42:05 <jortel> yeah, maybe
14:42:32 <mhrivnak> I suspect this could be summarized as "if I turn off repoview, future publishes still include repoview data".
14:42:38 <mhrivnak> It's likely stale data also.
14:42:50 <smyers> Does slapping on a --force-full fix that?
14:42:57 <mhrivnak> very likely.
14:43:03 <smyers> It's not intuitive, if so, but...sorta normal for pulp?
14:43:07 <smyers> So I think I'm conflicted
14:43:14 <bmbouter> me 2
14:43:29 <bmbouter> maybe just clarify this in the docs?
14:43:34 <mhrivnak> Ya. The copy step of incremental publish would benefit from excluding this data.
14:43:41 <bmbouter> oh yeah let's do that instead
14:43:47 <bmbouter> ignore my docs suggestoin it is not good
14:43:54 <mhrivnak> Or maybe it should have a whitelist of specifically which files it does copy. (maybe it does. I'm speculating)
14:44:09 <mhrivnak> In any case, I think a code change would improve the behavior.
14:44:13 <smyers> I like it, but would prefer to make the usage more intuitive if possible
14:44:19 <smyers> it = a docs change
14:44:36 <smyers> So even if we don't know what the change might look like...
14:44:45 <smyers> Is it an enhancement?
14:44:48 <smyers> I don't think so
14:44:52 <smyers> !propose accept
14:44:52 <smyers> #idea Proposed for #2349: Leave the issue as-is, accepting its current state.
14:44:53 <pulpbot> Proposed for #2349: Leave the issue as-is, accepting its current state.
14:44:54 <mhrivnak> I think it's a bug fix.
14:45:12 <mhrivnak> I think low severity.
14:45:12 <jortel> +1
14:45:17 <smyers> Agreed
14:45:21 <smyers> !propose triage normal low
14:45:21 <smyers> #idea Proposed for #2349: Priority: Normal, Severity: Low
14:45:22 <pulpbot> Proposed for #2349: Priority: Normal, Severity: Low
14:45:29 <mhrivnak> it only affects humans browsing, and there's an easy work-around.
14:45:32 <mhrivnak> +1
14:45:50 <bmbouter> +1
14:45:54 <asmacdo> !accept
14:45:54 <asmacdo> #agreed Priority: Normal, Severity: Low
14:45:55 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
14:45:55 <asmacdo> #topic UTC must be used when filtering records by date fields - http://pulp.plan.io/issues/2353
14:45:56 <pulpbot> 3 issues left to triage: 2353, 2363, 2364
14:45:56 <pulpbot> Pulp Issue #2353 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:45:57 <pulpbot> UTC must be used when filtering records by date fields - http://pulp.plan.io/issues/2353
14:46:43 <jortel> doc fix
14:46:45 <asmacdo> !propose accept
14:46:45 <asmacdo> #idea Proposed for #2353: Leave the issue as-is, accepting its current state.
14:46:46 <pulpbot> Proposed for #2353: Leave the issue as-is, accepting its current state.
14:46:53 <fdobrovo> +1
14:46:54 <daviddavis> hey look who submitted that bug
14:46:55 <mhrivnak> +1
14:47:01 <smyers> this freakin guy
14:47:04 <daviddavis> lol
14:47:13 <jortel> already causing trouble :/
14:47:18 <jortel> ;)
14:47:24 <smyers> +1 accept
14:47:25 <daviddavis> hehe
14:47:30 <asmacdo> lol
14:47:33 <asmacdo> !accept
14:47:33 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:47:33 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:47:34 <pulpbot> 2 issues left to triage: 2363, 2364
14:47:35 <asmacdo> #topic Pulp acts like all is well when a sync completely fails - http://pulp.plan.io/issues/2363
14:47:35 <pulpbot> RPM Support Issue #2363 [NEW] (unassigned) - Priority: Normal | Severity: Medium | Severity: Medium
14:47:35 <pulpbot> Pulp acts like all is well when a sync completely fails - http://pulp.plan.io/issues/2363
14:47:41 <smyers> heh
14:47:59 <asmacdo> propose ugh
14:48:06 <smyers> can spot the ichimonji10 bugs without clicking :)
14:48:22 <smyers> "Pulp is a LIAR. A LYING LIAR."
14:48:30 <ichimonji10> *cough*
14:48:31 <asmacdo> I hate that pulp lies
14:48:37 <mhrivnak> regression. should block 2.11
14:49:06 <smyers> +1
14:49:08 <jortel> +1
14:49:10 <ttereshc> +1
14:49:14 <asmacdo> !propose urgent high
14:49:14 <pulpbot> Error: "propose" is not a valid command.
14:49:18 <asmacdo> !propose triage urgent high
14:49:18 <asmacdo> #idea Proposed for #2363: Priority: Urgent, Severity: High
14:49:18 <pulpbot> Proposed for #2363: Priority: Urgent, Severity: High
14:49:24 <mhrivnak> reminds me of the book "Lies, and the Lying Liars who Tell Them"
14:49:30 <mhrivnak> but I digress...
14:49:39 <mhrivnak> +1
14:50:00 <asmacdo> !accept
14:50:00 <asmacdo> #agreed Priority: Urgent, Severity: High
14:50:00 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
14:50:01 <pulpbot> 1 issues left to triage: 2364
14:50:01 <asmacdo> #topic Inconsistent usage of strings and constants - http://pulp.plan.io/issues/2364
14:50:02 <pulpbot> RPM Support Issue #2364 [NEW] (unassigned) - Priority: Normal | Severity: Low | Severity: Low
14:50:02 <pulpbot> Inconsistent usage of strings and constants - http://pulp.plan.io/issues/2364
14:50:47 <mhrivnak> I found the problem! "I am trying to use pulp_rpm as an example of how to write a pulp plugin"
14:50:49 <mhrivnak> ;)
14:50:55 <smyers> heh
14:50:57 <jortel> heh
14:50:58 <smyers> !propose accept
14:50:58 <smyers> #idea Proposed for #2364: Leave the issue as-is, accepting its current state.
14:50:59 <pulpbot> Proposed for #2364: Leave the issue as-is, accepting its current state.
14:51:12 <asmacdo> we probably ought to reach out to them
14:51:22 <mhrivnak> Yes, I was just about to ask.
14:51:30 <mhrivnak> +1 accept
14:51:38 <smyers> he's in #pulp, nick misa
14:51:39 <mhrivnak> has anyone communicated with this person about plugin writing?
14:51:45 <smyers> if he's writing plugins we should get him in here
14:51:50 <smyers> (maybe?)
14:52:28 <asmacdo> yeah we should invite him
14:52:31 <bmbouter> we should
14:52:51 <asmacdo> ok mhrivnak pinged
14:52:55 <asmacdo> !accept
14:52:55 <asmacdo> #agreed Leave the issue as-is, accepting its current state.
14:52:55 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
14:52:57 <pulpbot> No issues to triage.
14:53:01 <asmacdo> !end
14:53:01 <asmacdo> #endmeeting