14:29:51 <asmacdo> #startmeeting Pulp Triage 2016-11-01
14:29:51 <asmacdo> #info asmacdo has joined triage
14:29:52 <pulpbot> Meeting started Tue Nov  1 14:29:51 2016 UTC and is due to finish in 60 minutes.  The chair is asmacdo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:52 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:29:52 <pulpbot> The meeting name has been set to 'pulp_triage_2016_11_01'
14:29:52 <pulpbot> asmacdo has joined triage
14:30:23 <dkliban> !here
14:30:23 <dkliban> #info dkliban has joined triage
14:30:23 <pulpbot> dkliban has joined triage
14:30:25 <mhrivnak> !here
14:30:25 <mhrivnak> #info mhrivnak has joined triage
14:30:26 <pulpbot> mhrivnak has joined triage
14:30:27 <bizhang> !here
14:30:27 <bizhang> #info bizhang has joined triage
14:30:27 <pulpbot> bizhang has joined triage
14:30:48 <ipanova> !here
14:30:48 <ipanova> #info ipanova has joined triage
14:30:49 <pulpbot> ipanova has joined triage
14:30:52 <bmbouter> !here
14:30:52 <bmbouter> #info bmbouter has joined triage
14:30:53 <pulpbot> bmbouter has joined triage
14:31:04 <asmacdo> !next
14:31:05 <ttereshc> !here
14:31:06 <asmacdo> #topic Can't skip distribution content using pulp-admin - http://pulp.plan.io/issues/2374
14:31:06 <ttereshc> #info ttereshc has joined triage
14:31:06 <pulpbot> 4 issues left to triage: 2374, 2377, 2378, 2379
14:31:07 <pulpbot> Pulp Issue #2374 [NEW] (unassigned) - Priority: Normal | Severity: Low | Severity: Low
14:31:08 <pulpbot> Can't skip distribution content using pulp-admin - http://pulp.plan.io/issues/2374
14:31:09 <pulpbot> ttereshc has joined triage
14:32:35 <bmbouter> there is a question on this, I am posting an answer now
14:32:47 <asmacdo> mhrivnak, it looks like since the distribution is in the config so i dont think its pulp-admin
14:32:48 <mhrivnak> Great. I think that may influence priority.
14:33:05 <jortel> !here
14:33:05 <jortel> #info jortel has joined triage
14:33:05 <pulpbot> jortel has joined triage
14:33:31 <mhrivnak> Should we come back to this one?
14:33:36 <bmbouter> posted
14:33:42 <bmbouter> we can, either way
14:33:52 <ipanova> i took a quick look at the code and seems like it is not a regression but this issue was always present there
14:33:54 <mhrivnak> ah, ok.
14:34:30 <asmacdo> anyone have a prio proposal?
14:34:42 <mhrivnak> !propose triage normal medium
14:34:42 <mhrivnak> #idea Proposed for #2374: Priority: Normal, Severity: Medium
14:34:43 <pulpbot> Proposed for #2374: Priority: Normal, Severity: Medium
14:34:45 <preethi> !here
14:34:45 <preethi> #info preethi has joined triage
14:34:45 <pulpbot> preethi has joined triage
14:34:49 <ipanova> +1
14:34:52 <jortel> +1
14:35:03 <ttereshc> +1
14:35:05 <mhrivnak> also, I suggest removing mention of pulp-admin
14:35:25 <mhrivnak> Except that it was used to reproduce.
14:36:00 <asmacdo> !suggest remove pulp-admin from subject, but include in reproducer steps
14:36:00 <asmacdo> #idea remove pulp-admin from subject, but include in reproducer steps
14:36:58 <pcreech> !here
14:36:58 <pcreech> #info pcreech has joined triage
14:36:59 <pulpbot> pcreech has joined triage
14:37:00 <asmacdo> !accept
14:37:00 <asmacdo> #agreed Priority: Normal, Severity: Medium
14:37:00 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Medium
14:37:02 <asmacdo> #topic 0025_importer_schema_change hits issue with last_sync being None - http://pulp.plan.io/issues/2377
14:37:02 <pulpbot> 3 issues left to triage: 2377, 2378, 2379
14:37:02 <pulpbot> Pulp Issue #2377 [NEW] (unassigned) - Priority: Normal | Severity: High | Severity: High
14:37:03 <pulpbot> 0025_importer_schema_change hits issue with last_sync being None - http://pulp.plan.io/issues/2377
14:37:48 <asmacdo> bmbouter, on the last bug, can I switch that to pulp_rpm?
14:38:04 <mhrivnak> There are complicating factors here.
14:38:33 <smyers> I separated this out from the issue dealing with this migration being for 2.11 but existing in 2.10.1. There's a good chance that the work in #2378 will fix this in 2.10.2.
14:38:41 <mhrivnak> Migration 0025 should have been released with 2.11.0. It is going to be withdrawn from 2.10.z, but the bug here is still legit.
14:39:02 <bmbouter> asmacdo: yes
14:39:03 <ipanova> should not this migration end up in pulp 2.11?
14:39:26 <ipanova> i see
14:39:33 <mhrivnak> ipanova, yes I think a new-and-improved version of this migration will land in 2.11, likely as migration 0027
14:40:01 <mhrivnak> This bug helped us notice that 2.11 code was accidentally released early, but this bug was not caused by that.
14:40:15 <mhrivnak> !propose triage high high
14:40:15 <mhrivnak> #idea Proposed for #2377: Priority: High, Severity: High
14:40:16 <pulpbot> Proposed for #2377: Priority: High, Severity: High
14:40:25 <mhrivnak> upgrade breaks for users who hit this bug.
14:40:47 <asmacdo> mhrivnak, how do you feel about urgent then?
14:41:07 <mhrivnak> I suppose since 2.11 is in beta now, we could go for urgent.
14:41:20 <mhrivnak> This fix does need to block 2.11.0
14:41:35 <mhrivnak> !propose triage urgent high
14:41:35 <mhrivnak> #idea Proposed for #2377: Priority: Urgent, Severity: High
14:41:35 <pulpbot> Proposed for #2377: Priority: Urgent, Severity: High
14:41:48 <ttereshc> +1
14:41:50 <jortel> +1
14:41:59 <bizhang> +1
14:42:13 <bmbouter> +1
14:42:19 <asmacdo> !accept
14:42:19 <asmacdo> #agreed Priority: Urgent, Severity: High
14:42:19 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
14:42:21 <asmacdo> #topic Bad merges forward on 2.10-dev - http://pulp.plan.io/issues/2378
14:42:21 <pulpbot> 2 issues left to triage: 2378, 2379
14:42:21 <pulpbot> Pulp Issue #2378 [NEW] (unassigned) - Priority: Urgent | Severity: High | Severity: High
14:42:22 <pulpbot> Bad merges forward on 2.10-dev - http://pulp.plan.io/issues/2378
14:42:27 <smyers> !propose accept
14:42:27 <smyers> #idea Proposed for #2378: Leave the issue as-is, accepting its current state.
14:42:27 <smyers> #info smyers has joined triage
14:42:28 <pulpbot> smyers has joined triage
14:42:29 <pulpbot> Proposed for #2378: Leave the issue as-is, accepting its current state.
14:42:33 <mhrivnak> +1
14:42:38 <smyers> If "on fire" was a priority, I'd set it to that.
14:42:50 <ttereshc> +1
14:42:51 <dkliban> lol
14:43:11 * mhrivnak is briefly tempted to add "on fire" to the redmine field
14:43:18 <smyers> heh
14:43:42 <asmacdo> there is an urgent severity also
14:43:48 <asmacdo> !propose triage urgent urgent
14:43:48 <asmacdo> #idea Proposed for #2378: Priority: Urgent, Severity: Urgent
14:43:49 <pulpbot> Proposed for #2378: Priority: Urgent, Severity: Urgent
14:44:16 <ttereshc> should we put urgent ones on a current sprint as well?
14:44:17 <mhrivnak> oh really?
14:44:17 <smyers> negative, a workaround exists
14:44:32 <asmacdo> !propose triage urgent high
14:44:32 <asmacdo> #idea Proposed for #2378: Priority: Urgent, Severity: High
14:44:33 <pulpbot> Proposed for #2378: Priority: Urgent, Severity: High
14:44:54 <mhrivnak> "ugrent" seems like a strange word to describe severity, but that's another discussion.
14:45:32 <mhrivnak> +1
14:45:36 <asmacdo> !accept
14:45:36 <asmacdo> #agreed Priority: Urgent, Severity: High
14:45:36 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High
14:45:37 <pulpbot> 1 issues left to triage: 2379
14:45:38 <asmacdo> #topic repomd.xml points to wrong updateinfo.xml.gz file - http://pulp.plan.io/issues/2379
14:45:38 <pulpbot> Pulp Issue #2379 [NEW] (unassigned) - Priority: High | Severity: High | Severity: High
14:45:39 <pulpbot> repomd.xml points to wrong updateinfo.xml.gz file - http://pulp.plan.io/issues/2379
14:45:52 <bmbouter> this is the issue I am working on currently
14:46:01 <bmbouter> we were tracking it as 1088, but I filed this new one instead
14:46:11 <smyers> For reference: https://docs.pulpproject.org/en/nightly/dev-guide/contributing/bugs.html?highlight=urgent#triage-issue-fields
14:46:12 <mhrivnak> This can lead to errata not being made available to clients when the user thinks they are.
14:46:17 <bmbouter> I need to assign this to myself
14:46:21 <mhrivnak> So this might be a good candidate for Urgent also.
14:46:25 <bmbouter> agreed
14:46:32 <jortel> agreed
14:46:43 <smyers> "High: Similar to Urgent, this issue severly impacts to operations of an organization, but a workaround does exist."
14:47:01 <bmbouter> it is now assigned
14:47:26 <asmacdo> thanks smyers, its been a while since I read thruogh that
14:47:53 <mhrivnak> !propose triage urgent high
14:47:53 <mhrivnak> #idea Proposed for #2379: Priority: Urgent, Severity: High
14:47:53 <pulpbot> Proposed for #2379: Priority: Urgent, Severity: High
14:48:14 <bmbouter> +1
14:48:18 <ttereshc> +1
14:48:36 <jortel> +1
14:48:41 <smyers> What target release for #2379?
14:48:46 <smyers> Assuming 2.10.z?
14:48:46 <bmbouter> !suggest add to sprint 10
14:48:46 <bmbouter> #idea add to sprint 10
14:49:09 <mhrivnak> It's been reproduced on 2.8, so I think we should also set the Version to 2.8
14:49:09 <ttereshc> bmbouter, +1, all urgent ones
14:49:28 <mhrivnak> yes, I think 2.10.z is the target
14:49:38 <bmbouter> yes I plan on 2.10.z
14:49:39 <smyers> !propose triage urgent high 2.10.z
14:49:39 <smyers> #idea Proposed for #2379: Priority: Urgent, Severity: High, Target Platform Release: 2.10.z
14:49:40 <pulpbot> Proposed for #2379: Priority: Urgent, Severity: High, Target Platform Release: 2.10.z
14:49:50 <smyers> secret third field
14:49:58 <mhrivnak> ooooo nice
14:50:25 <bmbouter> niiiice
14:50:45 <asmacdo> latest in redmine is 2.10.2, is that what you want smyers?
14:50:52 <smyers> I almost got the blockd changes done yesterday, but got a little distracted toward the end of the day. We should have the new "Blocks Release" field today
14:50:54 <smyers> asmacdo, yes
14:51:04 <asmacdo> cool
14:51:07 <asmacdo> we ready to accept?
14:51:12 <smyers> yes
14:51:15 <jortel> sure
14:51:15 <asmacdo> !accept
14:51:15 <asmacdo> #agreed Priority: Urgent, Severity: High, Target Platform Release: 2.10.z
14:51:15 <pulpbot> Current proposal accepted: Priority: Urgent, Severity: High, Target Platform Release: 2.10.z
14:51:16 <pulpbot> No issues to triage.
14:51:22 <asmacdo> !end
14:51:22 <asmacdo> #endmeeting