15:29:41 <bizhang> #startmeeting Pulp Triage 2016-11-15
15:29:41 <bizhang> #info bizhang has joined triage
15:29:42 <pulpbot> Meeting started Tue Nov 15 15:29:41 2016 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:42 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:42 <pulpbot> The meeting name has been set to 'pulp_triage_2016_11_15'
15:29:42 <pulpbot> bizhang has joined triage
15:29:45 <bmbouter> !here
15:29:45 <bmbouter> #info bmbouter has joined triage
15:29:46 <pulpbot> bmbouter has joined triage
15:29:46 <daviddavis> !here
15:29:46 <daviddavis> #info daviddavis has joined triage
15:29:47 <pulpbot> daviddavis has joined triage
15:29:47 <mhrivnak> !here
15:29:47 <mhrivnak> #info mhrivnak has joined triage
15:29:48 <pulpbot> mhrivnak has joined triage
15:29:50 <bizhang> !next
15:29:51 <pulpbot> 4 issues left to triage: 2414, 2418, 2422, 2424
15:29:51 <bizhang> #topic `ImproperlyConfigured`  exception in for detail list view endpoint - http://pulp.plan.io/issues/2414
15:29:52 <pulpbot> Pulp Issue #2414 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:29:52 <pulpbot> `ImproperlyConfigured`  exception in for detail list view endpoint - http://pulp.plan.io/issues/2414
15:29:52 <asmacdo> !here
15:29:52 <asmacdo> #info asmacdo has joined triage
15:29:53 <dkliban> !here
15:29:53 <dkliban> #info dkliban has joined triage
15:29:53 <pulpbot> asmacdo has joined triage
15:29:54 <pulpbot> dkliban has joined triage
15:30:13 <pcreech> #info pcreech has joined triage
15:30:13 <pcreech> !here
15:30:13 <pulpbot> pcreech has joined triage
15:30:40 <mhrivnak> pulp 3 bug?
15:30:43 <bmbouter> this needs to pulp3 tag
15:30:51 <dkliban> this is a pulp 3 bug
15:31:01 * bmbouter is not sure of the propose syntax
15:31:01 <asmacdo> yup pulp 3 only
15:31:05 <smyers> This is something that either MasterModelSerializer should do out of the box, or (if it can't) should be clearly documented as necessary.
15:31:12 <smyers> !suggest add pulp 3 tag
15:31:12 <smyers> #idea add pulp 3 tag
15:31:12 <smyers> #info smyers has joined triage
15:31:13 <pulpbot> smyers has joined triage
15:31:34 <bizhang> #idea Proposed for #2414: Leave the issue as-is, accepting its current state.
15:31:34 <bizhang> !propose accept
15:31:34 <pulpbot> Proposed for #2414: Leave the issue as-is, accepting its current state.
15:31:39 <smyers> +1
15:31:52 <bmbouter> +1
15:31:54 <mhrivnak> +1
15:31:54 <asmacdo> +1
15:31:57 <bizhang> !accept
15:31:57 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:31:57 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:31:58 <pulpbot> 3 issues left to triage: 2418, 2422, 2424
15:31:58 <bizhang> #topic pulp-admin rpm provider lost auto-publish - http://pulp.plan.io/issues/2418
15:31:59 <pulpbot> Pulp Issue #2418 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:31:59 <pulpbot> pulp-admin rpm provider lost auto-publish - http://pulp.plan.io/issues/2418
15:32:55 <pcreech> regression?
15:33:08 <mhrivnak> that's certainly the claim.
15:33:12 <bmbouter> very likely, but I'm not sure when
15:33:48 <bmbouter> I think either med/high or high/high
15:33:58 * smyers was also thinking high/high
15:34:00 <bmbouter> and maybe put it on the sprint? this looks not good
15:34:05 <smyers> !propose triage high high
15:34:05 <smyers> #idea Proposed for #2418: Priority: High, Severity: High
15:34:06 <pulpbot> Proposed for #2418: Priority: High, Severity: High
15:34:09 <mhrivnak> high/high seems good.
15:34:12 <bizhang> !suggest add to spring
15:34:12 <bizhang> #idea add to spring
15:34:16 <smyers> :D
15:34:20 <bmbouter> +1 to both
15:34:23 <bizhang> !suggest add to sprint
15:34:23 <bizhang> #idea add to sprint
15:34:36 <mhrivnak> +1
15:34:39 <asmacdo> wait a sec
15:34:41 <pcreech> +1
15:34:45 <asmacdo> is it autopublish or auto-publish
15:34:52 <smyers> hahaha yes
15:35:00 <smyers> #  pulp-admin rpm repo create --repo-id testname --autopublish false
15:35:02 <bmbouter> agreed
15:35:07 <smyers> OPT_AUTO_PUBLISH = PulpCliOption('--auto-publish', d, required=False,
15:35:13 <bmbouter> I see that too, good catch asmacdo
15:35:17 <smyers> asmacdo++
15:35:17 <pulpbot> asmacdo's karma is now 17
15:35:19 <asmacdo> \o/
15:35:21 <smyers> !propose needinfo
15:35:21 <smyers> #idea Proposed for #2418: This issue cannot be triaged without more info.
15:35:22 <pulpbot> Proposed for #2418: This issue cannot be triaged without more info.
15:35:37 <bmbouter> +1
15:35:43 <bizhang> !accept
15:35:43 <bizhang> #agreed This issue cannot be triaged without more info.
15:35:44 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
15:35:45 <bizhang> #topic pulp-admin 2.7 does not work with pulp-server 2.10 (pulp-rpm to be more specific) - http://pulp.plan.io/issues/2422
15:35:45 <pulpbot> 2 issues left to triage: 2422, 2424
15:35:46 <pulpbot> Pulp Issue #2422 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:35:47 <pulpbot> pulp-admin 2.7 does not work with pulp-server 2.10 (pulp-rpm to be more specific) - http://pulp.plan.io/issues/2422
15:36:03 <smyers> I can handle asking for the info on that last one
15:36:21 <bmbouter> thanks smyers
15:37:11 <mhrivnak> For this one, pulp-admin has always been required to be at the same version as the pulp it's talking to. I'm not sure how well that's documented though.
15:38:09 <bmbouter> I'm unsure what changed about this field and when
15:38:30 <pcreech> FieldDoesNotExist: The field 'checksum_type' does not exist on the document 'RPM'
15:38:39 <pcreech> ran into that one in rhui as well, going form 2.7-2.8
15:38:45 <asmacdo> could we convert this into a story? as an RFE for pulp 3 and its client? I agree that it would be a nice behavior.
15:39:41 <pcreech> which i guess could technically be an api regression?
15:39:56 <bmbouter> mhrivnak: I agree with what you are saying the versions need to be the same, but this is an api regression
15:40:37 <bmbouter> we have code in multiple places that is designed to preserve the mismatch between field names and field names we store internally
15:41:02 <mhrivnak> Good point.
15:41:02 <bmbouter> and we translate on the inbound requests and untranslate on the serialization (outbound)
15:41:06 <asmacdo> I feel like we keep getting bitten by checksum_type vs checksumtype
15:41:11 <bmbouter> agreed
15:41:37 <bmbouter> so I'm wondeirng how broad this is
15:41:43 <bmbouter> is it just that 1 upload spot he links to?
15:41:51 * smyers really doubts it
15:42:18 <mhrivnak> What else do you have in mind?
15:42:22 <bmbouter> agreed, but his bug is only claiming that much so we could fix it as its written
15:42:31 <smyers> Yep, and we should
15:43:22 <bizhang> !propose triage high high
15:43:22 <bizhang> #idea Proposed for #2422: Priority: High, Severity: High
15:43:23 <pulpbot> Proposed for #2422: Priority: High, Severity: High
15:44:08 <bmbouter> what about med/med
15:44:14 <daviddavis> +1
15:44:18 <mhrivnak> I like med/med better since the workaround is easy.
15:44:54 <bmbouter> we should post on it a little bit saying that really this is about an API regression and ask for a clearer reproducer or curl output from what the 2.7 pulp-admin is doing
15:44:54 <bizhang> !propose triage normal medium
15:44:54 <bizhang> #idea Proposed for #2422: Priority: Normal, Severity: Medium
15:44:55 <pulpbot> Proposed for #2422: Priority: Normal, Severity: Medium
15:45:00 <asmacdo> i am uneasy but ok with giving an API regression med/med...
15:45:59 <bizhang> med/high?
15:47:02 <bizhang> triage guide indicates regression=high
15:47:17 <mhrivnak> seems fine.
15:47:30 <bizhang> !propose triage normal high
15:47:30 <bizhang> #idea Proposed for #2422: Priority: Normal, Severity: High
15:47:31 <pulpbot> Proposed for #2422: Priority: Normal, Severity: High
15:47:34 <asmacdo> +1
15:47:59 <daviddavis> !accept
15:48:01 <bmbouter> that is ok with me, and I'll handle posting on the issue requesting for the curl reproducer
15:48:16 <bizhang> !accept
15:48:16 <bizhang> #agreed Priority: Normal, Severity: High
15:48:16 <pulpbot> Current proposal accepted: Priority: Normal, Severity: High
15:48:18 <bizhang> #topic restorecon runs unecessarily for some upgrades - http://pulp.plan.io/issues/2424
15:48:18 <pulpbot> 1 issues left to triage: 2424
15:48:18 <pulpbot> Pulp Issue #2424 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:48:19 <pulpbot> restorecon runs unecessarily for some upgrades - http://pulp.plan.io/issues/2424
15:48:55 <dkliban> high/high
15:49:13 <dkliban> this is not really our bug, but we need to implement a workaround
15:49:27 <dkliban> otherwise upgrades can take a really long time
15:49:28 <bmbouter> yeah it won't be too hard I posted a suggestion
15:49:39 <bmbouter> is this sprint material?
15:49:49 <mhrivnak> +1
15:49:53 <dkliban> i think so
15:49:56 <bizhang> !suggest add to sprint
15:49:56 <bizhang> #idea add to sprint
15:50:01 <mhrivnak> !propose triage high high
15:50:01 <mhrivnak> #idea Proposed for #2424: Priority: High, Severity: High
15:50:02 <pulpbot> Proposed for #2424: Priority: High, Severity: High
15:50:16 <bizhang> #agreed Priority: High, Severity: High
15:50:16 <bizhang> !accept
15:50:16 <pulpbot> Current proposal accepted: Priority: High, Severity: High
15:50:16 <bmbouter> +1
15:50:17 <pulpbot> No issues to triage.
15:50:21 <bizhang> !end
15:50:21 <bizhang> #endmeeting