15:29:52 <bizhang> #startmeeting Pulp Triage 2016-11-18
15:29:52 <bizhang> #info bizhang has joined triage
15:29:53 <pulpbot> Meeting started Fri Nov 18 15:29:52 2016 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:53 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:53 <pulpbot> The meeting name has been set to 'pulp_triage_2016_11_18'
15:29:53 <pulpbot> bizhang has joined triage
15:29:56 <misa> smyers: speaking about that, there was a lot of code I had to copy/paste from pulp_rpm when I wrote the syncing portion for the plugin
15:30:01 <fdobrovo> !here
15:30:01 <fdobrovo> #info fdobrovo has joined triage
15:30:01 <pulpbot> fdobrovo has joined triage
15:30:05 <mhrivnak> !here
15:30:05 <mhrivnak> #info mhrivnak has joined triage
15:30:05 <pulpbot> mhrivnak has joined triage
15:30:11 <bizhang> !next
15:30:12 <pulpbot> 4 issues left to triage: 2418, 2426, 2427, 2429
15:30:12 <bizhang> #topic pulp-admin rpm provider lost auto-publish - http://pulp.plan.io/issues/2418
15:30:13 <pulpbot> Pulp Issue #2418 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:30:13 <asmacdo> !here
15:30:13 <asmacdo> #info asmacdo has joined triage
15:30:13 <pulpbot> pulp-admin rpm provider lost auto-publish - http://pulp.plan.io/issues/2418
15:30:14 <pulpbot> asmacdo has joined triage
15:30:21 <daviddavis> !here
15:30:21 <daviddavis> #info daviddavis has joined triage
15:30:21 <pulpbot> daviddavis has joined triage
15:30:29 <pcreech> !here
15:30:29 <pcreech> #info pcreech has joined triage
15:30:29 <pulpbot> pcreech has joined triage
15:30:30 <jortel> !here
15:30:30 <jortel> #info jortel has joined triage
15:30:30 <pulpbot> jortel has joined triage
15:30:56 <asmacdo> !propose other close-notabug
15:30:56 <asmacdo> #idea Proposed for #2418: close-notabug
15:30:57 <pulpbot> Proposed for #2418: close-notabug
15:31:10 <smyers> We handled this as a pretty sever thing last week before wondering if there was any significance about --autopublish vs. --auto-publish
15:31:30 <asmacdo> it looks like hes working
15:31:43 <asmacdo> so i think it was autopublish vs auto-publish
15:31:48 <smyers> Based on the conversation had since then and the evidence in our code, it looks like this is something that did exist at some point in 2.x, and that we do want to exist, but not necessarily a high priority thing
15:31:57 <mhrivnak> It looks like the option may have been present on pulp 1, but has never been on pulp 2 in this plugin.
15:32:13 <mhrivnak> If it did exist on pulp 2, it was before September of 2012.
15:32:20 <smyers> yeah, I meant 1.x, pardon the typo
15:32:40 <bizhang> !accept
15:32:40 <bizhang> #agreed close-notabug
15:32:40 <pulpbot> Current proposal accepted: close-notabug
15:32:41 <pulpbot> 3 issues left to triage: 2426, 2427, 2429
15:32:41 <bizhang> #topic Update our Pulp 3.0 documentation with git commit message info - http://pulp.plan.io/issues/2426
15:32:42 <pulpbot> Pulp Issue #2426 [ASSIGNED] (daviddavis@redhat.com) - Priority: Normal | Severity: Medium
15:32:43 <pulpbot> Update our Pulp 3.0 documentation with git commit message info - http://pulp.plan.io/issues/2426
15:32:47 <smyers> Waaait
15:32:55 <asmacdo> i think we probably want this now
15:33:03 <bizhang> how do we go back?
15:33:04 <asmacdo> maybe as a story for the cli?
15:33:06 <smyers> It's not notabug, it's a story or an issue
15:33:15 <smyers> !issue 2418
15:33:19 <asmacdo> you do !issue <number>
15:33:20 <smyers> is how you go back
15:33:22 <bizhang> !issue 2418
15:33:23 <bizhang> #topic pulp-admin rpm provider lost auto-publish - http://pulp.plan.io/issues/2418
15:33:23 <pulpbot> Pulp Issue #2418 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:33:24 <pulpbot> pulp-admin rpm provider lost auto-publish - http://pulp.plan.io/issues/2418
15:33:34 <mhrivnak> There's a little more to it.
15:33:50 <mhrivnak> Part of the problem is that pulp-admin hides the existence of distributors.
15:33:59 <mhrivnak> But auto-publish is a per-distributor setting.
15:34:20 <mhrivnak> And pulp-admin even defaults to creating the two distributors with different values of auto-publish.
15:34:47 <daviddavis> what was the behavior in 1.x? do we know
15:34:47 <asmacdo> oh gosh.
15:34:51 <smyers> And there's a solution (I don't even consider it a workaround) in comment #5
15:35:06 <mhrivnak> We don't have a natural way currently to let the user have the control of which distributor the setting gets applied to vs. not.
15:35:18 <asmacdo> ah, right
15:35:19 <bmbouter> !here
15:35:19 <bmbouter> #info bmbouter has joined triage
15:35:19 <pulpbot> bmbouter has joined triage
15:35:37 <smyers> I think the issue is that we've got vestigial code talking about --auto-publish in there, and it could probably just go away. Then document the 'auto_publish' feature of distributors with example API calls to make it happen. Or something.
15:35:42 <asmacdo> ok, so this would be closed-wontfix and we document it
15:35:56 <bmbouter> documenting it is a form of fixing I think
15:35:57 <mhrivnak> I think that's a prudent approach.
15:36:07 <daviddavis> and removing the old auto-publish code as well
15:36:17 <daviddavis> the vestigial code
15:36:21 <asmacdo> !propose medium low
15:36:21 <pulpbot> Error: "propose" is not a valid command.
15:36:26 <asmacdo> !propose triage medium low
15:36:26 <asmacdo> #idea Proposed for #2418: Priority: Normal, Severity: Low
15:36:27 <pulpbot> Proposed for #2418: Priority: Normal, Severity: Low
15:36:34 <smyers> heh, that's a weird error
15:36:35 <asmacdo> !suggest docs bug
15:36:35 <asmacdo> #idea docs bug
15:36:40 <bizhang> should we add it to this sprint?
15:36:57 <asmacdo> i dont think so
15:36:58 <mhrivnak> I don't think there's any urgency to it, so I would not add it to the sprint.
15:37:05 <smyers> +1
15:37:21 <bizhang> !accept
15:37:21 <bizhang> #agreed Priority: Normal, Severity: Low
15:37:23 <bizhang> #topic Update our Pulp 3.0 documentation with git commit message info - http://pulp.plan.io/issues/2426
15:37:23 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
15:37:24 <pulpbot> 3 issues left to triage: 2426, 2427, 2429
15:37:25 <pulpbot> Pulp Issue #2426 [ASSIGNED] (daviddavis@redhat.com) - Priority: Normal | Severity: Medium
15:37:26 <pulpbot> Update our Pulp 3.0 documentation with git commit message info - http://pulp.plan.io/issues/2426
15:37:38 <asmacdo> !propose accept
15:37:38 <asmacdo> #idea Proposed for #2426: Leave the issue as-is, accepting its current state.
15:37:39 <pulpbot> Proposed for #2426: Leave the issue as-is, accepting its current state.
15:37:47 <bmbouter> agreed
15:37:48 <jortel> +1
15:37:51 <mhrivnak> Is this a bug?
15:37:58 <asmacdo> !suggest change to story
15:37:58 <asmacdo> #idea change to story
15:37:58 <daviddavis> no
15:37:59 <bmbouter> it's a task really
15:38:02 <bmbouter> or story
15:38:03 <smyers> ASSIGNED, this is just a bookkeeping issue related to something already being done and should be a task
15:38:05 <smyers> task
15:38:13 <bmbouter> agreed, task
15:38:13 <mhrivnak> Great. Let's make it a task.
15:38:17 <asmacdo> smyers, can i unsuggest?
15:38:20 <smyers> nope
15:38:25 <asmacdo> :(
15:38:25 <smyers> !suggest ake it a task, not a story
15:38:25 <smyers> #idea ake it a task, not a story
15:38:25 <smyers> #info smyers has joined triage
15:38:26 <pulpbot> smyers has joined triage
15:38:34 <smyers> And I'll throw a typo in the log, wooo
15:38:34 <bizhang> !accept
15:38:34 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:38:35 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:38:36 <pulpbot> 2 issues left to triage: 2427, 2429
15:38:36 <bizhang> #topic Apache's XSendFile directive causes 404 errors when trying to download rpm packages via HTTP - http://pulp.plan.io/issues/2427
15:38:37 <pulpbot> RPM Support Issue #2427 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:38:38 <pulpbot> Apache's XSendFile directive causes 404 errors when trying to download rpm packages via HTTP - http://pulp.plan.io/issues/2427
15:38:43 <asmacdo> lol
15:39:09 <smyers> looks terrifying! But really it looks like an upstream bug in mod xsendfile for the power pc arch
15:39:29 <mhrivnak> agreed and agreed.
15:39:35 <jortel> hm.. this looks familiar.
15:39:39 <asmacdo> it does
15:39:50 <asmacdo> was it was selinux last time jortel?
15:39:50 <smyers> I think I'd love to see a reply to bmbouter's question, so
15:39:54 <smyers> !propose needinfo
15:39:54 <smyers> #idea Proposed for #2427: This issue cannot be triaged without more info.
15:39:55 <pulpbot> Proposed for #2427: This issue cannot be triaged without more info.
15:40:28 <jortel> asmacdo: no idea w/o more info
15:40:31 <asmacdo> +1
15:40:33 <bizhang> !accept
15:40:33 <bizhang> #agreed This issue cannot be triaged without more info.
15:40:33 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
15:40:34 <bizhang> #topic repomd.xml in a published yum repository is empty when retrieved via HTTP - http://pulp.plan.io/issues/2429
15:40:35 <pulpbot> 1 issues left to triage: 2429
15:40:36 <pulpbot> RPM Support Issue #2429 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:40:37 <pulpbot> repomd.xml in a published yum repository is empty when retrieved via HTTP - http://pulp.plan.io/issues/2429
15:41:11 <mhrivnak> same
15:41:16 <mhrivnak> needinfo
15:41:24 <bmbouter> +1
15:41:28 <smyers> !propose needinfo
15:41:28 <smyers> #idea Proposed for #2429: This issue cannot be triaged without more info.
15:41:28 <pulpbot> Proposed for #2429: This issue cannot be triaged without more info.
15:41:28 <asmacdo> !propose needsinfo
15:41:29 <pulpbot> Error: "propose" is not a valid command.
15:41:49 <smyers> heh, I still love how propose is totoally a valid command and pulpbot's like "wut"
15:42:00 <bizhang> !accept
15:42:00 <bizhang> #agreed This issue cannot be triaged without more info.
15:42:00 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
15:42:01 <pulpbot> No issues to triage.
15:42:06 <bizhang> !end
15:42:06 <bizhang> #endmeeting