15:29:21 <bizhang> #startmeeting Pulp Triage 2016-11-29
15:29:21 <bizhang> #info bizhang has joined triage
15:29:22 <pulpbot> Meeting started Tue Nov 29 15:29:21 2016 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:22 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:22 <pulpbot> The meeting name has been set to 'pulp_triage_2016_11_29'
15:29:22 <pulpbot> bizhang has joined triage
15:29:29 <pcreech> !here
15:29:29 <pcreech> #info pcreech has joined triage
15:29:30 <pulpbot> pcreech has joined triage
15:29:34 <dkliban> !here
15:29:34 <dkliban> #info dkliban has joined triage
15:29:35 <pulpbot> dkliban has joined triage
15:29:41 <mhrivnak> !here
15:29:41 <mhrivnak> #info mhrivnak has joined triage
15:29:42 <pulpbot> mhrivnak has joined triage
15:29:43 <bizhang> !next
15:29:44 <pulpbot> 7 issues left to triage: 2429, 2431, 2434, 2437, 2438, 2441, 2445
15:29:44 <bizhang> #topic repomd.xml in a published yum repository is empty when retrieved via HTTP - http://pulp.plan.io/issues/2429
15:29:45 <pulpbot> RPM Support Issue #2429 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:29:46 <pulpbot> repomd.xml in a published yum repository is empty when retrieved via HTTP - http://pulp.plan.io/issues/2429
15:30:02 <pcreech> No response since attempt at followup 11 days ago
15:30:02 <bizhang> !propose skip
15:30:02 <bizhang> #idea Proposed for #2429: Skip this issue for this triage session.
15:30:03 <pulpbot> Proposed for #2429: Skip this issue for this triage session.
15:30:42 * pcreech wonders if we should close it
15:31:03 <jortel> !here
15:31:03 <jortel> #info jortel has joined triage
15:31:04 <pulpbot> jortel has joined triage
15:31:27 <mhrivnak> We can't skip it forever. I'd be fine closing it as worksforme
15:31:45 <ipanova> !here
15:31:45 <ipanova> #info ipanova has joined triage
15:31:45 <pulpbot> ipanova has joined triage
15:31:45 <mhrivnak> They can re-open or open a new issue if there is more info available in the future.
15:31:52 <smyers> alanoe, if you could chime in on this issue, we'd love to get it triaged
15:32:23 <jortel> +1
15:32:30 <smyers> I think I'm +1 on closed worksforme
15:32:41 <smyers> !propose other closed worksforme
15:32:41 <smyers> #idea Proposed for #2429: closed worksforme
15:32:41 <smyers> #info smyers has joined triage
15:32:43 <pulpbot> smyers has joined triage
15:32:44 <pulpbot> Proposed for #2429: closed worksforme
15:32:48 <pcreech> +1
15:32:50 <bizhang> !accept
15:32:50 <bizhang> #agreed closed worksforme
15:32:50 <pulpbot> Current proposal accepted: closed worksforme
15:32:51 <pulpbot> 6 issues left to triage: 2431, 2434, 2437, 2438, 2441, 2445
15:32:51 <bizhang> #topic Potential data corruption - http://pulp.plan.io/issues/2431
15:32:52 <pulpbot> Pulp Issue #2431 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:52 <smyers> can always reopen it
15:32:52 <pulpbot> Potential data corruption - http://pulp.plan.io/issues/2431
15:33:30 <ttereshc> !here
15:33:30 <ttereshc> #info ttereshc has joined triage
15:33:31 <pulpbot> ttereshc has joined triage
15:33:31 <pcreech> Sounds like we should just proably think of a way of 'protecting' certain fields in plugins in 3
15:33:44 <pcreech> not sure if we should convert to a story
15:34:01 <mhrivnak> We looked at this before. Who was going to take the next steps?
15:34:05 * mhrivnak wonders if it was him
15:34:28 <pcreech> It was a 'have a discussion with him' to find out what the issue really was last I remember
15:34:32 <smyers> yep https://pulpadmin.fedorapeople.org/triage/pulp-dev/2016/pulp-dev.2016-11-22-15.29.html
15:34:41 <smyers> !propose needinfo
15:34:41 <smyers> #idea Proposed for #2431: This issue cannot be triaged without more info.
15:34:43 <pulpbot> Proposed for #2431: This issue cannot be triaged without more info.
15:34:44 <smyers> still :)
15:34:56 <bizhang> !accept
15:34:56 <bizhang> #agreed This issue cannot be triaged without more info.
15:34:56 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
15:34:57 <pulpbot> 5 issues left to triage: 2434, 2437, 2438, 2441, 2445
15:34:57 <bizhang> #topic Add timing output to sync task steps - http://pulp.plan.io/issues/2434
15:34:58 <pulpbot> Pulp Issue #2434 [NEW] (unassigned) - Priority: Normal | Severity: High
15:34:59 <pulpbot> Add timing output to sync task steps - http://pulp.plan.io/issues/2434
15:35:09 <pcreech> does his note at the end not count as adding more info?  https://pulp.plan.io/issues/2431#note-1
15:35:10 <pulpbot> Title: Issue #2431: Potential data corruption - Pulp (at pulp.plan.io)
15:35:29 <bizhang> !issue 2431
15:35:30 <bizhang> #topic Potential data corruption - http://pulp.plan.io/issues/2431
15:35:30 <pulpbot> Pulp Issue #2431 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:35:32 <pulpbot> Potential data corruption - http://pulp.plan.io/issues/2431
15:36:02 <bizhang> we're not planning to fix this for pulp2 correct?
15:36:07 <mhrivnak> I did talk with the reporter via IRC.
15:36:23 <mhrivnak> And established that the upload API is awkward.
15:36:34 <mhrivnak> Which surprises nobody. ;)
15:36:41 <pcreech> probably not, but is probably somethign to think about for 3.0... /me wonders if it's convertable from bug to story
15:37:19 <mhrivnak> I think it boiled down to: you can mis-use the upload API and break stuff, but the API could be more helpful at directing you away from functionality that can break stuff.
15:37:41 <mhrivnak> I'll take another look today and think about how to adjust the issue.
15:37:45 <mhrivnak> !propose skip
15:37:45 <mhrivnak> #idea Proposed for #2431: Skip this issue for this triage session.
15:37:45 <pulpbot> Proposed for #2431: Skip this issue for this triage session.
15:37:48 <bmbouter> !here
15:37:48 <bmbouter> #info bmbouter has joined triage
15:37:49 <pulpbot> bmbouter has joined triage
15:37:53 <pcreech> 'As a plugin writer, i can specify read-only fields' or something like that
15:38:07 <smyers> Possibly. I think this is already covered in 3.0 with the explicit serializers. We've already put a lot of read-only fields in there, and consciously decided not to expose certain models, largely to keep stuff like this out of users hands
15:38:07 <bizhang> !accept
15:38:07 <bizhang> #agreed Skip this issue for this triage session.
15:38:07 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
15:38:08 <pulpbot> 5 issues left to triage: 2434, 2437, 2438, 2441, 2445
15:38:09 <bizhang> #topic Add timing output to sync task steps - http://pulp.plan.io/issues/2434
15:38:09 <pulpbot> Pulp Issue #2434 [NEW] (unassigned) - Priority: Normal | Severity: High
15:38:10 <pulpbot> Add timing output to sync task steps - http://pulp.plan.io/issues/2434
15:38:36 <ttereshc> looks like a story
15:38:58 <bizhang> !issue 2431
15:38:59 <bizhang> #topic Potential data corruption - http://pulp.plan.io/issues/2431
15:38:59 <pulpbot> Pulp Issue #2431 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:39:00 <pulpbot> Potential data corruption - http://pulp.plan.io/issues/2431
15:39:02 <bizhang> sigh...
15:39:12 <smyers> previous decision was "15:57:23 <mhrivnak> Let's skip, and talk to ehelms about it before dismissing it as not valuable."
15:39:20 <smyers> for #2434
15:39:20 <bmbouter> we did hear from ehelms
15:39:29 <bmbouter> and he convinced me that it would be valuable
15:39:32 <mhrivnak> bizhang, why are we back on 2431?
15:39:48 <bmbouter> at least enough to accept it as a story
15:39:51 <bizhang> it looked like we were still discussing
15:39:54 <bizhang> oops
15:39:55 <bmbouter> for 2434
15:39:58 <bizhang> !issue 2434
15:39:59 <bizhang> #topic Add timing output to sync task steps - http://pulp.plan.io/issues/2434
15:39:59 <pulpbot> Pulp Issue #2434 [NEW] (unassigned) - Priority: Normal | Severity: High
15:40:00 <pulpbot> Add timing output to sync task steps - http://pulp.plan.io/issues/2434
15:40:07 <mhrivnak> No worries. I think we're good with 2431.
15:40:24 <mhrivnak> !propose other convert to story
15:40:24 <mhrivnak> #idea Proposed for #2434: convert to story
15:40:24 <pulpbot> Proposed for #2434: convert to story
15:40:27 <bmbouter> +1
15:40:29 <pcreech> +1
15:40:31 <ttereshc> +1
15:40:33 <smyers> cool, I saw it the last update was 7 days ago and assumed that its status was unchanged since last triage as a result
15:40:39 <bmbouter> severity should be lowered though
15:40:39 <bizhang> !accept
15:40:39 <bizhang> #agreed convert to story
15:40:39 <pulpbot> Current proposal accepted: convert to story
15:40:40 <pulpbot> 4 issues left to triage: 2437, 2438, 2441, 2445
15:40:41 <bizhang> #topic Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:40:41 <pulpbot> Pulp Issue #2437 [NEW] (unassigned) - Priority: Normal | Severity: High
15:40:42 <pulpbot> Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:40:51 <bizhang> shoot I'm too fast with the accept
15:40:56 <bizhang> !issue 2434
15:40:57 <bizhang> #topic Add timing output to sync task steps - http://pulp.plan.io/issues/2434
15:40:57 <pulpbot> Pulp Issue #2434 [NEW] (unassigned) - Priority: Normal | Severity: High
15:40:58 <pulpbot> Add timing output to sync task steps - http://pulp.plan.io/issues/2434
15:40:59 <bmbouter> that's ok it's hard to know
15:41:00 <smyers> Stories have no severity :)
15:41:05 <bmbouter> ok great it's a non issue then
15:41:10 <bizhang> !next
15:41:11 <pulpbot> 4 issues left to triage: 2437, 2438, 2441, 2445
15:41:11 <bizhang> #topic Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:41:12 <pulpbot> Pulp Issue #2437 [NEW] (unassigned) - Priority: Normal | Severity: High
15:41:13 <pulpbot> Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:42:05 <bmbouter> so we tried to reproduce but couldn't
15:42:07 <mhrivnak> dkliban, what do you think?
15:42:34 <dkliban> it seems like this is a legitimate problem
15:42:44 <dkliban> i left more info in the comments
15:43:16 <bmbouter> but if we couldn't reproduce it can we triage it?
15:43:19 <mhrivnak> jortel, ?
15:43:22 <dkliban> we have a migration that is supposed to fix this issue, but it doesn't seem to work. it was added for 2.8.4
15:43:44 <ipanova> i think Filip was working on the issue which could fix this
15:44:11 <ipanova> sync of the unit and upload of the unit have different storage-paths
15:44:16 <ipanova> of the *same* unit
15:44:20 <dkliban> oh wow
15:44:31 <ipanova> i need to find the bug number
15:44:44 <bmbouter> does it make sense to post on this and skip for now?
15:44:59 <smyers> punt?
15:45:12 <smyers> (post?)
15:45:22 <mhrivnak> Seems reasonable. ipanova can comment on it with the other issue, and jortel can also take a look.
15:45:31 <dkliban> soudns good to me
15:45:35 <bizhang> !skip
15:45:36 <pulpbot> 3 issues left to triage: 2438, 2441, 2445
15:45:36 <bizhang> #topic http://pulp.plan.io/issues/2438
15:45:37 <pulpbot> Issue #2438 is private and must be viewed in Redmine
15:45:38 <pulpbot> http://pulp.plan.io/issues/2438
15:45:40 <bmbouter> we need to record that as a proposal
15:45:48 <bmbouter> without the !propose it won't go into the minutes
15:45:57 <bizhang> !issue 2437
15:45:58 <bizhang> #topic Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:45:58 <pulpbot> Pulp Issue #2437 [NEW] (unassigned) - Priority: Normal | Severity: High
15:45:59 <pulpbot> Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:46:01 <bizhang> !propose skip
15:46:01 <bizhang> #idea Proposed for #2437: Skip this issue for this triage session.
15:46:01 <pulpbot> Proposed for #2437: Skip this issue for this triage session.
15:46:03 <bizhang> !accept
15:46:03 <bizhang> #agreed Skip this issue for this triage session.
15:46:03 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
15:46:04 <pulpbot> 3 issues left to triage: 2438, 2441, 2445
15:46:05 <bizhang> #topic http://pulp.plan.io/issues/2438
15:46:05 <pulpbot> Issue #2438 is private and must be viewed in Redmine
15:46:06 <pulpbot> http://pulp.plan.io/issues/2438
15:46:14 <bmbouter> I had meant the part about posting and followup
15:46:38 <bizhang> !issue 2437
15:46:39 <bizhang> #topic Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:46:39 <pulpbot> Pulp Issue #2437 [NEW] (unassigned) - Priority: Normal | Severity: High
15:46:40 <pulpbot> Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:46:41 <mhrivnak> !propose other ipanova will relate another issue and jortel will take a look
15:46:41 <mhrivnak> #idea Proposed for #2437: ipanova will relate another issue and jortel will take a look
15:46:42 <pulpbot> Proposed for #2437: ipanova will relate another issue and jortel will take a look
15:46:52 <bizhang> !accept
15:46:52 <bizhang> #agreed ipanova will relate another issue and jortel will take a look
15:46:52 <pulpbot> Current proposal accepted: ipanova will relate another issue and jortel will take a look
15:46:53 <ipanova> will do
15:46:54 <pulpbot> 3 issues left to triage: 2438, 2441, 2445
15:46:54 <bizhang> #topic http://pulp.plan.io/issues/2438
15:46:55 <pulpbot> Issue #2438 is private and must be viewed in Redmine
15:46:56 <pulpbot> http://pulp.plan.io/issues/2438
15:46:56 <bmbouter> thank you!
15:47:31 <mhrivnak> ipanova was looking at this one.
15:47:43 <bmbouter> this can be public right?
15:47:44 <mhrivnak> Seems to be just confusion about which repos should or should not contain a "distribution" unit.
15:48:23 <bmbouter> I don't see anything here that motivates it being private
15:48:45 <mhrivnak> bmbouter, not sure why the reporter set it as private, but I'd want to confirm with them before making it public.
15:49:18 <bmbouter> that sounds reasonable, can we wait to triage before we resolve it's privateness
15:49:34 <ipanova> i think we should just document or set a note that depending on the distro feel url could change to sync distributions
15:50:33 <mhrivnak> I tend to agree that this is a low-severity and maybe low-priority documentation issue.
15:50:50 <ipanova> +1
15:50:58 <mhrivnak> just to help a user understand where they might find a kickstart tree.
15:51:01 <bmbouter> +1 but don't want to accept as private
15:51:08 <ipanova> agree but would be good to comment on the issue to give some explanation to the user
15:51:19 <ttereshc> link to cdn probably should be private
15:51:28 <ipanova> mhrivnak: should type slower :D
15:52:02 <mhrivnak> bmbouter, can we accept it and also inquire with the user about making it public?
15:52:18 <mhrivnak> Why block triaging on making it public?
15:52:19 <bmbouter> yes can we set an unembargo timeline
15:52:40 <smyers> bmbouter, I love that idea
15:52:41 <bmbouter> because private bugs are primarily for security things
15:52:56 <bmbouter> and private bugs are generally against the idea of open collaboration
15:53:01 <mhrivnak> Yes, and also for user privacy things.
15:53:05 <smyers> I don't think cdn paths are secret or otherwise privileged information.
15:53:12 * pcreech doesn't think we need to re-hash private vs public in triage
15:53:13 <bmbouter> this is not secret info
15:53:16 <mhrivnak> The fact that one company is a customer of another might be private.
15:53:44 <bmbouter> agreed, let's follow up after triage we can accept
15:53:45 <mhrivnak> I suggest we inquire about making this public, but not do so unless the user consents.
15:54:00 <dkliban> mhrivnak: sounds good to me. we can probably do this over IRC
15:54:02 <bmbouter> we can accept now and follow up on the privateness later
15:54:05 <bizhang> !propose triage low low
15:54:05 <bizhang> #idea Proposed for #2438: Priority: Low, Severity: Low
15:54:05 <pulpbot> Proposed for #2438: Priority: Low, Severity: Low
15:54:21 <ipanova> +1
15:54:23 <mhrivnak> +1
15:54:26 <ipanova> bug also should be renamed
15:55:15 <bmbouter> ipanova: before triaging it or after?
15:55:20 <ipanova> i can do that and also provide a comment to the reporter
15:55:23 <ipanova> does not matter
15:55:32 <bizhang> !propose other ipanova to rename and comment
15:55:32 <bizhang> #idea Proposed for #2438: ipanova to rename and comment
15:55:32 <pulpbot> Proposed for #2438: ipanova to rename and comment
15:55:48 <bmbouter> +1
15:55:54 <bizhang> !accept
15:55:54 <bizhang> #agreed ipanova to rename and comment
15:55:54 <pulpbot> Current proposal accepted: ipanova to rename and comment
15:55:55 <bizhang> #topic unassociating a docker_manifest removes docker_blob regardless of whether or not other docker_manifest in repo reference it - http://pulp.plan.io/issues/2441
15:55:56 <pulpbot> 2 issues left to triage: 2441, 2445
15:55:57 <pulpbot> Docker Support Issue #2441 [ASSIGNED] (ipanova@redhat.com) - Priority: High | Severity: High
15:55:58 <pulpbot> unassociating a docker_manifest removes docker_blob regardless of whether or not other docker_manifest in repo reference it - http://pulp.plan.io/issues/2441
15:56:23 <ipanova> this one already has the PR, i just wanted the team to set the sev/prio
15:56:50 <mhrivnak> At least high/high
15:57:25 <pcreech> +1
15:57:26 <mhrivnak> I don't think it needs to block a release, but it is very important to fix.
15:57:36 <ttereshc> !propose accept
15:57:36 <ttereshc> #idea Proposed for #2441: Leave the issue as-is, accepting its current state.
15:57:37 <pulpbot> Proposed for #2441: Leave the issue as-is, accepting its current state.
15:57:44 <bizhang> also move to current sprint?
15:57:47 <mhrivnak> yes.
15:57:56 <bizhang> !propose other move to current sprint
15:57:56 <bizhang> #idea Proposed for #2441: move to current sprint
15:57:57 <pulpbot> Proposed for #2441: move to current sprint
15:58:12 <bizhang> !accept
15:58:12 <bizhang> #agreed move to current sprint
15:58:13 <pulpbot> Current proposal accepted: move to current sprint
15:58:13 <bizhang> #topic pulp-server spec file does not require pulp-selinux to be at a specific version - http://pulp.plan.io/issues/2445
15:58:14 <pulpbot> 1 issues left to triage: 2445
15:58:15 <pulpbot> Pulp Issue #2445 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:58:16 <pulpbot> pulp-server spec file does not require pulp-selinux to be at a specific version - http://pulp.plan.io/issues/2445
15:59:30 <dkliban> i just filed this one
15:59:36 <mhrivnak> dkliban, any guidance on priority?
15:59:38 <bmbouter> +1 to accepting this as is, and also including it for sprint planning this week
15:59:41 <smyers> That seems odd; shouldn't pulp-selinux get updated if it's installed and a newer version is available, regardless of the dependency in pulp?
15:59:52 <bmbouter> yum doesn't do that I don't think
15:59:55 <mhrivnak> smyers, I was thinking the same.
16:00:05 <smyers> iirc we used to do this, the fix might be a git revert
16:00:22 <bmbouter> if you do a `yum update` yes but a `yum update pulp-server` it considers the pulp-selinux dep already satisfied
16:00:31 <bmbouter> and I think you are remembering the version number on libselinux which is different
16:00:37 <smyers> yep
16:00:48 <mhrivnak> bmbouter, ah, gotcha.
16:00:52 <bizhang> !propose accept
16:00:52 <bizhang> #idea Proposed for #2445: Leave the issue as-is, accepting its current state.
16:00:53 <pulpbot> Proposed for #2445: Leave the issue as-is, accepting its current state.
16:01:04 <bmbouter> dkliban: can you add this into the sprint planning mix?
16:01:07 <pcreech> can we add a statment to double check the fedora spec file as well?
16:01:09 <dkliban> i will
16:01:31 <bmbouter> +1 to that addition
16:01:36 <smyers> fedora specs are downstream, and belong in a downstream tracker/project
16:01:42 <bmbouter> oh right
16:01:46 <bmbouter> what smyers said
16:02:15 <pcreech> noted
16:02:29 * pcreech needs to remember to file a bugzilla bug
16:02:36 <bizhang> !accept
16:02:36 <bizhang> #agreed Leave the issue as-is, accepting its current state.
16:02:36 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
16:02:37 <pulpbot> No issues to triage.
16:02:43 <bizhang> !end
16:02:43 <bizhang> #endmeeting