15:29:24 <bizhang> #startmeeting Pulp Triage 2016-12-02
15:29:24 <bizhang> #info bizhang has joined triage
15:29:25 <pulpbot> Meeting started Fri Dec  2 15:29:24 2016 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:25 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:25 <pulpbot> The meeting name has been set to 'pulp_triage_2016_12_02'
15:29:25 <pulpbot> bizhang has joined triage
15:29:49 <smyers> !here
15:29:49 <smyers> #info smyers has joined triage
15:29:50 <pulpbot> smyers has joined triage
15:30:00 <smyers> might be a little delay as this meeting finishes up
15:30:23 <bizhang> makes sense
15:30:46 <ipanova> !here
15:30:46 <ipanova> #info ipanova has joined triage
15:30:47 <pulpbot> ipanova has joined triage
15:30:59 <mhrivnak> !here
15:30:59 <mhrivnak> #info mhrivnak has joined triage
15:30:59 <pulpbot> mhrivnak has joined triage
15:31:05 <bizhang> !next
15:31:06 <pulpbot> 4 issues left to triage: 2431, 2437, 2457, 2458
15:31:06 <bizhang> #topic Potential data corruption - http://pulp.plan.io/issues/2431
15:31:07 <pulpbot> Pulp Issue #2431 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:31:08 <pulpbot> Potential data corruption - http://pulp.plan.io/issues/2431
15:31:21 <elyezer> bmbouter: thank you for the more detailed comments about the issue, I still learning SELinux and I wasn't able to provide details about that
15:31:21 <mhrivnak> we can skip this one. I promise I'll deal with it today. :)
15:31:24 <elyezer> bmbouter++
15:31:24 <pulpbot> bmbouter's karma is now 59
15:31:37 <ttereshc> !here
15:31:37 <ttereshc> #info ttereshc has joined triage
15:31:37 <pulpbot> ttereshc has joined triage
15:31:37 <bizhang> mhrivnak, sounds good
15:32:07 <bizhang> !propose other mhrivnak to update
15:32:07 <bizhang> #idea Proposed for #2431: mhrivnak to update
15:32:07 <pulpbot> Proposed for #2431: mhrivnak to update
15:32:10 <bizhang> !accept
15:32:10 <bizhang> #agreed mhrivnak to update
15:32:10 <pulpbot> Current proposal accepted: mhrivnak to update
15:32:11 <pulpbot> 3 issues left to triage: 2437, 2457, 2458
15:32:11 <bizhang> #topic Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:32:12 <pulpbot> Pulp Issue #2437 [NEW] (unassigned) - Priority: Normal | Severity: High
15:32:13 <pulpbot> Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:32:45 <bizhang> Is this a configuration issue on the user's side?
15:33:03 <ipanova> i left a comment there, so we need to wait on user's answer
15:33:18 <smyers> Yeah, I think it's needinfo pending the answer to ina's question
15:33:19 <bizhang> !propose skip
15:33:19 <bizhang> #idea Proposed for #2437: Skip this issue for this triage session.
15:33:20 <pulpbot> Proposed for #2437: Skip this issue for this triage session.
15:33:24 <smyers> !propose needinfo
15:33:24 <smyers> #idea Proposed for #2437: This issue cannot be triaged without more info.
15:33:25 <pulpbot> Proposed for #2437: This issue cannot be triaged without more info.
15:33:26 <smyers> :)
15:33:37 <bizhang> that makes more sense +1
15:33:43 <ipanova> +1
15:33:57 <bizhang> !accept
15:33:57 <bizhang> #agreed This issue cannot be triaged without more info.
15:33:57 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
15:33:58 <pulpbot> 2 issues left to triage: 2457, 2458
15:33:59 <bizhang> #topic When syncing do not associate units that are already associated to the repo - http://pulp.plan.io/issues/2457
15:33:59 <pulpbot> RPM Support Issue #2457 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:34:00 <pulpbot> When syncing do not associate units that are already associated to the repo - http://pulp.plan.io/issues/2457
15:34:38 <ipanova> this is related to the current performance investigation on sync
15:35:31 <mhrivnak> It is sort of a regression. A few Y releases back, pulp did not try to re-create every association.
15:35:43 <ttereshc> ipanova, I think it is still worth checking if unit is present on fs, since 2.8.7 has no force_full to fix it
15:35:53 <ipanova> ttereshc: agree
15:35:55 <mhrivnak> It seems to have changed in 2.8.
15:35:55 <ttereshc> but +1 for not adding to catalog or re-association
15:36:44 <mhrivnak> !propose triage high low
15:36:44 <mhrivnak> #idea Proposed for #2457: Priority: High, Severity: Low
15:36:45 <pulpbot> Proposed for #2457: Priority: High, Severity: Low
15:37:09 <mhrivnak> nothing incorrect is happening, hence suggesting low severity.
15:37:25 <ttereshc> do we need to fix description?
15:37:34 <ipanova> i'd propose for high/medium, since for customer it is blocking point
15:37:46 <ttereshc> Iunderstood it like we do not have to check fs
15:38:11 <mhrivnak> I'm fine with high/medium
15:38:23 <bizhang> is sprint 11 the right place for it?
15:38:28 <ipanova> ttereshc: we do have to check, existent code already does the check
15:38:32 <mhrivnak> On a system under heavy load, this can make a big performance impact.
15:39:04 <mhrivnak> bizhang, it should probably carry forward to sprint 12.
15:39:09 <bizhang> !propose triage high medium
15:39:09 <bizhang> #idea Proposed for #2457: Priority: High, Severity: Medium
15:39:10 <pulpbot> Proposed for #2457: Priority: High, Severity: Medium
15:39:17 <mhrivnak> which we can do on Monday when I sweep stuff into the new sprint.
15:39:22 <bizhang> mhrivnak, cool
15:39:31 <mhrivnak> +0
15:39:33 <mhrivnak> ;)
15:39:35 <bmbouter> :-)
15:39:36 <ipanova> works for me
15:40:01 <ttereshc> I think this perfomance issue still requires discussion
15:40:11 <ttereshc> but for this redmine issue -0
15:40:20 <ttereshc> ;)
15:40:26 <bizhang> !accept
15:40:26 <bizhang> #agreed Priority: High, Severity: Medium
15:40:26 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
15:40:28 <bizhang> #topic Lazy download repo content task fails silently. - http://pulp.plan.io/issues/2458
15:40:28 <pulpbot> 1 issues left to triage: 2458
15:40:29 <pulpbot> Pulp Issue #2458 [NEW] (unassigned) - Priority: High | Severity: Medium
15:40:30 <pulpbot> Lazy download repo content task fails silently. - http://pulp.plan.io/issues/2458
15:41:46 <bizhang> !propose accept
15:41:46 <bizhang> #idea Proposed for #2458: Leave the issue as-is, accepting its current state.
15:41:47 <pulpbot> Proposed for #2458: Leave the issue as-is, accepting its current state.
15:42:13 <mhrivnak> jortel, priority suggestions?
15:42:26 <mhrivnak> I guess the ones on there are your suggestions. :)
15:42:30 <jortel> !here
15:42:30 <jortel> #info jortel has joined triage
15:42:31 <pulpbot> jortel has joined triage
15:42:48 <jortel> yep
15:42:50 <mhrivnak> is this new in 2.10? Or might it affect 2.9 or even 2.8?
15:43:14 <ipanova> i see that there should be just change in the log to move from debug to info
15:43:15 <jortel> likely much earlier than 2.10
15:43:39 <jortel> probably 2.8 but would need to look
15:43:41 <mhrivnak> in addition to logging, should the task just raise an exception so it can have a "failed" state?
15:44:13 <jortel> yes, it probably should
15:44:42 <mhrivnak> +1 accept
15:44:58 <ttereshc> I think it is a discussion which happens now and then :) we had even an issue for that - you see failed and succeeded at the same time
15:44:59 <ipanova> mhrivnak: i do not think so, because there is just one unit that failed the download
15:45:12 <ipanova> mhrivnak: i think we already had this kind of discussion
15:45:29 <mhrivnak> Ah, I see.
15:45:33 <mhrivnak> You're right.
15:45:36 <smyers> I think we're good to triage it, even if the fix itself is still up for debate (on the issue, preferably)
15:45:37 <ipanova> where we would not make the overall task fail if some of the units were not synced successfully
15:46:01 <mhrivnak> Does the task's result or progress report show the failure somehow?
15:46:08 <ipanova> mhrivnak: it should
15:46:15 <ipanova> at least it was doing so
15:46:26 <jortel> I added a comment to the issue regarding the task failing
15:46:27 <mhrivnak> ok, great.
15:46:33 <ipanova> the report would show units that failed the download
15:46:50 <ipanova> let's triage as it is
15:46:52 <ipanova> +1
15:47:08 <bizhang> !accept
15:47:08 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:47:08 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:47:09 <pulpbot> No issues to triage.
15:47:13 <bizhang> !end
15:47:13 <bizhang> #endmeeting