15:29:18 <bizhang> #startmeeting Pulp Triage 2016-12-09
15:29:18 <bizhang> #info bizhang has joined triage
15:29:19 <pulpbot> Meeting started Fri Dec  9 15:29:18 2016 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:19 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:19 <pulpbot> The meeting name has been set to 'pulp_triage_2016_12_09'
15:29:19 <pulpbot> bizhang has joined triage
15:29:21 <daviddavis> !here
15:29:21 <daviddavis> #info daviddavis has joined triage
15:29:22 <pulpbot> daviddavis has joined triage
15:29:33 <dkliban> !here
15:29:33 <dkliban> #info dkliban has joined triage
15:29:33 <pulpbot> dkliban has joined triage
15:30:51 <pcreech> !here
15:30:51 <pcreech> #info pcreech has joined triage
15:30:52 <pulpbot> pcreech has joined triage
15:30:54 <bizhang> !next
15:30:55 <pulpbot> 5 issues left to triage: 2437, 2464, 2465, 2473, 2478
15:30:56 <bizhang> #topic Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:30:56 <pulpbot> Pulp Issue #2437 [NEW] (unassigned) - Priority: Normal | Severity: High
15:30:57 <pulpbot> Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:31:07 <dkliban> we still have not heard from this user
15:31:10 <dkliban> let
15:31:14 <ipanova> !here
15:31:14 <ipanova> #info ipanova has joined triage
15:31:16 <pulpbot> ipanova has joined triage
15:31:17 <dkliban> 's skip it again
15:31:19 <bmbouter> !here
15:31:19 <bmbouter> #info bmbouter has joined triage
15:31:19 <pulpbot> bmbouter has joined triage
15:31:26 <ttereshc> !here
15:31:26 <ttereshc> #info ttereshc has joined triage
15:31:26 <pulpbot> ttereshc has joined triage
15:31:32 <preethi> !here
15:31:32 <preethi> #info preethi has joined triage
15:31:33 <pulpbot> preethi has joined triage
15:31:39 <ipanova> dkliban: i propose if he does not reply till next triage, let's close it
15:31:52 <bizhang> !propose needsinfo
15:31:52 <pulpbot> Error: "propose" is not a valid command.
15:31:54 <dkliban> ipanova: sounds good to me
15:31:54 <mhrivnak> !here
15:31:54 <mhrivnak> #info mhrivnak has joined triage
15:31:55 <pulpbot> mhrivnak has joined triage
15:32:06 <bizhang> !triage propose needsinfo
15:32:06 <pulpbot> https://pulp.plan.io/issues?query_id=30
15:32:19 <bizhang> uggg it's been a week and I forgot all the triage commands
15:32:30 <bizhang> !propose triage needsinfo
15:32:31 <pulpbot> (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
15:32:35 <jortel> !here
15:32:35 <jortel> #info jortel has joined triage
15:32:35 <pulpbot> jortel has joined triage
15:32:38 <bizhang> !propose needsinfo
15:32:38 <pulpbot> Error: "propose" is not a valid command.
15:33:51 <smyers> needinfo
15:33:54 <smyers> not needsinfo
15:34:20 <bizhang> ah oops
15:34:21 <bizhang> !propose needinfo
15:34:21 <bizhang> #idea Proposed for #2437: This issue cannot be triaged without more info.
15:34:22 <pulpbot> Proposed for #2437: This issue cannot be triaged without more info.
15:34:45 <mhrivnak> +1
15:34:54 <ttereshc> +1
15:35:14 <bizhang> !accept
15:35:14 <bizhang> #agreed This issue cannot be triaged without more info.
15:35:14 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
15:35:16 <pulpbot> 4 issues left to triage: 2464, 2465, 2473, 2478
15:35:16 <bizhang> #topic pulp-admin broken in vagrant environment on 2.y - http://pulp.plan.io/issues/2464
15:35:17 <pulpbot> Pulp Issue #2464 [NEW] (unassigned) - Priority: High | Severity: Medium
15:35:18 <pulpbot> pulp-admin broken in vagrant environment on 2.y - http://pulp.plan.io/issues/2464
15:36:09 <smyers> !propose accept
15:36:09 <smyers> #idea Proposed for #2464: Leave the issue as-is, accepting its current state.
15:36:09 <smyers> #info smyers has joined triage
15:36:10 <pulpbot> smyers has joined triage
15:36:11 <pulpbot> Proposed for #2464: Leave the issue as-is, accepting its current state.
15:36:13 <smyers> pin it and forget it
15:36:22 <mhrivnak> Sounds good.
15:36:26 <bmbouter> cool
15:36:31 <bizhang> !accept
15:36:31 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:36:31 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:36:32 <pulpbot> 3 issues left to triage: 2465, 2473, 2478
15:36:32 <bizhang> #topic Vagrant env does not install goferd systemd file - http://pulp.plan.io/issues/2465
15:36:33 <pulpbot> Pulp Issue #2465 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:36:34 <pulpbot> Vagrant env does not install goferd systemd file - http://pulp.plan.io/issues/2465
15:37:33 <dkliban> medium normal?
15:37:38 <daviddavis> +1
15:37:41 <smyers> how does the rpm get installed without the systemd service O.o
15:38:11 <bmbouter> I'm not sure, but this is a 2.y only issue (no goferd) on 3.0-dev
15:38:39 <bmbouter> this used to work also (iirc)
15:38:43 <jortel> the systemd for goferd is installed with "gofer" rpm, not python-gofer
15:39:03 <bizhang> !propose accept
15:39:03 <bizhang> #idea Proposed for #2465: Leave the issue as-is, accepting its current state.
15:39:04 <pulpbot> Proposed for #2465: Leave the issue as-is, accepting its current state.
15:39:08 <dkliban> +1
15:39:09 <bmbouter> @jortel: can you comment on the issue with that
15:39:13 <jortel> sure
15:39:23 <bmbouter> ty
15:39:29 <bizhang> !propose other jortel to comment
15:39:29 <bizhang> #idea Proposed for #2465: jortel to comment
15:39:30 <pulpbot> Proposed for #2465: jortel to comment
15:39:33 <bizhang> !accept
15:39:33 <bizhang> #agreed jortel to comment
15:39:33 <pulpbot> Current proposal accepted: jortel to comment
15:39:34 <pulpbot> 2 issues left to triage: 2473, 2478
15:39:35 <bizhang> #topic mock: there is no such thing as assert_any_with - http://pulp.plan.io/issues/2473
15:39:35 <pulpbot> Pulp Issue #2473 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:39:36 <pulpbot> mock: there is no such thing as assert_any_with - http://pulp.plan.io/issues/2473
15:39:48 <smyers> heh, misa++
15:40:39 <bizhang> !propose accept
15:40:39 <bizhang> #idea Proposed for #2473: Leave the issue as-is, accepting its current state.
15:40:40 <pulpbot> Proposed for #2473: Leave the issue as-is, accepting its current state.
15:40:47 <elyezer> ichimonji10: thank you
15:41:03 <smyers> I did some testing with this, and I'm also not sure how those tests aren't failing right now.
15:41:15 <elyezer> dkliban: I will be able to work on it after finishing the upgrade testing for 2.11
15:41:19 <smyers> That said, I'ma be that guy, and...
15:41:22 <smyers> !propose low low
15:41:22 <pulpbot> Error: "propose" is not a valid command.
15:41:29 <smyers> !propose triage low low
15:41:29 <smyers> #idea Proposed for #2473: Priority: Low, Severity: Low
15:41:30 <pulpbot> Proposed for #2473: Priority: Low, Severity: Low
15:42:23 <dkliban> +1
15:42:43 <ttereshc> +1
15:43:13 <bizhang> should we also figure out why the tests aren't failing as a part of this?
15:43:32 <jortel> if tests are failing shouldn't this be higher priority?
15:43:38 <smyers> Tests aren't failing
15:43:57 <smyers> At least not in our PR tester?
15:44:40 <mhrivnak> If tests do start to fail, that will naturally bump the priority. :)
15:44:54 <smyers> That code has been in place for a very long time, so despite assert_any_with not being a mock method, we've been happily living with it for a while.
15:44:55 <jortel> makes sense
15:45:14 <bmbouter> it must be that the tests aren't running
15:45:33 <misa_> bmbouter: or an older mock library, as I was hinting
15:45:50 <bmbouter> oh yes that could also be it
15:46:02 <bizhang> in that case are we all good with low/low?
15:46:51 <dkliban> i am
15:46:56 <misa_> if somebody other than me (and I think smyers did) reproduce this, and only those two are failing, then low/low seems appropriate
15:47:12 <bizhang> !accept
15:47:12 <bizhang> #agreed Priority: Low, Severity: Low
15:47:13 <pulpbot> Current proposal accepted: Priority: Low, Severity: Low
15:47:14 <bizhang> #topic Support more conservative dependency solving - http://pulp.plan.io/issues/2478
15:47:14 <pulpbot> 1 issues left to triage: 2478
15:47:15 <pulpbot> RPM Support Issue #2478 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:47:16 <pulpbot> Support more conservative dependency solving - http://pulp.plan.io/issues/2478
15:47:50 <smyers> I only reproduced it in a shell, basically just ran Mock().assert_any_with
15:48:19 <smyers> I was curious about #2478, because I thought we already filtered the dependency list to filter out old evrs with the same name
15:48:52 <smyers> I'm not very sure about that, though, so I don't feel confident calling regression
15:49:27 <mhrivnak> #2478 is an RFE
15:49:48 <jortel> agreed
15:50:01 <mhrivnak> right now, you can copy an erratum by itself, or copy it with "dep solving" on.
15:50:18 <mhrivnak> when dep solving is on, it grabs all the RPMs listed in the errata, plus all of their dependencies.
15:50:38 <mhrivnak> He's asking us to add an option to grab just the RPMs listed in the erratum.
15:51:13 <bizhang> !propose other change to story
15:51:13 <bizhang> #idea Proposed for #2478: change to story
15:51:14 <pulpbot> Proposed for #2478: change to story
15:51:45 <mhrivnak> +1
15:51:45 <smyers> That's not my understanding, rather it's to grab the RPMs listed in the erratum, and the latest known versions of the deps
15:52:01 <dkliban> that is not my understanding either. nothing about erratum in this issue
15:52:16 <dkliban> jsherrill: care to coomment on #2478?
15:52:21 <mhrivnak> oh crap, you're right. Wrong issue in my brain. :)
15:52:24 <smyers> he specifically gives the example that a single package is requested, and only the latest version of the dep should come with it in the example
15:52:26 * mhrivnak re-reads
15:53:00 <smyers> And I thought we actually did already do that, I just don't remember where (or in which) workflow we do it
15:53:01 <mhrivnak> Ok yes, still an RFE, but to be less greedy when dep solving.
15:53:14 <smyers> More greedy
15:53:14 <jsherrill> smyers: well the 2nd part was to not pull in the newest version if its already solved in the destination repo
15:53:27 <jsherrill> yes :)
15:53:45 <smyers> (I guess it depends on whether or not you interpret "conservative" to be "greedy" in this case)
15:54:29 <smyers> jsherrill, *not* pull in the latest version? That seems odd
15:54:37 <mhrivnak> Gotcha. I was just thinking about "greedy" being that it matches more stuff.
15:54:47 <smyers> regex greedy, got it
15:55:06 <ttereshc> smyers, I think it is more about *needed* version
15:55:11 <ttereshc> it may not be hte latest
15:55:21 <smyers> All makes sense, +1 RFE
15:56:11 <smyers> I think the particular example pointing to how yum update <pkg> behaves is particularly helpful, because I also think that's a little odd in exactly the same way :)
15:57:00 <mhrivnak> heh
15:57:01 <ttereshc> +1 for story
15:57:04 <bizhang> !accept
15:57:04 <bizhang> #agreed change to story
15:57:05 <pulpbot> Current proposal accepted: change to story
15:57:06 <pulpbot> No issues to triage.
15:57:10 <bizhang> !end
15:57:10 <bizhang> #endmeeting