15:29:21 <bizhang> #startmeeting Pulp Triage 2016-12-13
15:29:21 <bizhang> #info bizhang has joined triage
15:29:22 <pulpbot> Meeting started Tue Dec 13 15:29:21 2016 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:22 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:22 <pulpbot> The meeting name has been set to 'pulp_triage_2016_12_13'
15:29:22 <pulpbot> bizhang has joined triage
15:29:24 <mhrivnak> !here
15:29:24 <mhrivnak> #info mhrivnak has joined triage
15:29:24 <pulpbot> mhrivnak has joined triage
15:29:26 <daviddavis> !here
15:29:26 <daviddavis> #info daviddavis has joined triage
15:29:26 <pulpbot> daviddavis has joined triage
15:30:14 <jortel> !here
15:30:14 <jortel> #info jortel has joined triage
15:30:15 <pulpbot> jortel has joined triage
15:30:20 <bizhang> !next
15:30:21 <pulpbot> 6 issues left to triage: 2315, 2437, 2483, 2485, 2486, 2487
15:30:21 <bizhang> #topic Better logging at INFO level - http://pulp.plan.io/issues/2315
15:30:22 <pulpbot> Nectar Issue #2315 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:30:22 <dkliban> !here
15:30:22 <dkliban> #info dkliban has joined triage
15:30:22 <pulpbot> Better logging at INFO level - http://pulp.plan.io/issues/2315
15:30:23 <pulpbot> dkliban has joined triage
15:31:10 <bmbouter> !here
15:31:10 <bmbouter> #info bmbouter has joined triage
15:31:10 <pulpbot> bmbouter has joined triage
15:31:35 <bmbouter> I think this is coming up because it was private before
15:31:42 <pcreech> !here
15:31:42 <pcreech> #info pcreech has joined triage
15:31:43 <pulpbot> pcreech has joined triage
15:31:57 <bmbouter> oh no wait somehow I untriaged it
15:31:59 <mhrivnak> bmbouter, looks like you moved it from being a story to an issue.
15:32:02 <ipanova> !here
15:32:02 <ipanova> #info ipanova has joined triage
15:32:03 <pulpbot> ipanova has joined triage
15:32:04 <bmbouter> oh that is why
15:32:33 <bmbouter> I moved it to be an issue since it is an issue and also then it can become part of a z release for nectar
15:32:51 <bmbouter> this is one that we should put onto the sprint
15:33:04 <mhrivnak> I see. I'm on the fence about issue vs. some other type, since nothing is broken.
15:33:10 <mhrivnak> But I don't feel that strongly about it.
15:33:24 <bizhang> !propose other put on sprint 13
15:33:24 <bizhang> #idea Proposed for #2315: put on sprint 13
15:33:25 <pulpbot> Proposed for #2315: put on sprint 13
15:33:27 <bizhang> !propose accept
15:33:27 <bizhang> #idea Proposed for #2315: Leave the issue as-is, accepting its current state.
15:33:28 <pulpbot> Proposed for #2315: Leave the issue as-is, accepting its current state.
15:33:49 <mhrivnak> works for me.
15:33:51 <ttereshc> !here
15:33:51 <ttereshc> #info ttereshc has joined triage
15:33:52 <bmbouter> I generally agree, but an issue I think is the best because otherwise the release won't have any bugs
15:33:52 <pulpbot> ttereshc has joined triage
15:34:21 <bmbouter> +1 to current state and putting on sprint
15:34:41 <bizhang> !accept
15:34:41 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:34:42 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:34:43 <pulpbot> 5 issues left to triage: 2437, 2483, 2485, 2486, 2487
15:34:43 <bizhang> #topic Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:34:44 <pulpbot> Pulp Issue #2437 [NEW] (unassigned) - Priority: Normal | Severity: High
15:34:44 <pulpbot> Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:35:20 <ipanova> i suggest to close this
15:35:32 <mhrivnak> +1
15:35:42 <mhrivnak> close as worksforme?
15:35:48 <mhrivnak> Or some other reason?
15:35:51 <bmbouter> yes, and also invite them to re open if they can reproduce
15:36:01 <bmbouter> +1 worksforme
15:36:03 <dkliban> +1
15:36:04 <bmbouter> or give more input
15:36:05 <bizhang> !propose close worksforme
15:36:05 <pulpbot> Error: "propose" is not a valid command.
15:36:14 <bizhang> !propose other close worksforme
15:36:14 <bizhang> #idea Proposed for #2437: close worksforme
15:36:15 <pulpbot> Proposed for #2437: close worksforme
15:36:20 <bizhang> !accept
15:36:20 <bizhang> #agreed close worksforme
15:36:21 <jortel> +1
15:36:21 <pulpbot> Current proposal accepted: close worksforme
15:36:22 <bizhang> #topic pulp_rpm migration 0031 fails: cursor not found - http://pulp.plan.io/issues/2483
15:36:22 <pulpbot> 4 issues left to triage: 2483, 2485, 2486, 2487
15:36:23 <pulpbot> Pulp Issue #2483 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:36:24 <pulpbot> pulp_rpm migration 0031 fails: cursor not found - http://pulp.plan.io/issues/2483
15:38:03 <mhrivnak> I'm surprised we haven't seen this sooner.
15:39:40 <mhrivnak> !propose triage high high
15:39:40 <mhrivnak> #idea Proposed for #2483: Priority: High, Severity: High
15:39:40 <pulpbot> Proposed for #2483: Priority: High, Severity: High
15:39:45 <dkliban> +1
15:39:46 <jortel> +1
15:39:49 <ttereshc> yeah but it's 100K+ repositories
15:39:52 <ttereshc> +1
15:39:58 <bizhang> !accept
15:39:58 <bizhang> #agreed Priority: High, Severity: High
15:39:58 <pulpbot> Current proposal accepted: Priority: High, Severity: High
15:39:59 <pulpbot> 3 issues left to triage: 2485, 2486, 2487
15:39:59 <bizhang> #topic Downloading a RPM synced with different download_policies raises 500 Internal Server Error - http://pulp.plan.io/issues/2485
15:40:00 <pulpbot> Pulp Issue #2485 [NEW] (unassigned) - Priority: Urgent | Severity: High
15:40:01 <pulpbot> Downloading a RPM synced with different download_policies raises 500 Internal Server Error - http://pulp.plan.io/issues/2485
15:40:56 <mhrivnak> !propose skip
15:40:56 <mhrivnak> #idea Proposed for #2485: Skip this issue for this triage session.
15:40:56 <pulpbot> Proposed for #2485: Skip this issue for this triage session.
15:41:02 <mhrivnak> likely to be closed as notabug
15:41:05 <pcreech> +1
15:41:13 <ttereshc> +1
15:41:18 <bizhang> !accept
15:41:18 <bizhang> #agreed Skip this issue for this triage session.
15:41:18 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
15:41:19 <pulpbot> 2 issues left to triage: 2486, 2487
15:41:20 <bizhang> #topic Search is broken on docs site - http://pulp.plan.io/issues/2486
15:41:20 <pulpbot> Pulp Issue #2486 [NEW] (unassigned) - Priority: High | Severity: Medium
15:41:21 <pulpbot> Search is broken on docs site - http://pulp.plan.io/issues/2486
15:41:41 <bizhang> !propose accept
15:41:41 <bizhang> #idea Proposed for #2486: Leave the issue as-is, accepting its current state.
15:41:42 <pulpbot> Proposed for #2486: Leave the issue as-is, accepting its current state.
15:41:49 <bmbouter> I know the sprint selection is laser focused, but consider adding this to the sprint
15:42:19 <daviddavis> +1 seems like an easy fix
15:42:24 <dkliban> yeah ... we need to fix this ASAP. i had a hard time with our docs yesterday
15:42:36 <mhrivnak> +1
15:42:39 <bizhang> !propose other add to sprint 13
15:42:39 <bizhang> #idea Proposed for #2486: add to sprint 13
15:42:40 <jortel> +1
15:42:40 <pulpbot> Proposed for #2486: add to sprint 13
15:42:45 <bizhang> !accept
15:42:45 <bizhang> #agreed add to sprint 13
15:42:46 <pulpbot> Current proposal accepted: add to sprint 13
15:42:46 <bizhang> #topic Sync failure - DocumentTooLarge - http://pulp.plan.io/issues/2487
15:42:47 <pulpbot> 1 issues left to triage: 2487
15:42:48 <pulpbot> Pulp Issue #2487 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:42:49 <pulpbot> Sync failure - DocumentTooLarge - http://pulp.plan.io/issues/2487
15:43:43 <mhrivnak> Now that is surprising.
15:43:52 <mhrivnak> We've seen this before when an RPM has a huge file list
15:44:06 <jortel> or perhaps the changelog is huge
15:44:10 <mhrivnak> But it's surprising to see that some rpm in the foreman repo exceeds that limit.
15:44:46 <jortel> seems like high/high to me
15:45:03 <mhrivnak> agreed.
15:45:11 <bizhang> !propose triage high high
15:45:11 <bizhang> #idea Proposed for #2487: Priority: High, Severity: High
15:45:12 <pulpbot> Proposed for #2487: Priority: High, Severity: High
15:45:17 <mhrivnak> FWIW another katello user saw this last week with a different repo.
15:45:25 <mhrivnak> but worked around it by omitting one particular RPM they didn't need.
15:46:04 <jortel> true. so long as we're on mongo there is always a chance we can hit this unless we truncate the fields as needed.
15:46:17 <jortel> ugh.
15:46:25 <mhrivnak> compression is also an option to buy us a lot more room.
15:46:31 <jortel> true
15:46:34 <bizhang> are we all good with high high?
15:46:34 <mhrivnak> but anyway, those are implementation details. :)
15:46:38 <mhrivnak> +1
15:46:47 <ttereshc> +1
15:46:50 <dkliban> +1
15:46:54 <bizhang> !accept
15:46:54 <bizhang> #agreed Priority: High, Severity: High
15:46:54 <pulpbot> Current proposal accepted: Priority: High, Severity: High
15:46:56 <pulpbot> No issues to triage.
15:47:02 <daviddavis> woo
15:47:04 <bizhang> !issue 2483
15:47:05 <bizhang> #topic pulp_rpm migration 0031 fails: cursor not found - http://pulp.plan.io/issues/2483
15:47:05 <pulpbot> Pulp Issue #2483 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:47:06 <pulpbot> pulp_rpm migration 0031 fails: cursor not found - http://pulp.plan.io/issues/2483
15:47:09 <mhrivnak> quick addition here
15:47:14 <jortel> mhrivnak: yeah, I know ..
15:47:25 <mhrivnak> Agreed to add a BZ for this and add it to the current sprint?
15:47:44 <jortel> +1
15:47:48 <dkliban> +1
15:47:49 <daviddavis> worx4me
15:47:55 <mhrivnak> daviddavis, hah
15:48:14 <bizhang> does anyone want to volunteer to add the BZ?
15:48:45 <dkliban> bizhang: i can do it
15:49:02 <bizhang> !propose other dkliban to add BZ, add to sprint 13
15:49:02 <bizhang> #idea Proposed for #2483: dkliban to add BZ, add to sprint 13
15:49:03 <pulpbot> Proposed for #2483: dkliban to add BZ, add to sprint 13
15:49:07 <bizhang> !accept
15:49:07 <bizhang> #agreed dkliban to add BZ, add to sprint 13
15:49:07 <pulpbot> Current proposal accepted: dkliban to add BZ, add to sprint 13
15:49:08 <pulpbot> No issues to triage.
15:49:13 <bizhang> !end
15:49:13 <bizhang> #endmeeting