15:29:20 <bizhang> #startmeeting Pulp Triage 2016-12-16
15:29:20 <bizhang> #info bizhang has joined triage
15:29:20 <pulpbot> Meeting started Fri Dec 16 15:29:20 2016 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:20 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:20 <pulpbot> The meeting name has been set to 'pulp_triage_2016_12_16'
15:29:21 <pulpbot> bizhang has joined triage
15:29:21 <misa_> f-in unfortunate to find that out when I do the big migration in a few hours
15:29:30 <mhrivnak> !here
15:29:30 <mhrivnak> #info mhrivnak has joined triage
15:29:31 <pulpbot> mhrivnak has joined triage
15:29:35 <bmbouter> !here
15:29:35 <bmbouter> #info bmbouter has joined triage
15:29:35 <pulpbot> bmbouter has joined triage
15:29:40 <dkliban> !here
15:29:40 <dkliban> #info dkliban has joined triage
15:29:40 <pulpbot> dkliban has joined triage
15:29:49 <bizhang> !next
15:29:50 <pulpbot> 5 issues left to triage: 2437, 2491, 2492, 2493, 2494
15:29:50 <bizhang> #topic Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:29:51 <pulpbot> Pulp Issue #2437 [NEW] (unassigned) - Priority: Normal | Severity: High
15:29:52 <pulpbot> Upgrade from 2.8.0 to 2.10.2:  Post upgrade publish creates invalid links for pre-upgrade files - http://pulp.plan.io/issues/2437
15:29:59 <pcreech> !here
15:29:59 <pcreech> #info pcreech has joined triage
15:30:00 <pulpbot> pcreech has joined triage
15:30:31 <dkliban> mark as triaged
15:30:40 <dkliban> jortel is already helping the user figure it out
15:30:57 <daviddavis> #info daviddavis has joined triage
15:30:57 <daviddavis> !here
15:30:57 <pulpbot> daviddavis has joined triage
15:31:09 <ttereshc> !here
15:31:09 <ttereshc> #info ttereshc has joined triage
15:31:10 <pulpbot> ttereshc has joined triage
15:31:17 <bizhang> !propose accept
15:31:17 <bizhang> #idea Proposed for #2437: Leave the issue as-is, accepting its current state.
15:31:18 <pulpbot> Proposed for #2437: Leave the issue as-is, accepting its current state.
15:31:24 <dkliban> +1
15:31:29 <bmbouter> +1
15:32:04 <bizhang> !accept
15:32:04 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:32:05 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:32:05 <bizhang> #topic When stopping pulp_workers, pulp_celerybeat, and pulp_resource_manager gracefully, the status API still shows them as running - http://pulp.plan.io/issues/2491
15:32:06 <pulpbot> 4 issues left to triage: 2491, 2492, 2493, 2494
15:32:07 <pulpbot> Pulp Issue #2491 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:08 <pulpbot> When stopping pulp_workers, pulp_celerybeat, and pulp_resource_manager gracefully, the status API still shows them as running - http://pulp.plan.io/issues/2491
15:32:24 <mhrivnak> This is very unfortunate.
15:32:28 <bmbouter> indeed
15:32:31 <mhrivnak> !propose triage high high
15:32:31 <mhrivnak> #idea Proposed for #2491: Priority: High, Severity: High
15:32:31 <pulpbot> Proposed for #2491: Priority: High, Severity: High
15:32:37 <dkliban> +1
15:32:39 <bmbouter> also we should put this on a sprint
15:32:47 <mhrivnak> agreed.
15:32:48 <bmbouter> s/a /the /
15:33:02 <bizhang> !propose other put on sprint 13
15:33:02 <bizhang> #idea Proposed for #2491: put on sprint 13
15:33:03 <pulpbot> Proposed for #2491: put on sprint 13
15:33:19 <ttereshc> +1
15:33:30 <bizhang> #agreed put on sprint 13
15:33:30 <bizhang> !accept
15:33:30 <pulpbot> Current proposal accepted: put on sprint 13
15:33:32 <pulpbot> 3 issues left to triage: 2492, 2493, 2494
15:33:32 <bizhang> #topic Small memory leak in httpd when dispatching Pulp tasks - http://pulp.plan.io/issues/2492
15:33:33 <pulpbot> Pulp Issue #2492 [NEW] (unassigned) - Priority: Normal | Severity: Low
15:33:34 <pulpbot> Small memory leak in httpd when dispatching Pulp tasks - http://pulp.plan.io/issues/2492
15:34:34 <bmbouter> I propose accept and it has a BZ attached
15:34:42 <bmbouter> I'm not sure if you want this on the sprint or not
15:34:54 <mhrivnak> +1 add to sprint
15:34:57 <dkliban> +1
15:35:01 <bizhang> !propose accept
15:35:01 <bizhang> #idea Proposed for #2492: Leave the issue as-is, accepting its current state.
15:35:02 <pulpbot> Proposed for #2492: Leave the issue as-is, accepting its current state.
15:35:07 <bizhang> !propose other add to sprint
15:35:07 <bizhang> #idea Proposed for #2492: add to sprint
15:35:08 <pulpbot> Proposed for #2492: add to sprint
15:35:14 <bizhang> !accept
15:35:14 <bizhang> #agreed add to sprint
15:35:14 <pulpbot> Current proposal accepted: add to sprint
15:35:15 <pulpbot> 2 issues left to triage: 2493, 2494
15:35:16 <bizhang> #topic http://pulpproject.org/docs/ missing links to 2.10 and 2.11 stable docs - http://pulp.plan.io/issues/2493
15:35:16 <pulpbot> Pulp Issue #2493 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:35:17 <pulpbot> http://pulpproject.org/docs/ missing links to 2.10 and 2.11 stable docs - http://pulp.plan.io/issues/2493
15:35:57 <bmbouter> maybe this is not important but we use the github issue tracker for pulpproject.org issues
15:36:07 <bmbouter> https://github.com/pulp/pulpproject.org/issues/
15:36:08 <pulpbot> Title: Issues · pulp/pulpproject.org · GitHub (at github.com)
15:36:19 <dkliban> bmbouter: i thought about this when filing, but since this is about docs i put it here so we would triage it
15:36:32 <misa_> !here
15:36:32 <misa_> #info misa_ has joined triage
15:36:33 <pulpbot> misa_ has joined triage
15:36:43 <bmbouter> dkliban: that makes sense
15:36:52 <bizhang> !propose accept
15:36:52 <bizhang> #idea Proposed for #2493: Leave the issue as-is, accepting its current state.
15:36:53 <pulpbot> Proposed for #2493: Leave the issue as-is, accepting its current state.
15:37:11 <dkliban> +1
15:37:45 <ttereshc> +1
15:38:18 <bizhang> !accept
15:38:18 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:38:18 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:38:19 <pulpbot> 1 issues left to triage: 2494
15:38:20 <bizhang> #topic rename of id to package_group_id did not also populate a 'package_group_id' field in a unit's metadata section - http://pulp.plan.io/issues/2494
15:38:20 <pulpbot> Pulp Issue #2494 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:38:21 <pulpbot> rename of id to package_group_id did not also populate a 'package_group_id' field in a unit's metadata section - http://pulp.plan.io/issues/2494
15:40:05 <misa_> context: I thought all fields listed as unit key in the api would be returned by the api when fetching a single unit, and that is no longer true in 2.10
15:40:05 <misa_> or 2.8+ for that matter
15:40:08 <jortel> !here
15:40:08 <jortel> #info jortel has joined triage
15:40:08 <pulpbot> jortel has joined triage
15:41:21 <mhrivnak> misa_, when we moved modelling to use mongoengine, we had to rename some "id" fields as you see here, but did our best to add serializers that "fix" them on the way in and out of the API.
15:41:31 <mhrivnak> So the previous behavior would be preserved, and the API user wouldn't be impacted.
15:41:42 <misa_> yes, you did that :-)
15:41:53 <mhrivnak> I think you've just found a place in the API we missed.
15:41:57 <mhrivnak> Does that sound right?
15:42:01 <mhrivnak> Or is there more to it?
15:42:15 <misa_> I *think* you achieved your goal
15:42:26 <misa_> My point is that you now broke what I thought was an invariant
15:42:56 <misa_> package group units still have an 'id', to preserve backwards compat. That's great
15:43:18 <misa_> They should also have had a package_group_id (identical) because you claim there is a unit key field named package_group_id
15:44:28 <mhrivnak> Gotcha.
15:44:52 <mhrivnak> So it seems like this is a consistency issue we need to fix. Anyone else have thoughts?
15:45:58 * mhrivnak is juggling a separate IRC discussion and could use help getting this one wrapped up
15:46:05 <bizhang> !propose accept
15:46:05 <bizhang> #idea Proposed for #2494: Leave the issue as-is, accepting its current state.
15:46:06 <pulpbot> Proposed for #2494: Leave the issue as-is, accepting its current state.
15:46:09 <ttereshc> it seems like a valid point to me to expect unit key fields in response
15:46:16 <ttereshc> all of them
15:47:23 <elyezer> ichimonji10++
15:47:23 <pulpbot> ichimonji10's karma is now 81
15:47:30 <ichimonji10> :)
15:48:00 <bizhang> If no one has anymore suggestions I will accept this issue as-is, since I think we do need to fix it
15:48:06 <jortel> +1
15:48:10 <ttereshc> +1 for accept
15:48:30 <bizhang> !accept
15:48:30 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:48:30 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:48:32 <pulpbot> No issues to triage.
15:48:34 <bizhang> !end
15:48:34 <bizhang> #endmeeting