15:29:22 <bizhang> #startmeeting Pulp Triage 2016-12-20
15:29:22 <bizhang> #info bizhang has joined triage
15:29:23 <pulpbot> Meeting started Tue Dec 20 15:29:22 2016 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:23 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:23 <pulpbot> The meeting name has been set to 'pulp_triage_2016_12_20'
15:29:23 <pulpbot> bizhang has joined triage
15:30:07 <elyezer> dkliban: that helps, but when I create a puppet repo with http://forge.puppetlabs.com as the feed and use the --queries <query> option it will do the query by issuing a GET request at http://forge.puppetlabs.com/modules.json?q=<query> but that is accessing other place, will try to play and figure it out. Thanks for the help
15:30:20 <bmbouter> !here
15:30:20 <bmbouter> #info bmbouter has joined triage
15:30:21 <pulpbot> bmbouter has joined triage
15:31:29 <ttereshc> !руку
15:31:29 <pulpbot> Error: "руку" is not a valid command.
15:31:34 <ttereshc> !here
15:31:34 <ttereshc> #info ttereshc has joined triage
15:31:35 <pulpbot> ttereshc has joined triage
15:31:38 <dkliban> !here
15:31:38 <dkliban> #info dkliban has joined triage
15:31:39 <pulpbot> dkliban has joined triage
15:31:43 <bizhang> !next
15:31:44 <pulpbot> 5 issues left to triage: 2495, 2496, 2497, 2499, 2500
15:31:45 <bizhang> #topic When generating applicability data for multiple repositories, tasks throws error CursorNotFound - http://pulp.plan.io/issues/2495
15:31:45 <pulpbot> RPM Support Issue #2495 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:31:45 <pulpbot> When generating applicability data for multiple repositories, tasks throws error CursorNotFound - http://pulp.plan.io/issues/2495
15:32:14 <bizhang> !propose needsinfo
15:32:14 <pulpbot> Error: "propose" is not a valid command.
15:32:19 <asmacdo> !join
15:32:19 <pulpbot> Error: You don't have the admin capability. If you think that you should have this capability, be sure that you are identified before trying again. The 'whoami' command can tell you if you're identified.
15:32:22 <asmacdo> !here
15:32:22 <asmacdo> #info asmacdo has joined triage
15:32:22 <pulpbot> asmacdo has joined triage
15:32:24 <bizhang> !propose other needinfo
15:32:24 <bizhang> #idea Proposed for #2495: needinfo
15:32:24 <pulpbot> Proposed for #2495: needinfo
15:33:05 <asmacdo> +1
15:33:51 <dkliban> +1
15:33:52 <ttereshc> +1 I think we can wait, hopefully user will come back with info after upgrade
15:34:00 <bizhang> !accept
15:34:00 <bizhang> #agreed needinfo
15:34:00 <pulpbot> Current proposal accepted: needinfo
15:34:01 <bizhang> #topic Killing pulp_workers, pulp_celerybeat, and pulp_resource_manager causes the status API still shows them as running - http://pulp.plan.io/issues/2496
15:34:02 <pulpbot> 4 issues left to triage: 2496, 2497, 2499, 2500
15:34:02 <pulpbot> Pulp Issue #2496 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:34:03 <pulpbot> Killing pulp_workers, pulp_celerybeat, and pulp_resource_manager causes the status API still shows them as running - http://pulp.plan.io/issues/2496
15:34:50 <bmbouter> in thinking about the reliability of celerybeat I realized this
15:35:00 <daviddavis> !here
15:35:00 <daviddavis> #info daviddavis has joined triage
15:35:00 <pulpbot> daviddavis has joined triage
15:35:04 <pcreech> !here
15:35:04 <pcreech> #info pcreech has joined triage
15:35:05 <pulpbot> pcreech has joined triage
15:35:12 <dkliban> yeah ... i think this is high severity
15:35:30 <bmbouter> agreed, there is also a plan outlined on the bug
15:35:32 <bmbouter> iirc
15:35:48 <bizhang> I'm not sure if this should be high, since it's only an issue when we kill processes
15:36:19 <bizhang> not when we stop them cleanly with systemctl right?
15:36:23 <dkliban> it's an issue when processes segfault and pulp can't go on
15:36:29 <bmbouter> or the OOM
15:36:41 <bmbouter> or a stray SIGKILL to the wrong pid
15:36:49 <dkliban> and then katello thinks taht pulp is still operating
15:37:01 <bizhang> ah gotcha
15:37:11 <bmbouter> severity could be med I think, my main interest is wondering if this is sprint material or not
15:38:22 <asmacdo> seems like a high value bugfix to me, I'd +1 adding to the sprint
15:38:30 <dkliban> i think it's sprint worthy also
15:38:33 <bizhang> +1 from me too
15:38:41 <bizhang> !propose other add to sprint
15:38:41 <bizhang> #idea Proposed for #2496: add to sprint
15:38:42 <pulpbot> Proposed for #2496: add to sprint
15:38:44 <bmbouter> +1
15:38:53 <dkliban> +1 ... and +1 to the plan outlined there
15:39:09 <bizhang> we're ok with med/med?
15:39:25 <dkliban> as long as we add it to the sprint also
15:40:05 <bizhang> !accept
15:40:05 <bizhang> #agreed add to sprint
15:40:05 <pulpbot> Current proposal accepted: add to sprint
15:40:07 <bizhang> #topic Vagrant installs pulp-server rpm - http://pulp.plan.io/issues/2497
15:40:07 <pulpbot> 3 issues left to triage: 2497, 2499, 2500
15:40:08 <pulpbot> Pulp Issue #2497 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:40:09 <pulpbot> Vagrant installs pulp-server rpm - http://pulp.plan.io/issues/2497
15:40:53 <bizhang> !propose accept
15:40:53 <bizhang> #idea Proposed for #2497: Leave the issue as-is, accepting its current state.
15:40:53 <pulpbot> Proposed for #2497: Leave the issue as-is, accepting its current state.
15:41:05 <dkliban> i am good with the severity and priority. just want to add it to the sprint. anything affecting our dev environments should be fixed right away
15:41:20 <daviddavis> +1
15:41:51 <bmbouter> +1
15:41:51 <ttereshc> !propose other add to sprint
15:41:51 <ttereshc> #idea Proposed for #2497: add to sprint
15:41:52 <pulpbot> Proposed for #2497: add to sprint
15:42:13 <bizhang> !accept
15:42:13 <bizhang> #agreed add to sprint
15:42:13 <pulpbot> Current proposal accepted: add to sprint
15:42:14 <pulpbot> 2 issues left to triage: 2499, 2500
15:42:15 <bizhang> #topic 'Last Unit Added' attribute not updated - http://pulp.plan.io/issues/2499
15:42:15 <pulpbot> Pulp Issue #2499 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:42:15 <pulpbot> 'Last Unit Added' attribute not updated - http://pulp.plan.io/issues/2499
15:42:48 <mhrivnak> !here
15:42:48 <mhrivnak> #info mhrivnak has joined triage
15:42:48 <pulpbot> mhrivnak has joined triage
15:43:51 <dkliban> high severity
15:44:04 <ttereshc> we have rm #1847
15:44:04 <pulpbot> Pulp Issue #1847 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:44:05 <pulpbot> last_unit_added is not added in mongo repo collection records - http://pulp.plan.io/issues/1847
15:45:17 <dkliban> we can close it as a duplicate, but we should bump up the  severity.
15:45:20 <ttereshc> and a workaround https://pulp.plan.io/issues/1847#note-3
15:45:22 <pulpbot> Title: Issue #1847: last_unit_added is not added in mongo repo collection records - Pulp (at pulp.plan.io)
15:45:30 <mhrivnak> ah, good find.
15:45:58 <ttereshc> I can comment on new issue and close as dup
15:46:10 <bizhang> !propose other ttereshc to comment and close
15:46:10 <bizhang> #idea Proposed for #2499: ttereshc to comment and close
15:46:11 <pulpbot> Proposed for #2499: ttereshc to comment and close
15:46:14 <asmacdo> +1
15:46:27 <dkliban> but what about actually fixing the 1847?
15:46:52 <dkliban> it seems like we added a backwards incompatible change
15:46:55 <mhrivnak> shall we accept this, and re-triage 1847?
15:47:09 <bizhang> +1
15:47:17 <dkliban> +1
15:47:22 <bizhang> !accept
15:47:22 <bizhang> #agreed ttereshc to comment and close
15:47:22 <pulpbot> Current proposal accepted: ttereshc to comment and close
15:47:23 <pulpbot> 1 issues left to triage: 2500
15:47:24 <bizhang> #topic Error message is generic when uploading module with invalid name - http://pulp.plan.io/issues/2500
15:47:24 <pulpbot> Puppet Support Issue #2500 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:47:24 <pulpbot> Error message is generic when uploading module with invalid name - http://pulp.plan.io/issues/2500
15:48:14 <bizhang> #idea Proposed for #2500: Leave the issue as-is, accepting its current state.
15:48:14 <bizhang> !propose accept
15:48:14 <pulpbot> Proposed for #2500: Leave the issue as-is, accepting its current state.
15:48:26 <daviddavis> +0.9999999
15:48:40 <bizhang> daviddavis, lol
15:48:44 <daviddavis> :D
15:49:12 <mhrivnak> and add to sprint 13
15:49:18 <daviddavis> +1 to that too
15:49:24 <daviddavis> seems like an easy fix
15:49:31 <mhrivnak> I was thinking the same thing.
15:49:41 <bizhang> !propose other add to sprint 13, add tag easyfix
15:49:41 <bizhang> #idea Proposed for #2500: add to sprint 13, add tag easyfix
15:49:42 <pulpbot> Proposed for #2500: add to sprint 13, add tag easyfix
15:49:55 <ttereshc> is it possible that some details are visible but buried somewhere deep in the response?
15:50:13 <dkliban> ttereshc: they are not
15:50:13 <ttereshc> they are ususally visible with pulp-admin -vv
15:50:20 <ttereshc> dkliban, ok
15:50:46 <dkliban> ttereshc: but i will try out your suggestion
15:50:46 <ttereshc> they are not in the final message but sometimes can be extracted from the structure
15:51:02 <mhrivnak> I also wondered if more info might be in the task somewhere.
15:51:32 <bizhang> but either way we should return a clear error message without the user having to dig for it
15:52:24 <bizhang> any more comments before I accept this?
15:52:48 <ttereshc> +1
15:52:54 <dkliban> mhrivnak: ttereshc: we are very inconsistent about the content of the response and content of task status. it all depends on which importer or distributor is returning this
15:52:59 <dkliban> +1
15:53:02 <bizhang> !accept
15:53:02 <bizhang> #agreed add to sprint 13, add tag easyfix
15:53:02 <pulpbot> Current proposal accepted: add to sprint 13, add tag easyfix
15:53:04 <pulpbot> No issues to triage.
15:53:08 <bizhang> !issue 1847
15:53:09 <bizhang> #topic last_unit_added is not added in mongo repo collection records - http://pulp.plan.io/issues/1847
15:53:09 <pulpbot> Pulp Issue #1847 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:53:09 <pulpbot> last_unit_added is not added in mongo repo collection records - http://pulp.plan.io/issues/1847
15:53:48 <dkliban> normal priority, high severity, add to sprint?
15:54:00 <mhrivnak> I have a BZ in mind this could probably be aligned to.
15:54:25 <mhrivnak> +1.0000001
15:54:33 <bizhang> #idea Proposed for #1847: Priority: Normal, Severity: High
15:54:33 <bizhang> !propose triage normal high
15:54:33 <pulpbot> Proposed for #1847: Priority: Normal, Severity: High
15:54:52 <bizhang> !propose other add to sprint 13 mhrivnak to add BZ
15:54:52 <bizhang> #idea Proposed for #1847: add to sprint 13 mhrivnak to add BZ
15:54:52 <pulpbot> Proposed for #1847: add to sprint 13 mhrivnak to add BZ
15:55:17 <ttereshc> +1
15:55:53 <bizhang> !accept
15:55:53 <bizhang> #agreed add to sprint 13 mhrivnak to add BZ
15:55:53 <pulpbot> Current proposal accepted: add to sprint 13 mhrivnak to add BZ
15:55:54 <pulpbot> No issues to triage.
15:55:55 <daviddavis> mhrivnak++
15:55:55 <pulpbot> mhrivnak's karma is now 21
15:55:57 <bizhang> !end
15:55:57 <bizhang> #endmeeting