15:29:22 <bizhang> #startmeeting Pulp Triage 2017-01-03
15:29:22 <bizhang> #info bizhang has joined triage
15:29:23 <pulpbot> Meeting started Tue Jan  3 15:29:22 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:23 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:23 <pulpbot> The meeting name has been set to 'pulp_triage_2017_01_03'
15:29:23 <pulpbot> bizhang has joined triage
15:29:28 <dkliban> !here
15:29:28 <dkliban> #info dkliban has joined triage
15:29:28 <smyers> !here
15:29:28 <smyers> #info smyers has joined triage
15:29:28 <pulpbot> dkliban has joined triage
15:29:29 <pulpbot> smyers has joined triage
15:29:38 <asmacdo> !here
15:29:38 <asmacdo> #info asmacdo has joined triage
15:29:38 <pulpbot> asmacdo has joined triage
15:29:51 <bizhang> !next
15:29:52 <pulpbot> 6 issues left to triage: 2274, 2495, 2502, 2503, 2504, 2505
15:29:53 <bizhang> #topic Uploading duplicate content results in ambiguous error message - http://pulp.plan.io/issues/2274
15:29:53 <pulpbot> Pulp Issue #2274 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:29:54 <pulpbot> Uploading duplicate content results in ambiguous error message - http://pulp.plan.io/issues/2274
15:29:54 <mhrivnak> !here
15:29:54 <mhrivnak> #info mhrivnak has joined triage
15:29:55 <pulpbot> mhrivnak has joined triage
15:30:00 <daviddavis> !here
15:30:00 <daviddavis> #info daviddavis has joined triage
15:30:01 <pulpbot> daviddavis has joined triage
15:30:23 <jortel> !here
15:30:23 <jortel> #info jortel has joined triage
15:30:24 <pulpbot> jortel has joined triage
15:31:23 * mhrivnak reads
15:31:45 <bmbouter> !here
15:31:45 <bmbouter> #info bmbouter has joined triage
15:31:46 <pulpbot> bmbouter has joined triage
15:32:03 <bmbouter> I just untriaged this, see last comment
15:32:58 <daviddavis> I wonder if we should create a new bug in 2.12 or whatever to make the iso importer less strict
15:33:16 <daviddavis> and fix the error message in a prior release?
15:33:17 <dkliban> we should return the behavior that was present in 2.7
15:33:22 <mhrivnak> Seems like we might need some discussion on this before it can be triaged?
15:33:38 <bmbouter> agreed, I untriaged it to prompt that but we don't have to do it here, now
15:33:43 <bizhang> !propose needsinfo
15:33:43 <pulpbot> Error: "propose" is not a valid command.
15:33:49 <bizhang> !propose needinfo
15:33:49 <bizhang> #idea Proposed for #2274: This issue cannot be triaged without more info.
15:33:50 <pulpbot> Proposed for #2274: This issue cannot be triaged without more info.
15:34:05 <bizhang> we can comment on the bug and triage it on friday
15:34:09 <mhrivnak> +1
15:34:17 <bmbouter> +1, please go comment if you've goit ideas
15:34:37 <bizhang> !accept
15:34:37 <bizhang> #agreed This issue cannot be triaged without more info.
15:34:37 <pulpbot> Current proposal accepted: This issue cannot be triaged without more info.
15:34:38 <pulpbot> 5 issues left to triage: 2495, 2502, 2503, 2504, 2505
15:34:39 <bizhang> #topic When generating applicability data for multiple repositories, tasks throws error CursorNotFound - http://pulp.plan.io/issues/2495
15:34:39 <pulpbot> RPM Support Issue #2495 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:34:40 <pulpbot> When generating applicability data for multiple repositories, tasks throws error CursorNotFound - http://pulp.plan.io/issues/2495
15:35:05 <dkliban> we still have not received any feedback
15:35:29 <dkliban> i propose that we skip it again
15:35:33 <mhrivnak> What feedback are we waiting on?
15:35:44 <smyers> if the upgrade to 2.10.3 fixes this
15:36:02 <mhrivnak> Hm. I'm not expecting that upgrade to fix it.
15:36:03 <smyers> I guess it's still time-based, and an even larger number of cursors would still break
15:36:12 <mhrivnak> Just to make it less likely to hit the bug.
15:36:41 <bmbouter> have we considered increasing the timeout?
15:36:52 <bmbouter> maybe this isn't the place for that, I can post on the issue
15:36:55 <dkliban> bmbouter: you can't do it on older mongo
15:37:01 <bmbouter> oic
15:37:18 <bizhang> !propose needinfo
15:37:18 <bizhang> #idea Proposed for #2495: This issue cannot be triaged without more info.
15:37:19 <pulpbot> Proposed for #2495: This issue cannot be triaged without more info.
15:37:32 <mhrivnak> I think we should just triage it now, unless there are more questions to ask.
15:37:46 <mhrivnak> We are making a query and not using results quickly enough.
15:38:17 <mhrivnak> We should make whatever changes are necessary to use the results before the cursor times out.
15:38:36 <bmbouter> mhrivnak: so you think additional work is needed besdes the upgrade you mention in comment 1
15:38:38 <bmbouter> ?
15:38:42 <mhrivnak> Yes.
15:39:08 <bmbouter> I agree, can that recommendation be posted on it?
15:39:14 <bmbouter> if so +1 to triaging
15:39:36 <mhrivnak> Sure, I can clarify that.
15:39:49 <jortel> +1
15:39:56 <bizhang> med/low? since it's unlikely to occur in 2.10.3
15:40:17 <mhrivnak> Well, it's less likely.
15:40:28 <mhrivnak> It's harder to say whether it's "unlikely". :)
15:40:34 <smyers> I think the severity is probably at least medium
15:40:39 <jortel> seems like med/high is better
15:40:53 <mhrivnak> agreed.
15:41:02 <bmbouter> +1 to that
15:41:03 <bizhang> !propose triage medium high
15:41:03 <bizhang> #idea Proposed for #2495: Priority: Normal, Severity: High
15:41:04 <pulpbot> Proposed for #2495: Priority: Normal, Severity: High
15:41:19 <mhrivnak> works for me.
15:41:21 <bizhang> !accept
15:41:21 <bizhang> #agreed Priority: Normal, Severity: High
15:41:21 <pulpbot> Current proposal accepted: Priority: Normal, Severity: High
15:41:23 <bizhang> #topic cursor timeout in _duplicate_key_id_generator_aggregation() during sync - http://pulp.plan.io/issues/2502
15:41:23 <pulpbot> 4 issues left to triage: 2502, 2503, 2504, 2505
15:41:24 <pulpbot> RPM Support Issue #2502 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:41:25 <pulpbot> cursor timeout in _duplicate_key_id_generator_aggregation() during sync - http://pulp.plan.io/issues/2502
15:43:36 <mhrivnak> similar problem, but we have more info at least.
15:44:43 <mhrivnak> !propose triage high high
15:44:43 <mhrivnak> #idea Proposed for #2502: Priority: High, Severity: High
15:44:44 <pulpbot> Proposed for #2502: Priority: High, Severity: High
15:44:47 <mhrivnak> and add to sprint 13
15:45:07 <bizhang> +1
15:45:11 <jortel> +1
15:45:59 <bizhang> !propose other add to sprint 13
15:45:59 <bizhang> #idea Proposed for #2502: add to sprint 13
15:45:59 <pulpbot> Proposed for #2502: add to sprint 13
15:46:04 <bizhang> ^ so I don't forget
15:46:37 <bizhang> everyone good with high/high?
15:46:44 <daviddavis> yea
15:46:47 <jortel> yep
15:46:55 <bizhang> !accept
15:46:55 <bizhang> #agreed add to sprint 13
15:46:55 <pulpbot> Current proposal accepted: add to sprint 13
15:46:56 <pulpbot> 3 issues left to triage: 2503, 2504, 2505
15:46:56 <bizhang> #topic remove_missing does not seem to remove on_demand catalog entries - http://pulp.plan.io/issues/2503
15:46:57 <pulpbot> Pulp Issue #2503 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:46:58 <pulpbot> remove_missing does not seem to remove on_demand catalog entries - http://pulp.plan.io/issues/2503
15:47:18 <mhrivnak> jortel, thoughts on this one?
15:47:29 <jortel> mhrivnak: reading it now
15:48:47 <jortel> the remove missing means the packages are not in the remote repo, right?
15:49:23 <mhrivnak> right.
15:49:55 <jortel> this is pretty bad because the catalog is no longer valid and since the streamer only uses the first entry, it could cause a real problem.
15:50:15 <mhrivnak> right.
15:50:29 <jortel> high/high ?
15:50:46 <mhrivnak> +1 and also sprint 13
15:50:50 <jortel> agreed
15:50:52 <mhrivnak> jsherrill, want to make a BZ for this?
15:51:07 <mhrivnak> or link it if one already exists.
15:51:16 <mhrivnak> !propose triage high high
15:51:16 <mhrivnak> #idea Proposed for #2503: Priority: High, Severity: High
15:51:17 <pulpbot> Proposed for #2503: Priority: High, Severity: High
15:51:19 <mhrivnak> !propose other add to sprint 13
15:51:19 <mhrivnak> #idea Proposed for #2503: add to sprint 13
15:51:19 <pulpbot> Proposed for #2503: add to sprint 13
15:51:24 <bizhang> !accept
15:51:24 <bizhang> #agreed add to sprint 13
15:51:24 <pulpbot> Current proposal accepted: add to sprint 13
15:51:26 <bizhang> #topic errata applicability fails if errata packagelist doesn't exist - http://pulp.plan.io/issues/2504
15:51:26 <pulpbot> 2 issues left to triage: 2504, 2505
15:51:27 <pulpbot> Pulp Issue #2504 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:51:28 <pulpbot> errata applicability fails if errata packagelist doesn't exist - http://pulp.plan.io/issues/2504
15:52:24 <jsherrill> mhrivnak: reading
15:52:34 <jsherrill> mhrivnak: sure!
15:52:40 <mhrivnak> jsherrill, thanks.
15:52:55 <jsherrill> mhrivnak: lol i don't even remember writing this
15:53:07 <jsherrill> christmas break amnesia
15:53:09 <mhrivnak> jsherrill, had a good holiday I take it? :)
15:53:13 <jsherrill> hehe
15:53:20 <jortel> this should have a severity=high
15:53:31 <mhrivnak> and jsherrill just to be clear, that request is for #2503
15:53:37 <jsherrill> yep yep
15:53:47 <bizhang> !propose triage high high
15:53:47 <bizhang> #idea Proposed for #2504: Priority: High, Severity: High
15:53:48 <pulpbot> Proposed for #2504: Priority: High, Severity: High
15:54:00 <mhrivnak> this one is apparently a regression.
15:54:07 <bizhang> add to sprint 13?
15:54:35 <mhrivnak> Not sure about that. It doesn't seem to affect any known "real" repos.
15:54:48 <mhrivnak> jsherrill, is that your understanding on this?
15:55:12 <dkliban> i think the repo that is linked in the issue is real
15:55:31 <jsherrill> mhrivnak: it did affect the centos repos
15:55:34 <mhrivnak> dkliban, I thought it's just a contrived testing repo.
15:55:43 <mhrivnak> jsherrill, oh
15:55:43 <jsherrill> they move rpms between CR and the updates repo
15:55:51 <jsherrill> so it dissapeared from one repo, appeared in a 2nd
15:55:56 <jsherrill> and pulp was trying to still sync it from the CR repo
15:56:09 <dkliban> mhrivnak: i stand corrected. i thought it was the katello repo
15:56:10 <jsherrill> even though remove missing has removed it from the local CR copy
15:56:20 <mhrivnak> oh jsherrill I think we're on a different issue now.
15:56:25 <jsherrill> oh sorry
15:56:26 <mhrivnak> looking at #2504
15:56:28 <mhrivnak> https://pulp.plan.io/issues/2504
15:56:30 <pulpbot> Title: Issue #2504: errata applicability fails if errata packagelist doesn't exist - Pulp (at pulp.plan.io)
15:56:31 <mhrivnak> which you also filed. :)
15:56:36 <jsherrill> oh right
15:56:50 <jsherrill> yeah that was only seen on a 'test' repo
15:56:53 <jsherrill> but was a regression
15:57:00 <jsherrill> i don't know of any real repo that does this
15:57:07 <jsherrill> however, if one ever does the results are quite disasterous
15:57:20 <jsherrill> disastrous *
15:57:42 <jsherrill> because it completely blows up and doesn't generate applicability for that consumer
15:58:00 <mhrivnak> jsherrill, I think if you decide it's worthy of a BZ, we would add it to a sprint. :)
15:58:14 <jsherrill> mhrivnak: yeah i think its worthy
15:58:22 <jsherrill> because if a customer hits it were SOL :)
15:58:24 <mhrivnak> ack.
15:58:28 <jsherrill> i'll file a bz
15:58:30 <jsherrill> for it too
15:58:31 <mhrivnak> thanks!
15:58:34 <bizhang> !propose other add to sprint
15:58:34 <bizhang> #idea Proposed for #2504: add to sprint
15:58:35 <pulpbot> Proposed for #2504: add to sprint
15:58:38 <mhrivnak> +1
15:58:41 <bizhang> high/high good?
15:59:35 <mhrivnak> Works for me.
15:59:44 <bizhang> !accept
15:59:44 <bizhang> #agreed add to sprint
15:59:44 <pulpbot> Current proposal accepted: add to sprint
15:59:45 <pulpbot> 1 issues left to triage: 2505
15:59:45 <bizhang> #topic Improperly handled permission denied error in yum importer - http://pulp.plan.io/issues/2505
15:59:46 <pulpbot> RPM Support Issue #2505 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:59:47 <pulpbot> Improperly handled permission denied error in yum importer - http://pulp.plan.io/issues/2505
16:00:17 <asmacdo> can this happen in the wild?
16:00:33 <daviddavis> asmacdo: yes
16:00:38 <smyers> for those "add to sprint" proposals, it'd help the triage minutes out if they were "add to sprint <number>, triage as high/medium", for example
16:01:00 <asmacdo> good call smyers
16:01:07 <bizhang> smyers, oh cool, didn't know we can do both in one line
16:01:23 <asmacdo> daviddavis: can you elaborate on how this might happen  without deliberately reproducing?
16:01:34 <smyers> It's freeform text, anything after "other" just gets recorded as the proposal
16:01:59 <daviddavis> if you try to sync a local file repo that doesn't have the permissions properly set, you hit this
16:02:01 <smyers> And despite the fancy parsing, all proposals are strings :)
16:03:00 <mhrivnak> !propose triage medium low
16:03:00 <mhrivnak> #idea Proposed for #2505: Priority: Normal, Severity: Low
16:03:01 <pulpbot> Proposed for #2505: Priority: Normal, Severity: Low
16:03:31 <bizhang> +1
16:03:43 <daviddavis> I should probably update the title to reflect the bug and not the problem in the code
16:04:50 <daviddavis> done
16:04:54 <bizhang> !accept
16:04:54 <bizhang> #agreed Priority: Normal, Severity: Low
16:04:55 <pulpbot> Current proposal accepted: Priority: Normal, Severity: Low
16:04:56 <pulpbot> No issues to triage.
16:05:02 <bizhang> !end
16:05:02 <bizhang> #endmeeting