15:29:11 <bizhang> #startmeeting Pulp Triage 2017-01-06
15:29:11 <bizhang> #info bizhang has joined triage
15:29:11 <pulpbot> Meeting started Fri Jan  6 15:29:11 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:11 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:11 <pulpbot> The meeting name has been set to 'pulp_triage_2017_01_06'
15:29:11 <pulpbot> bizhang has joined triage
15:29:16 <mhrivnak> !here
15:29:16 <mhrivnak> #info mhrivnak has joined triage
15:29:16 <pulpbot> mhrivnak has joined triage
15:29:17 <jortel> !here
15:29:17 <jortel> #info jortel has joined triage
15:29:17 <pulpbot> jortel has joined triage
15:29:19 <daviddavis> !here
15:29:19 <daviddavis> #info daviddavis has joined triage
15:29:20 <pulpbot> daviddavis has joined triage
15:29:29 <bizhang> !next
15:29:30 <pulpbot> 6 issues left to triage: 2274, 2508, 2512, 2513, 2514, 2516
15:29:31 <bizhang> #topic Uploading duplicate content results in ambiguous error message - http://pulp.plan.io/issues/2274
15:29:31 <pulpbot> Pulp Issue #2274 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:29:32 <pulpbot> Uploading duplicate content results in ambiguous error message - http://pulp.plan.io/issues/2274
15:29:38 <ttereshc> bmbouter, it was an assumption in this usecase it is not related to the issue itself. The assumption is wrong, that's why I asked
15:30:25 <ttereshc> !here
15:30:25 <ttereshc> #info ttereshc has joined triage
15:30:26 <pulpbot> ttereshc has joined triage
15:30:30 <ipanova> !here
15:30:30 <ipanova> #info ipanova has joined triage
15:30:31 <pulpbot> ipanova has joined triage
15:30:36 <fdobrovo> !here
15:30:36 <fdobrovo> #info fdobrovo has joined triage
15:30:37 <pulpbot> fdobrovo has joined triage
15:30:55 <bmbouter> !here
15:30:55 <bmbouter> #info bmbouter has joined triage
15:30:55 <pulpbot> bmbouter has joined triage
15:31:06 <bizhang> !propose triage normal high
15:31:06 <bizhang> #idea Proposed for #2274: Priority: Normal, Severity: High
15:31:07 <pulpbot> Proposed for #2274: Priority: Normal, Severity: High
15:31:41 <jortel> +1
15:31:59 <mhrivnak> works for me
15:32:27 <dalley> !here
15:32:27 <dalley> #info dalley has joined triage
15:32:28 <pulpbot> dalley has joined triage
15:32:51 <ttereshc> +1
15:32:53 <bizhang> !accept
15:32:53 <bizhang> #agreed Priority: Normal, Severity: High
15:32:53 <pulpbot> Current proposal accepted: Priority: Normal, Severity: High
15:32:54 <bizhang> #topic /var/lib/pulp/static/rsa_pub.key has incorrect SELinux label - http://pulp.plan.io/issues/2508
15:32:55 <pulpbot> 5 issues left to triage: 2508, 2512, 2513, 2514, 2516
15:32:56 <pulpbot> Pulp Issue #2508 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:57 <pulpbot> /var/lib/pulp/static/rsa_pub.key has incorrect SELinux label - http://pulp.plan.io/issues/2508
15:33:53 <bmbouter> I outlined a fix for this on the issue
15:34:04 <bmbouter> it maybe could be low sev because I think pulp will still function normally
15:34:26 <mhrivnak> gotcha. What is the impact of this exactly?
15:35:26 <jortel> bmbouter: thanks for your investigation on 2508
15:36:30 <jortel> bmbouter: is any of the consumer getting a deny on this?
15:36:37 <bmbouter> I'm not sure there is a perceivable impact
15:36:48 <bmbouter> I don't think they will because httpd can read pulp_cert_t
15:37:28 <bizhang> !propose triage low low
15:37:28 <bizhang> #idea Proposed for #2508: Priority: Low, Severity: Low
15:37:28 <pulpbot> Proposed for #2508: Priority: Low, Severity: Low
15:37:32 <mhrivnak> bmbouter, just asking naively here: if there's no impact, should we close it as "notabug" or "wontfix"?
15:37:38 <mhrivnak> Or is there some benefit to fixing it?
15:37:47 <mhrivnak> I'm assuming there is some benefit, but I just don't know what it is.
15:38:55 <bmbouter> it's expected that everything in /var/lib/pulp/ is labeled one way, but this one file unexpectedly gets the wrong label
15:39:15 <bmbouter> and if we redefine pulp_cert_t we would introduce an issue unexpectedly
15:39:29 <mhrivnak> Ok. So it's just a benefit of being consistent with other files in the same neighborhood?
15:39:35 <mhrivnak> Then low/low sounds good to me.
15:39:39 <bmbouter> well more with the policy definition
15:39:41 <jortel> +1
15:39:54 <mhrivnak> Gotcha.
15:40:01 <misa> !here
15:40:01 <misa> #info misa has joined triage
15:40:02 <pulpbot> misa has joined triage
15:40:21 <bizhang> bmbouter, low/low sounds ok to you?
15:40:23 <bmbouter> low/low sounds fine
15:40:26 <bizhang> !accept
15:40:26 <bizhang> #agreed Priority: Low, Severity: Low
15:40:28 <bizhang> #topic Puppet Importer swallows exception when one is raised during upload - http://pulp.plan.io/issues/2512
15:40:28 <pulpbot> Current proposal accepted: Priority: Low, Severity: Low
15:40:29 <pulpbot> 4 issues left to triage: 2512, 2513, 2514, 2516
15:40:30 <pulpbot> Puppet Support Issue #2512 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:40:31 <pulpbot> Puppet Importer swallows exception when one is raised during upload - http://pulp.plan.io/issues/2512
15:41:08 <bizhang> !propose accept
15:41:08 <bizhang> #idea Proposed for #2512: Leave the issue as-is, accepting its current state.
15:41:08 <pulpbot> Proposed for #2512: Leave the issue as-is, accepting its current state.
15:41:18 <bmbouter> +1
15:41:26 <jortel> +1
15:41:26 <dkliban> +1
15:41:33 <mhrivnak> +1
15:41:34 <bizhang> !accept
15:41:34 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:41:35 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:41:35 <dalley> +1
15:41:36 <pulpbot> 3 issues left to triage: 2513, 2514, 2516
15:41:37 <bizhang> #topic RPM Importer swallows exception when one is raised during upload - http://pulp.plan.io/issues/2513
15:41:38 <pulpbot> RPM Support Issue #2513 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:41:39 <pulpbot> RPM Importer swallows exception when one is raised during upload - http://pulp.plan.io/issues/2513
15:41:44 <bizhang> !propose accept
15:41:44 <bizhang> #idea Proposed for #2513: Leave the issue as-is, accepting its current state.
15:41:44 <pulpbot> Proposed for #2513: Leave the issue as-is, accepting its current state.
15:41:46 <daviddavis> same thing but for rpms
15:41:59 <daviddavis> +1
15:41:59 <ttereshc> +1
15:42:01 <mhrivnak> +1
15:42:05 <bmbouter> +1
15:42:09 <bizhang> !accept
15:42:09 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:42:10 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:42:10 <bizhang> #topic Creating a group no longer updates the existing group - http://pulp.plan.io/issues/2514
15:42:11 <pulpbot> 2 issues left to triage: 2514, 2516
15:42:12 <pulpbot> RPM Support Issue #2514 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:42:13 <pulpbot> Creating a group no longer updates the existing group - http://pulp.plan.io/issues/2514
15:43:01 <bizhang> !propose triage normal high
15:43:01 <bizhang> #idea Proposed for #2514: Priority: Normal, Severity: High
15:43:02 <pulpbot> Proposed for #2514: Priority: Normal, Severity: High
15:43:11 <mhrivnak> !propose triage high high
15:43:11 <mhrivnak> #idea Proposed for #2514: Priority: High, Severity: High
15:43:12 <pulpbot> Proposed for #2514: Priority: High, Severity: High
15:43:16 <misa> working on a fix
15:43:16 <dalley> +1
15:43:20 <daviddavis> +∑∞ i=1 1/2^i
15:43:21 <mhrivnak> misa++
15:43:21 <pulpbot> misa's karma is now 5
15:43:23 <misa> and yes, high
15:43:36 <misa> because tehre is no good workaround
15:43:44 <mhrivnak> This is quite problematic for a user who needs to do this.
15:43:50 <bizhang> sounds good to me
15:43:52 <bizhang> !accept
15:43:52 <bizhang> #agreed Priority: High, Severity: High
15:43:53 <pulpbot> Current proposal accepted: Priority: High, Severity: High
15:43:54 <bizhang> #topic worker heartbeat log statement mishandles timezone - http://pulp.plan.io/issues/2516
15:43:54 <pulpbot> 1 issues left to triage: 2516
15:43:55 <pulpbot> Pulp Issue #2516 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:43:56 <pulpbot> worker heartbeat log statement mishandles timezone - http://pulp.plan.io/issues/2516
15:44:24 <bmbouter> +1 to accepting as is
15:44:29 <bmbouter> I also wrote my recommended fix on here
15:44:45 <mhrivnak> I'll just suggest low severity.
15:45:23 <bizhang> should we add to sprint 13?
15:45:33 <mhrivnak> The only impact on a user is that if they have set the log level to debug, and then read this log message, they'll be confused.
15:45:38 <mhrivnak> yes, add to sprint 13.
15:46:07 <bizhang> !propose other add to sprint 13, triage as normal/low
15:46:07 <bizhang> #idea Proposed for #2516: add to sprint 13, triage as normal/low
15:46:08 <pulpbot> Proposed for #2516: add to sprint 13, triage as normal/low
15:46:20 <fdobrovo> +1
15:46:36 <bizhang> !accept
15:46:36 <bizhang> #agreed add to sprint 13, triage as normal/low
15:46:36 <pulpbot> Current proposal accepted: add to sprint 13, triage as normal/low
15:46:37 <pulpbot> No issues to triage.
15:46:39 <bizhang> !END
15:46:39 <bizhang> #endmeeting