15:29:00 <bizhang> #startmeeting Pulp Triage 2017-01-20
15:29:00 <bizhang> #info bizhang has joined triage
15:29:00 <bizhang> !start
15:29:00 <pulpbot> Meeting started Fri Jan 20 15:29:00 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:00 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:00 <pulpbot> The meeting name has been set to 'pulp_triage_2017_01_20'
15:29:00 <pulpbot> bizhang has joined triage
15:29:37 <dalley> !here
15:29:37 <dalley> #info dalley has joined triage
15:29:37 <pulpbot> dalley has joined triage
15:30:02 <mhrivnak> !here
15:30:02 <mhrivnak> #info mhrivnak has joined triage
15:30:02 <pulpbot> mhrivnak has joined triage
15:30:21 <daviddavis> !here
15:30:21 <daviddavis> #info daviddavis has joined triage
15:30:22 <pulpbot> daviddavis has joined triage
15:30:24 <bizhang> !next
15:30:25 <pulpbot> 5 issues left to triage: 2427, 2531, 2532, 2536, 2537
15:30:26 <bizhang> #topic Apache's XSendFile directive causes 404 errors when trying to download rpm packages via HTTP - http://pulp.plan.io/issues/2427
15:30:26 <pulpbot> RPM Support Issue #2427 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:30:27 <pulpbot> Apache's XSendFile directive causes 404 errors when trying to download rpm packages via HTTP - http://pulp.plan.io/issues/2427
15:30:29 <ipanova> !here
15:30:29 <ipanova> #info ipanova has joined triage
15:30:30 <pulpbot> ipanova has joined triage
15:31:44 <mhrivnak> Did anyone talk to the second user who saw this problem?
15:31:50 <mhrivnak> Were they also on PPC64?
15:32:06 <daviddavis> good question
15:32:09 <ttereshc> !here
15:32:09 <ttereshc> #info ttereshc has joined triage
15:32:10 <pulpbot> ttereshc has joined triage
15:32:29 <daviddavis> mhrivnak: I'm almost wondering if they just hit a 404 and assumed it was the same issue
15:32:50 <mhrivnak> daviddavis, me too
15:32:56 <mhrivnak> It's hard to know.
15:33:21 <mhrivnak> bmbouter, did you have any additional context for re-opening the issue?
15:34:00 <ipanova> maybe let's skip it for now to get more info
15:34:06 <daviddavis> +1
15:34:10 <mhrivnak> Works for me.
15:34:19 <bizhang> !propose needsinfo
15:34:19 <pulpbot> Error: "propose" is not a valid command.
15:34:24 <bizhang> !propose triage needsinfo
15:34:25 <pulpbot> (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
15:34:32 <bizhang> !propose other needsinfo
15:34:32 <bizhang> #idea Proposed for #2427: needsinfo
15:34:33 <pulpbot> Proposed for #2427: needsinfo
15:34:37 <bizhang> !accept
15:34:37 <bizhang> #agreed needsinfo
15:34:37 <pulpbot> Current proposal accepted: needsinfo
15:34:39 <bizhang> #topic pulp python modules use other project's namespace - http://pulp.plan.io/issues/2531
15:34:39 <pulpbot> 4 issues left to triage: 2531, 2532, 2536, 2537
15:34:40 <pulpbot> Pulp Issue #2531 [NEW] (unassigned) - Priority: Normal | Severity: Urgent
15:34:41 <pulpbot> pulp python modules use other project's namespace - http://pulp.plan.io/issues/2531
15:34:59 <dkliban> !HERE
15:34:59 <dkliban> #info dkliban has joined triage
15:35:00 <pulpbot> dkliban has joined triage
15:35:04 <bizhang> The BZ for this was closed as wontfix
15:35:07 <ipanova> dkliban:  we see :D
15:35:19 <dkliban> lol
15:35:21 <ipanova> bizhang: yes, i suggest going same here
15:35:22 <bmbouter> !here
15:35:22 <bmbouter> #info bmbouter has joined triage
15:35:23 <pulpbot> bmbouter has joined triage
15:35:50 <bizhang> !propose other close wontfix
15:35:50 <bizhang> #idea Proposed for #2531: close wontfix
15:35:51 <pulpbot> Proposed for #2531: close wontfix
15:35:53 <bmbouter> for 2427 I propose that we skip
15:35:53 <mhrivnak> I suggest we skip this for now until we can have more discussion.
15:36:00 <bmbouter> +1 to skip
15:36:02 <dkliban> +1
15:36:16 <ipanova> well, ok
15:36:25 <bizhang> !propose skip
15:36:25 <bizhang> #idea Proposed for #2531: Skip this issue for this triage session.
15:36:25 <pulpbot> Proposed for #2531: Skip this issue for this triage session.
15:36:31 <bmbouter> mhrivnak: re 2427 I did not have more context and +1 to getting more info on that one
15:36:32 <mhrivnak> Not that we're likely to change name, but it will help us discuss options and alternatives if we keep this open for now.
15:36:41 <bizhang> !accept
15:36:41 <bizhang> #agreed Skip this issue for this triage session.
15:36:41 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
15:36:42 <pulpbot> 3 issues left to triage: 2532, 2536, 2537
15:36:43 <bizhang> #topic rsync distributor without force_full incorrectly skips publishing some units - http://pulp.plan.io/issues/2532
15:36:43 <pulpbot> Pulp Issue #2532 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:36:44 <pulpbot> rsync distributor without force_full incorrectly skips publishing some units - http://pulp.plan.io/issues/2532
15:36:56 <ipanova> mhrivnak: sounds reasobable
15:37:10 <ipanova> mhrivnak:  but i see that the main discussion is happening on the pfc ticket
15:37:16 <ipanova> fpc*
15:37:39 <mhrivnak> ipanova, yep. We can discuss more after triage if you like.
15:37:53 <mhrivnak> high/high for this one?
15:38:03 <dkliban> +1
15:38:08 <bmbouter> +1
15:38:11 <bizhang> !propose triage high high
15:38:11 <bizhang> #idea Proposed for #2532: Priority: High, Severity: High
15:38:12 <pulpbot> Proposed for #2532: Priority: High, Severity: High
15:38:13 <bmbouter> add to sprint?
15:38:22 <dkliban> yes
15:38:29 <mhrivnak> This is unusual: "Note I haven't attempted to reproduce this, the bug report is based on code review of latest master ( 6fc2861fd14793f8461d232cb641b5112d271519 )."
15:38:42 <mhrivnak> dkliban, thoughts on that?
15:38:56 <dkliban> let's triage it as high/high and i'll take a look at it
15:38:56 <ttereshc> we can verify it at least
15:39:09 <mhrivnak> Sounds good. And add to sprint.
15:39:14 <ttereshc> +1
15:39:25 <bizhang> !propose other triage high/high, add to sprint, dkliban to take a look
15:39:25 <bizhang> #idea Proposed for #2532: triage high/high, add to sprint, dkliban to take a look
15:39:26 <pulpbot> Proposed for #2532: triage high/high, add to sprint, dkliban to take a look
15:39:41 <bizhang> !accept
15:39:41 <bizhang> #agreed triage high/high, add to sprint, dkliban to take a look
15:39:41 <pulpbot> Current proposal accepted: triage high/high, add to sprint, dkliban to take a look
15:39:43 <bizhang> #topic error for docker pull of non-existent tag not clear - http://pulp.plan.io/issues/2536
15:39:43 <pulpbot> 2 issues left to triage: 2536, 2537
15:39:44 <pulpbot> Crane Issue #2536 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:39:45 <pulpbot> error for docker pull of non-existent tag not clear - http://pulp.plan.io/issues/2536
15:39:56 <mhrivnak> !propose skip
15:39:56 <mhrivnak> #idea Proposed for #2536: Skip this issue for this triage session.
15:39:57 <pulpbot> Proposed for #2536: Skip this issue for this triage session.
15:40:07 <mhrivnak> reporter is still investigating
15:40:13 <mhrivnak> and promised to add more info
15:40:16 <ipanova> mhrivnak: just a note that if tag doesnot exist it should give 404 and not 400
15:40:30 <dkliban> yep
15:40:42 <mhrivnak> ipanova, the docker client is " speaking plain HTTP to an SSL-enabled server port."
15:40:44 <mhrivnak> hence the 404
15:40:46 <mhrivnak> er, 400
15:41:00 <ipanova> but i hit this issue as well with plain http
15:41:21 <ipanova> i actually cannot normally configure crane already for couple of days, *sigh*
15:41:24 <mhrivnak> ipanova, ok. Then perhaps you can add more detail to the bug report.
15:41:45 <bizhang> !accept
15:41:45 <bizhang> #agreed Skip this issue for this triage session.
15:41:46 <pulpbot> Current proposal accepted: Skip this issue for this triage session.
15:41:46 <bizhang> #topic 2.12 Release notes missing features - http://pulp.plan.io/issues/2537
15:41:47 <pulpbot> 1 issues left to triage: 2537
15:41:48 <pulpbot> Packaging Issue #2537 [NEW] (unassigned) - Priority: High | Severity: Medium
15:41:49 <pulpbot> 2.12 Release notes missing features - http://pulp.plan.io/issues/2537
15:42:01 <bizhang> !propose other accept and add to sprint
15:42:01 <bizhang> #idea Proposed for #2537: accept and add to sprint
15:42:01 <pulpbot> Proposed for #2537: accept and add to sprint
15:42:08 <ipanova> +1
15:42:22 <mhrivnak> +1
15:42:44 <mhrivnak> And maybe add some public shaming. ;)
15:43:04 <ttereshc> +1
15:43:04 <bizhang> lol
15:43:07 <bizhang> #agreed accept and add to sprint
15:43:07 <bizhang> !accept
15:43:07 <pulpbot> Current proposal accepted: accept and add to sprint
15:43:09 <pulpbot> No issues to triage.
15:43:09 * smyers has a todo list item for public shaming today
15:43:14 <bizhang> #endmeeting