15:29:08 <bizhang> #startmeeting Pulp Triage 2017-01-31
15:29:08 <bizhang> #info bizhang has joined triage
15:29:09 <pulpbot> Meeting started Tue Jan 31 15:29:08 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:09 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:09 <pulpbot> The meeting name has been set to 'pulp_triage_2017_01_31'
15:29:09 <pulpbot> bizhang has joined triage
15:29:16 <dalley_> !here
15:29:16 <dalley_> #info dalley_ has joined triage
15:29:17 <pulpbot> dalley_ has joined triage
15:29:33 <daviddavis> !here
15:29:33 <daviddavis> #info daviddavis has joined triage
15:29:33 <pulpbot> daviddavis has joined triage
15:29:47 <smyers> !here
15:29:47 <smyers> #info smyers has joined triage
15:29:48 <pulpbot> smyers has joined triage
15:30:04 <bizhang> !next
15:30:05 <mhrivnak> !here
15:30:06 <bizhang> #topic error for docker pull of non-existent tag not clear - http://pulp.plan.io/issues/2536
15:30:06 <mhrivnak> #info mhrivnak has joined triage
15:30:06 <pulpbot> 7 issues left to triage: 2536, 2547, 2550, 2551, 2552, 2553, 2554
15:30:06 <pulpbot> Crane Issue #2536 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:30:07 <pulpbot> error for docker pull of non-existent tag not clear - http://pulp.plan.io/issues/2536
15:30:08 <pulpbot> mhrivnak has joined triage
15:30:55 <bizhang> mhrivnak, what are your thoughts about this issue?
15:31:49 <mhrivnak> It still smells like a bug, or at least a rough edge, in docker.
15:32:43 <mhrivnak> I'm ok with accepting it onto the sprint for investigation.
15:32:49 <daviddavis> +1 from me
15:33:10 <mhrivnak> I think it'll require some digging to figure out exactly what the 302 redirect points at, and what docker does with that.
15:33:25 <bizhang> !propose other accept and add to sprint 14
15:33:25 <bizhang> #idea Proposed for #2536: accept and add to sprint 14
15:33:25 <pulpbot> Proposed for #2536: accept and add to sprint 14
15:33:58 <bizhang> !accept
15:33:58 <bizhang> #agreed accept and add to sprint 14
15:33:58 <pulpbot> Current proposal accepted: accept and add to sprint 14
15:34:00 <bizhang> #topic Cannot sync RHEL 7.3 ISO - http://pulp.plan.io/issues/2547
15:34:00 <pulpbot> 6 issues left to triage: 2547, 2550, 2551, 2552, 2553, 2554
15:34:00 <pulpbot> Pulp Issue #2547 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:34:01 <pulpbot> Cannot sync RHEL 7.3 ISO - http://pulp.plan.io/issues/2547
15:34:08 <daviddavis> looks like this one needs info
15:34:17 <dkliban> !here
15:34:17 <dkliban> #info dkliban has joined triage
15:34:18 <pulpbot> dkliban has joined triage
15:34:36 <mhrivnak> Oh, I think this was fixed.
15:34:40 <mhrivnak> There were missing files on the CDN.
15:34:46 <mhrivnak> And that was fixed.
15:35:02 <bizhang> !close NOTABUG
15:35:02 <pulpbot> Error: "close" is not a valid command.
15:35:09 <bizhang> !propose other close notabug
15:35:09 <bizhang> #idea Proposed for #2547: close notabug
15:35:10 <pulpbot> Proposed for #2547: close notabug
15:36:03 <bizhang> !accept
15:36:03 <bizhang> #agreed close notabug
15:36:04 <pulpbot> Current proposal accepted: close notabug
15:36:05 <pulpbot> 5 issues left to triage: 2550, 2551, 2552, 2553, 2554
15:36:05 <bizhang> #topic Publishing via rsync does not correctly look at publish records - http://pulp.plan.io/issues/2550
15:36:06 <pulpbot> Pulp Issue #2550 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:36:07 <pulpbot> Publishing via rsync does not correctly look at publish records - http://pulp.plan.io/issues/2550
15:36:18 <daviddavis> so I am working in this area now
15:36:31 <bizhang> !propose other accept and add to sprint14
15:36:31 <bizhang> #idea Proposed for #2550: accept and add to sprint14
15:36:32 <pulpbot> Proposed for #2550: accept and add to sprint14
15:37:26 <bizhang> daviddavis, I assume we want this on sprint 14 since it blocks another sprint 14 item
15:37:47 <daviddavis> it doesn't block it but it would be an easy fix since I am working in the same area
15:38:22 <daviddavis> it actually does kind of block it or it makes testing #2532 harder
15:38:23 <mhrivnak> Seems reasonable.
15:38:37 <bizhang> !accept
15:38:37 <bizhang> #agreed accept and add to sprint14
15:38:38 <pulpbot> Current proposal accepted: accept and add to sprint14
15:38:39 <bizhang> #topic PLP0000 error reported for "celery.worker.job:ERROR: (15661-67328) WorkerLostError: Worker exited prematurely: signal 6 (SIGIOT)" - http://pulp.plan.io/issues/2551
15:38:39 <pulpbot> 4 issues left to triage: 2551, 2552, 2553, 2554
15:38:39 <pulpbot> Pulp Issue #2551 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:38:40 <pulpbot> PLP0000 error reported for "celery.worker.job:ERROR: (15661-67328) WorkerLostError: Worker exited prematurely: signal 6 (SIGIOT)" - http://pulp.plan.io/issues/2551
15:38:52 * smyers shakes fist at plp0000
15:39:04 <daviddavis> lol
15:39:50 <bizhang> !propose accept
15:39:50 <bizhang> #idea Proposed for #2551: Leave the issue as-is, accepting its current state.
15:39:50 <pulpbot> Proposed for #2551: Leave the issue as-is, accepting its current state.
15:40:52 <bizhang> everyone's so quiet today
15:41:02 <smyers> ...except it's definitely not a blocker for 2.11.z, so I'll take that off
15:41:07 <daviddavis> we're all sick
15:41:13 <dalley_> yeah..
15:41:20 <daviddavis> I wonder if the bug title should be updated based on https://pulp.plan.io/projects/pulp/activity?from=2017-01-30
15:41:21 <pulpbot> Title: Activity - Pulp (at pulp.plan.io)
15:41:31 <mhrivnak> definitely needs a title improvement
15:41:38 <daviddavis> err link should be https://pulp.plan.io/issues/2551#note-2
15:41:39 <pulpbot> Title: Issue #2551: PLP0000 error reported for "celery.worker.job:ERROR: (15661-67328) WorkerLostError: Worker exited prematurely: signal 6 (SIGIOT)" - Pulp (at pulp.plan.io)
15:42:15 <daviddavis> something like Generic PLP0000 error not helpful
15:42:49 <bizhang> should we add to sprint 14? since we're doing a lot of generic logging improvements
15:42:52 <mhrivnak> This strikes me though as the kind of thing that we're not going to allocate a special PLP#### for.
15:43:07 <mhrivnak> So I'd focus the title on just getting more info into the task's error info.
15:43:44 <mhrivnak> +1 add to sprint
15:44:29 <daviddavis> +1
15:44:32 <dkliban> +1
15:44:37 <dalley_> +1
15:44:43 <bizhang> !propose other accept, retitle, and add to sprint
15:44:43 <bizhang> #idea Proposed for #2551: accept, retitle, and add to sprint
15:44:44 <pulpbot> Proposed for #2551: accept, retitle, and add to sprint
15:44:56 <bizhang> !accept
15:44:56 <bizhang> #agreed accept, retitle, and add to sprint
15:44:56 <pulpbot> Current proposal accepted: accept, retitle, and add to sprint
15:44:58 <pulpbot> 3 issues left to triage: 2552, 2553, 2554
15:44:58 <bizhang> #topic updating ostree rpm gives error on sync: LibError: GLib.Error('No such file or directory', 'g-io-error-quark', 1) - http://pulp.plan.io/issues/2552
15:44:59 <pulpbot> OSTree Support Issue #2552 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:44:59 <pulpbot> updating ostree rpm gives error on sync: LibError: GLib.Error('No such file or directory', 'g-io-error-quark', 1) - http://pulp.plan.io/issues/2552
15:45:18 <mhrivnak> jortel, ?
15:46:27 <smyers> Looks a whole lot like ostree is broken :(
15:46:40 <mhrivnak> yep.
15:47:02 <dkliban> yeah .. so i think that this should probably be filed upstream against ostree
15:47:47 <bizhang> should we closeout the redmine issue then?
15:47:55 <mhrivnak> Let's skip and let jortel weigh in later.
15:48:00 <smyers> Could just be the glib python bindings should've raised an IOError, though, not a LibError
15:48:01 <dkliban> +1 to skip for now
15:48:10 <bizhang> !skip
15:48:11 <pulpbot> 2 issues left to triage: 2553, 2554
15:48:12 <bizhang> #topic Unable to sync isolinux and efi directory - http://pulp.plan.io/issues/2553
15:48:12 <pulpbot> Pulp Issue #2553 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:48:12 <pulpbot> Unable to sync isolinux and efi directory - http://pulp.plan.io/issues/2553
15:48:27 <dkliban> i was talking to the reporter of this issue yesterday
15:48:53 <dkliban> and he noticed that isolinux is not being published by Pulp
15:48:59 * jortel looks
15:49:23 <dkliban> mhrivnak: do you know if we made the decision to not publish it for any particular reason?
15:49:53 <mhrivnak> dkliban, I do not know.
15:50:22 <mhrivnak> If it's referenced by treeinfo, it should get sync'd and published.
15:50:25 <jortel> bizhang: I can weigh in on 2552 at the end if you want me to.
15:50:38 <bizhang> jortel, sounds good!
15:50:46 <sklav> if i may comment on 2553
15:50:52 <dkliban> sklav: please do
15:50:58 <dkliban> sklav is the reporter
15:51:01 <sklav> currently we publish liveOS etc..
15:51:25 <sklav> isolinux and efi would also be required in order to allow people to use the repo for provisioning
15:52:32 <mhrivnak> sklav, do you have an example repo URL?
15:52:53 <sklav> centos.mirror.iweb.cahttp://centos.mirror.iweb.ca/7/os/x86_64/
15:52:57 <sklav> sorry
15:52:59 <sklav> http://centos.mirror.iweb.ca/7/os/x86_64/
15:53:21 <sklav> EFI and isolinux are missing when a sync is performed
15:53:41 <mhrivnak> Gotcha.
15:53:47 <mhrivnak> That's helpful.
15:54:00 <mhrivnak> We should probably discuss this a bit more after triage.
15:54:04 <dkliban> mhrivnak: yesterday i synced the above repo with rpms and drpms skipped. i observed that isolinux was missing
15:54:30 <dkliban> mhrivnak: i agree. sklav let's discuss some more after this meeting is over in a couple of mins
15:54:47 <sklav> sure
15:55:08 <dkliban> mhrivnak: should we mark this as triaged?
15:55:19 <dkliban> or skip that part for rightnow?
15:55:25 <mhrivnak> I would skip for now.
15:55:29 <bizhang> !skip
15:55:31 <pulpbot> 1 issues left to triage: 2554
15:55:32 <bizhang> #topic client side exception when removing python package from repository - http://pulp.plan.io/issues/2554
15:55:32 <pulpbot> Python Support Issue #2554 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:55:33 <pulpbot> client side exception when removing python package from repository - http://pulp.plan.io/issues/2554
15:55:58 <dkliban> i filed this issue yesterday. i think we should fix it for Pulp Python 2.0.1
15:56:19 <dkliban> the units get removed, but pulp-admin chokes on the response from the API
15:56:29 <bizhang> !propose accept
15:56:29 <bizhang> #idea Proposed for #2554: Leave the issue as-is, accepting its current state.
15:56:30 <pulpbot> Proposed for #2554: Leave the issue as-is, accepting its current state.
15:57:11 <jortel> +1
15:57:24 <bizhang> !accept
15:57:24 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:57:24 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:57:26 <pulpbot> No issues to triage.
15:57:29 <bizhang> !issue 2552
15:57:30 <bizhang> #topic updating ostree rpm gives error on sync: LibError: GLib.Error('No such file or directory', 'g-io-error-quark', 1) - http://pulp.plan.io/issues/2552
15:57:30 <pulpbot> OSTree Support Issue #2552 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:57:30 <pulpbot> updating ostree rpm gives error on sync: LibError: GLib.Error('No such file or directory', 'g-io-error-quark', 1) - http://pulp.plan.io/issues/2552
15:58:33 <jortel> We have dealt with this over the last 2 years.  smyers is correct in that when the worker dies due to libostree core dump, it leave this the ostree (backing)  repo in a badly broken state.
15:59:46 <bizhang> so we should file this upstream?
15:59:53 <mhrivnak> jortel, so this error happens only after a repo has been corrupted?
16:00:06 <jortel> the only thing pulp should consider doing is either: 1) document how to fix which is has been to delete the repo.  2) have the plugin delete it when it detects that it's broken.  3) as colin if there is a way to repair it.
16:00:14 <jortel> mhrivnak: yes
16:01:00 <jortel> or, the remote repo is corrupted but I have not observed that case.
16:01:09 <jortel> and I doubt that
16:01:13 <mhrivnak> jortel, do you think we could catch that error and provide a more useful error message?
16:02:09 <mhrivnak> I'm not sure how easy it would be to distinguish it from some other kind of error.
16:02:10 <jortel> mhrivnak: perhaps but it won't be pretty since we'd need to parse the string in the exception :/
16:03:29 <jortel> mhrivnak: the best case is that we ensure that ostree has fixed the crash (I thought they did) and ensure users are fully updated.
16:03:38 <mhrivnak> Gotcha. In any case, I'm in favor then of accepting this issue, and let's decide later on which specific steps we want to take.
16:03:54 <jortel> sounds good.
16:03:55 <mhrivnak> Documenting this as a known issue would be a good step.
16:04:13 <bizhang> !propose accept
16:04:13 <bizhang> #idea Proposed for #2552: Leave the issue as-is, accepting its current state.
16:04:14 <pulpbot> Proposed for #2552: Leave the issue as-is, accepting its current state.
16:04:17 <mhrivnak> jortel, can you add the info you provided here to that issue?
16:04:30 <jortel> mhrivnak: will do.
16:04:36 <bizhang> !accept
16:04:36 <bizhang> #agreed Leave the issue as-is, accepting its current state.
16:04:36 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
16:04:38 <bizhang> !end
16:04:38 <bizhang> #endmeeting
16:04:38 <pulpbot> No issues to triage.