15:29:34 <bizhang> #startmeeting Pulp Triage 2017-02-03
15:29:34 <bizhang> #info bizhang has joined triage
15:29:34 <pulpbot> Meeting started Fri Feb  3 15:29:34 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:34 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:34 <pulpbot> The meeting name has been set to 'pulp_triage_2017_02_03'
15:29:34 <pulpbot> bizhang has joined triage
15:30:18 <jortel> ichimonji10: thanks the link to the smash_test email.  I rightly assumed it was my lousy email skills ;)
15:30:21 <mhrivnak> !here
15:30:21 <mhrivnak> #info mhrivnak has joined triage
15:30:22 <pulpbot> mhrivnak has joined triage
15:30:23 <jortel> !here
15:30:23 <jortel> #info jortel has joined triage
15:30:24 <pulpbot> jortel has joined triage
15:30:25 <ttereshc> !here
15:30:26 <ttereshc> #info ttereshc has joined triage
15:30:26 <pulpbot> ttereshc has joined triage
15:31:08 <ichimonji10> (:
15:32:31 <smyers> !here
15:32:31 <smyers> #info smyers has joined triage
15:32:32 <pulpbot> smyers has joined triage
15:32:39 <bizhang> sorry I had some connections issues to my znc
15:32:41 <bizhang> !start
15:32:41 <bizhang> #info bizhang has joined triage
15:32:41 <pulpbot> Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
15:32:42 <pulpbot> bizhang has joined triage
15:32:46 <bizhang> !next
15:32:48 <pulpbot> 8 issues left to triage: 2553, 2556, 2557, 2559, 2560, 2561, 2562, 2563
15:32:48 <bizhang> #topic Unable to sync isolinux and efi directory - http://pulp.plan.io/issues/2553
15:32:49 <pulpbot> Pulp Issue #2553 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:49 <pulpbot> Unable to sync isolinux and efi directory - http://pulp.plan.io/issues/2553
15:34:08 <mhrivnak> I think we can accept this as normal/medium
15:34:25 <bizhang> !propose accept normal medium
15:34:25 <pulpbot> propose accept Propose accepting the current issue in its current state.
15:34:26 <mhrivnak> Pulp has never sync'd these directories. It would be nice if it did, but it's hardly been missed.
15:34:39 <mhrivnak> They are only used when making a bootable ISO.
15:34:59 <smyers> +1
15:35:03 <mhrivnak> And there is no index or metadata file that can be used to discover them, so it's a PITA
15:35:27 <bizhang> !accept
15:35:28 <pulpbot> No action proposed, nothing to accept.
15:35:40 <mhrivnak> wat
15:35:43 <bizhang> #idea Proposed for #2553: Leave the issue as-is, accepting its current state.
15:35:43 <bizhang> !propose accept
15:35:43 <pulpbot> Proposed for #2553: Leave the issue as-is, accepting its current state.
15:35:47 <bizhang> !accept
15:35:47 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:35:48 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:35:49 <pulpbot> 7 issues left to triage: 2556, 2557, 2559, 2560, 2561, 2562, 2563
15:35:49 <bizhang> #topic Data validation for the importer config is lacking - http://pulp.plan.io/issues/2556
15:35:50 <pulpbot> Python Support Issue #2556 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:35:50 <pulpbot> Data validation for the importer config is lacking - http://pulp.plan.io/issues/2556
15:36:36 <daviddavis> !here
15:36:36 <daviddavis> #info daviddavis has joined triage
15:36:37 <pulpbot> daviddavis has joined triage
15:36:41 * bizhang failing at triage commands today
15:37:31 <bizhang> #2556 is an issue for all the pulp plugins not just python right?
15:37:58 <mhrivnak> I think we'd want to file a separate issue for each plugin if so.
15:38:08 <jortel> yep
15:38:22 <daviddavis> isn't this also an issue for other things like distributors?
15:38:44 <mhrivnak> probably.
15:39:11 <bmbouter> !here
15:39:11 <bmbouter> #info bmbouter has joined triage
15:39:12 <pulpbot> bmbouter has joined triage
15:39:25 <mhrivnak> !propose accept
15:39:25 <mhrivnak> #idea Proposed for #2556: Leave the issue as-is, accepting its current state.
15:39:25 <mhrivnak> #info mhrivnak has joined triage
15:39:26 <smyers> So, as far as I know we can't even do this in pulp 3, since everything in the api is backed by modeled data
15:39:26 <pulpbot> mhrivnak has joined triage
15:39:27 <pulpbot> Proposed for #2556: Leave the issue as-is, accepting its current state.
15:39:33 <mhrivnak> We can file more bugs on other areas if we want.
15:39:42 <smyers> I'm wondering if we'll ever actually fix this
15:39:55 <smyers> But, only wondering, and don't disagree with the proposed triage :)
15:40:25 <daviddavis> if we really want to fix this problem across all of pulp, it's going to be a can of worms
15:40:31 <mhrivnak> smyers, are you saying that pulp 3 will fix this, because the validation will "just work" ?
15:40:31 <smyers> yeah
15:40:44 <bmbouter> agreed
15:41:01 <smyers> I think pulp 3 has already fixed this, because the attempt to map the unserialized data to a django model will fail miserably.
15:41:04 <bmbouter> the importer config will be validated in pulp3 (both platform and custom definitions)
15:41:15 <luto> bizhang: thanks!
15:41:17 <smyers> Even if pulp accepts the data, it won't spit it back out, because it won't have saved it anywhere
15:41:33 <bizhang> maybe we should close this as won't fix?
15:41:38 <daviddavis> +1
15:41:44 <daviddavis> and say it'll be fixed in 3.0
15:41:53 <bmbouter> yeah def add the comment
15:42:01 <mhrivnak> Works for me.
15:42:05 <bizhang> !propose other close won't fix, add comment that it will be fixed in pulp3
15:42:05 <bizhang> #idea Proposed for #2556: close won't fix, add comment that it will be fixed in pulp3
15:42:06 <pulpbot> Proposed for #2556: close won't fix, add comment that it will be fixed in pulp3
15:42:16 <bizhang> !accept
15:42:16 <bizhang> #agreed close won't fix, add comment that it will be fixed in pulp3
15:42:17 <pulpbot> Current proposal accepted: close won't fix, add comment that it will be fixed in pulp3
15:42:17 <smyers> !action smyers comment and close it
15:42:18 <pulpbot> 6 issues left to triage: 2557, 2559, 2560, 2561, 2562, 2563
15:42:18 <bizhang> #topic better help for pulp admin - http://pulp.plan.io/issues/2557
15:42:18 <smyers> #action smyers comment and close it
15:42:18 <smyers> #info smyers has joined triage
15:42:19 <pulpbot> Pulp Issue #2557 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:42:20 <pulpbot> better help for pulp admin - http://pulp.plan.io/issues/2557
15:42:21 <pulpbot> smyers has joined triage
15:42:25 <smyers> erm
15:42:29 <smyers> I was already in triage, pulpbot
15:42:33 <smyers> I think oyu might be sick.
15:42:37 <daviddavis> lol
15:42:45 <ttereshc> yeah, devconf flu
15:42:53 <bmbouter> ugh
15:43:00 <bmbouter> jluza and I were talking about this
15:43:08 <bmbouter> he is filing pulp3 use cases
15:43:08 <smyers> keep it on the right side of the atlantic please :)
15:43:41 <bmbouter> I think this is a feature
15:43:43 <smyers> #2557 is a story, no?
15:43:44 * jortel back.  hopped on call w/ dkliban.
15:43:55 <ttereshc> +1 to story
15:43:59 <bizhang> !propose other change to story
15:43:59 <bizhang> #idea Proposed for #2557: change to story
15:44:00 <pulpbot> Proposed for #2557: change to story
15:44:04 <smyers> "As a user, the pulp-admin CLI gives me...good?...help text."
15:44:24 <jluza> bmbouter, 3? 2557 is 1st, multicall is 2nd and what is the 3rd?
15:44:32 <dalley> !here
15:44:32 <dalley> #info dalley has joined triage
15:44:33 <pulpbot> dalley has joined triage
15:44:52 <jortel> +1 to story
15:45:00 <daviddavis> jluza: 3.0 is the version of pulp
15:45:27 <bizhang> !accept
15:45:27 <bizhang> #agreed change to story
15:45:27 <pulpbot> Current proposal accepted: change to story
15:45:29 <pulpbot> 5 issues left to triage: 2559, 2560, 2561, 2562, 2563
15:45:29 <bizhang> #topic Empty pkglist for the erratum may be generated which may cause yum not to find applicable packages - http://pulp.plan.io/issues/2559
15:45:30 <pulpbot> RPM Support Issue #2559 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:45:30 <pulpbot> Empty pkglist for the erratum may be generated which may cause yum not to find applicable packages - http://pulp.plan.io/issues/2559
15:45:43 <jluza> daviddavis, ah! I was reading that I will file 3 issues.
15:45:47 <daviddavis> :)
15:45:49 * jluza needs coffee
15:46:14 <smyers> I can probably comment on #2557 and maybe give a little context regarding the api autogeneration stuff and how that might look in a cli...
15:46:48 <bmbouter> smyers: please do
15:46:57 * smyers task adds
15:47:12 <bmbouter> ty!
15:47:31 <daviddavis> +1 to accepting #2559
15:47:43 <mhrivnak> !propose triage other high high and add to sprint
15:47:43 <pulpbot> (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
15:47:53 <mhrivnak> !propose other high high and add to sprint
15:47:53 <mhrivnak> #idea Proposed for #2559: high high and add to sprint
15:47:54 <pulpbot> Proposed for #2559: high high and add to sprint
15:47:58 <smyers> +1 to high high and sprint, I was thinking similar
15:48:04 <ttereshc> yeah, you type faster
15:48:06 <ttereshc> +1
15:48:12 <bmbouter> +1
15:48:15 <bizhang> !accept
15:48:15 <bizhang> #agreed high high and add to sprint
15:48:16 <pulpbot> Current proposal accepted: high high and add to sprint
15:48:16 <bizhang> #topic Non-unique collection names in erratum pkglists causes yum not to show all packages - http://pulp.plan.io/issues/2560
15:48:17 <pulpbot> 4 issues left to triage: 2560, 2561, 2562, 2563
15:48:17 <pulpbot> RPM Support Issue #2560 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:48:18 <pulpbot> Non-unique collection names in erratum pkglists causes yum not to show all packages - http://pulp.plan.io/issues/2560
15:48:19 <smyers> ttereshc, this is a great issue btw
15:48:23 <smyers> great write up
15:48:58 <ttereshc> thanks
15:49:20 <ttereshc> this one is less urgent I think but better be fixed soon as well
15:49:29 <daviddavis> med/med and add to sprint?
15:49:36 <smyers> I remember we talked about doing this to collection names, did we just not file an issue and therefore not follow through?
15:50:13 <smyers> But yeah, that's not important for triage. I'd love to see this in sprint 15 or 16
15:50:42 <bizhang> !propose other triage med med, add to sprint
15:50:42 <bizhang> #idea Proposed for #2560: triage med med, add to sprint
15:50:43 <pulpbot> Proposed for #2560: triage med med, add to sprint
15:50:48 <ttereshc> smyers, I do not remember tbh
15:51:14 <smyers> well we have an issue now, so it's all good :)
15:51:28 <smyers> +1 to proposal
15:51:32 <jortel> +1
15:51:35 <bizhang> !accept
15:51:35 <bizhang> #agreed triage med med, add to sprint
15:51:35 <pulpbot> Current proposal accepted: triage med med, add to sprint
15:51:37 <bizhang> #topic pulp_python 2.0 new features are not documented - http://pulp.plan.io/issues/2561
15:51:37 <pulpbot> 3 issues left to triage: 2561, 2562, 2563
15:51:38 <pulpbot> Python Support Issue #2561 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:51:39 <pulpbot> pulp_python 2.0 new features are not documented - http://pulp.plan.io/issues/2561
15:52:00 <bmbouter> should this be a release blocker?
15:52:16 <smyers> for 2.13.0, you mean?
15:52:20 <mhrivnak> It already is.
15:52:28 <mhrivnak> Well, it already blocked a release.
15:52:50 <bmbouter> oic, ty
15:53:11 <bizhang> !propose other triage high medium, add to sprint
15:53:11 <bizhang> #idea Proposed for #2561: triage high medium, add to sprint
15:53:12 <pulpbot> Proposed for #2561: triage high medium, add to sprint
15:53:12 <smyers> Yeah, I opened it that way, assuming that it's really a docs task (though I forgot to tag it as such :\)
15:53:48 <smyers> So between now and whever we kick out 2.13, we ought to be able to get it done, and we really realy should
15:53:58 <mhrivnak> Do we really want it on a sprint right now?
15:54:09 <mhrivnak> We could add it. I'm fine with that.
15:54:17 <mhrivnak> But there's no urgency.
15:54:21 <smyers> I was wondering that, too. We're just sorta tossing everything on there
15:54:39 <smyers> Sprint 16+ is fine, imo
15:54:44 <mhrivnak> And if we add it now, we might not get to make Austin do it. :)
15:55:02 <smyers> !propose triage high medium
15:55:02 <smyers> #idea Proposed for #2561: Priority: High, Severity: Medium
15:55:03 <pulpbot> Proposed for #2561: Priority: High, Severity: Medium
15:55:11 <smyers> No adding to sprint 15
15:55:20 <bizhang> !accept
15:55:20 <bizhang> #agreed Priority: High, Severity: Medium
15:55:21 <pulpbot> Current proposal accepted: Priority: High, Severity: Medium
15:55:22 <pulpbot> 2 issues left to triage: 2562, 2563
15:55:22 <bizhang> #topic Installation document is not working - http://pulp.plan.io/issues/2562
15:55:23 <pulpbot> Pulp Issue #2562 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:55:23 <pulpbot> Installation document is not working - http://pulp.plan.io/issues/2562
15:56:09 <smyers> Yeah...what's in that issue isn't what's in the install docs
15:56:25 <smyers> I can take this one on
15:56:34 <bmbouter> if we think it's right, we can comment and close NOTABUG?
15:56:41 <smyers> bmbouter, exactly my plan
15:56:47 <bizhang> #idea Proposed for #2562: smyers will comment and close
15:56:47 <bizhang> !propose other smyers will comment and close
15:56:47 <pulpbot> Proposed for #2562: smyers will comment and close
15:56:49 <bmbouter> \o/
15:57:04 <mhrivnak> +1 thanks
15:57:07 <bizhang> !accept
15:57:07 <bizhang> #agreed smyers will comment and close
15:57:07 <pulpbot> Current proposal accepted: smyers will comment and close
15:57:09 <bizhang> #topic MongoDB deployment link broken in docs - http://pulp.plan.io/issues/2563
15:57:09 <pulpbot> 1 issues left to triage: 2563
15:57:09 <pulpbot> Pulp Issue #2563 [NEW] (unassigned) - Priority: Low | Severity: Medium
15:57:10 <pulpbot> MongoDB deployment link broken in docs - http://pulp.plan.io/issues/2563
15:57:31 <bizhang> !propose accept
15:57:31 <bizhang> #idea Proposed for #2563: Leave the issue as-is, accepting its current state.
15:57:32 <pulpbot> Proposed for #2563: Leave the issue as-is, accepting its current state.
15:57:38 <daviddavis> I can spend today fixing this
15:57:46 <smyers> severity is effectively nonexistent, but it's such an easy fix
15:57:47 <daviddavis> and leave for the weekend once it's complete
15:57:54 <mhrivnak> +1
15:58:02 <smyers> especially since I think the fix might be to just delete that sentence/link :)
15:58:05 <mhrivnak> -1 leaving for weekend when it's fixed ;)
15:58:09 <daviddavis> lol
15:58:16 <bizhang> !accept
15:58:16 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:58:17 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:58:18 <pulpbot> No issues to triage.
15:58:19 <ttereshc> :)
15:58:22 <bizhang> !end
15:58:22 <bizhang> #endmeeting