15:30:25 <bizhang> #startmeeting Pulp Triage 2017-02-07
15:30:25 <bizhang> #info bizhang has joined triage
15:30:25 <pulpbot> Meeting started Tue Feb  7 15:30:25 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:25 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:25 <pulpbot> The meeting name has been set to 'pulp_triage_2017_02_07'
15:30:25 <pulpbot> bizhang has joined triage
15:30:37 <ipanova> mhrivnak: sure, i did not realize first he was talking about api call
15:30:44 <ttereshc> !here
15:30:44 <ttereshc> #info ttereshc has joined triage
15:30:45 <pulpbot> ttereshc has joined triage
15:31:01 <jortel> !here
15:31:01 <jortel> #info jortel has joined triage
15:31:02 <pulpbot> jortel has joined triage
15:31:08 <mhrivnak> !here
15:31:08 <mhrivnak> #info mhrivnak has joined triage
15:31:08 <pulpbot> mhrivnak has joined triage
15:31:12 <bizhang> !next
15:31:13 <pulpbot> 3 issues left to triage: 2569, 2570, 2573
15:31:13 <bizhang> #topic allowed_keys documented as wrong type - http://pulp.plan.io/issues/2569
15:31:14 <pulpbot> RPM Support Issue #2569 [NEW] (unassigned) - Priority: Normal | Severity: Low
15:31:14 <pulpbot> allowed_keys documented as wrong type - http://pulp.plan.io/issues/2569
15:31:14 <dalley_> !here
15:31:14 <dalley_> #info dalley_ has joined triage
15:31:14 <pulpbot> dalley_ has joined triage
15:31:20 <daviddavis> !here
15:31:20 <daviddavis> #info daviddavis has joined triage
15:31:21 <pulpbot> daviddavis has joined triage
15:31:26 <ipanova> !here
15:31:26 <ipanova> #info ipanova has joined triage
15:31:26 <pulpbot> ipanova has joined triage
15:31:41 <bizhang> !propose accept
15:31:41 <bizhang> #idea Proposed for #2569: Leave the issue as-is, accepting its current state.
15:31:43 <pulpbot> Proposed for #2569: Leave the issue as-is, accepting its current state.
15:31:59 <mhrivnak> +1
15:32:17 <ipanova> +1
15:32:24 <bizhang> !accept
15:32:24 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:32:24 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:32:26 <bizhang> #topic Periodical download_deferred task is triggered even if there is nothing to download. - http://pulp.plan.io/issues/2570
15:32:26 <pulpbot> 2 issues left to triage: 2570, 2573
15:32:26 <pulpbot> Pulp Issue #2570 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:27 <pulpbot> Periodical download_deferred task is triggered even if there is nothing to download. - http://pulp.plan.io/issues/2570
15:32:27 <dkliban> #info dkliban has joined triage
15:32:27 <dkliban> !here
15:32:27 <pulpbot> dkliban has joined triage
15:33:13 <mhrivnak> I lean toward closed-notabug with this one. Other thoughts?
15:33:33 <smyers> +1 notabug
15:35:14 <dkliban> +1
15:35:24 <bizhang> !propose other close notabug
15:35:24 <bizhang> #idea Proposed for #2570: close notabug
15:35:24 <pulpbot> Proposed for #2570: close notabug
15:35:29 <ipanova> i do not have string preferences, i just feel uncomfortable to see deferred tasks when i do not have lazy content at all
15:35:41 <ipanova> s/string/strong
15:35:46 <dkliban> ipanova: i feel the same way. but this works for now
15:35:49 <smyers> It strikes me as being totally normal
15:36:26 <jortel> seems low priority but a worth while optimization.
15:37:18 <aconway> dkliban: thanks
15:37:45 <jortel> I'm +0
15:37:51 <aconway> dkliban: whassat? ValueError: Boolean pulp_manage_rsync is not defined
15:38:02 <aconway> dkliban: missing some selinux setup for the rsync tests?
15:38:24 <bizhang> we can close this for now and reopen if we feel differently later?
15:38:24 <daviddavis> aconway: https://docs.pulpproject.org/plugins/pulp_rpm/tech-reference/rsync-distributor.html
15:38:44 <mhrivnak> I think that's fine. We still have a story open for the caching-only behavior, which could help.
15:38:55 <bizhang> !accept
15:38:55 <bizhang> #agreed close notabug
15:38:55 <pulpbot> Current proposal accepted: close notabug
15:38:56 <pulpbot> 1 issues left to triage: 2573
15:38:57 <bizhang> #topic UserWarning: MongoClient open before fork - http://pulp.plan.io/issues/2573
15:38:57 <pulpbot> Pulp Issue #2573 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:38:57 <pulpbot> UserWarning: MongoClient open before fork - http://pulp.plan.io/issues/2573
15:39:12 <smyers> wontfix
15:39:18 <mhrivnak> I'm continually amazed at how much users dislike warnings in the log.
15:39:23 <ttereshc> isn't it the same https://pulp.plan.io/issues/1580#note-13
15:39:23 <aconway> daviddavis: the tests are trying to --modify it but it seems to not exist.
15:39:25 <pulpbot> Title: Issue #1580: Mongo connection is opened before process is forked - Pulp (at pulp.plan.io)
15:39:32 * smyers finds the link
15:39:36 <ttereshc> and with patch for those who don't like
15:39:40 <ttereshc> smyers, ^
15:40:05 <mhrivnak> ah, great.
15:40:15 <daviddavis> aconway: weird, I don't know what package provides it. dkliban probably does tho.
15:40:31 <mhrivnak> wait, why is 1580 closed-currentrelease?
15:40:32 * mhrivnak reads
15:40:46 <aconway> daviddavis: anyway thanks for the link, has other stuff I needed to know...
15:41:02 <smyers> Thanks, ttereshc. :)
15:41:04 <daviddavis> aconway: np
15:41:35 <dkliban> aconway: is the pulp-selinux package installed/
15:41:39 <dkliban> ?
15:41:40 <mhrivnak> I was going to propose making this a duplicate of 1580, but it's confusing that 1580 appears to have been "fixed".
15:41:47 <dkliban> haha
15:41:59 <dkliban> mhrivnak: your bug must have been fixed also :)
15:42:57 <aconway> dkliban: nope, that'll be it. I installed with ansible - is there an extra flag needed to pull that in?
15:43:18 <mhrivnak> 1580 seems to be specifically about the streamer?
15:44:18 <dkliban> mhrivnak: i think so
15:44:26 <smyers> Yeah, the title there probably needs to be set back to the original, and in hindsight starting at https://pulp.plan.io/issues/1580#note-4 it should have been a separate issue maybe
15:44:28 <pulpbot> Title: Issue #1580: Mongo connection is opened before process is forked - Pulp (at pulp.plan.io)
15:44:28 <dkliban> mhrivnak: my comments in there say we should fix for workers also
15:44:49 <mhrivnak> Ok.
15:44:54 <ipanova> https://github.com/pulp/pulp/pull/2409/files#diff-abee42f9c3a1b498c07cb513ca7cb974R454
15:44:54 <dkliban> aconway: i think ansible checks if you have selinux enabled or disabled. what's the status of that on your machine?
15:44:54 <pulpbot> Title: suppress and log pymongo "connect before fork" warnings by seandst · Pull Request #2409 · pulp/pulp · GitHub (at github.com)
15:45:06 <mhrivnak> !propose other close - wontfix and reference the comments from #1580
15:45:06 <mhrivnak> #idea Proposed for #2573: close - wontfix and reference the comments from #1580
15:45:07 <pulpbot> Proposed for #2573: close - wontfix and reference the comments from #1580
15:45:39 <bizhang> !accept
15:45:39 <bizhang> #agreed close - wontfix and reference the comments from #1580
15:45:40 <pulpbot> Current proposal accepted: close - wontfix and reference the comments from #1580
15:45:41 <pulpbot> No issues to triage.
15:45:43 <bizhang> !end
15:45:43 <bizhang> #endmeeting