15:29:45 <bizhang> #startmeeting Pulp Triage 2017-02-10
15:29:45 <bizhang> #info bizhang has joined triage
15:29:45 <pulpbot> Meeting started Fri Feb 10 15:29:45 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:45 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:45 <pulpbot> The meeting name has been set to 'pulp_triage_2017_02_10'
15:29:45 <pulpbot> bizhang has joined triage
15:30:00 <ipanova> !here
15:30:00 <ipanova> #info ipanova has joined triage
15:30:00 <pulpbot> ipanova has joined triage
15:30:00 <daviddavis> !here
15:30:00 <daviddavis> #info daviddavis has joined triage
15:30:00 <pulpbot> daviddavis has joined triage
15:30:08 <dkliban> !here
15:30:08 <dkliban> #info dkliban has joined triage
15:30:08 <pulpbot> dkliban has joined triage
15:30:12 <mhrivnak> !here
15:30:12 <mhrivnak> #info mhrivnak has joined triage
15:30:13 <pulpbot> mhrivnak has joined triage
15:30:19 <bizhang> !next
15:30:21 <bizhang> #topic pulp-admin sometimes errors when watching tasks - http://pulp.plan.io/issues/2574
15:30:21 <pulpbot> 6 issues left to triage: 2574, 2577, 2580, 2581, 2582, 2584
15:30:22 <pulpbot> Puppet Support Issue #2574 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:30:23 <pulpbot> pulp-admin sometimes errors when watching tasks - http://pulp.plan.io/issues/2574
15:30:27 <dalley> !here
15:30:27 <dalley> #info dalley has joined triage
15:30:27 <pulpbot> dalley has joined triage
15:30:59 <ttereshc> !here
15:30:59 <ttereshc> #info ttereshc has joined triage
15:31:00 <pulpbot> ttereshc has joined triage
15:31:04 <preethi> !here
15:31:04 <preethi> #info preethi has joined triage
15:31:05 <pulpbot> preethi has joined triage
15:31:34 <mhrivnak> Seems likely limited to puppet repo syncs.
15:31:55 <smyers> think it's the delete skipping resource locking?
15:32:21 <smyers> not sure how to triage, though...
15:32:41 <ipanova> i would like qe to provide us manual steps to reproduce, we might struggle for a while until we reproduce this
15:32:59 <mhrivnak> smyers, how do deletes and resource locking factor in?
15:33:04 <ipanova> because seems like it happens just when automation is run
15:33:16 <smyers> I see a reproducer in comment #7
15:33:35 <mhrivnak> Oh right.
15:34:01 <mhrivnak> The end of comment 7 looks like a standard pulp-admin parsing error.
15:34:30 <mhrivnak> Probably either items_done or items_total is None, and it craps out.
15:34:45 <ipanova> smyers: sure but the traceback output is from the test anyway
15:35:01 <mhrivnak> So I think pulp-admin just dies prematurely. No locking or deleting bugs.
15:35:37 <ipanova> !propose triage low low
15:35:37 <ipanova> #idea Proposed for #2574: Priority: Low, Severity: Low
15:35:38 <pulpbot> Proposed for #2574: Priority: Low, Severity: Low
15:36:37 <mhrivnak> I'm ok with low low. I'd also be ok with normal/low
15:37:15 <dalley> +1
15:37:51 <bizhang> !accept
15:37:51 <bizhang> #agreed Priority: Low, Severity: Low
15:37:51 <pulpbot> Current proposal accepted: Priority: Low, Severity: Low
15:37:53 <bizhang> #topic last_unit_added is not updated when units are copied over from another repo - http://pulp.plan.io/issues/2577
15:37:53 <pulpbot> 5 issues left to triage: 2577, 2580, 2581, 2582, 2584
15:37:53 <pulpbot> Pulp Issue #2577 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:37:54 <pulpbot> last_unit_added is not updated when units are copied over from another repo - http://pulp.plan.io/issues/2577
15:38:21 <dkliban> high / high ?
15:38:23 <mhrivnak> !propose other high/high add to sprint
15:38:23 <mhrivnak> #idea Proposed for #2577: high/high add to sprint
15:38:23 <pulpbot> Proposed for #2577: high/high add to sprint
15:38:31 <ipanova> !propose triage high high
15:38:31 <ipanova> #idea Proposed for #2577: Priority: High, Severity: High
15:38:32 <pulpbot> Proposed for #2577: Priority: High, Severity: High
15:38:34 <dalley> +1
15:38:53 <ttereshc> +1
15:39:12 <mhrivnak> ipanova, are you also in favor of adding to sprint?
15:39:17 <ipanova> i think it will be good to check if during upload of the unit the last_unit_added is set as well
15:39:21 <mhrivnak> since you overwrote my proposal... ;)
15:39:36 <ipanova> mhrivnak: sorry i did not see that, you we re faster
15:39:39 <ipanova> mhrivnak: sure
15:39:42 <bizhang> !propose other triage high high add to sprint
15:39:42 <bizhang> #idea Proposed for #2577: triage high high add to sprint
15:39:43 <pulpbot> Proposed for #2577: triage high high add to sprint
15:39:46 <bizhang> !accept
15:39:46 <bizhang> #agreed triage high high add to sprint
15:39:46 <pulpbot> Current proposal accepted: triage high high add to sprint
15:39:48 <pulpbot> 4 issues left to triage: 2580, 2581, 2582, 2584
15:39:48 <bizhang> #topic http://pulp.plan.io/issues/2580
15:39:49 <pulpbot> Issue #2580 is private and must be viewed in Redmine
15:39:49 <pulpbot> http://pulp.plan.io/issues/2580
15:40:13 <ipanova> can we please go back to #2577
15:40:26 <bizhang> !issue 2577
15:40:27 <bizhang> #topic last_unit_added is not updated when units are copied over from another repo - http://pulp.plan.io/issues/2577
15:40:27 <pulpbot> Pulp Issue #2577 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:40:28 <pulpbot> last_unit_added is not updated when units are copied over from another repo - http://pulp.plan.io/issues/2577
15:40:32 <ipanova> if team agrees with upload case
15:40:44 <daviddavis> ipanova: setting last_unit_added during upload was fixed here I believe https://github.com/pulp/pulp/pull/2905
15:40:45 <pulpbot> Title: Update last_unit_added when unit is imported to repo. by werwty · Pull Request #2905 · pulp/pulp · GitHub (at github.com)
15:41:12 <bizhang> ipanova, https://pulp.plan.io/issues/1847
15:41:13 <ipanova> daviddavis: cool, then disregard my question
15:41:14 <pulpbot> Title: Issue #1847: last_unit_added is not added in mongo repo collection records - Pulp (at pulp.plan.io)
15:41:18 <bizhang> I missed the copy case when I worked on this
15:41:21 <mhrivnak> would be good to have a smash test for it though
15:41:26 <ipanova> agree
15:41:26 <daviddavis> +1
15:41:27 <mhrivnak> If someone would like to file that
15:41:30 <dalley> +1
15:41:31 * mhrivnak looks at ipanova ;)
15:41:43 <ipanova> mhrivnak: sure, will do
15:41:50 <mhrivnak> Thanks!
15:41:58 <bizhang> !issue 2580
15:41:59 <bizhang> #topic http://pulp.plan.io/issues/2580
15:41:59 <pulpbot> Issue #2580 is private and must be viewed in Redmine
15:41:59 <pulpbot> http://pulp.plan.io/issues/2580
15:43:09 <mhrivnak> I'm still not real clear on what happens, but I think the summary is: try to export a repo to ISO, hit a disk full error, and Pulp either doesn't cleanup like it should, or maybe even fails to make it clear that the publish is incomplete.
15:43:29 <daviddavis> what is a private bug?
15:43:39 <ipanova> i think we can make it public
15:43:41 <smyers> Someone checked "private" when filing
15:43:46 <daviddavis> oh
15:43:49 <ipanova> i don't see any sensitive info here
15:44:04 <smyers> precedent is that we should get permission from the filer before making an issue public
15:44:11 <dalley> yeah I was wondering why it was private :)
15:44:17 <ipanova> smyers: oooh i see, gotcha
15:44:24 <ipanova> jluza: ^^
15:44:27 <smyers> (so jluza, can we make #2580 public?) :)
15:45:03 <ttereshc> there was a discussion on internal channel, that probably not
15:45:08 <ipanova> smyers: we can triage it for now, and leave the question on the issue not wait now
15:45:17 <mhrivnak> In the mean time, I think this needs to be reproduced before we'll know enough about what behavior might be incorrect.
15:45:29 <mhrivnak> But we could triage it now.
15:45:56 <ipanova> !propose triage normal normal
15:45:56 <ipanova> #idea Proposed for #2580: Priority: Normal, Severity: Medium
15:45:57 <pulpbot> Proposed for #2580: Priority: Normal, Severity: Medium
15:46:00 <ttereshc> !propose accept
15:46:00 <ttereshc> #idea Proposed for #2580: Leave the issue as-is, accepting its current state.
15:46:00 <pulpbot> Proposed for #2580: Leave the issue as-is, accepting its current state.
15:46:12 <ttereshc> oops :) but it is the same
15:46:12 <smyers> I can't tell by this that pulp is actually doing anything wrong
15:46:39 <smyers> So I'm +1 reproducer
15:46:54 <ipanova> i think with next export the truncated files will be overriden once there will be some more space
15:47:22 <mhrivnak> +1 accept
15:47:55 <dkliban> +1
15:48:12 <ttereshc> smyers, so do you propose not to triage it now?
15:48:54 <jluza> smyers, yes, you can, there are only repo names and that shouldn't matter
15:49:22 <ipanova> thanks jluza
15:49:27 <smyers> ttereshc, I propose nothing. :)
15:49:45 <smyers> I don't have enough info to triage it, but if others do then excellent
15:50:11 <bizhang> !accept
15:50:11 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:50:11 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:50:13 <pulpbot> 3 issues left to triage: 2581, 2582, 2584
15:50:13 <bizhang> #topic Release notes out of date - http://pulp.plan.io/issues/2581
15:50:14 <pulpbot> Puppet Support Issue #2581 [NEW] (unassigned) - Priority: Normal | Severity: Low
15:50:14 <pulpbot> Release notes out of date - http://pulp.plan.io/issues/2581
15:50:50 <daviddavis> are the rel notes up to date in the repo?
15:51:04 <smyers> nope
15:51:13 <bizhang> Do we need to produce release notes when there aren't any features added?
15:51:29 <smyers> I slapped the 2.13 page into the index to make the docs builder happy, but there's a gap from 2.8 to 2.13
15:51:48 <mhrivnak> We should at least have something that says "Nothing changed"
15:51:59 <smyers> And historically we have
15:52:11 <bizhang> !propose accept
15:52:11 <bizhang> #idea Proposed for #2581: Leave the issue as-is, accepting its current state.
15:52:11 <pulpbot> Proposed for #2581: Leave the issue as-is, accepting its current state.
15:52:19 <daviddavis> add to sprint?
15:52:23 <ipanova> yeah like here http://docs.pulpproject.org/plugins/pulp_puppet/user-guide/release-notes/2.8.x.html#pulp-puppet-2-8-3 bizhang
15:52:24 <pulpbot> Title: Pulp Puppet 2.8 Release Notes — Pulp Project 2.12 documentation (at docs.pulpproject.org)
15:52:25 <dalley> ..were there features added?
15:52:42 <daviddavis> dalley: no
15:52:51 <dalley> looking at the commit history, there's not really a lot there
15:52:54 <smyers> It doesn't matter
15:53:19 <bizhang> !propose other accept and add to sprint
15:53:19 <bizhang> #idea Proposed for #2581: accept and add to sprint
15:53:20 <pulpbot> Proposed for #2581: accept and add to sprint
15:53:27 <daviddavis> !accept
15:53:34 <daviddavis> :(
15:53:43 <mhrivnak> daviddavis, you're not the driver. :)
15:53:44 <smyers> "Nothing changed" is valueable info for a user, and (imo) necessary as long as we're constantly bumping puppet and rpm's versions due to platform changes.
15:53:47 <daviddavis> lol
15:53:57 <smyers> I expect he got a bot msg, "You are not the meeting chair."
15:53:58 * daviddavis tries to be a backseat driver
15:54:00 <smyers> :)
15:54:11 <bizhang> !accept
15:54:11 <bizhang> #agreed accept and add to sprint
15:54:11 <pulpbot> Current proposal accepted: accept and add to sprint
15:54:12 <pulpbot> 2 issues left to triage: 2582, 2584
15:54:13 <bizhang> #topic Pipe leak in any parent Pulp celery process triggered by qpidd restart - http://pulp.plan.io/issues/2582
15:54:13 <pulpbot> Pulp Issue #2582 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:54:13 <pulpbot> Pipe leak in any parent Pulp celery process triggered by qpidd restart - http://pulp.plan.io/issues/2582
15:54:46 <daviddavis> oh this is not good
15:54:55 <mhrivnak> !propose other high high add to sprint
15:54:55 <mhrivnak> #idea Proposed for #2582: high high add to sprint
15:54:55 <ipanova> bizhang: what about making #2581 a task and check that on all plugins we have release note up-to-date?
15:54:55 <pulpbot> Proposed for #2582: high high add to sprint
15:55:18 <smyers> maaaaaaan this looks hard
15:55:22 <mhrivnak> I wonder if this will turn out to be a qpid client library bug, but even if so, we'll need to prove it.
15:55:26 <smyers> +1 mhrivnak's proposal
15:55:37 <daviddavis> +1
15:55:41 <bizhang> ipanova, let's swich back to 2581 at the end of the triage and discuss
15:55:59 <bizhang> !accept
15:55:59 <bizhang> #agreed high high add to sprint
15:55:59 <pulpbot> Current proposal accepted: high high add to sprint
15:56:00 <bizhang> #topic Mongo cursor times out during task pulp.server.managers.content.orphan.delete_all_orphans - http://pulp.plan.io/issues/2584
15:56:01 <pulpbot> 1 issues left to triage: 2584
15:56:01 <pulpbot> Pulp Issue #2584 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:56:02 <pulpbot> Mongo cursor times out during task pulp.server.managers.content.orphan.delete_all_orphans - http://pulp.plan.io/issues/2584
15:56:41 <daviddavis> pulp 3.0 is looking more appealing by the day
15:56:49 <mhrivnak> yeeeeees
15:56:59 <smyers> ipanova, I've actually got a note to discuss releasenotes-ness in an upcoming meeting. I don't think that discussion is appropriate during triage, but I can add a link to that meeting's agenda
15:57:37 <daviddavis> I think accept this as normal medium and add to sprint?
15:57:41 <mhrivnak> !propose other accept and add to sprint
15:57:41 <mhrivnak> #idea Proposed for #2584: accept and add to sprint
15:57:42 <pulpbot> Proposed for #2584: accept and add to sprint
15:57:47 <dalley> +1
15:57:50 <ipanova> +1
15:57:51 <ttereshc> I saw this issue recently on a customer system as well
15:57:53 <ttereshc> +1
15:58:23 <ipanova> smyers: there is nothing to discuss right now, just make sure we check not just puppet plugin but all of them
15:58:46 <ipanova> +1
15:58:58 <ipanova> ah, i already plused one))
15:59:03 <bizhang> !accept
15:59:03 <bizhang> #agreed accept and add to sprint
15:59:03 <pulpbot> Current proposal accepted: accept and add to sprint
15:59:05 <pulpbot> No issues to triage.
15:59:12 <bizhang> !end
15:59:12 <bizhang> #endmeeting