15:30:00 <bizhang> #startmeeting Pulp Triage 2017-02-17
15:30:00 <bizhang> #info bizhang has joined triage
15:30:00 <pulpbot> Meeting started Fri Feb 17 15:30:00 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:00 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:00 <pulpbot> The meeting name has been set to 'pulp_triage_2017_02_17'
15:30:00 <pulpbot> bizhang has joined triage
15:30:03 <mhrivnak> #info mhrivnak has joined triage
15:30:03 <mhrivnak> !here
15:30:04 <pulpbot> mhrivnak has joined triage
15:30:06 <daviddavis> !here
15:30:06 <daviddavis> #info daviddavis has joined triage
15:30:07 <pulpbot> daviddavis has joined triage
15:30:09 <jortel> !here
15:30:09 <jortel> #info jortel has joined triage
15:30:09 <pulpbot> jortel has joined triage
15:30:12 <bizhang> !next
15:30:13 <bizhang> #topic Disallow re-uploading the same package twice - http://pulp.plan.io/issues/1389
15:30:14 <pulpbot> 6 issues left to triage: 1389, 2588, 2589, 2591, 2592, 2593
15:30:14 <pulpbot> Pulp Issue #1389 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:30:15 <pulpbot> Disallow re-uploading the same package twice - http://pulp.plan.io/issues/1389
15:30:53 <dalley> !here
15:30:53 <dalley> #info dalley has joined triage
15:30:54 <pulpbot> dalley has joined triage
15:30:56 <ipanova> !here
15:30:56 <ipanova> #info ipanova has joined triage
15:30:56 <pulpbot> ipanova has joined triage
15:31:05 <ttereshc> !here
15:31:05 <ttereshc> #info ttereshc has joined triage
15:31:05 <pulpbot> ttereshc has joined triage
15:31:11 <dkliban> !here
15:31:11 <dkliban> #info dkliban has joined triage
15:31:11 <pulpbot> dkliban has joined triage
15:31:20 <bizhang> accept and add to sprint?
15:31:36 <daviddavis> bizhang: +1
15:31:41 <jortel> +1
15:32:05 <mhrivnak> +1
15:32:07 <bizhang> !propose other accept and add to sprint 15
15:32:07 <bizhang> #idea Proposed for #1389: accept and add to sprint 15
15:32:08 <pulpbot> Proposed for #1389: accept and add to sprint 15
15:32:11 <bizhang> !accept
15:32:11 <bizhang> #agreed accept and add to sprint 15
15:32:11 <pulpbot> Current proposal accepted: accept and add to sprint 15
15:32:13 <pulpbot> 5 issues left to triage: 2588, 2589, 2591, 2592, 2593
15:32:13 <bizhang> #topic Pulp Gets Stuck On A Particular Mirror - http://pulp.plan.io/issues/2588
15:32:14 <pulpbot> Pulp Issue #2588 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:32:14 <pulpbot> Pulp Gets Stuck On A Particular Mirror - http://pulp.plan.io/issues/2588
15:33:15 <ttereshc> sounds quite bad :( prio high?
15:34:12 <daviddavis> is the problem that pulp is storing the destination url and retrying that instead of the original url?
15:35:17 <jortel> the catalog contains the url as would be used by the importer for 'immediate'
15:35:17 <mhrivnak> Oh, I might know what's going on here. Interesting problem.
15:35:43 <mhrivnak> jortel, the yum importer can have a mirror list URL.
15:35:54 <mhrivnak> Which gets resolved to a specific mirror during sync.
15:36:06 <mhrivnak> I wonder if the catalog entries are made using that specific mirror URL.
15:36:46 <daviddavis> ah, yea
15:36:59 <bmbouter> !here
15:36:59 <bmbouter> #info bmbouter has joined triage
15:37:00 <jortel> could be.  I'd have to look.
15:37:00 <pulpbot> bmbouter has joined triage
15:37:04 <daviddavis> high and add to sprint?
15:37:09 <mhrivnak> Not real sure what the right approach is.
15:37:29 <jortel> yeah, i'd need to think/dig through it
15:37:34 <bizhang> needsinfo and retriage after jortel takes a look?
15:37:46 <mhrivnak> I think that's a fine idea.
15:37:49 <daviddavis> works for me
15:37:51 <jortel> +1
15:37:52 <bizhang> !propose other needsinfo, jortel to take a look
15:37:52 <bizhang> #idea Proposed for #2588: needsinfo, jortel to take a look
15:37:53 <mhrivnak> We can brainstorm on it and come back in a few days.
15:37:53 <pulpbot> Proposed for #2588: needsinfo, jortel to take a look
15:37:58 <bizhang> !accept
15:37:58 <bizhang> #agreed needsinfo, jortel to take a look
15:37:58 <pulpbot> Current proposal accepted: needsinfo, jortel to take a look
15:37:59 <bizhang> #topic Pulp 2.13 nightly fails to start on RHEL 7.3 - http://pulp.plan.io/issues/2589
15:38:00 <pulpbot> 4 issues left to triage: 2589, 2591, 2592, 2593
15:38:00 <pulpbot> Pulp Issue #2589 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:38:01 <pulpbot> Pulp 2.13 nightly fails to start on RHEL 7.3 - http://pulp.plan.io/issues/2589
15:38:09 <daviddavis> looks like celery just needs to be updated
15:38:15 <daviddavis> high and add to sprint
15:38:19 <dkliban> +1
15:38:50 <bizhang> !propose other triage high/high add to sprint
15:38:50 <bizhang> #idea Proposed for #2589: triage high/high add to sprint
15:38:51 <pulpbot> Proposed for #2589: triage high/high add to sprint
15:39:20 <mhrivnak> What about medium priority?
15:39:20 <ttereshc> +1
15:39:24 <mhrivnak> Since it's not released yet.
15:39:36 <daviddavis> +1
15:39:38 <mhrivnak> No users affected.
15:39:39 <jortel> +1
15:40:22 <dalley> +1
15:40:30 <bizhang> I'd be ok with med too, but we probably want to get the nightly working sooner rather than later
15:40:35 <bizhang> are these +1 to med prio?
15:41:02 <jortel> actually, I vote for high/high
15:41:21 <dalley> agreed, and it's fairly low difficulty
15:41:29 <mhrivnak> What is this blocking right now?
15:41:39 <dalley> it should block 2.13
15:41:50 <dalley> the tag got removed by accident because of that redmine bug
15:42:08 <mhrivnak> Is testing not working because of it?
15:42:49 <dalley> mhrivnak, pulp basically does not work on rhel7 without a newer version of celery
15:42:54 <mhrivnak> I can easily be sold on high priority. :) I'm just looking for what the current impact is of this bug.
15:43:18 <dalley> workers and resource manager immediately crash
15:43:46 <jortel> vote not to add it to the sprint.
15:44:27 <mhrivnak> jortel, can you elaborate on why you're advocating high priority and not adding to the sprint?
15:45:21 <jortel> i think they are separate things.  not all high prio needs to be rush onto a sprint.
15:45:45 <jortel> but should be considered first for future sprints
15:45:47 <mhrivnak> Agreed. I'm just looking for any kind of explanation of what you're thinking along both lines. :)
15:46:48 <jortel> i'm concerned med/high it will not be visible enough.  higher vis will help ensure it will be fixed before blocking anything.
15:46:55 <bmbouter> (I'm also in another meeting), but I think this will block 2.13
15:47:40 <mhrivnak> I think we're all in agreement that it blocks 2.13
15:47:46 <jortel> yep
15:48:14 <bmbouter> cool, +1 to sprint for that
15:48:18 <mhrivnak> I'm ok with high prio and not on the sprint, or med prio and add it to the sprint.
15:48:29 <jortel> I'm -0 for adding to the sprint.  I think next sprint would be fine.
15:48:44 <bmbouter> the thing is that when we upgrade to 3.1.20 pulp-smash is going to break
15:48:59 <mhrivnak> Fine with me. That gets back to what the current impact is of the bug, which so far I'm hearing "None".
15:49:00 <bmbouter> so the dev fix is easy, but we will then have a new problem
15:50:09 <bmbouter> mhrivnak: do you mean impact is none due to it not being released?
15:50:22 <mhrivnak> We've been on this 10 minutes. I'm ok with virtually anything at this point. :)
15:50:30 <daviddavis> lol
15:50:45 <dalley> FYI, if we were to upgrade to 3.1.17 instead of 3.1.20 it would not break pulp-smash
15:50:52 <bizhang> !propose other triage med/high add to sprint
15:50:52 <bizhang> #idea Proposed for #2589: triage med/high add to sprint
15:50:53 <pulpbot> Proposed for #2589: triage med/high add to sprint
15:50:54 <mhrivnak> bmbouter, yes. If this is causing a problem for someone right now, then that suggests we should prioritize it more highly.
15:51:08 <bizhang> !accept
15:51:08 <bizhang> #agreed triage med/high add to sprint
15:51:08 <pulpbot> Current proposal accepted: triage med/high add to sprint
15:51:08 <dalley> but it would still resolve the issue
15:51:10 <bizhang> #topic pulp not starting properly, apache pulp-manage-db throwing errors - http://pulp.plan.io/issues/2591
15:51:10 <pulpbot> 3 issues left to triage: 2591, 2592, 2593
15:51:11 <pulpbot> Pulp Issue #2591 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:51:12 <pulpbot> pulp not starting properly, apache pulp-manage-db throwing errors - http://pulp.plan.io/issues/2591
15:51:40 <bizhang> ^ we can argue more about it after triage
15:52:36 <bizhang> close worksforme? or should we take a closer look at this?
15:53:12 <mhrivnak> If someone could comment on it to help that person work around the problem, I think that would be fine.
15:53:18 <mhrivnak> It doesn't seem like we're going to be able to reproduce.
15:53:29 <jortel> agreed
15:53:31 <ttereshc> it looks like user reported upgrade from 2.10
15:53:46 <ttereshc> preethi tried from 2.11
15:53:48 <elyezer> bmbouter: I am back
15:54:16 <ttereshc> maybe it's a typo
15:54:23 <ttereshc> preethi, ^
15:54:52 <preethi> ttereshc: i saw that, I can try it today
15:55:10 <bizhang> !propose other needsinfo, preethi to try 2.10 upgrade
15:55:10 <bizhang> #idea Proposed for #2591: needsinfo, preethi to try 2.10 upgrade
15:55:11 <pulpbot> Proposed for #2591: needsinfo, preethi to try 2.10 upgrade
15:55:20 <jortel> +1
15:55:41 <mhrivnak> works for me.
15:55:43 <bizhang> !accept
15:55:43 <bizhang> #agreed needsinfo, preethi to try 2.10 upgrade
15:55:43 <pulpbot> Current proposal accepted: needsinfo, preethi to try 2.10 upgrade
15:55:44 <bizhang> #topic repos.fedorapeople.org repository certificate changed since 2017-02-14  - http://pulp.plan.io/issues/2592
15:55:45 <pulpbot> 2 issues left to triage: 2592, 2593
15:55:45 <pulpbot> Pulp Issue #2592 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:55:46 <pulpbot> repos.fedorapeople.org repository certificate changed since 2017-02-14  - http://pulp.plan.io/issues/2592
15:56:08 <mhrivnak> Seems this is el6 only.
15:56:48 <mhrivnak> And will be difficult/impossible to solve if the linked stackoverflow approach doesn't work.
15:57:23 <mhrivnak> I lean toward "wontfix".
15:57:47 <mhrivnak> Especially considering that 2.12, our current bugfix release, isn't affected.
15:58:20 <smyers> Only thing I'd recommend that isn't "wontfix" is change it to add a note to the install docs
15:58:22 <jortel> I'm fine with wontfix
15:58:37 <smyers> But even that is "eh", because it's also reasonable to remove el6 from the install docs starting with 2.12.0
15:59:01 <bizhang> !propose other close wontfix
15:59:01 <bizhang> #idea Proposed for #2592: close wontfix
15:59:02 <pulpbot> Proposed for #2592: close wontfix
15:59:16 <smyers> +1 wontfix
15:59:42 <bizhang> !accept
15:59:42 <bizhang> #agreed close wontfix
15:59:42 <pulpbot> Current proposal accepted: close wontfix
15:59:43 <pulpbot> 1 issues left to triage: 2593
15:59:44 <bizhang> #topic Single-package error during sync is not being propogated up through the CLI - http://pulp.plan.io/issues/2593
15:59:44 <pulpbot> Pulp Issue #2593 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:59:44 <pulpbot> Single-package error during sync is not being propogated up through the CLI - http://pulp.plan.io/issues/2593
16:00:02 <bizhang> !propose accept
16:00:02 <bizhang> #idea Proposed for #2593: Leave the issue as-is, accepting its current state.
16:00:03 <pulpbot> Proposed for #2593: Leave the issue as-is, accepting its current state.
16:00:29 <dalley> low/low
16:00:49 <mhrivnak> I assume this is rpm-specific?
16:00:55 <dalley> I believe so
16:01:28 <mhrivnak> Gotcha. We can move it then to the "rpm" project in redmine.
16:01:31 <bizhang> !propose other move to pulp_rpm project, triage low/low
16:01:31 <bizhang> #idea Proposed for #2593: move to pulp_rpm project, triage low/low
16:01:31 <pulpbot> Proposed for #2593: move to pulp_rpm project, triage low/low
16:01:39 <mhrivnak> works for me.
16:01:42 <daviddavis> +1
16:01:43 <ttereshc> +1
16:01:45 <bmbouter> one sec
16:01:48 <bizhang> !accept
16:01:48 <bizhang> #agreed move to pulp_rpm project, triage low/low
16:01:48 <pulpbot> Current proposal accepted: move to pulp_rpm project, triage low/low
16:01:50 <pulpbot> No issues to triage.
16:01:56 <bmbouter> isn't this issue in platform
16:02:01 <bmbouter> in the CLI of platform
16:02:21 <bizhang> !issue 2593
16:02:22 <bizhang> #topic Single-package error during sync is not being propogated up through the CLI - http://pulp.plan.io/issues/2593
16:02:22 <pulpbot> Pulp Issue #2593 [NEW] (unassigned) - Priority: Normal | Severity: Medium
16:02:22 <pulpbot> Single-package error during sync is not being propogated up through the CLI - http://pulp.plan.io/issues/2593
16:02:35 <bmbouter> +1 to low low, but isn't the progress reporting generic or rpm specific?
16:02:38 <mhrivnak> pulp_rpm sync has mostly custom CLI rendering.
16:02:48 <bmbouter> ok
16:02:57 <bmbouter> then this sounds right I thought it was generic
16:03:08 <mhrivnak> Because it pre-dates the step framework, which gave us a unified progress structure.
16:03:14 <bmbouter> oic
16:03:16 <bmbouter> ty
16:03:20 <bizhang> do we also want to talk more about #2589
16:03:20 <mhrivnak> Sure thing!
16:03:20 <bmbouter> +1 to the previous resolution
16:03:28 <bmbouter> yes please
16:03:35 <bizhang> !issue 2589
16:03:36 <bizhang> #topic Pulp 2.13 nightly fails to start on RHEL 7.3 - http://pulp.plan.io/issues/2589
16:03:36 <pulpbot> Pulp Issue #2589 [NEW] (unassigned) - Priority: Normal | Severity: Medium
16:03:37 <pulpbot> Pulp 2.13 nightly fails to start on RHEL 7.3 - http://pulp.plan.io/issues/2589
16:04:15 <bmbouter> so we know we need to upgrade python-celery
16:04:27 <dalley> any version of celery > 3.1.11 should work, but versions > 3.1.17 will break pulp-smash
16:04:40 <bmbouter> the thing is that fedoras already have 3.1.20
16:04:43 <bmbouter> so pulp-smash is already broken
16:04:49 <dalley> true
16:05:52 <bmbouter> that is why I +1 to upgrading to 3.1.20 for consistency on all platforms and have pulp-smash fix whatever the problem is
16:06:08 <mhrivnak> That sounds reasonable.
16:06:56 <bizhang> give that we want to fix pulp instead of installing a different celery version do we still want to add it to the sprint?
16:08:18 <bmbouter> we need to upgrade the celery version and fix pulp-smash
16:08:32 <bmbouter> upgrading celery will resolve the bug, but pulp-smash will need to be updated to match
16:09:19 <dalley> this is a relevant celery issue to the pulp-smash problems
16:09:20 <dalley> https://github.com/celery/celery/issues/2663
16:09:21 <pulpbot> Title: celery 3.1.18 doesn't work w/ Django dummy db · Issue #2663 · celery/celery · GitHub (at github.com)
16:09:50 <dalley> they don't plan to fix it themselves
16:09:58 <elyezer> I've found the reason why 2.13 jobs are timing out, who was looking into it?
16:10:20 <bizhang> gotcha, I thought it was a pulp celery 3.2.20 issue not a pulp-smash celery issue
16:10:46 <bizhang> ok so we're all good with the preciously propose resolution?
16:11:20 <bizhang> !end
16:11:20 <bizhang> #endmeeting