15:29:55 <bizhang> #startmeeting Pulp Triage 2017-02-24
15:29:55 <bizhang> #info bizhang has joined triage
15:29:55 <pulpbot> Meeting started Fri Feb 24 15:29:55 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:55 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:55 <pulpbot> The meeting name has been set to 'pulp_triage_2017_02_24'
15:29:55 <pulpbot> bizhang has joined triage
15:30:20 <jortel> !here
15:30:20 <jortel> #info jortel has joined triage
15:30:20 <pulpbot> jortel has joined triage
15:30:36 <jortel> daviddavis: thanks
15:30:38 <ipanova> !here
15:30:38 <ipanova> #info ipanova has joined triage
15:30:39 <pulpbot> ipanova has joined triage
15:30:42 <preethi> !here
15:30:42 <preethi> #info preethi has joined triage
15:30:43 <pulpbot> preethi has joined triage
15:30:48 <bizhang> !next
15:30:49 <pulpbot> 4 issues left to triage: 2588, 2603, 2605, 2608
15:30:49 <bizhang> #topic Pulp Gets Stuck On A Particular Mirror - http://pulp.plan.io/issues/2588
15:30:50 <pulpbot> Pulp Issue #2588 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:30:50 <pulpbot> Pulp Gets Stuck On A Particular Mirror - http://pulp.plan.io/issues/2588
15:31:12 <bmbouter> !here
15:31:12 <bmbouter> #info bmbouter has joined triage
15:31:13 <pulpbot> bmbouter has joined triage
15:31:45 <ttereshc> !here
15:31:45 <ttereshc> #info ttereshc has joined triage
15:31:45 <pulpbot> ttereshc has joined triage
15:31:49 <ipanova> jortel: any updates on this issue?
15:31:53 <mhrivnak> !here
15:31:53 <mhrivnak> #info mhrivnak has joined triage
15:31:53 <pulpbot> mhrivnak has joined triage
15:32:26 <thomasmckay> !here
15:32:26 <thomasmckay> #info thomasmckay has joined triage
15:32:26 <pulpbot> thomasmckay has joined triage
15:33:10 <jortel> looking
15:33:16 <daviddavis> !here
15:33:16 <daviddavis> #info daviddavis has joined triage
15:33:17 <pulpbot> daviddavis has joined triage
15:34:04 <dalley> !here
15:34:04 <dalley> #info dalley has joined triage
15:34:05 <pulpbot> dalley has joined triage
15:34:13 <mhrivnak> Perhaps we should just accept this as-is, and jortel can keep this use case in mind while thinking about the pulp 3 plugin/download API.
15:34:21 <jortel> 2588 is a broken scenario.  not a regression but a flaw in the way the importer populates (lazy) catalog wrt mirror lists.
15:34:51 <jortel> mhrivnak: yes. exactly.  this will be much easier to fix in pulp3 and have already taken it into account with download api.
15:35:02 <mhrivnak> !propose accept
15:35:02 <mhrivnak> #idea Proposed for #2588: Leave the issue as-is, accepting its current state.
15:35:03 <pulpbot> Proposed for #2588: Leave the issue as-is, accepting its current state.
15:35:18 <jortel> mhrivnak: this should not be fixed in the way catalog entries are generated.
15:36:06 <mhrivnak> ack
15:36:16 <bizhang> mhrivnak, should I tag this as pulp3?
15:36:55 <bizhang> how are we keeping track of the issues to keep in mind for pulp3?
15:37:02 <mhrivnak> Seems reasonable. I don't know that we've done that before with a pulp 2 bug, but I think it makes sense.
15:37:13 <mhrivnak> Mostly we're tracking them as use cases / stories.
15:37:23 <bizhang> !propose other accept and tag pulp3
15:37:23 <bizhang> #idea Proposed for #2588: accept and tag pulp3
15:37:24 <pulpbot> Proposed for #2588: accept and tag pulp3
15:37:28 <bizhang> !accept
15:37:28 <bizhang> #agreed accept and tag pulp3
15:37:29 <pulpbot> Current proposal accepted: accept and tag pulp3
15:37:30 <bizhang> #topic Search API does weird filtering on association - http://pulp.plan.io/issues/2603
15:37:30 <pulpbot> 3 issues left to triage: 2603, 2605, 2608
15:37:30 <pulpbot> Pulp Issue #2603 [NEW] (unassigned) - Priority: Normal | Severity: High
15:37:31 <pulpbot> Search API does weird filtering on association - http://pulp.plan.io/issues/2603
15:37:35 <jortel> I'll post a comment about how this should be addressed in p3
15:38:01 <mhrivnak> jortel, thanks
15:38:36 <mhrivnak> I think this should also be fixed in pulp 3, which will probably just happen for free.
15:39:25 <jortel> agreed
15:39:27 <mhrivnak> I'm ok with leaving this open as-is until we release Pulp 3.
15:39:30 <ipanova> !propose other accept and tag pulp3
15:39:30 <ipanova> #idea Proposed for #2603: accept and tag pulp3
15:39:30 <pulpbot> Proposed for #2603: accept and tag pulp3
15:39:44 <bizhang> !accept
15:39:44 <bizhang> #agreed accept and tag pulp3
15:39:44 <pulpbot> Current proposal accepted: accept and tag pulp3
15:39:45 <mhrivnak> I could also see a case for closing it now, but lean toward keeping it open.
15:39:46 <bizhang> #topic Ovirt, Openstack | Malformed repository: metadata is missing for some packages in filelists.xml and in other.xml - http://pulp.plan.io/issues/2605
15:39:46 <pulpbot> 2 issues left to triage: 2605, 2608
15:39:46 <pulpbot> Pulp Issue #2605 [NEW] (unassigned) - Priority: Normal | Severity: High
15:39:47 <pulpbot> Ovirt, Openstack | Malformed repository: metadata is missing for some packages in filelists.xml and in other.xml - http://pulp.plan.io/issues/2605
15:40:07 <ipanova> ttereshc: ^
15:40:51 <mhrivnak> !propose other advise the user on what the problem is and close - notabug
15:40:51 <mhrivnak> #idea Proposed for #2605: advise the user on what the problem is and close - notabug
15:40:51 <ipanova> Tanya was looking into this, she said she found an issue
15:40:51 <pulpbot> Proposed for #2605: advise the user on what the problem is and close - notabug
15:41:01 <mhrivnak> oh?
15:42:01 <mhrivnak> skip for now then?
15:42:07 <ttereshc> I just put a comment there
15:42:36 <mhrivnak> oh weird.
15:43:45 <mhrivnak> If it's a legit bug, seems like it could affect a lot of people.
15:44:07 <ttereshc> there should be some special conditions for that
15:44:13 <ipanova> let's check this out
15:44:17 <bizhang> !propose triage normal high
15:44:17 <bizhang> #idea Proposed for #2605: Priority: Normal, Severity: High
15:44:17 <pulpbot> Proposed for #2605: Priority: Normal, Severity: High
15:44:24 <ipanova> +1
15:44:27 <jortel> +1
15:44:30 <mhrivnak> +1 add to sprint also
15:44:37 <mhrivnak> at least to figure out how bad it is.
15:44:38 <bizhang> !propose other triage normal high add to sprint
15:44:38 <bizhang> #idea Proposed for #2605: triage normal high add to sprint
15:44:39 <pulpbot> Proposed for #2605: triage normal high add to sprint
15:44:50 <bizhang> !accept
15:44:50 <bizhang> #agreed triage normal high add to sprint
15:44:50 <pulpbot> Current proposal accepted: triage normal high add to sprint
15:44:52 <pulpbot> 1 issues left to triage: 2608
15:44:52 <bizhang> #topic Update crane installation and configuration docs - http://pulp.plan.io/issues/2608
15:44:53 <pulpbot> Crane Issue #2608 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:44:53 <pulpbot> Update crane installation and configuration docs - http://pulp.plan.io/issues/2608
15:45:10 <ipanova> we should convert it to task, and i vote to add it to sprint
15:45:29 <ipanova> because dkliban and me were dealing with this lately and it is fresh in the memory
15:45:45 <mhrivnak> I think thomasmckay would appreciate more crane documentation too. ;)
15:45:45 <bizhang> !propose other covert to task add to sprint
15:45:45 <bizhang> #idea Proposed for #2608: covert to task add to sprint
15:45:45 <pulpbot> Proposed for #2608: covert to task add to sprint
15:45:57 <mhrivnak> +1
15:45:58 <ttereshc> +1
15:46:02 <ipanova> yeah mhrivnak that's for sure
15:46:11 <bizhang> !accept
15:46:11 <bizhang> #agreed covert to task add to sprint
15:46:12 <pulpbot> Current proposal accepted: covert to task add to sprint
15:46:13 <pulpbot> No issues to triage.
15:46:17 <bizhang> !end
15:46:17 <bizhang> #endmeeting