15:29:51 <bizhang> #startmeeting Pulp Triage 2017-03-10
15:29:51 <bizhang> #info bizhang has joined triage
15:29:51 <pulpbot> Meeting started Fri Mar 10 15:29:51 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:51 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:51 <pulpbot> The meeting name has been set to 'pulp_triage_2017_03_10'
15:29:51 <pulpbot> bizhang has joined triage
15:29:56 <dkliban> !here
15:29:56 <dkliban> #info dkliban has joined triage
15:29:56 <pulpbot> dkliban has joined triage
15:30:32 <ipanova> !руку
15:30:32 <pulpbot> Error: "руку" is not a valid command.
15:30:37 <ipanova> ops
15:30:39 <ipanova> !here
15:30:39 <ipanova> #info ipanova has joined triage
15:30:40 <dalley> lol
15:30:40 <pulpbot> ipanova has joined triage
15:30:42 <dalley> !here
15:30:42 <dalley> #info dalley has joined triage
15:30:43 <pulpbot> dalley has joined triage
15:30:59 <bizhang> !next
15:31:01 <bizhang> #topic Blobs need checksum verification during sync - http://pulp.plan.io/issues/2624
15:31:01 <pulpbot> 5 issues left to triage: 2624, 2625, 2627, 2628, 2629
15:31:01 <pulpbot> Docker Support Issue #2624 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:31:02 <pulpbot> Blobs need checksum verification during sync - http://pulp.plan.io/issues/2624
15:31:52 <ipanova> this needs to be converted into a story and needs more discussion
15:32:01 <dkliban> sounds good to me
15:32:04 <dalley> +1
15:32:10 <dkliban> ipanova: do you want to convert it?
15:32:44 <ipanova> dkliban: yeah will do, i just want to make sure other teammates will provide feedback
15:32:51 <preethi> !here
15:32:51 <preethi> #info preethi has joined triage
15:32:52 <bizhang> !action ipanova to convert to story
15:32:52 <bizhang> #action ipanova to convert to story
15:32:52 <pulpbot> preethi has joined triage
15:33:31 <bizhang> !propose other ipanova to convert to story
15:33:31 <bizhang> #idea Proposed for #2624: ipanova to convert to story
15:33:31 <pulpbot> Proposed for #2624: ipanova to convert to story
15:33:50 <bizhang> !accept
15:33:50 <bizhang> #agreed ipanova to convert to story
15:33:50 <pulpbot> Current proposal accepted: ipanova to convert to story
15:33:53 <pulpbot> 4 issues left to triage: 2625, 2627, 2628, 2629
15:33:54 <bizhang> #topic Syncronyzed manifests are not content trusted - http://pulp.plan.io/issues/2625
15:33:54 <pulpbot> Docker Support Issue #2625 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:33:54 <pulpbot> Syncronyzed manifests are not content trusted - http://pulp.plan.io/issues/2625
15:34:01 <dkliban> i think the same is true for this one also
15:34:01 <ipanova> well, same here
15:34:02 <jortel> #info jortel has joined triage
15:34:02 <jortel> !here
15:34:02 <pulpbot> jortel has joined triage
15:34:26 <bizhang> !propose other ipanova to convert to story
15:34:26 <bizhang> #idea Proposed for #2625: ipanova to convert to story
15:34:27 <pulpbot> Proposed for #2625: ipanova to convert to story
15:35:02 <bizhang> !accept
15:35:02 <bizhang> #agreed ipanova to convert to story
15:35:02 <pulpbot> Current proposal accepted: ipanova to convert to story
15:35:04 <bizhang> #topic Uploading drpm by pulp-admin with --checksum-type fails - http://pulp.plan.io/issues/2627
15:35:04 <pulpbot> 3 issues left to triage: 2627, 2628, 2629
15:35:04 <pulpbot> Pulp Issue #2627 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:35:05 <pulpbot> Uploading drpm by pulp-admin with --checksum-type fails - http://pulp.plan.io/issues/2627
15:35:56 <ttereshc> !here
15:35:56 <ttereshc> #info ttereshc has joined triage
15:35:57 <pulpbot> ttereshc has joined triage
15:36:09 <dkliban> seems like a high/high to me
15:36:22 <dkliban> pulp-admin is not working right
15:36:56 <bizhang> !propose triage high high
15:36:56 <bizhang> #idea Proposed for #2627: Priority: High, Severity: High
15:36:57 <pulpbot> Proposed for #2627: Priority: High, Severity: High
15:37:12 <jortel> +0 on high/high
15:38:08 <ipanova> i think we can change the naming just before it arrives to the API part
15:38:21 <ipanova> should not be difficult to fix
15:38:51 <dkliban> i think it's an easy fix also
15:38:54 <ipanova> what about adding this to the sprint?
15:39:08 <ipanova> because this was a new feature i think in pulp 2.12
15:39:09 <ttereshc> I believe it is not a regression
15:39:14 <ipanova> and it is kinda broken
15:39:20 <ipanova> ttereshc:  it is not
15:39:32 <ipanova> because this upload of drpm was implemented recently
15:40:24 <ipanova> ttereshc: pardon, 2.11 https://pulp.plan.io/issues/1806
15:40:26 <pulpbot> Title: Story #1806: As a user, I can use pulp-admin to upload drpms - RPM Support - Pulp (at pulp.plan.io)
15:40:44 <bizhang> wouldn't this also affect srpm and rpm?
15:41:06 <ipanova> bizhang: should not
15:41:10 <ttereshc> bizhang, I do not think so
15:41:19 <ipanova> bizhang: drpm has different model inheritance
15:41:26 <ipanova> from srpm/rpm
15:41:45 <ttereshc> I agree it is not good that pulp-admin does not work properly but  for drpms high/high + add to sprint is too much imho
15:42:12 <ipanova> !propose triage other accept as it is and add to sprint
15:42:12 <pulpbot> (propose triage <priority> <severity> [target_release]) -- Propose triage values including priority, severity, and an optional target release.
15:42:13 <jortel> since there is no bz associated, let's not put on the sprint just now.  we can do that during next sprint planning if we want.
15:42:14 <smyers> The API still does it right?
15:42:16 <ttereshc> and there is a workaround to use API
15:42:21 <ipanova> ttereshc: i agree
15:42:34 <ttereshc> smyers, I think so
15:42:50 <ipanova> jortel: next sprint we're planning to switch to pulp 3
15:42:52 <preethi> I think API works we do have smash test AFIK
15:43:05 <bizhang> !propose triage high high
15:43:05 <bizhang> #idea Proposed for #2627: Priority: High, Severity: High
15:43:06 <smyers> High sev is for thing which impact critical workflows but have a workaround, where critical workflows is on the order of "sync any repo, install pulp, etc". I don't think this qualifies as High.
15:43:06 <pulpbot> Proposed for #2627: Priority: High, Severity: High
15:43:17 <jortel> ipanova: mainly pulp3 but that does not mean we wont do any pulp2 bugs.
15:43:28 <bizhang> !propose triage high medium
15:43:28 <bizhang> #idea Proposed for #2627: Priority: High, Severity: Medium
15:43:28 <pulpbot> Proposed for #2627: Priority: High, Severity: Medium
15:43:31 <ipanova> jortel: i see
15:43:44 <jortel> like 95% pulp3 ..
15:44:13 <ttereshc> it is probably faster to fix than to discuss it :)
15:44:19 <dkliban> i agree
15:44:23 <ipanova> well i bet we will not do this if we will not fix it now, and reason i'd like to have this fixed is that it is quite recent and new feature
15:44:26 <ipanova> broken one
15:44:31 <ipanova> ttereshc++
15:44:31 <pulpbot> ttereshc's karma is now 18
15:44:36 <ipanova> let's fix it!
15:44:41 <dkliban> let's fix it
15:45:02 <ipanova> i am ok with normal/medium and add to sprint
15:45:09 <dkliban> +1
15:45:12 <bizhang> !propose other add to sprint and fix it
15:45:12 <bizhang> #idea Proposed for #2627: add to sprint and fix it
15:45:13 <pulpbot> Proposed for #2627: add to sprint and fix it
15:45:16 <bmbouter> !here
15:45:16 <bmbouter> #info bmbouter has joined triage
15:45:16 <pulpbot> bmbouter has joined triage
15:45:30 <ipanova> +1
15:45:33 <bizhang> !accept
15:45:33 <bizhang> #agreed add to sprint and fix it
15:45:33 <pulpbot> Current proposal accepted: add to sprint and fix it
15:45:35 <bizhang> #topic Syncing a puppet repo that doesn't have a feed doesn't fail gracefully - http://pulp.plan.io/issues/2628
15:45:35 <pulpbot> 2 issues left to triage: 2628, 2629
15:45:35 <pulpbot> Puppet Support Issue #2628 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:45:36 <pulpbot> Syncing a puppet repo that doesn't have a feed doesn't fail gracefully - http://pulp.plan.io/issues/2628
15:45:37 <jortel> +1 and let's move on.
15:46:28 <bmbouter> I thought this was a duplicate but I couldn't find the one I remembered filing
15:46:35 * bmbouter looks again
15:46:45 <ipanova> bmbouter: i bet it was filled once against rpm plugin
15:46:51 <ipanova> bmbouter: i found a BZ
15:46:54 <ipanova> quite old one
15:46:58 <ipanova> but this one is puppet
15:47:27 <ttereshc> !propose accept
15:47:27 <ttereshc> #idea Proposed for #2628: Leave the issue as-is, accepting its current state.
15:47:27 <pulpbot> Proposed for #2628: Leave the issue as-is, accepting its current state.
15:47:33 <ipanova> bmbouter: here you go https://bugzilla.redhat.com/show_bug.cgi?id=1003965
15:48:05 <ipanova> +1
15:48:12 <bizhang> !accept
15:48:12 <bizhang> #agreed Leave the issue as-is, accepting its current state.
15:48:12 <pulpbot> Current proposal accepted: Leave the issue as-is, accepting its current state.
15:48:13 <pulpbot> 1 issues left to triage: 2629
15:48:14 <bizhang> #topic max_speed param does not work in yum_importer.json - http://pulp.plan.io/issues/2629
15:48:14 <pulpbot> RPM Support Issue #2629 [NEW] (unassigned) - Priority: Normal | Severity: Medium
15:48:15 <pulpbot> max_speed param does not work in yum_importer.json - http://pulp.plan.io/issues/2629
15:48:36 <bmbouter> ipanova:  https://pulp.plan.io/issues/355
15:48:38 <pulpbot> Title: Issue #355: Need error handling and message for repo sync with a bad feed - RPM Support - Pulp (at pulp.plan.io)
15:49:00 <bmbouter> not sure if those should be combined or not
15:49:10 <dkliban> i haven't tried to reproduce it but i talked to the filer and it seems like #2629 is a legitimate bug
15:49:11 <ipanova> bmbouter:  it is a different one
15:49:34 <bmbouter> ipanova: I'll look a bit more for the dup b/c I'm pretty sure I filed this already
15:49:43 <dkliban> !propose triage high high
15:49:43 <dkliban> #idea Proposed for #2629: Priority: High, Severity: High
15:49:43 <pulpbot> Proposed for #2629: Priority: High, Severity: High
15:49:53 <ipanova> bmbouter:  this one is about handling bad feed, and the other one has no feed at all
15:49:57 <ipanova> bmbouter:  sounds good
15:50:31 <dkliban> i am proposing high/high because this is needed for syncing from certain repos. some servers will start giving 404s if you are trying to download too fast
15:51:19 <bmbouter> ipanova: ack and I cannot find the one I filed. ty for filing
15:51:30 <bizhang> dkliban, that sounds reasonable to me
15:51:33 <ipanova> i would go with high/medium
15:51:38 <ttereshc> dkliban, is there a workaround?
15:51:57 <ttereshc> dkliban, I mean is it the only way user can specify the parameter?
15:51:59 <dkliban> ttereshc: i am nto sure. perhaps it can be specified at sync time
15:52:08 <ttereshc> that's what I think
15:52:16 <dkliban> i know it can be specified at sync time, but i don't know if it's respected
15:52:25 <jortel> I think low/med.  there are other ways to specify besides using the .json file.  plus, the bandwidth limiting in pulp2 is really not good anyway.
15:52:27 <dkliban> so we should definitely investigate
15:52:31 <ipanova> seems like the case you stated is very rare because we received the report just now dkliban
15:53:42 <dkliban> ipanova: perhaps
15:53:49 <ipanova> what about to triage as it is\
15:54:10 <dkliban> ipanova: i am ok with that. i'll talk to the reporter some more about it
15:54:18 <dkliban> ipanova: he was not available to join triage
15:54:27 <ipanova> dkliban: sounds good
15:54:37 <bizhang> !propose other accept, dkliban will talk to reporter
15:54:37 <bizhang> #idea Proposed for #2629: accept, dkliban will talk to reporter
15:54:37 <pulpbot> Proposed for #2629: accept, dkliban will talk to reporter
15:54:42 <ipanova> +1
15:54:46 <dkliban> +1
15:54:47 <bizhang> !accept
15:54:47 <bizhang> #agreed accept, dkliban will talk to reporter
15:54:48 <pulpbot> Current proposal accepted: accept, dkliban will talk to reporter
15:54:48 <jortel> fine
15:54:49 <pulpbot> No issues to triage.
15:54:54 <dkliban> woohoo!
15:54:55 <bizhang> !end
15:54:55 <bizhang> #endmeeting