14:34:39 <bizhang> #startmeeting Pulp Triage 2017-03-17
14:34:39 <bizhang> #info bizhang has joined triage
14:34:39 <bizhang> !start
14:34:39 <pulpbot> Meeting started Fri Mar 17 14:34:39 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:34:39 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:34:39 <pulpbot> The meeting name has been set to 'pulp_triage_2017_03_17'
14:34:39 <pulpbot> bizhang has joined triage
14:35:40 <dalley> !here
14:35:40 <dalley> #info dalley has joined triage
14:35:40 <pulpbot> dalley has joined triage
14:36:01 <bmbouter> #info bmbouter has joined triage
14:36:01 <bmbouter> !here
14:36:01 <pulpbot> bmbouter has joined triage
14:36:49 <bizhang> !next
14:36:50 <pulpbot> 3 issues left to triage: 2637, 2639, 2642
14:36:51 <bizhang> #topic Debian dependencies represented in pulp - http://pulp.plan.io/issues/2637
14:36:51 <pulpbot> Debian Support Issue #2637 [NEW] (mihai.ibanescu@gmail.com) - Priority: Normal | Severity: Medium
14:36:52 <pulpbot> Debian dependencies represented in pulp - http://pulp.plan.io/issues/2637
14:38:37 <bizhang> I'm not sure what our next step for this issue is
14:39:56 <bizhang> smyers, you probably know the most about debian packaging, do you want to work with misa on this?
14:41:53 <bmbouter> will this result in a change to platform?
14:42:08 <bmbouter> it's filed as an issue but I'm not sure what the defect is
14:42:42 <bizhang> the way I read it it's looking for feedback on the design of the plugin
14:43:32 <bizhang> maybe it should be a task instead?
14:44:12 <bizhang> let's skip it for now and triage when the right people are here
14:44:13 <bizhang> !skip
14:44:15 <pulpbot> 2 issues left to triage: 2639, 2642
14:44:15 <bizhang> #topic Upgrade to 1.2.1 beta fails on fedora 24 - http://pulp.plan.io/issues/2639
14:44:16 <pulpbot> OSTree Support Issue #2639 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:44:17 <pulpbot> Upgrade to 1.2.1 beta fails on fedora 24 - http://pulp.plan.io/issues/2639
14:44:27 <bmbouter> bizhang: +1 to that
14:44:54 <bmbouter> this seems like sev should be high
14:45:06 <bmbouter> because if you are on F24 you cannot use pulp
14:45:21 <smyers> you cannot use ostree
14:45:31 <bmbouter> oh yes ty
14:46:58 <smyers> But Just make sure you get to comment 2, I'm not sure at this point if you can upgrade to ostree 2.12.2 in any fedora right now
14:47:47 <bizhang> would this block release 2.12.2?
14:47:50 <smyers> I think we can decide that we need to know that before continuing, or accept that if it's broken in f24 it's probably broken in f25 and we should fix it
14:48:11 <bizhang> do we block releases on plugin issues?
14:48:48 <smyers> I'm not sure that we have a precedent here. I still don't know why this didn't happen for upgrades to <=2.12.1
14:48:54 <bmbouter> agreed
14:49:19 <bmbouter> we need to be able to continue to release so maybe this should go on a sprint?
14:49:53 <smyers> Yeah, given that it's a fix to a plugin, we could potentially fix the packaging and release ostree 1.2.1-2 after the fact
14:49:56 <smyers> and ostree-only hotfix
14:49:58 <smyers> an
14:51:02 <bizhang> !propose other normal/normal add to sprint
14:51:02 <bizhang> #idea Proposed for #2639: normal/normal add to sprint
14:51:03 <pulpbot> Proposed for #2639: normal/normal add to sprint
14:51:33 <smyers> Works for me, and I think maybe this gets to be a line item for the next team meeting?
14:51:49 <bizhang> sounds good, I'll add it to the etherpad
14:52:05 <bizhang> #agreed normal/normal add to sprint
14:52:05 <bizhang> !accept
14:52:05 <pulpbot> Current proposal accepted: normal/normal add to sprint
14:52:07 <bizhang> #topic --auth-ca parameter on repo creation not working - http://pulp.plan.io/issues/2642
14:52:07 <pulpbot> 1 issues left to triage: 2642
14:52:08 <pulpbot> RPM Support Issue #2642 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:52:09 <pulpbot> --auth-ca parameter on repo creation not working - http://pulp.plan.io/issues/2642
14:52:18 <smyers> I can take care of that if you want to stay focused on triage, just lemme know
14:53:23 <bizhang> smyers, saw your message after I updated the pad :)
14:53:30 <smyers> cool
14:55:34 <smyers> As mentioned in the issue, this issue stems from a discussion on pulp-list that we haven't yet engaged in. I wonder if there's maybe no bug here, and we're just missing something in the docs about setting this up?
14:56:01 <smyers> I'm not sure what to propose for triage
14:56:37 <ichimonji10> elyezer++
14:56:37 <pulpbot> elyezer's karma is now 122
14:57:11 <bizhang> !propose other needsinfo bizhang will test --auth-ca command
14:57:11 <bizhang> #idea Proposed for #2642: needsinfo bizhang will test --auth-ca command
14:57:12 <pulpbot> Proposed for #2642: needsinfo bizhang will test --auth-ca command
14:57:27 <smyers> works for me
14:57:31 <bizhang> !accept
14:57:31 <bizhang> #agreed needsinfo bizhang will test --auth-ca command
14:57:31 <pulpbot> Current proposal accepted: needsinfo bizhang will test --auth-ca command
14:57:33 <pulpbot> No issues to triage.
14:57:50 <bizhang> smyers, what should we do for https://pulp.plan.io/issues/2637
14:57:52 <pulpbot> Title: Issue #2637: Debian dependencies represented in pulp - Debian Support - Pulp (at pulp.plan.io)
14:59:16 <bizhang> I'm reading it as needing feedback on pulp_deb design, should we convert it to a task?
14:59:27 <smyers> Not sure. I think it's low prio/low sev, and that we'll be seeing a PR from misa about it if it isn't already posted
14:59:47 <bizhang> !issue 2637
14:59:48 <bizhang> #topic Debian dependencies represented in pulp - http://pulp.plan.io/issues/2637
14:59:48 <pulpbot> Debian Support Issue #2637 [NEW] (mihai.ibanescu@gmail.com) - Priority: Normal | Severity: Medium
14:59:49 <pulpbot> Debian dependencies represented in pulp - http://pulp.plan.io/issues/2637
14:59:55 <bizhang> #idea Proposed for #2637: Priority: Low, Severity: Low
14:59:55 <bizhang> !propose triage low low
14:59:55 <smyers> I think the feedback's already been gotten, that's about implementing it in pulp_deb
14:59:55 <pulpbot> Proposed for #2637: Priority: Low, Severity: Low
15:00:39 <bizhang> would it make more sense as a story?
15:00:59 <smyers> Yeah, I was just thinking about that. Probably yes.
15:01:17 <bizhang> #idea Proposed for #2637: low/low convert to story
15:01:17 <bizhang> !propose other low/low convert to story
15:01:17 <pulpbot> Proposed for #2637: low/low convert to story
15:01:24 <smyers> But maybe it's a task, maybe it's a refactor assuming pulp's output doesn't change.
15:01:31 <smyers> Story seems fine
15:01:42 <bizhang> cool
15:01:44 <bizhang> #agreed low/low convert to story
15:01:44 <bizhang> !accept
15:01:44 <pulpbot> Current proposal accepted: low/low convert to story
15:01:45 <pulpbot> No issues to triage.
15:01:46 <bizhang> #endmeeting
15:01:46 <bizhang> !end