14:30:02 <bizhang> #startmeeting Pulp Triage 2017-03-21
14:30:02 <bizhang> #info bizhang has joined triage
14:30:02 <bizhang> !start
14:30:02 <pulpbot> Meeting started Tue Mar 21 14:30:02 2017 UTC and is due to finish in 60 minutes.  The chair is bizhang. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:02 <pulpbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:02 <pulpbot> The meeting name has been set to 'pulp_triage_2017_03_21'
14:30:02 <pulpbot> bizhang has joined triage
14:30:22 <mhrivnak> !here
14:30:22 <mhrivnak> #info mhrivnak has joined triage
14:30:23 <pulpbot> mhrivnak has joined triage
14:30:25 <ipanova> #info ipanova has joined triage
14:30:25 <ipanova> !here
14:30:25 <pulpbot> ipanova has joined triage
14:30:41 <ttereshc> #info ttereshc has joined triage
14:30:41 <ttereshc> !here
14:30:41 <pulpbot> ttereshc has joined triage
14:30:59 <bizhang> !next
14:31:00 <dkliban> !here
14:31:02 <bizhang> #topic pulp not starting properly, apache pulp-manage-db throwing errors - http://pulp.plan.io/issues/2591
14:31:02 <dkliban> #info dkliban has joined triage
14:31:02 <pulpbot> 4 issues left to triage: 2591, 2642, 2643, 2644
14:31:03 <pulpbot> Pulp Issue #2591 [NEW] (unassigned) - Priority: High | Severity: High
14:31:04 <pulpbot> pulp not starting properly, apache pulp-manage-db throwing errors - http://pulp.plan.io/issues/2591
14:31:05 <pulpbot> dkliban has joined triage
14:32:06 <daviddavis> !here
14:32:06 <daviddavis> #info daviddavis has joined triage
14:32:07 <pulpbot> daviddavis has joined triage
14:32:09 <mhrivnak> This is the one Kodiak hit over the weekend. We still don't know the root cause, but we do have a reliable and simple workaround.
14:32:24 <mhrivnak> It's also not reproducible on 2.10 or 2.12.
14:32:37 <jortel> #info jortel has joined triage
14:32:37 <jortel> !here
14:32:37 <pulpbot> jortel has joined triage
14:33:12 <bizhang> close wontfix?
14:33:13 <ttereshc> WONTFIX until we have a reproducer?
14:33:35 <mhrivnak> I think that's reasonable.
14:33:42 <bizhang> !propose other close WONTFIX
14:33:42 <bizhang> #idea Proposed for #2591: close WONTFIX
14:33:43 <pulpbot> Proposed for #2591: close WONTFIX
14:34:22 <bizhang> !accept
14:34:22 <bizhang> #agreed close WONTFIX
14:34:22 <ipanova> would not it be better worksforme?
14:34:22 <pulpbot> Current proposal accepted: close WONTFIX
14:34:23 <pulpbot> 3 issues left to triage: 2642, 2643, 2644
14:34:24 <bizhang> #topic --auth-ca parameter on repo creation not working - http://pulp.plan.io/issues/2642
14:34:24 <pulpbot> RPM Support Issue #2642 [NEW] (unassigned) - Priority: Normal | Severity: Medium
14:34:25 <pulpbot> --auth-ca parameter on repo creation not working - http://pulp.plan.io/issues/2642
14:34:55 <bizhang> I've been looking at this one, but I'm not sure how to get repo auth working in pulp
14:35:07 <bizhang> Does anyone else want to take over?
14:35:37 <mhrivnak> It's a bit of a black art. Historically, nobody wants to use this feature except Red Hat. :)
14:36:12 <bizhang> well if we're all on the same page for this I can continue trying
14:36:16 <bizhang> #idea Proposed for #2642: needsinfo
14:36:16 <bizhang> !propose other needsinfo
14:36:16 <pulpbot> Proposed for #2642: needsinfo
14:36:32 <mhrivnak> I think the biggest factor here is that there isn't enough documentation.
14:37:02 <mhrivnak> bizhang, I have a couple thoughts we could look at this afternoon.
14:37:10 <bizhang> yeah, I can update the docs /if/ I can figure out how to get it working with the current docs :P
14:37:15 <bizhang> mhrivnak, that sounds good
14:37:32 <mhrivnak> Perhaps skip it for now?
14:37:47 <bizhang> !skip
14:37:48 <pulpbot> 2 issues left to triage: 2643, 2644
14:37:48 <bizhang> #topic DKR1008: Could not find registry API at https://docker-registry.engineering.redhat.com - http://pulp.plan.io/issues/2643
14:37:49 <pulpbot> Docker Support Issue #2643 [NEW] (unassigned) - Priority: Normal | Severity: High
14:37:50 <pulpbot> DKR1008: Could not find registry API at https://docker-registry.engineering.redhat.com - http://pulp.plan.io/issues/2643
14:38:17 <ipanova> i am working on this
14:38:26 <ipanova> and it seems like the issue is not on the pulp side
14:38:55 <bizhang> ipanova, do you want to comment and close?
14:39:04 <ipanova> i will try to reach other engineers who could tell more details about the internal docker registry to confirm that we're safe here
14:39:09 <ipanova> bizhang: not yet
14:39:28 <mhrivnak> !propose other skip until ipanova confirms the root cause
14:39:28 <mhrivnak> #idea Proposed for #2643: skip until ipanova confirms the root cause
14:39:29 <pulpbot> Proposed for #2643: skip until ipanova confirms the root cause
14:39:29 <ipanova> bizhang: i mean i don;t to want to close it yet
14:39:37 <ipanova> yup
14:39:41 <ttereshc> +1 to skip
14:40:06 <bizhang> #agreed skip until ipanova confirms the root cause
14:40:06 <bizhang> !accept
14:40:06 <pulpbot> Current proposal accepted: skip until ipanova confirms the root cause
14:40:08 <pulpbot> 1 issues left to triage: 2644
14:40:08 <bizhang> #topic pulp fails to correctly process WWW-Authenticate headers - http://pulp.plan.io/issues/2644
14:40:09 <pulpbot> Docker Support Issue #2644 [NEW] (unassigned) - Priority: Normal | Severity: High
14:40:10 <pulpbot> pulp fails to correctly process WWW-Authenticate headers - http://pulp.plan.io/issues/2644
14:40:34 <ipanova> i am working on this as well
14:40:51 <daviddavis> this sounds familiar
14:40:57 <mhrivnak> ipanova, does it seem like a straight-forward fix?
14:41:11 <ipanova> i am not sure it is correct to give the scope of both push and pull when you're trying just to have read access
14:41:17 <ipanova> mhrivnak: it does
14:41:47 <ipanova> mhrivnak: but since we're having just read access i don't know if we need to forsee pull,push case
14:41:56 <mhrivnak> I think it's important that pulp can sync from artifactory, so I'd +1 adding to the sprint and getting this done.
14:42:10 <ipanova> mhrivnak: ok, agree
14:42:40 <ipanova> i am just trying to understand if it is correct from the registry side to return both read and write access when just read was requested
14:43:09 <bizhang> !propose other accept and add to sprint
14:43:09 <bizhang> #idea Proposed for #2644: accept and add to sprint
14:43:10 <pulpbot> Proposed for #2644: accept and add to sprint
14:43:13 <mhrivnak> eh, does it matter if they give pulp extra access?
14:43:23 <ipanova> mhrivnak: well not for pulp
14:43:35 <ipanova> mhrivnak:  but this way i'd report a bug for artyfactory :-P
14:43:49 <mhrivnak> Fair enough.
14:44:19 <ipanova> +1 to add to sprint
14:44:41 <bizhang> leave it as normal/high?
14:45:17 <mhrivnak> ipanova, note that their docker support is not open source, so factor that into prioritization. ;)
14:46:03 <ipanova> mhrivnak: gotcha
14:46:11 <mhrivnak> normal/high seems reasonable.
14:46:11 <ipanova> i will take care of this
14:46:18 <bizhang> !accept
14:46:18 <bizhang> #agreed accept and add to sprint
14:46:18 <pulpbot> Current proposal accepted: accept and add to sprint
14:46:20 <pulpbot> No issues to triage.
14:46:22 <bizhang> #endmeeting
14:46:22 <bizhang> !end